Jump to content

Recommended Posts

Hi! A common problem, I'd say. For some reason my game can't seem to handle enb presets. I get an 15 fps hit when using Enhanced Shaders for example, an enb that is supposed to be performance friendly. My rig should be able to handle that: Xeon 1231 v3, GTX 970, 8 GB RAM, game is installed on a SSD.

 

I followed the guide, installed Medium texture versions when possible, toyed around with ENB and ini settings, but nothing seems to work. Heres an example: I run around Goodsprings, at first the FPS is at a wonderful 60. Afterwards I go to the gas station and take a look around. Pointing the camera in the direction of Victors shack, my FPS goes instantly to 47. Without ENB I gain more or less +8 to +10 frames.

 

Does anyone know what I can try to remedy this, preferably without deactivating the enb? How is this performance loss even possible an my machine?

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Hi! A common problem, I'd say. For some reason my game can't seem to handle enb presets. I get an 15 fps hit when using Enhanced Shaders for example, an enb that is supposed to be performance friendly. My rig should be able to handle that: Xeon 1231 v3, GTX 970, 8 GB RAM, game is installed on a SSD.

 

I followed the guide, installed Medium texture versions when possible, toyed around with ENB and ini settings, but nothing seems to work. Heres an example: I run around Goodsprings, at first the FPS is at a wonderful 60. Afterwards I go to the gas station and take a look around. Pointing the camera in the direction of Victors shack, my FPS goes instantly to 47. Without ENB I gain more or less +8 to +10 frames.

 

Does anyone know what I can try to remedy this, preferably without deactivating the enb? How is this performance loss even possible an my machine?

 

Thanks in advance!

Well, that's FNV... No matter how powerful your PC is the engine is old and ENB will hit the performance very hard. Personally, I've switched to Lucent ENB - it doesn't hit the performance that much and picture is nice (at least on my taste). But don't expect steady 60 fps if you are using ENB.

Also I doubt that texture size in your case make any real difference. It's ENB's additional effects and old engine combination...

Share this post


Link to post
Share on other sites

so it's not uncommon that certain areas in the game will make your fps take a nosedive? I'm gonna try your ENB, cause without one my game looks way too bleak and washed out. otherwise I'm still open to any and all suggestions.

Share this post


Link to post
Share on other sites

so it's not uncommon that certain areas in the game will make your fps take a nosedive? I'm gonna try your ENB, cause without one my game looks way too bleak and washed out. otherwise I'm still open to any and all suggestions.

Yeah, it's definitely not uncommon. And if you are using Project Nevada Extra Options - the Rebalance module there is known to cause gradual performance degradation.

Share this post


Link to post
Share on other sites

One setting I know I have heard stories of tanking people's FPS (even on 980Ti's) is the bHookLightCriticalSections setting in your StutterRemover.ini file. Double check it is set to 0 as I know it destroyed my FPS by 40+ FPS or more in certain areas. Another setting I recommend is to disable the games V-Sync and disable the stutter remover's FPS control (set bManageFPS=0) and then go into your Nvidia Control Panel (or use Nnvidia Inspector) and force Adaptive V-Sync. Only use your GPU to manage V-Sync. This is what I do because the games V-Sync is completely borked; causing FPS issues and weird game speed issues all around.

 

Oh, and since you're using an ENB it is a known problem that the ENBoost can cause serious issues on Nvidia cards regarding FPS (though some people won't admit it). Try turning off the ReduceSystemMemoryUsage and just see if that helps with the FPS drops. ENB is practically broken for Fallout and I recommend switching to a SweetFX or ReShade preset if you can find one. :\  

 

Edit: typos

Edited by Audley
  • Upvote 1

Share this post


Link to post
Share on other sites

Yeah, it's definitely not uncommon. And if you are using Project Nevada Extra Options - the Rebalance module there is known to cause gradual performance degradation.

oh yeah, I'm certainly feeling that one. I haven't tried switching off the rebelance module, but the FPS degradation is rediculous :\ I finished testing and am now playing for realsies, getting sometimes 35 FPS in freaking Goodsprings after a while. I really hope the mod author looks at the problem and will let us know if he finds anything.

 

One setting I know I have heard stories of tanking people's FPS (even on 980Ti's) is the bHookLightCriticalSections setting in your StutterRemover.ini file. Double check it is set to 0 as I know it destroyed my FPS by 40+ FPS or more in certain areas. Another setting I recommend is to disable the games V-Sync and disable the stutter remover's FPS control (set bManageFPS=0) and then go into your Nvidia Control Panel (or use Nnvidia Inspector) and force Adaptive V-Sync. Only use your GPU to manage V-Sync. This is what I do because the games V-Sync is completely borked; causing FPS issues and weird game speed issues all around.

 

Oh, and since you're using an ENB it is a known problem that the ENBoost can cause serious issues on Nvidia cards regarding FPS (though some people won't admit it). Try turning off the ReduceSystemMemoryUsage and just see if that helps with the FPS drops. ENB is practically broken for Fallout and I recommend switching to a SweetFX or ReShade preset if you can find one. :\  

 

Edit: typos

I always use Nvidias V-Sync, turning off the in-game option. But everything else you listed is definetly worth looking into. Gonna start modifying some ini files then, thanks! :>

Share this post


Link to post
Share on other sites

One setting I know I have heard stories of tanking people's FPS (even on 980Ti's) is the bHookLightCriticalSections setting in your StutterRemover.ini file. Double check it is set to 0 as I know it destroyed my FPS by 40+ FPS or more in certain areas. Another setting I recommend is to disable the games V-Sync and disable the stutter remover's FPS control (set bManageFPS=0) and then go into your Nvidia Control Panel (or use Nnvidia Inspector) and force Adaptive V-Sync. Only use your GPU to manage V-Sync. This is what I do because the games V-Sync is completely borked; causing FPS issues and weird game speed issues all around.

 

Oh, and since you're using an ENB it is a known problem that the ENBoost can cause serious issues on Nvidia cards regarding FPS (though some people won't admit it). Try turning off the ReduceSystemMemoryUsage and just see if that helps with the FPS drops. ENB is practically broken for Fallout and I recommend switching to a SweetFX or ReShade preset if you can find one. :\  

 

Edit: typos

I believe if you are using ENB with preset you either need to have in game vsync on or fps limit in the ENB.

 

Disabling ReduceSystemMemoryUsage will disable ENBoost. ENBoost is not used to improve graphics. It's used to reduce process memory usage and increase game stability when there are many HD textures used.

oh yeah, I'm certainly feeling that one. I haven't tried switching off the rebelance module, but the FPS degradation is rediculous :\ I finished testing and am now playing for realsies, getting sometimes 35 FPS in freaking Goodsprings after a while. I really hope the mod author looks at the problem and will let us know if he finds anything.

 

I always use Nvidias V-Sync, turning off the in-game option. But everything else you listed is definetly worth looking into. Gonna start modifying some ini files then, thanks! :>

Yes, I highly recommend disabling Extra Options Rebalance. But you will need to start a new game, mind you.

Share this post


Link to post
Share on other sites

I believe if you are using ENB with preset you either need to have in game vsync on or fps limit in the ENB.

 

Disabling ReduceSystemMemoryUsage will disable ENBoost. ENBoost is not used to improve graphics. It's used to reduce process memory usage and increase game stability when there are many HD textures used.

I realize this and my opinion still stands... the setting does not work properly for some users. I do not know why, but for me it will cause my game to stutter severely. It always happens in the same area and when I look in the same direction but goes away when the setting is turned off. I've talked to Boris about it and he cannot replicate it on his end so he has not tried to fix it. Happens solely in New Vegas as ENBoost works fine in Fallout 3 and Skyrim.

Share this post


Link to post
Share on other sites

well, the problem still persists. bHookLightCriticalSections and fps control were already disabled. deactivating enboost didn't do it for me either. I remembered reading something interesting on the stutter remover page and decided to activate breplaceheap in the nvsr ini with various iheapsize values. it seems to dampen the fps degradation to an accaptable degree, but my game crashes with an out of memory error after a certain number of area transitions :\

 

my hopes and dreams are now with a rebalance patch. seems like the author is actively looking for possible bugs within his mod, which is good news.

Share this post


Link to post
Share on other sites

Couple advises:

1. Change process priority for FalloutNV.exe to High and change affinity to 0 and 2 cores (both can be done if you press ctrl-shift-esc and go to Details tab or better yet to use something like Lasso which can do it for you automatically when you launch the game). This gave me 4-7 fps boost.

2. With GTX 970 the bottleneck for the game performance is not a videocard. It's a CPU. So if you can, overclock your CPU.

3. Make sure when you run the game there are no other CPU hungry processes. Go to process explorer (ctrl-shift-esc, Details), sort by CPU and see if there is anything there with more then 1% - unload it.

4. In a stutter remover mod ini make sure you have master section set to something like this:

 

Master = {

_comment = You can turn on or off each distinct feature from here.

bManageFPS = 0

bHookCriticalSections = 1

bHookLightCriticalSections = 0

bHookHashtables = 1

bReplaceHeap = 1

bReplaceGetTickCount = 1

bLogToConsole = 0

bFastExit = 1

bFlushLog = 1

iSchedulingResolution = 1

bReplaceRandom = 1

bExperimentalStuff = 0

iMainHookPoint = 1

}

 

5. Find a spot inside the game with low fps. Save. Exit. Uncheck ALL esps and esms except for default. Load that save and check if FPS went significantly up. Exit. Enable a portion starting from the top and moving to the bottom. Load the game, see if FPS got worse... rinse and repeat until you find which mods are affecting your FPS. For me it was mods like FPS Weapon Wheel - totally unexpected...

6. Most of ini tweaks are either a placebo or will actually harm your game performance... Try deleting (renaming to back up) and recreating from the Fallout Launcher.

7. Go to NVidia Control panel and set Maximum Pre-Render Frames to 1, Multi-Display to Single Display Mode and Power Management to Prefer Maximum Performance. Rest leave as default.

Edited by raycrios

Share this post


Link to post
Share on other sites

thanks for the suggestions. most of them don't really apply to my config, sadly. neither cpu nor gfx are at max capacity when playing nv, which leads me to believe that this is not a hardware issue. I also refrain from using crap like game booster or whatever, so there are never secondary fps killers as far as I can tell.

 

my stutter remover ini looks almost exactly the same except for the heap replacement. when active I get out of memory crashes after 5 or 6 area transitions. do you mind sharing your heap options part of the ini? maybe I've punched in some wrong numbers there.

 

unfortunately doing the steps described in 5. won't do me any good here. once my framerate drops to 25-28 I would close and restart the game. no matter where my char would end up at this point, the fps will jump back up to a solid 60, some busy areas notwithstanding. walking around, quick traveling start the slow degradation again, until I end up at 25 fps (no matter where I am).

 

I will try limiting cpu cores and playing around with the nvidia cc but I don't think it will help much. there has to be a mod conflict somewhere :\

Share this post


Link to post
Share on other sites

thanks for the suggestions. most of them don't really apply to my config, sadly. neither cpu nor gfx are at max capacity when playing nv, which leads me to believe that this is not a hardware issue. I also refrain from using crap like game booster or whatever, so there are never secondary fps killers as far as I can tell.

 

my stutter remover ini looks almost exactly the same except for the heap replacement. when active I get out of memory crashes after 5 or 6 area transitions. do you mind sharing your heap options part of the ini? maybe I've punched in some wrong numbers there.

 

unfortunately doing the steps described in 5. won't do me any good here. once my framerate drops to 25-28 I would close and restart the game. no matter where my char would end up at this point, the fps will jump back up to a solid 60, some busy areas notwithstanding. walking around, quick traveling start the slow degradation again, until I end up at 25 fps (no matter where I am).

 

I will try limiting cpu cores and playing around with the nvidia cc but I don't think it will help much. there has to be a mod conflict somewhere :\

How do you determine max capacity of cpu? Do you check load on cores and none of them are loaded to 100%? But if you do that when alt-tabbed then game will pause and CPU load will instantly drop... Here's my stutter remover ini: https://pastebin.com/YKsNBdB9

Share this post


Link to post
Share on other sites

to keep track of my cpu load I simply open up a tool like cpu-z on my second monitor while playing the game an my main.

 

tried your ini config but 20 minutes later I got an out of memory error :\ oh well, thanks anyway. playing fo4 at a steady 60 is really liberating right now but modded NV is sooo so good though :D

Share this post


Link to post
Share on other sites

Tracking performance statistics is a lot easier if you have two or more monitors. I usually use a combination of Skyrim Performance Monitor and Windows Performance Monitor on a secondary monitor while I play the game on the primary monitor. This way I can glance at the second monitor to see all the stats while I'm playing.

 

If you have a single monitor, Skyrim Performance Monitor is the best option. Skyrim Performance Monitor stops capturing data after you exit the game and keeps the data in the charts so you can easily check out the statistics after playing for a while.

Share this post


Link to post
Share on other sites

well, the first paragraph is what I was talking about. while playing on my main, I can keep an eye on my second screen, enjoying how my lazy ass cpu almost never goes over 20% while my GPU is being productive at 70%, more or less. I understand the stutter and fps drops, it is an olde engine after all. but having your fps shrink down to a measly 30 after a while, even indoors - now that sucks. reloading a save isn't enough, I have to restart the game to enjoy 30 minutes of flawless 60 fps.

 

little update on what I've tried so far:

 

- deactivating all instances of NVSR

- removing texture mods

- making sure the 4GB mod does what it does

- purging my sweet ass cellbuffer

- crying in a corner

- using the skyrim enb .dll instead of the native one

- using lasso to limit cores

- modifying the threaded ai in the ini and whatnot

- installing the game performance mod (might turn out to be a mistake in the long run)

- more crying

 

I think I'm officially out of ideas. I'm still convinced that this is a mod issue. It has to be, right? gonna go full savegame destroyer and deactivate nevada skies, just for a while. awop as well perhaps. thankfully mod organizer exists which makes it easy to add and remove all sorts of stuff.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.