Jump to content

Recommended Posts

Hello,

I am happy to say the mod list is very easy to follow, at least for someone familiar with the procedures. I've run into a problem after installing the CR patch however. According to MO, it requires an esp from the "Helmet Overlay" mod despite that mod only containing an esm.

I realize this list is brand new so there are probably several small tweaks incoming. Thank you for your time, I understand how much work this all takes!

Share this post


Link to post
Share on other sites
54 minutes ago, sailor_silica said:

Hello,

I am happy to say the mod list is very easy to follow, at least for someone familiar with the procedures. I've run into a problem after installing the CR patch however. According to MO, it requires an esp from the "Helmet Overlay" mod despite that mod only containing an esm.

I realize this list is brand new so there are probably several small tweaks incoming. Thank you for your time, I understand how much work this all takes!

As a temporary fix, creating a copy of the Helmet Overlay esm and changing the extension to esp seems to work.

Share this post


Link to post
Share on other sites

@Majorman is out until next week I think, but @Greg was helping him validate this build, so he may have some suggestions for you or the guide instructions.

Share this post


Link to post
Share on other sites

@sailor_silicaI am indeed away from my PC for about a week, but I've taken note on the issue. From what I've seen thus far, Helmet Overlay was updated on 14 September and its esp got updated to an esm. Thus I will have to update the CR Patch to reflect this. Would you like to test out the new CR Patch when it gets ready? 

Luckily for you, judging from the comments section of Helmet Overlay, renaming the esm to esp should not make a difference. 

Edit: I would recommend using version 1.6.3 of Helmet Overlay as a fallback for the time being (until I update the patch) . Can anyone suggest how to download older versions of mods via the new "File Archive" function of Nexus? I can't get to a download screen on my phone, but there should be a way. 

Share this post


Link to post
Share on other sites
3 hours ago, Majorman said:

Edit: I would recommend using version 1.6.3 of Helmet Overlay as a fallback for the time being (until I update the patch) . Can anyone suggest how to download older versions of mods via the new "File Archive" function of Nexus? I can't get to a download screen on my phone, but there should be a way. 

At the bottom of all Mod page > File pages, there will be an "Archived" button that will  reveal any archived (old) versions .. I think the caveat is that the Archive system had to be up before a mod was deleted. Looks like this one has a bunch of options, and 1.6.3 is at the bottom:

https://www.nexusmods.com/newvegas/mods/67870/?tab=files&category=archived

Share this post


Link to post
Share on other sites

@z929669, @sailor_silicaI have found an older (beta) version of the CR Patch on my Google drive. My memories (and the readme) show it must be independent of Helmet Overlay - so it should not screw up the whole Step setup due to having a master file that no longer exists. I have named this version a "Quick Fix" as I don't have access to my gaming PC at the moment and cannot provide a better resolution. 

Pros:

  • this version should not look for HelmetOverlay.esp and will not crash your whole Step setup.
  • It will give me time to adapt the CR patch to work with the latest version of Helmet Overlay.

Cons:

  • It does not support Helmet Overlay and the NV Interiors Project currently.

I would appreciate it if sailor_silica or @Gregcan confirm that I've indeed uploaded the version that's independent on Helmet Overlay as I have no way to confirm it from my wife's laptop. If that's not the case, I guess we will have to wait till I get back and remove those entries via xEdit.

Share this post


Link to post
Share on other sites

I'm back from my vacation and have properly "fixed" the CR patch to include all features except the extended Helmet Overlay support (so that it will no longer look for Helmet Overlay.esp when the plugin was changed to an .esm in the latest version of the mod). I will attempt to re-add the Helmet Overlay support shortly, but the mod  author changed the way overlays are implemented (via a .txt file rather than FormID list edits) and I will need some time to test it out.

Also updated the install instructions on Helmet Overlay's Step Wiki Page. There are 2 extra steps added.

Thanks everyone for their patience.

  • Like 1

Share this post


Link to post
Share on other sites

Hi guys and thanks for all the work you do here. Unfortunately I have a problem for the first time since using step back form Oblivion.

FNV only loads into the loading screen, no text but music is playing. I started the whole process from the start to make sure I didn't miss something. I went through each section and enable all mods in a section and loaded FNV, all worked fine until I enabled the FNVCRP, then it fails to load. Help please guys.

Share this post


Link to post
Share on other sites

@Majorman

Sorry I've been away a bit myself. The updated patch seems to work perfectly. I'll keep my eyes peeled for future updates and should be able to respond a tad faster in the future. Thanks!

Share this post


Link to post
Share on other sites
On 9/25/2021 at 1:29 AM, Meridian_UK said:

Hi guys and thanks for all the work you do here. Unfortunately I have a problem for the first time since using step back form Oblivion.

FNV only loads into the loading screen, no text but music is playing. I started the whole process from the start to make sure I didn't miss something. I went through each section and enable all mods in a section and loaded FNV, all worked fine until I enabled the FNVCRP, then it fails to load. Help please guys.

I will re-upload the CR Patch with the experimental Helmet Overlay fix later today. Please try the latest version when I do, then report back on your results. Hopefully , it should fix your issue.

Edit: the update is available for download. It re-implements the Helmet Overlay support. I have updated the mod version on the Nexus, so everyone that has downloaded the patch should be notified that there's an update available.

Share this post


Link to post
Share on other sites

I installed the updated file and the game loaded into the main screen ok. I then realised I forgot to run LOOT.

I ran LOOT and then I had the same problem as before. If I put the patch last the game loads fine. After running LOOT it puts the patch 6th from bottom. eg

Step Fallout NV CR Patch.esp

OWB-Path Lights.esp
Simple Interior Lighting.esp
FNVLODGen.esp
tmzLODadditions.esp
Altitude.esp

 

EDIT: Just to test where the game failed to load I ran LOOT again and moved the patch up in the load order one place at a time and ran the game after each move until the patch was back in the place LOOT put it and the game loaded every time. No idea now, the games seems to be working.

Edited by Meridian_UK

Share this post


Link to post
Share on other sites
25 minutes ago, Meridian_UK said:

I installed the updated file and the game loaded into the main screen ok. I then realised I forgot to run LOOT.

I ran LOOT and then I had the same problem as before. If I put the patch last the game loads fine. After running LOOT it puts the patch 6th from bottom. eg

Step Fallout NV CR Patch.esp

OWB-Path Lights.esp
Simple Interior Lighting.esp
FNVLODGen.esp
tmzLODadditions.esp
Altitude.esp

 

EDIT: Just to test where the game failed to load I ran LOOT again and moved the patch up in the load order one place at a time and ran the game after each move until the patch was back in the place LOOT put it and the game loaded every time. No idea now, the games seems to be working.

When it fails to load, are you starting new or loading a save? These issues can always come from a save game that depends on different plugins or load order. Always test by launching a new game to be sure.

Share this post


Link to post
Share on other sites

OK understood, and thanks.

Having said that, would it be ok to use one of the alternate start mods so I don't have to go through the whole vault start again?

Share this post


Link to post
Share on other sites
23 minutes ago, Meridian_UK said:

OK understood, and thanks.

Having said that, would it be ok to use one of the alternate start mods so I don't have to go through the whole vault start again?

That should work fine, but @Majorman will need to confirm to be certain. You should just install and enable it and sort with LOOT to test. You can simply disable it in MO if there are problems.

EDIT: to be safe, use it only for testing and disable afterward (until Majorman confirms). Always sort your mods whenever plugins are added/removed/enabled/disabled

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By TechAngel85
      Discussion topic:
      Here We Go Again - World Interactions by tarlazo
      Wiki Link
       
    • By Newtant
      Hello!

      I've stumbled upon a weird issue that I haven't encountered or read about before. I'm running Windows 8.1 and a fresh install of Fallout New Vegas with no mods so far. I'm trying to get Mod Organizer and the 4GB exe to work together, but despite following all of the advice, tips and workarounds it's still not happening. Right now I can launch the 4GB exe through Mod Organizer. The game starts, I can load a save and 'play'. The problem is that all of the text has disappeared or is invisible. I can only navigate the main menu by memory, the ingame popups regarding the DLC is missing the text as well.

      This issue does not happen if I start the game on its own with the normal exe.
      This issue does not happen if I start the 4GB exe on its own.

      It only happens if I start the either the normal or the 4GB exe through Mod Organizer.

      NVSE is being loaded, it doesn't matter if I'm using NVSE stable or beta.
      I'm using NVAC, without it the game crashes before arriving at the main menu. NVAC seems to be working, the log is showing several handled errors. (Pastebin)
      Yes, I've added '-laaexe .\FalloutMO.exe' to the launch arguments, that helped me get around the access is denied error but produced this text error.
      I did try compatability modes, I've tried starting MO, the 4GB or both as administrator. No dice.

      I've arrived at a point where I really don't know what it could be or what I could try next. One thing I do know, however, is that I can't go back to the pre-MO modding, so I'm turning to you helpful people and hope that someone here has an idea.

      Thanks in advance!
       
      Pictures:
      New Vegas installation folder
      Mod Organizer executable settings
      Disappeared text main menu #1
      Disappeared text main menu #2
      Disappeared text ingame
       
      Edit:
       
      I deleted all of the fallout .inis as well in case some of my text/font settings were messed up, but that didn't work either.
    • By TechAngel85
      Discussion topic:
      Bellyaches HD Dragon Replacer Pack (SE) by Wrig675/I2edShift
      Wiki Link
       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.