Jump to content

Recommended Posts

  • 3 weeks later...
6 hours ago, RainingTacco said:

Why would i get "wrong script error" when using Dyndolod DLL for 1.5.9.7? Are the scripts for newer version? Where i can download scripts for 1.5.97?

None of the files from DynDOLOD contain the text "wrong script error", so it is unclear if that is the actual message or where it comes from.

The papyrus scripts are independent of the runtime version. There is one version for DynDOLOD 2/3 generating DynDOLOD plugins of version 2.45 and one version for DynDOLOD plugins version 3.00 for the large reference workarounds.

Provide an actual proper error report. Refer to the DynDOLOD 3 Alpha thread.

Link to comment
Share on other sites

3 hours ago, sheson said:

None of the files from DynDOLOD contain the text "wrong script error", so it is unclear if that is the actual message or where it comes from.

The papyrus scripts are independent of the runtime version. There is one version for DynDOLOD 2/3 generating DynDOLOD plugins of version 2.45 and one version for DynDOLOD plugins version 3.00 for the large reference workarounds.

Provide an actual proper error report. Refer to the DynDOLOD 3 Alpha thread.

 

"Dyndolod.dll scripts are wrong version"  in MCM - "Dyndolod.dll papyrus scripts are wrong version".Dyndolod dll is loaded after Dyndolod scripts which overwrite resources as required in FAQ. 

I use 1.5.97 DLL with newest scripts. I couldn't find scripts for 1.5.97. 

Edited by RainingTacco
Link to comment
Share on other sites

12 minutes ago, RainingTacco said:

"Dyndolod.dll scripts are wrong version"  in MCM - "Dyndolod.dll papyrus scripts are wrong version"

I use 1.5.97 DLL with newest scripts. I couldn't find scripts for 1.5.97. 

If WorkaroundLargeReferencesBugs=1 is used, install the DynDOLOD DLL SE - Scripts 3 as linked from the requirements. https://dyndolod.info/Help/Large-Reference-Bugs-Workarounds#Requirements

Link to comment
Share on other sites

"Always download the DynDOLOD DLL [SE/VR] - Scripts archive and one of the DynDOLOD DLL [SE/VR] - [SKSE64/SKSEVR] Plugin archive for the SKSE version and game runtime version that is used."

 

I would love to do that, but dyndolod website nor nexus doesn't provide archive for older version of scripts for 1.5.97. There's only ONE download for scripts and i assume they don't work with 1.5.97 DLL. 

 

 

Link to comment
Share on other sites

6 minutes ago, RainingTacco said:

"Always download the DynDOLOD DLL [SE/VR] - Scripts archive and one of the DynDOLOD DLL [SE/VR] - [SKSE64/SKSEVR] Plugin archive for the SKSE version and game runtime version that is used."

 

I would love to do that, but dyndolod website nor nexus doesn't provide archive for older version of scripts for 1.5.97. There's only ONE download for scripts and i assume they don't work with 1.5.97 DLL. 

The papyrus scripts are independent of the runtime version. There is one version for DynDOLOD 2/3 generating DynDOLOD plugins of version 2.45 and one version for DynDOLOD plugins version 3.00 for the large reference workarounds.

As I already explained, all runtimes / DLLs use the same scripts, that is why the sentence says to "always download the DynDOLOD DLL [SE/VR] - Scripts archive"

Link to comment
Share on other sites

Ok your archived links finally worked - would be nice if they were visible on nexus. I propose making it easier to see. Dyndolod is great program, but the website...ugh, it's like straight outta 90s with things thrown all over the place. 

Edited by RainingTacco
Link to comment
Share on other sites

22 minutes ago, RainingTacco said:

Ok your archived links finally worked - would be nice if they were visible on nexus. I propose making it easier to see. Dyndolod is great program, but the website...ugh, it's like straight outta 90s with things thrown all over the place. 

On the contrary, things are not thrown all over the place and the website is as modern as it gets. https://mother****ingwebsite.com

There is exactly one page that explains everything about the experimental workarounds: https://dyndolod.info/Help/Large-Reference-Bugs-Workarounds.
The requirements with the links are already there and fully explained. Nothing else is needed for the current experimental state of the workarounds.

DynDOLOD 3 is an ALPHA version to ALPHA test and find problems. https://dyndolod.info
This website and DynDOLOD 3 are currently an ALPHA version to test things and iron out bugs.
Certain things may be incomplete, not work as expected or change considerably between versions.

The experimental workarounds are obviously for experienced users already participating in the ALPHA test. 

The experimental scripts are not shown on Nexus deliberately for the time being, because Nexus users would just mindlessly download them because they are newer and thus there would be thousands of posts about the scripts being the wrong version since those users would not know about and also should not test the experimental workarounds.

  • Like 1
Link to comment
Share on other sites

I had no workaround enabled and yet the message was there. Seems that Dyndolod Alpha 3.0 needs different scripts, and they were buried in "large reference" subsection.

Edit: Ok it was only disabled in MCM, and enabled in dyndolod_sse.ini. Seems that it bakes it into .esm/.esp on every new game. 

Edit2: Yep definitely, the large workaround is baked into the very dyndolod files, and reenables itself every new game. So if you want no large reference fix, you need to redo the dyndolod. I thought it will be toggleable fix, but it needs different scripts and reenable itself everytime. 

Link to comment
Share on other sites

3 hours ago, RainingTacco said:

I had no workaround enabled and yet the message was there. Seems that Dyndolod Alpha 3.0 needs different scripts, and they were buried in "large reference" subsection.

Edit: Ok it was only disabled in MCM, and enabled in dyndolod_sse.ini. Seems that it bakes it into .esm/.esp on every new game. 

Edit2: Yep definitely, the large workaround is baked into the very dyndolod files, and reenables itself every new game. So if you want no large reference fix, you need to redo the dyndolod. I thought it will be toggleable fix, but it needs different scripts and reenable itself everytime. 

By default DynDOLOD 2/3 generate plugins with version 2.45, hence they use the same version of scripts 2.8x since years. They are the first download link on the Nexus page.

https://dyndolod.info/Help/Large-Reference-Bugs-Workarounds#Requirements
This will generate DynDOLOD plugins and data files with the version 3.0 instead of version 2.45. That means updated papyrus scripts are required.

https://dyndolod.info/Help/Mod-Configuration-Menu#Large-References-Fix
If the large reference system is used (uLargeRefLODGridSize > uGridsToLoad), the Large Reference Fix checkbox should be checked, so that dynamic LOD objects for large references in the FarGrid switch correctly.

Link to comment
Share on other sites

  • 2 weeks later...

I use Vortex.  I noticed something in Gamer Poets video I saw about the load order between dyndolod dll - scripts and dyndolod dll - dll(whichever version of game).  It appears the video shows scripts loaded before dll.  But on your site, I see you have scripts loaded after dll.  Im going with what you have, but am curious if I am correct on this?

Link to comment
Share on other sites

2 hours ago, Kansas72 said:

I use Vortex.  I noticed something in Gamer Poets video I saw about the load order between dyndolod dll - scripts and dyndolod dll - dll(whichever version of game).  It appears the video shows scripts loaded before dll.  But on your site, I see you have scripts loaded after dll.  Im going with what you have, but am curious if I am correct on this?

As with MO, you can use Vortex to check for file conflicts among enabled mods.

You will find that these two files have none and can be merged into a single mod (they are components of one mod), so mod priority doesn't matter between the two.

Install this mod after DynDOLOD Resources (this mod should have higher priority).

Link to comment
Share on other sites

2 hours ago, Kansas72 said:

I use Vortex.  I noticed something in Gamer Poets video I saw about the load order between dyndolod dll - scripts and dyndolod dll - dll(whichever version of game).  It appears the video shows scripts loaded before dll.  But on your site, I see you have scripts loaded after dll.  Im going with what you have, but am curious if I am correct on this?

It does not matter since the DynDOLOD DLL and the DynDOLOD DLL scripts have no conflicting files.

https://dyndolod.info/Help/DynDOLOD-DLL

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.