Jump to content
  • 0
Sign in to follow this  
Wolfstorm321

How to solve this? Vanilla retextures wont show in LOD

Question

I've made a retexture for the vanilla Whiterun windmill. 

Used a new entry, as these are separate placements. I didnt wanted to interfere with the original model. 

 

First try, using texture sets for the new colors: 

 

windmill01.jpg

 

Second try, copied the mesh and put these textures inside the mesh, using Nifscope: 

 

windmill02.jpg

 

Both times, I used the full model for the LOD, as seem below: 

 

windmill03.jpg

 

If I used the standard LOD, I would not get the new textures, as it would load the LOD from the standard vanilla texture. 

In both times, I ran TexGen and Dyndolod. I've got the same result: 

 

windmill04.jpg

 

Why this is happening? I ran TexGen, ran Dyndolod, ran xLodGen for the terrain (although the terrain dont have anything to do with these objects), but I'm still getting the vanilla LOD, for a object with a entire separate entry, using a different mesh, and assigned the full model for the LOD mesh in the CK. 

This is also happening with other vanilla objects, copied from the nordic ruins and retextured, and which passed through the same processes, also using full models for the LOD mesh in the CK. They all show the vanilla LOD when distant. 

This is not happening with custom meshes from other authors, though. These are running fine with retextures, even using the same meshes with texture sets. Only vanilla meshes are being affected. 

Is there a special rule I should put in Dyndolod for it? I tried this one below, but still got the same result: 

 

windmill05.jpg

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Mesh rules take priority over the base record LOD assignments unless the "use original LOD assignment" is checked. It should fall back to the base record definitions if there is no matching rule (and no wrfarmhousewindmill2_lod*.nif).

 

The (partial) path/filename.nif of the mesh rule needs to match the model assigned to MODL - Model Filename.

 

In the screenshot the VWD flag is set. Right next to check box it says "apply rule only if matching LOD meshes exist", which means the rule is only applied if a wrfarmhousewindmill2_lod*.nif exists, which is most likely not the case. So do not set the VWD to make it use the full model in this case.

 

In case the full model is used for LOD, DynDOLOD should also be using any replacement textures defined on the base record when generating LOD.

 

If you still have trouble with this, upload the plugins/models/rules so I can have a look.

Edited by sheson

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.