Jump to content
Sign in to follow this  
dreamer1986

Compass/HP/AP missing after finishing install

Recommended Posts

I noticed these are missing from my game. I initially thought that maybe ihud was to blame, but even if I don't activate it, these are still missing.

 

Did anyone encounter this problem, and if you did, can you please tell me how to fix it?

 

Thanks,

Dreamer

Share this post


Link to post
Share on other sites

I really don't understand how all these problems occur to you people. You just follow the guide and everything works just fine.

 

Ok, maybe I haven't installed everything since some mods are just a matter of preference, but especially after UIO the User Interface section is more than a piece of cake to accomplish. Imagine that in the past we had to deal with specific mods being able to install only through FOMM, then create mods from the Overwrite Folder in MO, sort them, look out for overwritten xml's, even manually manipulating xml's to include features from one hud mod with the other, etc.

 

What I did was exactly following the guide's instructions for the mods I have included in my setup.

 

pDpcj8r.jpg

 

 

I haven't installed the Advanced Recon mods for my own preference reasons and to save up some plugin slots, the Flashlight mod because I never actually used it or find it any useful in general, the Powered Power Armor mod again for preference/plugin space reasons and the same applies for the JIP mods. The Supplemental UI section is again a matter of taste for each individual but its not so critical overall. Mods like the descriptive icons or the no more dots mods are again a personal choice to not include them, but other than that if you install everything the way and order the guide instructs you there is 0 problems, at least for me.

 

But even with all of them installed, like I did in a previous setup everything worked flawlessly as far as I remember. I would remember a missing compass and HP/AP bars for sure!

 

I didn't tweak any of the occurring overwrites I just let them be in the order I installed the conflicting mods. After all, UIO is taking care of everything.

 

Sorry if I sound aggresive, but there are so many topics popping about UI issues while in the meanwhile I can't seem to reproduce anything no matter how faulty I try to install the mods in the guide in order to let's say find the issue of yours and others problems. It's just non sense :O_o:

Share this post


Link to post
Share on other sites

Indeed you sound aggressive. I also followed the guide as carefully as I could, but I skipped less mods than you, and maybe that's why I have this problem.

 

Anyway, my load order is this:

Active Mod Files:

 

00  Fallout3.esm
01  Anchorage.esm
02  ThePitt.esm
03  StreetLights.esm
04  BrokenSteel.esm
05  PointLookout.esm
06  Zeta.esm
07  Unofficial Fallout 3 Patch.esm  [Version 1.8]
08  CALIBR.esm  [Version 1.4]
09  Advanced Recon Tech.esm
0A  Inventory Access.esm
0B  aHUD.esm
0C  iHUD.esm
0D  Mart's Mutant Mod.esm
0E  ArefuExpandedByAzar.esm
0F  DCInteriors_ComboEdition.esm
10  EVE.esm  [Version 0.99]
11  AWorldOfPainFO3.esm
12  Vault 101 Revisited.esm
13  WastelandGuards01.esm
14  CRAFT.esm
15  FO3 Wanderers Edition - Main File.esm
16  Detect Traps.esm
17  tubrrCompound.esm
18  Enhanced Weather - Rain and Snow.esm
19  Xepha's Dynamic Weather.esm
1A  Project Beauty.esm
1B  xCALIBR.esm
1C  20th Century Weapons.esm
1D  CrowdedCities_v2.esm
1E  DarNifiedUIF3.esp
1F  Advanced Recon Tech.esp
20  Advanced Recon Range Finder.esp
21  Flashlight-LOS.esp
22  DynamicCrosshair.esp
23  Stimpak Counter.esp
24  PPA - The Pitt.esp
25  JIP Realistic Weapon Overheating.esp
26  JIP Selective-Fire.esp
27  YearlingBooks.esp
28  Confessor Cromwell has a Break_EV.esp
++  PaladinHossPekFix.esp
29  CASM.esp
2A  The Mantis Imperative - Mantis.esp  [Version 1.08]
2B  FO3 Wanderers Edition - Main File.esp
2C  WeaponModKits.esp
2D  WeaponModKits - FWE Master Release.esp
2E  FO3 Wanderers Edition - DLC Broken Steel.esp
2F  20th Century Weapons -Plus- Reborn FWE-WMK-Calibr14_V1_70RC_18668.esp
30  MetroCars.esp
31  Big Town Overhaul [GangStore].esp
32  FortIndependenceRedesigned.esp
33  FO3 Wanderers Edition - DLC Anchorage.esp
34  FO3 Wanderers Edition - DLC The Pitt.esp
35  UUF3P - FWE Patch.esp
36  Realistic Interior Lighting.esp
37  Blackened FWE + MMM + EVE + Project Beauty.esp  [Version 3.3]
38  ArlingtonRestoration.esp
39  tubRRCompound.esp
3A  Rivet City Realignment.esp
3B  Temple of the Union Overhaul.esp
3C  Caravan Merchants Heal After Combat.esp
++  DIFF.esp
3D  The Mantis Imperative - Jello.esp  [Version 1.08--ADVENTURE]
3E  HeirApparent.esp  [Version 1.81]
++  FO3 Wanderers Edition - DLC Point Lookout.esp
3F  Advanced Recon Tech FWE.esp
40  Laurens_Bathroom_poetry_V1.esp
41  Xepha's Dynamic Weather - Main + DLC Merged.esp
42  DCInt_ARoomWithAView.esp
43  PLweightadjust.esp  [Version 1.08]
44  NotSoFast.esp  [Version 1.07]
++  WeaponModKits - FWE Talon Loot Crash Fix.esp
45  JIP Companions Command & Control.esp
46  FO3 Wanderers Edition - DLC Mothership Zeta.esp
++  The Mantis Imperative - Nasty Zeta No Scaling.esp  [Version 1.1]
47  MoreMapMarkers.esp
48  BaileysCrossingMetro.esp
++  Hi-Res Weapons & Ammo Textures - The Pitt.esp  [Version 1.2.0]
++  Hi-Res Weapons & Ammo Textures.esp  [Version 1.2.0]
49  RubblePilesFix.esp
4A  Enhanced Weather - Weather Sounds in Interiors.esp
4B  Xepha's Dynamic Weather - Dynamic Sneak Bonus.esp
++  Xepha's Dynamic Weather - Green Tint Remover.esp
4C  Xepha's Dynamic Weather - Rain.esp
4D  Xepha's Dynamic Weather - Sandstorms.esp
4E  UrgeWashingtonBoS.esp
**  Project Beauty- Broken Steel.esp
**  Project Beauty- Point Lookout.esp
4F  K9Breeds.esp
50  BBBackpacks-v1-1.esp
51  Museum.esp
52  K9BreedsMoreDogs.esp
53  Kentbury Way.esp
54  Dree Perks.esp
55  Existence2.0.esp
56  CanterburyCommonsInteriors.esp
57  Xepha's Dynamic Weather - Weather Machine (Quest Added).esp
58  AutoGates.esp
59  Xepha's Dynamic Weather - Weather Machine (Vendor Added).esp
++  K9BreedsPatchDLCPitt.esp
5A  FeralGhoulTest.esp
5B  GlowingGhouls-MMM.esp
5C  Dragonskin Tactical Outfit.esp
5D  Advanced Recon Gear.esp
5E  Detect Traps Merged.esp
5F  Powered Power Armor.esp
60  PPA - Broken Steel.esp
61  PPA - FWE.esp
62  PPA - Mothership Zeta.esp
63  PPA - Operation Anchorage.esp
64  DragonskinBonusPack.esp
65  UniqueWeaponsRetextured.esp
++  UniqueWeaponsRetextured_FWE.esp  [Version 1.2]
66  WeaponModKits - BrokenSteel.esp
67  WeaponModKits - OperationAnchorage.esp
68  WeaponModKits - ThePitt.esp
69  UniqueWeaponsRetexturedPITT.esp
++  UniqueWeaponsRetexturedPITT_FWE.esp  [Version 1.1]
++  xCALIBR_20CW_v5.12.esp
6A  WeaponModKits - Zeta.esp
6B  WeaponModKits - PointLookout.esp
6C  PLFewerItems.esp
++  20th Century Weapons Non-Changing Weapon Conditions.esp
6D  CALIBRv14 Ammunition Schematics for FWE-WMK-CRAFT-V1_3-18639.esp
6E  Brahmin Dairy Products.esp
6F  ZL-SVD-CALIBR.esp
70  IntoTheDeepWoods.esp  [Version 1.061]
71  ArefuExpandedByAzar-FixOptFireBarrels.esp
72  RockopolisRebuilt.esp
73  CONELRAD 640-1240.esp
74  ArefuExpandedByAzar-Radio.esp
75  PAL - MERGED.esp
76  megalight.esp
77  FO3NeckChains.esp
++  Chems and Meds Re-Textures Pack.esp
++  Paradise Lost - Unique Texture and Icon.esp
78  RagdollOverhaulFo3.esp
++  AnimatedFanV2f3.esp
79  GNR Enhanced.esp
++  PPA - FWE 2.esp
++  PPA - FWE Tougher NPC Power Armour.esp
++  Dragonskin_for_FWE_2014.esp
++  SVDForFWE.esp
7A  20th Century Weapons -Plus- Reborn Cut Weapons.esp
++  FO3LODGen.esp
7B  Flora Overhaul.esp
7C  Bashed Patch, 0.esp

 


 

Edited by dreamer1986

Share this post


Link to post
Share on other sites

User Interface problems in almost all cases are not a load order issue. It's just what xml file loads finally in your game. And of course how organized that specific xml is and what it contains. Which is what UIO is helping you with.

 

The only visual conflict I can think of is with let's say 2 mods that both include an interfaceshared0.dds file in which case you'll be missing the customized icons, compass arrows, or whatever from the overwritten mod.

 

Bare in mind, that the other UI problem I saw somewhere recently with the missing menu/mouse pointer when starting the game is not always a fonts/UI issue. I use a weapon replacer mod not included in the guide called Book Of Earache(BOE) which when loaded together with the any of the Big Town Overhaul's plugins it would make my menu/mouse disappear. Both mods do not conflict anywhere, either files or records in FO3Edit, but I would get this problem no matter what. FO3's engine is bugged as hell and nothing can be done about it.

 

My advice, copy your current profile into a new testing profil and untick all the mods till your UI section. Start testing your hud in-game from there and make sure that everything works fine. Then add every section of the guide one by one (ok obviously you can skip this with the textures mods or mods that generally include only textures, meshes or sounds) testing your hud in-game until you find what bugs your game. Although I doubt it would be any mod later in the guide.

Share this post


Link to post
Share on other sites

Thanks for trying to help me. I was hoping it would be something that I could fix easier. And anyway, I have bigger problems right now, with the MO profiles getting corrupted after a time, it seems, leading to "Fallout 3 has stopped working". How tiresome.

Share this post


Link to post
Share on other sites

Verify integrity of game files in Steam or do a complete re-install of the game if not using a steam version. Run the FalloutLauncher.exe choose your video settings (Antialiasing and Anisotropic Filtering ---> Off, HDR ---> ticked, Water Displacement ---> unticked if planning to use ENB), launch the game choose your in-game settings (white fonts for optimal performance of Better High Detail Map mod, untick all autosave options), exit and then go in your Documents and set your newly created fallout.ini and falloutprefs.ini to read-only. Probably you should do the same for the Fallout_Default.ini (if it's not already by itself) in your Data folder.

 

After all these, start MO create a profile, then go into your installation folder/Mod Organizer/profiles/your profile/ and untick the fallout.ini and falloutprefs.ini from being read-only so you can tweak and change them for that specific profile you created.

 

That's how I keep my vanilla ini's intact and backed up. You can do all the font changes, Quad core fix tweaks and generally all the tweaks suggested by the guide in that MO profile's specific ini's.

Always keep a totally vanilla FO3 profile in MO with just the official DLC's (maybe also the Updated Unofficial FO3 Patch) just for the sake of it, it's never a bad idea.

It's also a good practice to create a new profile every time you finish a section of the guide and after you've checked that the previous one is working correct in all aspects. That way, when you screw something and come to a dead end you can always delete that profile, copy the previous one and continue from a point you know it is working fine.

 

A general suggestion I remember seeing from some old Fallout Remastered topics would be to start a completely vanilla gamethrough, do all the generic stuff until you exit the Vault 101. Make a hard save there and start modding/testing your mods from that save on. It doesn't matter if it makes sense or not, this game is the most crash prone and bugged game I've ever seen so even pointless things matter.

 

After you do all this and finish the UI section I might be able to help you personally with any problem, since I've followed this process like more than 30 times the last 1.5 year so I remember any issue that I came across.

 

Believe me I have completed this guide multiple times just to start the game and see it crashing, not loading, not behaving as expected, etc. I've been where you are now so many times it's not even funny mentioning it anymore. Modding is a continuous trial & error process and every time you start from the beginning at least you feel stronger and far more experienced than the last one.

 

When you finish all this, we can start talking about load order stuff since me personally I disagree with the use of LOOT or BOSS, since both are not perfect and have major flaws (for LOOT the fact that it places weather plugins like in the middle of your load order is just something to begin with).

 

PS. I've never had any profile getting corrupted in MO. First time I read about that. Can you specify what do you mean by "corrupted"? A profile working fine and the next day not working?

Edited by Brainfever

Share this post


Link to post
Share on other sites

1. Several user comments suggest that the fomod installer in MO doesn't always provide the right files. The two most problematic cases are the "FWE_Master_Release_6-0_-_Part_1" file and the "Better High Detail Map and Icons" file. In both cases there isn't much real need for the fomod installer with these mods and this guide since what needs to be installed is straightforward, and the installation is fairly easy to do manually. I'll add some material in the guide about doing so for these two mods.

 

2. With the use of MO and UIO, the UI mods other than the DarnUI mod, FWE and associated files, Dynamic Crosshair, and aHUD should be easy to install, and their MO priority can be changed without causing problems as long as the mods that UIO needs to see have lower installation priority than UIO each time the game starts (UIO rebuilds the main HUD xml file each time the game starts). As Braintree mentions, these UI mods can even be left out and installed later, as long as they are then put into the correct installation order.

 

3. The UIO Nexus page describes what is needed to add a mod; it basically says to add a file that includes the name of the folder and xml file inside "menus\prefabs". Any mods that do more to the "menus" folder than adding a folder inside  prefabs and an xml file can potentially cause problems unless the proper steps are taken. aHUD is problematic because it also modifies the primary HUD menu xml file, and for UIO to recognize that a mod has added a new version of hud_main_menu.xml that has higher priority than the one that UIO saw the first time it ran it is necessary to delete the copy of "menus\main\hud_main_menu.xml.uio" in Overwrite. If aHUD is added after UIO is run the first time, the fix for aHUD is in the guide; if aHUD is used without this fix the visibility of some UI elements like the compass might be affected.The fix for Dynamic Crosshair is also in the guide; even though UIO says is supports Dynamic Crosshair there are problems without this fix.

Share this post


Link to post
Share on other sites

Thank you for the replies, Kelmych and Brainfever. 30 installs? Wow, I admire your patience ::): .

 

My current problems seem to go far beyond UI it seems.

 

Yes, Brainfever, when I say that MO profiles get corrupted, I mean that they work for a while and after I get "Fallout has stopped responding". Initially, I fixed that by returning to the default profile, which had the original esm's, and activating and ordering all the mods in the left panel. And the game worked fine, for about one hour and a half. But then I deactivated ahud, to see if that fixes the missing compass, and I again get "Fallout has stopped responding", even if I reactivate ahud. And it seems that all profiles are affected now, even the default :confused:

 

I think maybe the only solution is to completely reinstall, but I don't have the energy to do that right now, especially since at the end I might have the same weird MO problem. Maybe in a couple of weeks.

Edited by dreamer1986

Share this post


Link to post
Share on other sites

When UIO is used you can't just deactiveate aHUD (since it has the copy of "menus\main\hud_main_menu.xml" with the highest MO priority). If you do this you also need to delete the file: "menus\main\hud_main_menu.xml.uio" in Overwrite in the left pane of MO before restarting the game so UIO will properly regenerate this file. If you later reactivate aHUD you need to copy the original version of this file from the archive file of aHUD into "Mod Organizer\mods\aHUD\main\menu" and do this deletion again before restarting.

 

Ideally UIO would put the current version of "menus\main\hud_main_menu.xml" in UIO itself, but unfortunately it doesn't. This causes problems unless you are careful with any mods that have this file since if they have the highest priority version of the file UIO will replace this file with one that UIO creates.

Share this post


Link to post
Share on other sites

Just wanted to say that I made a complete reinstall, being a lot more careful than the first time, and removing about a third of the mods I originally selected, and the game seems to work! Even the compass works correctly this time. Just Lucas Simms still doesn't have arms, like last time, and I have some black spots on my characters skin for no reason, but I'll settle with that. I'm just happy that it works!

 

Thank you, again, Kelmych, for this great guide! ::):

Edited by dreamer1986

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By sheson
      This is a beta of [FNV|FO3|FO4|FO4VR|TES5|SSE|TES5VR|ENDERAL|ENDERALSE]LODGen/Edit with terrain LOD meshes and textures generation.
      This is for experienced mod authors and users that know how to use xEdit, xLODGen or DynDOLOD already.
      Installation and Setup
      Download
      xLODGen beta 86 - based on 4.1.4b
      Unzip into a dedicated folder outside of any Steam, game or mod manager folders or special Windows folders like Program Files.
      Rename xLODGen.exe to [game mode]LODGen.exe (TES5LODGen.exe for example) or start with command line parameter -fnv, -fo3, -fo4, -fo4vr, -tes5, tes5vr, -sse, -enderal, -enderalse
      Use -o:"c:\OutputPath\" command line parameter to change where files are generated to, default is the game folder.
      Do not generate into any game or any mod manager folders.
      Requirements
      Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 - Required by LODGen.exe/LODGenx64.exe and Texconv.exe/Texconvx64.exe. Get matching platform x86/x64 depending on which xLODGen.exe (x86) or xLODGenx64.exe (x64) is used.
      RTFM and Share Results
      See the included Skyrim-Occlusion-Readme.txt for a brief explanation of the Skyrim TVDT Occlusion data generation. Read the hints that are shown when the mouse pointer rests on a setting. Ask specific questions or give feedback in the dedicated Skyrim TVDT - Occlusion Data thread.
      See the included Terrain-LOD-Readme.txt for a brief explanation of the settings for terrain LOD generation. Read the hints that are shown when the mouse pointer rests on a setting. Ask specific questions about terrain LOD in this thread for a more in-depth explanation if required and share feedback (with screenshots) about results or problems.
      These tools generate LOD meshes and textures "exactly" like CK, but not like the meshes and textures which are shipping with the games (they are often manually edited).
      However, these tools provide more options and higher resolutions (use the x64 version if there are memory errors because you believe you require 4k or higher) and can be updated to add more useful features and options.
      I did some testing in the different games, but finding the best combinations of options and settings requires lots of testing and are a matter of personal opinion and which game is used, the load order, mods, even different worldspaces probably.
      That means, I am only able to give generic guidelines and hints to send you off to find and test for yourself and share your results. My main interested is that generations works correctly and without problems for now.
      Check out the thread xLODGen Terrain Settings Compare. Also refer to any modding guide which has a list of relevant mods close to your load order.
      The object and tree LOD generation is the same as the current versions of xEdit / xLODGen. Refer to their respective descriptions and explanations.
      Obviously, users of Skryim/Enderal/Skyrim SE/Skyrim VR/EnderalSE continue to use the easier and more comprehensive DynDOLOD for drastically improved object and tree LOD generation and only use xLODGen for terrain LOD (and maybe Occlusion) generation.
      First Time
      Here are suggestion to start without going crazy and that should be quick enough to generate:
      Set quality of meshes for LOD4 to 5 and then +5 for each next level. Or just set levels 8/16/32 to 10.
      Check protect cell borders (yes it fixes the ugly terrain drops at outer cell borders that still exist in Fallout 4).
      Use the max vertices setting only if you want to hard limit max file size.
      In Skyrim Special Edition or Skyrim VR, if you notice terrain briefly flickering when new areas are loading in, set [Display] bEnableLandFade=0 in Skyrim.INI
      Set Optimize Unseen to off for LOD4 for first generation. Start experimenting with a value of 550 with a quality setting of 10 or lower for LOD32 (used for map) and compare coastlines and file size to other settings.
      To quickly generate terrain LOD meshes just for the map, check only terrain LOD Meshes, check the Specific Chunk checkbox and set drop down to 32. Leave SW fields empty for complete map or set SW cell coordinates to same values as a *.btr filename to test a specific area with lots of water, river etc.
      Set texture sizes to 512 for a start. Larger sizes and large world spaces will take a considerable time (like 15 to 30 minutes or more easily). Each higher resolution means quadruple the work.
      Use DXT1 for diffuse and 565 (DXT1 if on Windows 7) for normal maps. If generating for Skyrim Special Edition use BC7. Uncheck mipmaps, raise steepness and Bake normal maps.
      For now, leave the Brightness, Contrast and Gamma at 0 and 1.0 respectively. It seems that only Skyrim CK and Skyrim SE CK are manipulating the intensity of the textures to adjust for the noise.dds and the god awful "improved" snow shader of Skyrim SE (just turn that thing off, really). If textures seem too dark in the game, brighten the noise.dds instead or vice versa. That way you can get perfectly matching LOD textures that look just like the textures in the loaded cells. For Skyrim a good average color of the noise texture seems to be around #C0. See below for a couple noise texture downloads.
      If you want to test larger texture sizes, use the chunk option to limit the number of textures that need to be generated. For example, check [x] Specific chunk, leave the drop down empty and set WS to the lower left cell coordinate of an 32x32 area, like 0, 0. It will then generate all textures up to 31,31. Not all worldspaces have their origin at 0,0 so you will have to check already generated meshes/texture filenames for their lower left coordinates.
      Questions and Feedback
      Obliviously anything related to terrain LOD should be posted in this thread.
      Posts related to Occlusion should be made here.
      Recommended Optionals
      TES5-Terrain-Tamriel.esm (Mega), SSE-Terrain-Tamriel.esm (Mega)
      TES5-Terrain-Tamriel-Extend.esm (Mega), SSE-Terrain-Tamriel-Extend.esm (Mega) - These extend the sea of ghost further to the north (see screenshots)
      SSE-Terrain-Tamriel-Full-Extend.esm (Mega) - Entire map from -96,-96 to 95,96 with northern ocean extension. Useful for mod authors.
      Put in game data folder obviously. Adds back terrain for Skyrim (Tamriel worldspace) at the outer edges so there is no missing terrain meshes/textures when generating terrain LOD for Skyrim.
      Load as early with lowest priority as possible, so that any other plugins overwriting or adding land records or cells with the same coordinates take precedence.
      Only required to be loaded when generating terrain LOD. No harm done when loaded in-game but typically the player can not get close to these areas. There are no effects outside the far away added cells.
      Noise
      Single color flat noise, Adjusted vanilla noise, HD Terrain Noise Texture SE
      Examples for Skyrim. Install to game folder like any other texture mod. The noise texture is applied in-game on top of terrain LOD textures, so no effect for LOD generation.
      Only the red channel is used in case the textures is not a grey channel format. MipMaps are ignored. The textures is tiled 3x3 per LOD quad, e.g. for LOD level 4, the noise texture is repeated 3 times to cover 4 cells, for LOD level 8, the noise texture is repeated 3 times to cover 8 cells and so on.
      Test-Terrain-Tamriel.7z
      For testing terrain LOD distances. Plain color terrain LOD textures for Tamriel with coordinates for every LOD quad. Green for LOD 4, yellow for LOD8, blue for LOD 16 and red for LOD 32.
    • By se7enex
      Lucas Simms himself is missing his arms. I can see his gloves but his actual arms are invisible. I can't even begin to imagine what the fluff could be causing that. I did have issues with .32 and Mausers having big red exclamation marks but that's because it REQUIRES (listed in mod guide as optional) the individual weapon remakes. 

      Springvale Sewers, a AWOP location crashes consistently when I try to enter it. 

       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.