Jump to content
TechAngel85

New STEP Vsync Settings (all STEP users affected!)

Recommended Posts

Recently, Z and I did some testing ( testing results are here and the post following it ) regarding user complaints of vsync and iPresentInterval settings. This testing revealed a couple things:

  • iPresentInterval has no affect when placed in the SkyrimPrefs.ini. It belongs in the Skyrim.ini file under the [Display] section. In other words, when setting iPresentInterval=0 in SkyrimPrefs.ini, there is no impact, but doing the same in Skyrim.ini disables vsync.
  • iPresentInterval should always be set to 1; its default

Old Recommendations:

  • set iPresentInterval=0 in the SkyrimPrefs.ini file
    • This is incorrect and erroneous on our part

New Recommendations:

  • iPresentInterval should be present in neither the Skyrim.ini nor the SkyrimPrefs.ini file
    • Please delete it from both INIs  Should be added to Skyrim.ini under [Display] as iPresentInterval=1
  • Set vsync in the video drives to "application controlled" for your card
    • see updated instructions below for both AMD and Nvidia users
  • Enable vsync in the enblocal.ini file for ENBoost

The new recommendation is to add iPresentInterval to the Skyrim.ini files. Users can view the updated instructions for ENBoost here and go here for the video card drivers. ALL users should update by following the new instructions to ensure their game and system are set up properly for STEP.

 

The Changelog has been updated to reflect all changes as well as all applicable Guides.

Share this post


Link to post
Share on other sites

With the old settings everything went smoothly with 50 to 60fps

Then I changed it according to this suggestion and now I get stutter every 2 or 3 seconds and a framerate drop to sometimes 20 to 30fps.

 

Surprisingly changing back to the old settings doesn't help.

 

That is really confusing.

 

Any suggestions?

Share this post


Link to post
Share on other sites

If changing it back doesn't help, then it isn't this that is causing your issue. Open a support request in the Support Forum for more help.

Share this post


Link to post
Share on other sites

I deleted the iPresentInterval line from my Skyrim.ini and SkyrimPrefs.ini files by starting Mod Organizer > Tools > INI Editor.
However, when I open the MO > Tools > Configurator the iPresentInterval setting is still there and it's set at "1". I can set it to "0". But I cannot delete it, AFAIK.
Am I doing something wrong?

I navigated to E: Steam/SteamApps/common/Skyrim to edit enblocal.ini setting iPresentInterval to "true".
This has got to be correct, right?

I am having problems configuring the settings in the Nvidia Inspector.
Antaliasing Mode: I have the option "App Control". I assume this is correct.
Antialiasing Setting: There is no "Application-controlled / Off" option. There is "None" and then a huge list of Multi-Samples, Super-Samples and Mixed Samples (and a few other options). None of the options is 2x2 or 4x4. There's 2x_H, 2x_V, 4x, 4x_BIAS, 4x_GAMMA.

Anisotropic Filtering Mode: There is no "User Defined / Off" setting. There is "Selector User", "Selector App", and "Selector Cond"
Anisotropic Filtering Setting: 16x (good here)

Vertical Sync Tear Control: There is no "Standard" setting. I have "Enable" and "Disable".
Vertical Sync: There is no "Use 3D Application" setting. I have "Force On", ForceOff", "Passive", "FlipInterval 2", "FlipInterval 3", FlipInterval 4".

What am I doing wrong?

Nvidia Inspector 1.9.7.3
GeForce Experience 2.1.4
3D Vision Controller Driver v344.75
3D Vision Driver v344.75
Graphics Driver v344.75
HD Audio Driver v1.3.32.1
PhysX System Software 9.14.0702

Windows 7

Share this post


Link to post
Share on other sites

The instrcutions are kind of incorrect.

I dont know why it was worded like that and i dont have nvidia so yeah, just a heads up.

 

Ipresetinterval should be in skyrim prefs and set to 1

Ipresetinterval should not be in enblocal.ini

 

The mode is correct and i assume that the setting doesnt take effect because the mode is set to application controlled

 

I am unsure of the af setting so leave it on what it currently is but enb should override it regardless... maybe

You'll know when it is not working.

 

For vsync use passive and tear control to what setting it is currently on

 

Youre not doing anything wrong, the instructions are a bit dodgy.

dont look at me, I didnt write it.

:p

Share this post


Link to post
Share on other sites

Don't want to mess things up but I'm sure the latest guides say to remove iPresentInterval from all inis that have it and let the graphics cards' control software set the vsync.

 

As to the 'Configurator' tool. I think it is best to use something else to edit the inis. Not too sure how that GUI is populated but the listing of that setting may just be an artifact and not actually in the ini that is used.

 

Use the 'INI Editor' or just edit them with Notepad.

Share this post


Link to post
Share on other sites

- iPresentInterval needs to be set in skyrim.ini or it will have no effect.

- if iPresentInterval is not set in skyrim.ini it always defaults to 1

- if iPresentInterval is not in any ini file and you change the value in configurator then it will be placed in skyrim.ini and it will work

- if iPresentInterval is in skyrimprefs.ini and you change the value in configurator then the setting will remain in skyrimprefs.ini and will have no effect (configurator trusts YOUR placement of settings over its own)

 

Now the fun part: The ini files generated automatically by skyrim itself (through the launcher) place iPresentInterval in skyrimprefs.ini!

Let me repeat that: Skyrim itself places this setting (and who knows how many else) in the wrong ini file.

Share this post


Link to post
Share on other sites

 

- if iPresentInterval is not in any ini file and you change the value in configurator then it will be placed in skyrim.ini and it will work

- if iPresentInterval is in skyrimprefs.ini and you change the value in configurator then the setting will remain in skyrimprefs.ini

I think the point here is the 'Configurator' shows this setting as the default, 1, if the Skyrim.ini is edited outside of MO and that setting is removed.

But this GUI doesn't reflect what is in the ini unless a change is made and saved by that GUI.

The current discussion about vsync done by STEP suggested removing this setting, not setting it to 0, thus it doesn't exist.

Use of the 'Configurator' then shows this setting has returned even though the actual ini doesn't show it? Correct?

 

No ini setting == iPresentInterval is on

The only way to disable it is to change it to 0, correct?

 

Also I think it may be safe to say that since the ENB acts an extension to the Skyrim executable, if it is set in the enbseries.ini then for all intents and purposes, it is the same thing as it being set in the Skyrim.ini.

But I think the testing showed that it needs to be removed in skyrim.ini as it will be set by the ENB.

 

So, if you have an ENB this needed setting is in that ini not the Skyrim one.

Edited by GrantSP

Share this post


Link to post
Share on other sites

This is really weird, because I swear it kind of did something when placed in skyrimprefs.ini before - like few months ago when I still played Skyrim. Everytime I set it to 0, my FPS went crazy into 150+ range, even with vsync on in enblocal.ini. Now it seems to work exactly like this thread says. Weird!

Share this post


Link to post
Share on other sites

Yeah I know what you mean.

I am trying to get my head around all of this and seeing conflicting input isn't making this easy.

 

Some things I'm sure about, some I'm 50% sure and some I have no idea about. When all those areas converge, as in this case: Skyrim + ENB + MO + user input.

 

aarrrrrrghh :O_o:  :wacko:

Share this post


Link to post
Share on other sites

No...

ipresetinterval NEEDS to be in skyrim prefs.

Its there by default.

 

It also needs to be set equal to 1 which is also default

 

Its not in the wrong location. You disable it and fps is greater than 60.

Share this post


Link to post
Share on other sites

No...

ipresetinterval NEEDS to be in skyrim prefs.

Its there by default.

 

It also needs to be set equal to 1 which is also default

 

Its not in the wrong location. You disable it and fps is greater than 60.

Incorrect and you need to stop saying such without the testing to back it up. You're confusing people. Z and I have done extensive testing (Freyrgjurd also helped out). Tannin has also confirmed the same. iPresentInterval does nothing when placed in SkyrimPrefs.ini. Follow the links and do the testing yourself to confirm and post your result. Until that happens and we see the evidence through testing, you're words above will be taken with a grain of salt. (that's harsh, blunt and straight to the point, but no need to sugar coat it) If you are 100% positive of your accuracy in your statement, you need to complete the testing so we can look into it properly. You've got to back up your claims with testing around here because when you tell me one thing that contradicts what others are saying and claiming, I'm going to asking, "where's the proof?"

 

Tannin is 100% accurate on his post.

 

We recommend deleting the parameter altogether from both places which will tell Skyrim to use the default value of 1; therefore, there is no reason to even have it in the INIs when the default value is the correct value. As Tannin said, the configurator places it in the place it was originally placed when it copied the default INIs. Personally, I never use the configurator so I can't vouch for it's usage. I always edit manually.

Share this post


Link to post
Share on other sites

I navigated to E: Steam/SteamApps/common/Skyrim to edit enblocal.ini setting iPresentInterval to "true".

This has got to be correct, right?

 

I am having problems configuring the settings in the Nvidia Inspector.

Antaliasing Mode: I have the option "App Control". I assume this is correct.

Antialiasing Setting: There is no "Application-controlled / Off" option. There is "None" and then a huge list of Multi-Samples, Super-Samples and Mixed Samples (and a few other options). None of the options is 2x2 or 4x4. There's 2x_H, 2x_V, 4x, 4x_BIAS, 4x_GAMMA.

 

Anisotropic Filtering Mode: There is no "User Defined / Off" setting. There is "Selector User", "Selector App", and "Selector Cond"

Anisotropic Filtering Setting: 16x (good here)

 

Vertical Sync Tear Control: There is no "Standard" setting. I have "Enable" and "Disable".

Vertical Sync: There is no "Use 3D Application" setting. I have "Force On", ForceOff", "Passive", "FlipInterval 2", "FlipInterval 3", FlipInterval 4".

 

What am I doing wrong?

As long as iPresentInteral is set to 1 then you're good. We just recommend deleting it although so that it'll default to 1 without the user having to worry about setting it manually. As someone else already stated, iPresnetInterval should be in Skyrim.ini and not in enblocal.ini.

 

As for Inspector, different cards have different settings. I can't account for all of the possibilities because I only have one card and can only give reference to what is available on that card.

 

Antaliasing Mode: Correct. Leave it as application controlled

Antialiasing Setting: You really should have that option as it's a standard option. If you really don't set it to 2x Multisampling.

 

Anisotropic Filtering Mode: What kind of funky nvidia card do you have? My guess where using be Selector User

 

Vertical Sync Tear Control: Enable

Vertical Sync: My guess would be passive.

 

You have some really odd settings for a GTX 770. I have a GTX 760 so you really should have the same options as I do. You're positive you're on the "Elder Scrolls V: Skyrim" profile in Inspector?

Share this post


Link to post
Share on other sites

- iPresentInterval needs to be set in skyrim.ini or it will have no effect.

- if iPresentInterval is not set in skyrim.ini it always defaults to 1

- if iPresentInterval is not in any ini file and you change the value in configurator then it will be placed in skyrim.ini and it will work

- if iPresentInterval is in skyrimprefs.ini and you change the value in configurator then the setting will remain in skyrimprefs.ini and will have no effect (configurator trusts YOUR placement of settings over its own)

 

Now the fun part: The ini files generated automatically by skyrim itself (through the launcher) place iPresentInterval in skyrimprefs.ini!

Let me repeat that: Skyrim itself places this setting (and who knows how many else) in the wrong ini file.

THIS.

 

We suggest removing iPresentInterval altogether from skyrim.ini file to simplify, because it should always be set to '1'. We don't care if it is in skyrimprefs.ini, because it has no effect, but it is simpler to just remove this line from BOTH INIs and avoid the whole semantic discussion.

 

I would guess that because MO built-in Skyrim Configurator is a GUI version of most of the INI content, it houses all settings that it accounts for whether those lines are or are not removed from the INIs themselves ... so we may need to just state exactly what the user should do (i.e., REMOVE iPresentInterval line from skyrimprefs.ini and ADD iPresentInterval=1 to skyrim.ini).

 

@Member121

Regarding the NVIDIA Inspector and card you have installed: I agree with Tech that you seem to have some non-standard settings for such a relevant GPU, so I wonder if you need to update your NVIDIA Inspector software. Your settings are very inconvenient, and I don't use NVIDIA, so I can't be much help as to how prevalent your settings are and if they are GPU dependent or Inspector dependent.

 

Somewhat contrary to what Tech recommends (and only IF your Inspector software is totally up to date and those values are what they are for your card):

 

Antaliasing Mode: I have the option "App Control". I assume this is correct. Yes, and this is the main setting, so the following should be 'None'

Antialiasing Setting: There is no "Application-controlled / Off" option. There is "None" and then a huge list of Multi-Samples, Super-Samples and Mixed Samples (and a few other options). None of the options is 2x2 or 4x4. There's 2x_H, 2x_V, 4x, 4x_BIAS, 4x_GAMMA.

 

Anisotropic Filtering Mode: There is no "User Defined / Off" setting. There is "Selector User", "Selector App", and "Selector Cond"

Anisotropic Filtering Setting: 16x (good here) This would seem to ensure that ENB and/or SKyrim can take control ... 'User' seems global, and 'Cond' seems like some thing configurable using command-line options or something like that.

 

Vertical Sync Tear Control: There is no "Standard" setting. I have "Enable" and "Disable". You should verify that vsync works this way, otherwise use 'Enable' as Tech stated. This is a strange option and seems redundant with the one below.

Vertical Sync: There is no "Use 3D Application" setting. I have "Force On", ForceOff", "Passive", "FlipInterval 2", "FlipInterval 3", FlipInterval 4". This should be the global control that includes the setting just above.

 

Please see that Inspector is latest revision available (the software provider should be updating relatively frequently to account for new cards and their enhanced/added sensors)

Share this post


Link to post
Share on other sites

I just did it the other day...

i set it to zero and my fps went rediculously high.

 

Ill look back but for me its always worked logically...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ShiranZou
      Hi Gang.
      5 days in and I finally found STEP: Core, after looking for guidance from Gopher and GamerPoets.
      I've familiarized myself with the tools needed, and am starting to follow STEP: Core.
       
      However, I am unhappy with the results of using ENBoost.
      I'm unsure if it's actually beneficial to me, having 896 mb VRam and 4Gigs Ram.
      With Vsync enabled, I can hit 30 fps drops too easily, with just 5-10 npcs or looking at Riverwood from the bridge.
       
      I benchmarked in-game and my GPU uses 100% most of the time indoors. 70% outdoors. CPU almost always 30%.
      ^ Using Skyrim Performance Monitor, which refuses to run while ENBInjector is active. So, I'm not sure of the actual effect of ENBoost.
      This is with every possible setting minimized, at 60+fps. Near rivers I can go over 120 fps and get screen flickers... see link.
      https://forums.steampowered.com/forums/showthread.php?t=2580126
       
      I am really hating the notion of using Vsync. Can I use an Fps Limiter instead? If so, which one?
       
      Is ENBoost(or VSync) truly required for every1 following STEP: Core? If so, why is it needed exactly?
       
      My Spec
      https://wiki.step-project.com/User:ShiranZou/SystemSpecs
    • By MaroES
      Please look at my settings in this album I made before giving suggestions.  https://imgur.com/a/O9rdK
       
      I've also turned off vsync in the Nvidia control panel and enabled it in enblocal.ini but that didn't do anything.
       
      The only thing that sort of works is the enb fps limiter, which sorta works.  If I set it to 60 fps it caps it to 51, although with it off I can get to the high 70s.  
      It stays at 51fps until I set the fps limiter to 64 fps... really random.
       
      I have a 1080p monitor at a 60hz refresh rate.
       
      What am I not doing right?
       
      I honestly haven't used S.T.E.P. that much outside of a few tweaks.  
      Considering this issue mostly deals with vsync, which I think should be unrelated to my mods, I hope it's okay if I ask for help here.
       
      ENB:  Enhanced Shaders NLA
       
      Mods/plugins: https://modwat.ch/PoombyBear#/plugins
       
      Modtools:  Mod Organizer, Wyre Bash, Loot, TES5Edit
       
      Patchers: DSR, FNIS, and PerMa
       
      PC Specs:  gtx 970 (driver version 353.06), i5-4690k, 8 gigs of ram, Windows 7 64 bit
       
      edit 06/12/2015:  The issue is still unresolved, so I figured I would show my ini files and nvidia settings in their current state.
       
      skyrim.ini https://textuploader.com/nr86
       
      skyrimprefs.ini https://textuploader.com/nr8q
       
      enblocal.ini https://textuploader.com/nr8u
       
      enbseries.ini https://textuploader.com/nr87
       
      nvidia tesv.exe settings https://i.imgur.com/68VZZMF.png?1
       
      Reinstalling Mod Organizer, SKSE, updating my enb version, and making sure there are no comments on the vsync line in enblocal.ini did not solve the issue.
    • By TehKaoZ
      Hello,
       
      I am curious if I am doing this right and was hoping to find someone with a bit of knowledge who could help. Not too recently I got this monitor :https://www.newegg.com/Product/Product.aspx?Item=N82E16824236313
       
      It runs at 144 Hertz and I was trying to figure out how this would work in enb. I am not super technical but based on my research this type of number is more or less useless for Skyrim because by default the games fps is capped at 60. Furthermore I cap my fps at 35 because I use a pretty heavy enb (Serenity) and I hate when my frames jump up and down by drastic numbers.
       
      The advice online is that one should set their V-sync (via Nvidia inspector) at 1/3 refresh or 1/4 to prevent the monitor from producing a sort of ghosting effect at lower frames. Basically what I did was turn off enb v-sync, and set to system 1/4 refresh. Other types of advice included setting the monitor to lower Hertz but the screen's colors look completely off when I do this (plus I can only set it as low as 120).
       
      Anyways, wondering if anyone uses a similar monitor and what they did when running Skyrim. Thanks!
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.