Jump to content
  • 0
Sign in to follow this  
MaroES

Vsync not working, setting pics inside

Question

Please look at my settings in this album I made before giving suggestions.  https://imgur.com/a/O9rdK

 

I've also turned off vsync in the Nvidia control panel and enabled it in enblocal.ini but that didn't do anything.

 

The only thing that sort of works is the enb fps limiter, which sorta works.  If I set it to 60 fps it caps it to 51, although with it off I can get to the high 70s.  

It stays at 51fps until I set the fps limiter to 64 fps... really random.

 

I have a 1080p monitor at a 60hz refresh rate.

 

What am I not doing right?

 

I honestly haven't used S.T.E.P. that much outside of a few tweaks.  

Considering this issue mostly deals with vsync, which I think should be unrelated to my mods, I hope it's okay if I ask for help here.

 

ENB:  Enhanced Shaders NLA

 


 

Modtools:  Mod Organizer, Wyre Bash, Loot, TES5Edit

 

Patchers: DSR, FNIS, and PerMa

 

PC Specs:  gtx 970 (driver version 353.06), i5-4690k, 8 gigs of ram, Windows 7 64 bit

 

edit 06/12/2015:  The issue is still unresolved, so I figured I would show my ini files and nvidia settings in their current state.

 


 


 


 


 

nvidia tesv.exe settings https://i.imgur.com/68VZZMF.png?1

 

Reinstalling Mod Organizer, SKSE, updating my enb version, and making sure there are no comments on the vsync line in enblocal.ini did not solve the issue.

Edited by MaroES

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

The following should fix it:

  1. Set EnableVSync to true in enblocal.ini
  2. Set Vertical Sync to Use the 3D application setting in Nvidia Inspector

Share this post


Link to post
Share on other sites
  • 0

Thank you for the reply.  I've done as you suggested and I'm afraid it didn't work.  

 

I made a small album of the settings I changed in case I did something incorrectly.  https://imgur.com/a/v23le

Edited by MaroES

Share this post


Link to post
Share on other sites
  • 0

Hmmm... unfortunately I don't have an Nvidia card and was going by the settings we recommend on the STEP Guide. I really cannot understand how you can have no Vsync, unless you have some other program hooking Skyrim that is disabling Vsync.

Share this post


Link to post
Share on other sites
  • 0

What about in Nvidia settings for Elder scrolls Skyrim (tesv.exe)? Your pictures do not show that one.

Share this post


Link to post
Share on other sites
  • 0

I really cannot understand how you can have no Vsync, unless you have some other program hooking Skyrim that is disabling Vsync.

Yea... I feel clueless.  

 

It baffles me that in the last screenshot vsync is checked in the enb settings but the fps is not synced to my monitor's 60hz refresh rate.

 

Vsync works fine for other games.  I also mod Fallout New Vegas with an ENB and have no issues with Vsync.

 

What Hz is your monitor?

60hz.

 

 

What about in Nvidia settings for Elder scrolls Skyrim (tesv.exe)? Your pictures do not show that one.

These are my tesv.exe settings, except I changed vsync from "on" to "use 3d application settings."  https://i.imgur.com/7UDyBD4.png

 

I've haven't had success with either setting.  

Edited by MaroES

Share this post


Link to post
Share on other sites
  • 0

 

The following should fix it:

  1. Set EnableVSync to true in enblocal.ini
  2. Set Vertical Sync to Use the 3D application setting in Nvidia Inspector

 

This should do it I'd say.. I recently had my fps capped at 51 even in menus while I was very certain I set it at 58. I've only had it happen once and can't remember how I fixed it though, lol. Might it be something silly like the current d3d9.dll file you're using? Try getting the latest version. Another thing that might help.. make sure there are no 'comments' on the vsync=true line in enblocal.ini, for example "EnableVSync=true  // Set this to true if you want to enable vsync". Recently me and another user had some trouble with turning on/off options when there were comments from a mod author on the same line. We both hadn't encountered this before but removing the comments did the trick. EDIT: Doesn't look like this is the case on your screenshots, sorry.

 

It might also be totally irrelevant but I guess you could try it out.

Edited by Pretendeavor

Share this post


Link to post
Share on other sites
  • 0

Might it be something silly like the current d3d9.dll file you're using? Try getting the latest version.

Another thing that might help.. make sure there are no 'comments' on the vsync=true line in enblocal.ini, for example "EnableVSync=true  // Set this to true if you want to enable vsync". 

Thanks for the suggestions.  I updated my d3d9.dll file from v0.269 to v0.272 and I can confirm there are no comments

on the vsync line in enblocal.ini, but I unfortunately still have the same problem.

Share this post


Link to post
Share on other sites
  • 0

I wanted to make an update and say that I tested vsync in Skyrim via the Steam launcher and it was working properly with my ENB active (but it's still not working in Mod Organizer).  I used the Nvidia vsync "yes" setting."  This means that my enb ini's are fine, and that something is going on in Mod Organizer.  I've reinstalled MO and updated to the latest version but it didn't fix the issue, so I think (but I'm not 100% sure) that the issue doesn't have to do with MO itself.

 

Does anyone have suggestions on where I should troubleshoot next?

Edited by MaroES

Share this post


Link to post
Share on other sites
  • 0

If you make changes via the Skyrim Launcher those will be saved in the default INI files in your 'My Games' folder. The active profile in MO will have used the default INI files as its base from BEFORE those changes.

Any changes to your INIs will need to done to the set of files used in the current profile, either by MO's INI editor, Configurator or by hand with a text editor.

Share this post


Link to post
Share on other sites
  • 0

Thanks for the reply.

 

I understand how ini's work in Mod Organizer profiles, but I'm not quite sure what you're suggesting in terms of troubleshooting or what I may be doing wrong.

Share this post


Link to post
Share on other sites
  • 0

Please do the following test for me:

  1. Run Skyrim through MO just to the main menu of the game
  2. Open the console and type saveini
  3. Exit the game
  4. In Overwrite there should now be an INI file with the name of the last plugin loaded.
  5. Post the INI file to Pastebin and give us the link
  6. Important! Delete the file from Overwrite.

Share this post


Link to post
Share on other sites
  • 0

Okay, that shows me that the problem is something (most likely a mod with a custom plugin INI file or, less likely, a MO INI tweak) is overwriting your value for iPresentInterval, setting it always to 0. Please look in your plugins list in MO for a paperclip icon. All ESPs\ESMs with a paperclip by them have an INI file that the game loads that will overwrite settings you have made in your INI files. Find the mod that has the INI file that contains iPresentInterval in it and remove that setting from the INI file, and VSync should work properly.

 

If that fails, look inside your profile folder and find the initweaks file. Open it and see if iPresentInterval is in there. Do NOT edit this file! If the value is in there, one of your mods has a MO INI tweak that is disabling VSync. If that is the case, you will have to go on an INI tweak witch hunt by double-clicking each mod, going to the INI tab, and find the INI tweak in the bottom left corner.

Share this post


Link to post
Share on other sites
  • 0

Using your suggestion I was able to find that the file "Update.ini" (taken from tony971's Speed and Stability Guide for ENB on the nexus) had a tweak iPresentInterval=0.

 

I deleted that tweak and was able to get vsync to work through the ENB (but not the Nvidia Control Panel).

 

Of course I'm getting more crashes for some reason, but hopefully I can figure that out on my own.  I'm going to take a break from troubleshooting for now.

 

ENB Vsync is good enough for me atm.  Thank you for the help, I wouldn't have figured this out on my own and haven't gotten this kind of help on any other forum ::): .

Edited by MaroES

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By ShiranZou
      Hi Gang.
      5 days in and I finally found STEP: Core, after looking for guidance from Gopher and GamerPoets.
      I've familiarized myself with the tools needed, and am starting to follow STEP: Core.
       
      However, I am unhappy with the results of using ENBoost.
      I'm unsure if it's actually beneficial to me, having 896 mb VRam and 4Gigs Ram.
      With Vsync enabled, I can hit 30 fps drops too easily, with just 5-10 npcs or looking at Riverwood from the bridge.
       
      I benchmarked in-game and my GPU uses 100% most of the time indoors. 70% outdoors. CPU almost always 30%.
      ^ Using Skyrim Performance Monitor, which refuses to run while ENBInjector is active. So, I'm not sure of the actual effect of ENBoost.
      This is with every possible setting minimized, at 60+fps. Near rivers I can go over 120 fps and get screen flickers... see link.
      https://forums.steampowered.com/forums/showthread.php?t=2580126
       
      I am really hating the notion of using Vsync. Can I use an Fps Limiter instead? If so, which one?
       
      Is ENBoost(or VSync) truly required for every1 following STEP: Core? If so, why is it needed exactly?
       
      My Spec
      https://wiki.step-project.com/User:ShiranZou/SystemSpecs
    • By TechAngel85
      Recently, Z and I did some testing ( testing results are here and the post following it ) regarding user complaints of vsync and iPresentInterval settings. This testing revealed a couple things:
      iPresentInterval has no affect when placed in the SkyrimPrefs.ini. It belongs in the Skyrim.ini file under the [Display] section. In other words, when setting iPresentInterval=0 in SkyrimPrefs.ini, there is no impact, but doing the same in Skyrim.ini disables vsync. iPresentInterval should always be set to 1; its default Old Recommendations:
      set iPresentInterval=0 in the SkyrimPrefs.ini fileThis is incorrect and erroneous on our part New Recommendations:
      iPresentInterval should be present in neither the Skyrim.ini nor the SkyrimPrefs.ini filePlease delete it from both INIs  Should be added to Skyrim.ini under [Display] as iPresentInterval=1 Set vsync in the video drives to "application controlled" for your cardsee updated instructions below for both AMD and Nvidia users Enable vsync in the enblocal.ini file for ENBoost The new recommendation is to add iPresentInterval to the Skyrim.ini files. Users can view the updated instructions for ENBoost here and go here for the video card drivers. ALL users should update by following the new instructions to ensure their game and system are set up properly for STEP.
       
      The Changelog has been updated to reflect all changes as well as all applicable Guides.
    • By TehKaoZ
      Hello,
       
      I am curious if I am doing this right and was hoping to find someone with a bit of knowledge who could help. Not too recently I got this monitor :https://www.newegg.com/Product/Product.aspx?Item=N82E16824236313
       
      It runs at 144 Hertz and I was trying to figure out how this would work in enb. I am not super technical but based on my research this type of number is more or less useless for Skyrim because by default the games fps is capped at 60. Furthermore I cap my fps at 35 because I use a pretty heavy enb (Serenity) and I hate when my frames jump up and down by drastic numbers.
       
      The advice online is that one should set their V-sync (via Nvidia inspector) at 1/3 refresh or 1/4 to prevent the monitor from producing a sort of ghosting effect at lower frames. Basically what I did was turn off enb v-sync, and set to system 1/4 refresh. Other types of advice included setting the monitor to lower Hertz but the screen's colors look completely off when I do this (plus I can only set it as low as 120).
       
      Anyways, wondering if anyone uses a similar monitor and what they did when running Skyrim. Thanks!
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.