Jump to content
Blackice

FPS Limiter (by GriefReaper)

Recommended Posts

STEP does not recommend this mod ....

Please carefully follow the instructions under STEP 1 of the latest guide in order to configure graphics optimally. There are several ifs/ands, so carefully follow those instructions and you should be good to go.

 

--if not, then please post specifics about your hardware and setup as described at bottom of this post ... and read the links to further info in that post.

 

This mod is completely redundant with the more comprehensive solutions that are currently available.

 

STEP

 

 


FPS LIMITER by GriefReaper

Play without V-sync!

Gained performance and fixed micro stuttering.

Tested with AMD's ATI HD6870 2GB.

 

This is a replacement of the d3d9.dll file and includes a .cfg file. Works with ENB.

 

This mod helped against some micro stuttering I was experiencing while using ENB's V-sync. With V-sync on I was experiencing micro stuttering at some places like outdoors with lots of foliage or some dungeons, that made it look like my FPS dropped heavily while it was still around 40. It looked like 25 but was running at 40.

 

First I disabled V-sync altogether which got rid of the stuttering but introduced the high FPS physics problem. Skyrim was made to work with locked or limited FPS and V-sync locks FPS, console versions also have limited FPS. This problem causes forces to seem multiplied at higher than 60 FPS, as the physics in Skyrim are based on frames and not on time. Items appear lighter and vibrate, making noises and sometimes bounce all over the place when touched, it also causes flickering of water and repeating water sounds.

 

Now, ENB has a built-in FPS limiter that fixes the physics bug and allows you to play without V-sync. I tried this but it still allowed for less frequent micro stuttering in some places, more like hitches.

 

Now, FPS limiter does the same thing, but changes the d3d9.dll instead. Follow the instructions for ENB users (change the proxy settings in ENB). Ignore the comment about forcing on V-sync on the video card if you have the same problem as I have.

 

This mod allowed me to play without V-sync and does not cause any physics abnormalities I am aware of. It makes my game much smoother by removing the 'fake' stuttering caused by V-sync or ENB. I haven't seen any screen tearing so far either. It might have other uses as it appears superior to ENB's frame limiter.

Share this post


Link to post
Share on other sites

Seems rather superfluous but maybe I haven't noticed the "micro-stutters" or hitches when just using the FPS Limit function built into the ENBseries. Lately I just keep vsync on (as always) and don't use the limiter because I've seen no real benefit to having it on with vsync.

 

From enblocal.ini:

[LIMITER]

WaitBusyRenderer=false

EnableFPSLimit=false

FPSLimit=10.0

Share this post


Link to post
Share on other sites

This mod is exactly the same as that implemented with ENB FPS limiter ... same method too. See the STEP guide for configuring ENBoost and graphics driver software to get rid of microstutter.

 

Vsync does NOT cause microstutter. it completely cures it (by capping FPS) as well as vertical tearing. I have worked a lot with this lately and have several posts around here on the topic. The 2.2.8 guide has all of the recommendations for the correct setup.

 

Basically, this mod (FPS limiter) is completely redundant, and there is no reason at all to use it. Follow the guide instructions and use ENBoost with vsync properly set, and don't use the FPS limiter in that mod either. I am pretty sure that ENBoost has built-in tri-buffering too.

 

See the following post and links therein to learn more:

https://forum.step-project.com/showthread.php?tid=3455&pid=65488#pid65488

Share this post


Link to post
Share on other sites

How important/necessary is it to turn vsync off in the skyrimprefs.ini just to turn it "on" in the enblocal.ini?

 

I guess what I am asking, wouldn't it just be better to leave that skyrimprefs at the default value and let the enb sort it out?

Share this post


Link to post
Share on other sites

At least in my case it worked to fix the stuttering. So it might work for others with similar setups. Since it worked for me and there was a clear difference between using ENB's limiter or this mod, it's definitely worth a try.

 

ENB's graphics effects are off, as per STEP Guide:

UsePatchSpeedhackWithoutGraphics=true

 

Video card settings as per STEP Guide:

CCC Wait for Vertical Refresh: Always off

CCC OpenGL Triple Buffering: Off

 

Micro stuttering - looks as if FPS is low, but is actually high - occurred with

ENB V-Sync: on

ENB Frame Limiter: off

FPS Limiter (by GriefReaper): off

 

Less frequent stutter - more like single frames dropping every second - i had with:

ENB V-Sync: off

ENB Frame Limiter: on

FPS Limiter (by GriefReaper): off

 

or both on:

ENB V-Sync: off

ENB Frame Limiter: on

FPS Limiter (by GriefReaper): on

 

Stuttering completely disappeared with:

ENB V-Sync: off

ENB Frame Limiter: off

FPS Limiter (by GriefReaper): on

 

or everything off, but this introduced the physics bug.

 

I did not try different CCC settings or using 'Vanilla' V-Sync

 

I guess i don't experience screen tearing because thanks to the incredible STEP Core pack, my FPS is always more than 35. OR, it could be because i am running in borderless full-screen.

Share this post


Link to post
Share on other sites

At least in my case it worked to fix the stuttering. So it might work for others with similar setups. Since it worked for me and there was a clear difference between using ENB's limiter or this mod, it's definitely worth a try.

 

ENB's graphics effects are off, as per STEP Guide:

UsePatchSpeedhackWithoutGraphics=true

 

Video card settings as per STEP Guide:

CCC Wait for Vertical Refresh: Always off

CCC OpenGL Triple Buffering: Off

 

Micro stuttering - looks as if FPS is low, but is actually high - occurred with

ENB V-Sync: on

ENB Frame Limiter: off

FPS Limiter (by GriefReaper): off

 

Less frequent stutter - more like single frames dropping every second - i had with:

ENB V-Sync: off

ENB Frame Limiter: on

FPS Limiter (by GriefReaper): off

 

or both on:

ENB V-Sync: off

ENB Frame Limiter: on

FPS Limiter (by GriefReaper): on

 

Stuttering completely disappeared with:

ENB V-Sync: off

ENB Frame Limiter: off

FPS Limiter (by GriefReaper): on

 

or everything off, but this introduced the physics bug.

 

I did not try different CCC settings or using 'Vanilla' V-Sync

 

I guess i don't experience screen tearing because thanks to the incredible STEP Core pack, my FPS is always more than 35. OR, it could be because i am running in borderless full-screen.

I can confirm that for AMD at least, ENB v-sync (with CCC vsync set to always off and skyrimprefs vsync set to 0) I get terrible microstutter with my R9 290. It seems like my fps tanks sometimes when it reads a steady 30-40. ENB vsync does not solve microstutter for amd.

Share this post


Link to post
Share on other sites

That's a bold claim to make... In fact ENB vsync works perfectly fine on my hd6950 2gb.

 

The problem you describe is usually (not always) fixed by changing the memory values, compression or driver manager parameters to get rid of stutter caused by ENBoost.

Share this post


Link to post
Share on other sites

That's a bold claim to make... In fact ENB vsync works perfectly fine on my hd6950 2gb.

 

The problem you describe is usually (not always) fixed by changing the memory values, compression or driver manager parameters to get rid of stutter caused by ENBoost.

Can you either explain here or send me a PM as to what those values are and what I can change them to? I currently have my videomb value in enblocal set to 4096 (I have a 4gb VRAM card) and the reservedmemory set to 128. 

Share this post


Link to post
Share on other sites

I can confirm that for AMD at least, ENB v-sync (with CCC vsync set to always off and skyrimprefs vsync set to 0) I get terrible microstutter with my R9 290. It seems like my fps tanks sometimes when it reads a steady 30-40. ENB vsync does not solve microstutter for amd.

 

Please try playing without v-sync and with the ENB limiter on. If you get hitches, try this FPS Limiter mod.

My game runs super smooth now.

 

My ENBlocal.ini values are as follows:

 

[PROXY]
EnableProxyLibrary=true
InitProxyFunctions=true
ProxyLibrary=FL_d3d9.dll

[GLOBAL]
UsePatchSpeedhackWithoutGraphics=true
UseDefferedRendering=true
IgnoreCreationKit=true
ForceFakeVideocard=false

[PERFORMANCE]
SpeedHack=true
EnableOcclusionCulling=true

[MULTIHEAD]
ForceVideoAdapterIndex=false
VideoAdapterIndex=0

[MEMORY]
ExpandSystemMemoryX64=true
ReduceSystemMemoryUsage=true
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=256
VideoMemorySizeMb=
EnableCompression=true
AutodetectVideoMemorySize=true

[WINDOW]
ForceBorderless=true
ForceBorderlessFullscreen=true

[ENGINE]
ForceAnisotropicFiltering=true
MaxAnisotropy=16
AddDisplaySuperSamplingResolutions=false
EnableVSync=false
VSyncSkipNumFrames=0

[LIMITER]
WaitBusyRenderer=false
EnableFPSLimit=false
FPSLimit=55.0

[INPUT]
//shift
KeyCombination=16
//f12
KeyUseEffect=123
//home
KeyFPSLimit=36
//num /       106
KeyShowFPS=106
//print screen
KeyScreenshot=44
//enter
KeyEditor=13
//f4
KeyFreeVRAM=115

[ADAPTIVEQUALITY]
Enable=false
Quality=1
DesiredFPS=20.0

[ANTIALIASING]
EnableEdgeAA=false
EnableTemporalAA=false
EnableSubPixelAA=false
EnableTransparencyAA=false

[FIX]
FixGameBugs=true
FixParallaxBugs=true
FixAliasedTextures=true
IgnoreLoadingScreen=true
IgnoreInventory=true
FixSsaoHairTransparency=true
FixTintGamma=true
RemoveBlur=false
FixSubSurfaceScattering=true
FixSkyReflection=true
FixCursorVisibility=true

 

 

I read that you can set ReservedMemorySizeMb much lower if you have the VRAM, for 2GB it can be set to 64.

As you can see mine is 256 and works fine now. This is what the calculator recommended in the STEP guide told me.

 

Stuttering can be caused by a myriad of reasons, so try everything.

Share this post


Link to post
Share on other sites

Allright I am by no means an ENBoost expert but it took me months to get it to run without stutter. It is very system dependent and reading your responses to other thread it might even be an issue with the R9 290, or the driver (which versioo do you use? 14.1 has been problematic for many people on many games) or even the limitation of PCIE-2.0 bandwith (though I seriously doubt that). There's a lot of false or biased info on ENBoost so I'm tryign to give you suggestions based on my personal experience with it.

 

My settings are:

 

[MEMORY]

ExpandSystemMemoryX64=true

ReduceSystemMemoryUsage=true

DisableDriverMemoryManager=true

DisablePreloadToVRAM=false

EnableUnsafeMemoryHacks=false

ReservedMemorySizeMb=128

VideoMemorySizeMb=1920

EnableCompression=true

AutodetectVideoMemorySize=false

 

You should try switching each of those settings independently to true or false and see whether it makes a difference.

 

I'd first try EnbleCompression=false. If that doesn't make a difference, put it back to =true.

 

Then DisableDriverMemoryManager=true/false. There have been different recommendations for this over time for AMD cards. You should give both a try.

 

ReservedMemorySizeMB=128. Default =64 but that causes stutter on my system. Try increasing this up to a value which doesn't cause stutter (if any). The lower the value the less chance for CTDs. Least that what Boris said. 64,128,256,512 are common values. I've never been sure whether 769 or 1024 is the max for this.

 

VideoMemorySizeMb= Try putting this 128mb lower than your max vram. You can read that Boris does it like that over here: https://home.comcast.net/~thunor/images/hosted/config/memory.html

 

Finally, if all else fails, try ReduceSystemMemoryUsage=false. THis will basically disable the offloading of RAM to the enbhost.exe process so you will have to deal again with the 3.1gb limit. But you can determine whether this is the issue.

Share this post


Link to post
Share on other sites

Blackice, What is your gpu and what do you have the limiter set to? 60? And you also disabled vsync in ccc and skyrimprefs?


Neorox, I see that many users have preloadtovram set to galse. Mine is set to true. I think that is the first thing I should try since it can reduce stuttet when set to false, right?

Share this post


Link to post
Share on other sites

See my signature.

 

I simply have Vsync on in ENB and in CCC it is set to 'off, unless application specifies'. Ipresentinterval=1

 

Also I am thinking since you mention that you seem capped at 30 FPS: There are different varieties of VSync (I forgot their terms) but I know one of them caps you at half your monitor's refresh rate (i.e. 60/2=30) if you are running less than 60 FPS. Might be worth looking into that and whether such is settings is enabled somewhere in CCC or RadeonPro.

Share this post


Link to post
Share on other sites

Neorox, I see that many users have preloadtovram set to galse. Mine is set to true. I think that is the first thing I should try since it can reduce stuttet when set to false, right?

Ehhh YES. That setting is very likely to cause stuttering if you have it at =true. The only reason to set it to true is if you must save vram... Which is totally unnecessary with your shiny 290.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.