Jump to content
  • 0
Sign in to follow this  
GSDFan

User a_rod wanted a way to have the Steam overlay in fallout 3

Question

User a_rod on the Nexus forums posted the following asking about Fallout 3 and the Steam overlay.

I've been using Mod Organizer for Fallout 3 & Fallout NV, and I've noticed that the Steam overlay does not want to work for Fallout 3 when run from MO. I do use FOSE, however the Steam overlay does not even want to work for Fallout3.exe and FalloutLauncher.exe when run from MO either. I even tried renaming the fose_loader.exe to FalloutLauncher.exe and still the Steam overlay does not come up.

 

I want to be able to run my game with mods through Mod Organizer while I have my hours played recorded from the same game through Steam.

And also have my Steam friends to see that I'm in-game playing through Steam.

 

Fallout NV & Skyrim works perfectly in that regard, but why doesn't Fallout 3?

 

Edit: Can somebody else (Mainly those who own Fallout 3 goty edition on steam and also uses Mod Organizer) test this out?

So far it seems like I'm the only one with this problem.

The following is my attempt to tackle and solve this problem. Please be aware this is a hack, and as such it is prone to failure from unseen events not encountered in my testing.

 

First off testing was done to provide a baseline of the interaction of MO and Steam.

 

 

Vanilla (Steam) testing.

The game was launched from the play button, which brings up the launcher window. Play was clicked to start the game. The result was I had the Steam overlay and the Windows live overlay. Of course no mods were available as MO is not running.

 

Next the game was launched from FalloutLauncher.exe in the game directory. The result was I got the launcher window. Play was clicked to start the game. I got both the Steam and Windows live overlay. Note: If the Steam Client Service, here after referred to as SCS, which is the Steam Windows tray icon is stopped, it will start back up if it has been closed.

 

Next Fallout 3 Executable, Fallout3.exe, was launched with SCS running. The result was I got only the Windows live overlay to run. This was repeated with SCS closed and the result was the same as should be expected.

 

Next the game was launched from fose_loader.exe while SCS running. The result was that I did not get any of the overlays to work.

 

Mod Organizer testing.

Fallout launcher from MO. The SCS was running. The result was only the Windows live overlay would work.

My initial testing with MO was a dismal failure until I realized that my method was flawed. I neglected the fact in order to work, Steam needed to be hooked by MO. All of my testing was with SCS running. I exited the SCS and ran the launcher again. This time I had some success. I now had the Windows live and Steam overlay, but no mods.

 

Next I tried to launch FOSE with SCS turned off. The result was I had mods, but the windows and Steam overlay were not working. The SCS was not launching. I tried a FOSE command line option, -altexe , the path pointing to Steam.exe, but got an error from FOSE that I had an unknown version of Fallout.

I needed a way to launch FOSE and steam at the same time. I turned to the internet for some inspiration and found that others were having the same problem with the vanilla game.

The common consensus was to rename some files in the games directory.

 

So this is what I did. It is kuldgy but it works.

 

Preparation:

Navigate to the Fallout 3 directory. Once there make copies of FalloutLauncher.exe and fose_loader.exe.

 

Rename FalloutLauncher.exe to FalloutLauncher-Orig.exe.

 

Rename fose_loader.exe to FalloutLauncher.exe.

 

In MO create an executable to Steam.exe. Nothing else is needed. Give it a name, click modify and that OK.

 

This next part is critical. Go to the Windows task bar and look for the Steam icon, right click on it and exit steam. Steam needs to closed in order for MO to hook it.

 

When you want to run the game click on the Steam executable in MO. MO will launch a new instance of Steam to hook. Once Steam is running you can either run FO3 from the Steam interface or from shortcut on the desktop.

 

You now have Fallout 3 running with FOSE and Steam overlay from MO.

 

Now for the downside. With this configuration you cannot create a new game from the menu system. It just won’t work. When new is selected nothing happens. To get around this you have to make an executable to the copy of the launcher and do it from there. You will not have any mods available at this time.

MO will stay locked if you have the close MO when started disabled.

Steam client service will stay hooked until exited.

 

There may be other unforeseen problems. I did not fully test under a heavily modded game and I only tested one FOSE  

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

This is what I did:

 

- Rename Fallout3.exe to Fallout3ng.exe

- Copy fose_loader.exe to Fallout3.exe

- Edit that Fallout3.exe with a hex editor and change the first instance of Fallout3.exe to Fallout4.exe

- Change the load mechanism in Mod Organizer to Script Extender under Settings - Tab Workaround

- Make sure there's a hook.dll and mo_path.txt under ../FOSE/Plugins

- Install NVAC and Fallout Stutter Remover Files directly into ../FOSE/Plugins(circumventing the VFS) and deactivate the two in MO

 

I was able to load the game with FOSE and Steam overlay either through Steam or by launching FalloutLauncher.exe directly in Windows explorer. Launching the game through Mod Organizer left me without the Steam overlay, regardless of wether I used FalloutLauncher.exe of fose_loader.exe.

 

I'm not far into the guide(installed ui mods and unofficial patches) yet but it seems to be working thus far. Loaded up a savegame at the vault exit and had the installed mods initialize and work correctly from what I can discern.

Edited by tsc0815

Share this post


Link to post
Share on other sites
  • 0

I have the same problem with Steam overlays in Fallout 3, but not with Fallout NV or Skyrim. Perhaps the Mod Organizer gurus have a more elegant solution. I realize it's really a Steam problem since similar problems occur with other mod managers.

Share this post


Link to post
Share on other sites
  • 0

I tried the method GDSFan mentions and I can get the game running with FOSE and Steam overlays, but none of the mods or Fallout.ini/FalloutPrefs.ini from MO seem to be present when I tried this.

 

I haven't tried the 2nd method yet, but I expect that any other FOSE mods like Enhanced Camera will also need to installed directly into Data.

Share this post


Link to post
Share on other sites
  • 0

Yes. At the end of the guide I have the following files in my (physical) ..datafoseplugins directory:

 

FOSE_EnhancedCamera.dll

FOSE_EnhancedCamera.ini

hook.dll

mo_path.dll

nvac.dll

sr_Fallout_Stutter_Remover.dll

sr_Fallout_Stutter_Remover.ini

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.