Jump to content
Spigotron

Framerate Limit Capped at 60 FPS

Recommended Posts

I am at the part of the guide that instructs me to run a benchmark. I carefully followed all of the instructions to uncap frame rates, but my game still seems to be capped at 60 FPS. I don't have G-Sync.

Does anyone have any recommendations for uncapping the frame rate? I'm really stumped here. My settings in SSEDisplayTweaks.ini:

EnableVSync=false
MaximumRefreshRate=300
FramerateLimit=300
FramerateLimitMode=1
UIFramerateLimit=59

Share this post


Link to post
Share on other sites

Check you video driver software for anything related to 'sync'. There may be a proprietary name for it. Hover over settings and note descriptions. Then also be sure that SSE Display Tweaks is configured for the performance test by disabling vsync as we describe. Also be sure that EnableFPSLimit=false in enblocal.ini. There are at least four places where frame rate limiting can be enabled ... at least two places vsync can be enabled. It caps frame rates to your monitor refresh (most often 60). You only need the set in SSE Display Tweaks, where you can toggle it.

Share this post


Link to post
Share on other sites

I actually had this problem at one point, and switching from borderless windowed mode to fullscreen mode fixed it for me for some reason.

Share this post


Link to post
Share on other sites
16 hours ago, DoubleYou said:

I actually had this problem at one point, and switching from borderless windowed mode to fullscreen mode fixed it for me for some reason.

Then could you go back to borderless? Or are you stuck with fullscreen?

Share this post


Link to post
Share on other sites

I have not been able to use borderless windowed mode with uncapped framerate on AE as of yet. Not sure why. Probably something on my end, but I see little reason to debug. 

Share this post


Link to post
Share on other sites

Did you try disabling the Discord overlay or exiting Discord while playing in borderless windowed mode? Just asking because one person alleged his was capped at 60 FPS until he exited Discord.

Share this post


Link to post
Share on other sites
19 minutes ago, Greg said:

Did you try disabling the Discord overlay or exiting Discord while playing in borderless windowed mode? Just asking because one person alleged his was capped at 60 FPS until he exited Discord.

I swear I had this disabled already, but it was enabled, so I disabled it again. Tested again, and framerate was capped to 60 in windowed mode. Put it back in fullscreen mode, and it was uncapped again. I literally have no idea what would cause this, but it is definitely the case on my system, and apparently the OP's.

Share this post


Link to post
Share on other sites

This is expected, no surprise here. This applies to any game on Windows 10 and later, it's not specific to Skyrim or SSE Display Tweaks.

In Borderless Fullscreen Window mode, the game's window is controlled by Windows' DWM (Desktop Window Manager) which always uses (triple-buffered) V-Sync, so the framerate is capped to the monitor's refresh rate. The VRAM is also shared between the game and Windows + the other running apps, which makes task-switching and using multiple monitors seamless in Windows. 60 is not a magic number, it's simply the refresh rate of your specific monitor. If you use a high refresh rate or variable refresh rate monitor, the cap will be different: e.g. 144 fps, 240 fps, ...

No matter what the in-game or driver settings for V-Sync are set to, Windows DWM enforces V-Sync, so V-Sync is always enabled in Borderless Fullscreen Window mode. In STEP SSE's case, this includes the Skyrim INI setting and SSE Display Tweaks configuration.

In Exclusive Fullscreen mode, the GPU and screen are fully controlled by the game which can disable V-Sync and render frames at a pace exceeding the monitor's refresh rate. This causes long pauses and "black-outs" or "flashes" when task-switching in Windows as control is transferred from the game to the OS or vice-versa, and resources are swapped in and out of VRAM.

Those of you using a high refresh rate monitor may think the framerate is uncapped because you can get higher than 60 fps, but does it actually go higher than your monitor's actual refresh rate? For example, if the monitor is 240 Hz and you're getting 120 fps, that doesn't mean anything: V-Sync is still enabled via DWM and frame rate is capped at 240 fps.

There is a special DirectX rendering mode (in DirectX 11 and later I believe) that allows a game to render at uncapped framerates (without V-Sync) even in Borderless Fullscreen Window while maintaining seamless integration with DWM in recent Windows 10 and later. This requires specific GPU and driver support, which may not be available depending on GPU grade and age. This also requires that the game engine is designed to leverage this mode, so only games released in the last 3-4 years might support it.

SSE Display Tweaks can theoretically use this special mode if supported by the hardware, in which case its V-Sync switch should be effective even in Bordeless Fullscreen Window mode. I can't confirm whether it works or not in practice, but users can look at the log (in Documents/My Games/Skyrim Special Edition/SKSE/SSEDisplayTweaks.log), towards the end there will be some messages relating to Swap Effect and Desktop hardware composition. Here for example an excerpt from my log, showing that my crappy hardware doesn't support it:

[Window] [0x9E02EA] Message hook installed
[Window] [0x9E02EA] Window created [Skyrim Special Edition] (0,0,1920,1200)
[Render] [D3D] Requesting mode: 1920x1200@0 | VSync: 1 | Windowed: 1
[Render] [D3D] SwapEffect: flip_discard | SwapBufferCount: 3 | Tearing: 0 | Flags: 0x00000002
[Render] [D3D] Windowed hardware composition support: no

In summary: results will vary depending on each user's specific hardware setup and the only way to ensure that framerates are uncapped for benchmarking purposes in all cases is to switch (temporarily) to Exclusive Fullscreen mode.

I had pointed out this fact back while beta-testing STEP SSE 2.0 and commented on it in one of the Admin topics (Skyrim SE INIs / BethINI / Performance Tuning), but it didn't resonate nor "stick". I hope the above is clearer and more convincing than my initial comments.

Further reading:

Share this post


Link to post
Share on other sites

@Mousetick Thanks for the insights. It is now clear, sensible, and will 'stick' to my brain.

@DoubleYou I think we should consider changing to Fullscreen mode in the initial BethINI setup and later instruct to switch to borderless as desired (with very brief explanation of the advantages). This alleviates the issue with the least disruption, I suspect.

I have a 144 Hz monitor and my fully modded setup doesn't achieve that frame rate even with my decent hardware and no ENB/DynDOLOD (112 FPS peak), so I never experienced this issue in my testing. You didn't, because you were in fullscreen mode due to this issue. @TechAngel85 didn't, and I am not sure why.

Share this post


Link to post
Share on other sites

I definitely had framerate unlocked before the AE update in borderless windowed mode, as framerates were well above my 75 hz monitor, but the above is definitely the cause of the issue now. 

Share this post


Link to post
Share on other sites
4 hours ago, TechAngel85 said:

Windows 10 and I don't have this issue.

You are in borderless on a 60 Hz monitor on Win 10 and can get > 60 FPS?

Share this post


Link to post
Share on other sites
1 hour ago, z929669 said:

You are in borderless on a 60 Hz monitor on Win 10 and can get > 60 FPS?

Yes. I can verify later after dinner.

Share this post


Link to post
Share on other sites

In order to compare experiences/results/configurations, I'd suggest you include your SkyrimPrefs.ini, SSEDisplayTweaks.ini and SSEDisplayTweaks.log to provide objective unambiguous information.

Moreover, SSEDisplayTweaks.ini has configuration settings in the [Render] section which can override SkyrimPrefs.ini if they are un-commented, which can lead to confusion about which display mode is actually being applied. Hence the need to look at the log.

Moreover, ENB may also have its own display mode settings which may or may not override SSEDisplayTweaks.ini and/or SkyrimPrefs.ini, leading to even more confusion. I don't use ENB so I don't know whether it's relevant or not.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Badfrog88
      Following a clean re-install of Skyrim AE, I've been reinstalling the Step Guide and had intended to include everything. Because of this I have installed the ENB options in all the steps prior to Post Processing. Now I'm not so sure I want to install/run an ENB with this build. Is it safe to jump to Step 05 or do I need to remove and reinstall the mods with the Post Processing (blue) flag? I am getting between 91-115 FPS in Riften with my new 144 Hz monitor.
    • By MegaDan32
      Hi! I have been trying to mod my Skyrim game for a couple of days now and I have been meticulosly following the STEP Skyrim Special Editio Guidelines and I have finally arrived to step 6.24.2. I already finished sorting the plugins with LOOT and already finished the standar cleaning procedures. Now I have to proceed with the performance benchmark which requires to launch the game for the first time after downloading and installing all the mods. Now here is the problem: When launching Skyrim, it will open, it shows the logo and a little loading animation on the bottom right, and it closes itself after a couple of seconds -No error pop ups or anything. I am pretty new when it comes to modding and I have no idea of what could be causing this problem, and I would love to fix this instead of uninstalling everything and retrying in a couple of months.
      Thank a lot beforehand!
    • By Mousetick
      Discussion topic:
      I'm Walkin' Here by Fudgyduff
      Wiki Link
      SKSE plugin with customizable JSON configuration.
      QOL: Disables collision between player and NPCs so that they don't push the player or block narrow passages.
      The description on the Nexus mod page is very short and rather vague:
      What this does exactly is disabling collision so the NPCs are no longer solid: they can walk through the player and vice-versa. They'll still get in your face while you're in a conversation, or clump together stuck in passageways. So it's not perfect, but it's much better than vanilla.
      The following NPCs and situations are addressed:
      Disables collision while the player is in dialogue. Disables collision between the player and their allies. Disables collision between the player and their summons. Disables collision between the player and their allies' summons. Each of the above can be turned on or off via configuration settings (all ON by default).
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.