Jump to content
  • 0
MartinMiggs

SKSE no longer connecting to Skyrim from MO

Question

Okay, so I recently made what should have been a simple error that is most likely responsible for SKSE failing to launch Skyrim properly when run through MO; however, nothing that I've tried has been able to fix the problem so far.

 

What happened:

I hit the 'Run' button with SKSE selected in the dropdown executables menu on MO like normal.

A message box appeared warning me that Steam was not currently running and that my game might not start properly if I proceeded as is.

I unthinkingly hit 'No' to continue trying to run the game without running Steam.

Obviously, at this point, MO stopped being able to run Skyrim.

 

I read that this is kind of a common problem, and all you need to do is reset the dialogue in MO's settings, run Steam, and continue playing as normal, but this has failed. I reset the dialogue, and to make sure the dialogue triggered, I had Steam not running, the dialogue showed up when I hit 'Run' in MO, and I made sure to hit 'Yes' to log into Steam. Still doing the same ol' thing, which I'll describe next below.

 

What happens when I try to run SKSE through MO:

Mod Organizer closes, because I set it to do that when it runs SKSE.

The small black box appears in the top left corner of my screen for a consistent 4 seconds (takes one second when SKSE not run through MO).

The black box disappears, and then I can wait as long as I please, but no game window ever shows up.

At this point, if I try to run the regular Skyrim launcher from Steam, it will tell me that it cannot because 'the app' is already open.

This error message from Steam does not appear if I restart my computer and launch vanilla Skyrim from Steam first.

So, regular Steam launcher works fine if I haven't run MO before it.

SKSE outside of MO also works just fine if I haven't run MO before it.

SKSE is installed perfectly fine. I followed Gopher's youtube tutorial for installing SKSE through MO. The SKSE_launcher.exe and those two other files are in the Skyrim folder, the Data folder was installed normally through MO, and I created the SKSE ini (not a txt) in the MO/mods/SkyrimScriptExtender folder. SKSE in the executables dropdown menu is the launcher.exe in the Skyrim folder.

MO ran SKSE perfectly fine without any hiccups for a couple of months before I got the Steam error message and clicked the incorrect response, so I can't possibly imagine what else could be responsible.

 

 

Edit:

I just found another thread with a general 'Skyrim won't start' title that sheds a little light onto the situation, but no great final solution. Apparently this is a Steam update problem? (Which probably explains why Steam signed itself out on me, usually it's always running.) I can get SKSE to run from MO again if I exit out of Steam, run SKSE, hit yes in the message box to run Steam, and then hit 'Okay' as soon as possible before Steam has begun to open. This is really ridiculous though.

Edited by MartinMiggs

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

There is a current open issue in the Bug Genie that seems to be related to the latest Steam client update and users with Win8.x. At this point in time there is no concensus on what are the conditions that cause this issue and as @Tannin, MO's author, uses Win8.x and hasn't experienced this it might be hard to track down.

If I can encourage you head over to the MO Bug Genie and see if your observations can be added to the issue.

Share this post


Link to post
Share on other sites
  • 0

This began happening to me today.  Even making sure Steam is running, SKSE says it's not.  I've not been able to get the game to load at all.  Has any solutions been found, or is it simply a case of wait until another Steam update fixes the problem?

 

I tried the fix offered by Bug Genie, but have had no success with the process_blacklist.txt solution.  I'm still getting a "Steam isn't running" error when I try starting the game with SKSE and MO.

 

Any other possible fixes?  I'm almost tempted to try a crack which indicates just how frustrating this is.

Edited by n0mad23

Share this post


Link to post
Share on other sites
  • 0

There's a force steam loader command that can be used; however, I can't be more specific than that since I'm currently at work.

Share this post


Link to post
Share on other sites
  • 0

I've been searching for command lines (I'm assuming that's how one forces steam loader with SKSE) but have come up dry.  I'm baffled as to what to do short of resorting to finding a crack and bypassing Steam all together.  I'd rather not do that.  Playing (and having to restart) the game without mods seems equally unreasonable.

 

I tried making a text file in my Mod Organizer folder, "process_blacklist.txt" and put in "steam.exe" and "steamerrorreporter.exe" (no quotations) on separate lines.  No help.  

 

What's happening is this:

 

I attempt to fire up Skyrim using the SKSE launcher within MO.  A pop up box appears on the desktop.  The top bar of this box reads "start steam?"  The box says "Steam is required to be running already to correctly start the game.  Should MO start Steam now?"

 

Steam is definitely running.  I've pulled up Task Manager and checked, rechecked, and then checked again.

 

If I say yes to starting Steam again, naturally it pulls up the Steam Skyrim launcher.  I tried firing up a vanilla game this way to make sure it works, and no problems.

 

However every time I try to start it with SKSE I get the same pop-up box message.

 

It's got to be a Steam Update, right?  I've done nothing to my mod list since early yesterday, and played the game in several sessions over the day and evening.  I turned of and restarted the computer several times in that time frame as well.  I had no problems until i tried to fire up the game earlier today.

 

Hope someone out there knows the answer to this.  I'd hate to have to resort to a crack to actually play a game that I own (+ 2 DLC's!)  I've got Skyrim on disc even!

Share this post


Link to post
Share on other sites
  • 0

Using Windows 8 I guess?

 

And don't even bother using a crack. 1) A lot of mods at Nexus wont work if you do and 2) You'll POSSIBLY get banned at Nexus if you're found to be doing it. Possibly other mod sites as well.

 

The -forcesteamloader argument is often used in the MO executable for SKSE. You could at least try that. Open MO, go to executables and type that in the arguments field for SKSE as typed.

Share this post


Link to post
Share on other sites
  • 0

 

And don't even bother using a crack. 1) A lot of mods at Nexus wont work if you do and 2) You'll POSSIBLY get banned at Nexus if you're found to be doing it. Possibly other mod sites as well (including this one).

 

The -forcesteamloader argument is often used in the MO executable for SKSE. You could at least try that. Open MO, go to executables and type that in the arguments field for SKSE as typed.

Have you double checked that SKSE is still installed properly? As in you have the skse files in the skyrim directory and you have the SKSE script files in MO like in the guide? I'd also try reverifying your skyrim files to be sure., despite it seemingly working with Vanilla.

https://wiki.step-project.com/Skyrim_Script_Extender

Share this post


Link to post
Share on other sites
  • 0

Excuse my hyperbole in the earlier post.  While I might "threaten" going with cracks, it's actually against my ethics and moral nature.  I still occupy the position that if you have legitimately purchased a copy of software, you should be allowed to do with it whatever you want, as long as it remains in your possession, but that's a debate for some other time and forum.  What I'm basically saying is while I actually considered trying to get the game running again by switching over to Nexus Mod Manager, I honestly wouldn't go with a crack for several reasons - some of which are articulated above.  Thanks for your patience.

 

Thank you all for such awesome advice.  After many hours of tinkering and trying different things I've got Skyrim with MO working again.  What I actually did (or if any of these things helped) remains an exercise in confused head-scratching.  

 

I was able to get SKSE to launch Skyrim last night, BUT only when using the -forcesteamloader in a shortcut I made to SKSE.  It only worked one time.  After that it was right back to the "Steam needs to be running" pop-up error box.  Putting the command line switch into the argument box of MO's SKSE executable only gave me the Steam Load error message.  Weird, huh?

 

It was the same when I tried it this morning, too.  No luck.  I spent a bit more time on the WIKI MO page (thanks phazer11 for that!) and if nothing else, I'm a bit better versed in MO than I was a few hours ago.

 

So I restarted my computer just a bit ago, and had a surprise when Steam actually asked me to log-in to my account.  That hasn't happened since this problem began.  I thought to myself, "could it be?"

 

Yup - SKSE and my modded Skyrim game are both working fine again.  I've started and exited the game 3 times now and all is well.

 

It's very strange to me - I've got several games installed on this "dream machine" but the only one I really want to fire up at all is Skyrim.  I bet there are a few readers of this who can totally relate.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By DogWada
      I'm using MO2 for Skyrim LE. When i first installed MO2 i selected "Create a portable instance" when i was prompted, so i don't have a global instance, i'm not sure if that's ok? I used Vortex before this and had no issues with FNIS so i do know how to use it.

      At this point i've watched multiple MO setup and installation guides and read a bunch of forum posts but i can't get GenerateFNISforUsers.exe to work when it's run through MO Executables. When i run it, it says:
      Generator: C:\Games\MO2\mods\2 FNIS Behavior 7_6\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      ">>Warning: Bad installation. Generator not run from <Skyrim_Data>\Tools\GenerateFNIS_for_Users. If you use a mod manager, run FNIS from its list of supported tools.<<
      Skyrim 32bit: ??.??.?? - C:\Games\Steam\steamapps\common\Skyrim\ (Steam)
      >>Warning: Expected generator path: C:\Games\Steam\steamapps\common\Skyrim\data\tools\GenerateFNIS_for_Users not found<<"
      But when i run "Explore Virtual Folder" and open GenerateFNISforUsers.exe there it loads all my mods fine. I could just activate it this way or go to the data tab in the right MO pane and right-click GenerateFNISforUsers.exe and select "Execute with VFS" each time but i'm concerned something won't work if im doing it this way, and it's less convenient to activate it like this every time.
      I did what this guide said: https://youtu.be/53472H4lAuA?t=597(timestamped) but this didn't work for me either. For him when he runs the GenerateFNISforUsers.exe through MO tools it says "MO is locked while the executionable is running", for me i get this message: and FNIS doesn't show on my screen so i can't see if it's loading my mods correctly or anything. If i click "Unlock" it says: and i think crashes FNIS. If i don't press unlock and just wait a few seconds the message will go away and my overwrite folder will have contents.
      After all of that if i set the Executables to the same directory i used for this process it still just gives me the same 2 warnings like i said at the start of the post.
      So what am i doing wrong here? What should i do?
       
    • By ApparatusHappy
      Ive been modding for a few years now, and its gone without a hitch. I dont use vortex since its over complicated, and use a community driven NMM (Nexus Mod Manager.) Ive tried installing skse64 to play my new mod profile, but i cant seem to load it on skse. It somewhat loads on vanilla, but very buggy and a ton of mods wont work. Ive uninstalled, reinstalled, disabled and re enabled, and ive even run on administrator, and reinstalled SKSE itself. Nothing seems to be working. i can give screenshots if needed
    • By frihyland
      Discussion thread:
      Mod Organizer Guide by DoubleYou & Step Modifications
      Wiki Link --> DOCUMENTATION UPDATE TOPIC
       

      This thread is for discussion and improvement of the Mod Organizer Guide on the wiki.
       
       
       
      This thread is for discussion of the Mod Organizer Guide, and should NOT be used for support/troubleshooting. Please use the Official Support Forum for support/troubleshooting.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.