Jump to content
Sign in to follow this  
Mephitic

Unsure if this can be changed

Recommended Posts

The demarcation for grass shown in the center of the left image below below is stark and distracting.

The bare areas fill in if I approach, as shown in the second image.

xLODGen, NGIO, TexGen, and DynDOLOD were run with HD settings recommended by S.T.E.P.
https://stepmodifications.org/wiki/SkyrimSE:2.0.0#xLODGen

Is there anything I can do to make the demarcation less drastic?

I've tried changing grass LOD mode in DynDOLOD and NGIO (GrassControl.config.txt) to no avail.

I also tried changing grass density but that didn't help, either.

Changing the mode in NGIO to zero works (sort of), the bare areas fill in with appropriate grasses but that takes DynDOLOD out of the picture and completely tanks performance.

grass_1.thumb.png.589c9477bc6beb6ca85f268756accc5f.pnggrass_2.thumb.png.24a1b8891e402a7c2464c0a0dfe07c1a.png

Is there anything I can do with generation settings in any of these tools to improve this situation?
I'm willing to sacrifice some performance if necessary.

Thank you in advance for any information or advice you may offer.

Share this post


Link to post
Share on other sites

My guess would be something up in the INI settings. If you haven't looked there yet, our BethINI setup is designed to work partly in combo with our LOD section (along with other things). So I would visit there. @DoubleYou would be your man. I've tagged him so he will be along when he is able.

Share this post


Link to post
Share on other sites
12 hours ago, Mephitic said:

The demarcation for grass shown in the center of the left image below below is stark and distracting.

The bare areas fill in if I approach, as shown in the second image.

xLODGen, NGIO, TexGen, and DynDOLOD were run with HD settings recommended by S.T.E.P.
https://stepmodifications.org/wiki/SkyrimSE:2.0.0#xLODGen

Is there anything I can do to make the demarcation less drastic?

I've tried changing grass LOD mode in DynDOLOD and NGIO (GrassControl.config.txt) to no avail.

I also tried changing grass density but that didn't help, either.

Changing the mode in NGIO to zero works (sort of), the bare areas fill in with appropriate grasses but that takes DynDOLOD out of the picture and completely tanks performance.

grass_1.thumb.png.589c9477bc6beb6ca85f268756accc5f.pnggrass_2.thumb.png.24a1b8891e402a7c2464c0a0dfe07c1a.png

Is there anything I can do with generation settings in any of these tools to improve this situation?
I'm willing to sacrifice some performance if necessary.

Thank you in advance for any information or advice you may offer.

Try setting "Mode" in the bottom-middle of the DynDOLOD GUI to '1'.

Either use our BethINI configuration to set your game INI values correctly for LOD distance and grass, or configure as follows:

skyrim.ini

[Grass]
bAllowCreateGrass=1
bAllowLoadGrass=0
bEnableGrassFade=0
fGrassFadeRange=14128

skyrimprefs.ini

[Grass]
fGrassMaxStartFadeDistance=6144
fGrassMinStartFadeDistance=0
fGrassStartFadeDistance=6144

NGIO

UseGrassCache = True
ExtendGrassDistance = True
ExtendGrassCount = False 

The following override the two corresponding game INI settings above, so they can be set as follows or commented:

OverwriteGrassDistance = 6144
OverwriteGrassFadeRange = 14128 

 

Use ..\DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_SSE.ini to configure GrassBrightness* values to alter grass LOD tint if defaults don't match your grass.

Share this post


Link to post
Share on other sites

Thank you z929669. All of those settings (DynDOLOD mode, game INIs and NGIO) are exactly what I have currently.

As I noted in my post, I've experimented with other settings for these values with no success.

I guess the only question remaining is draw distance - I haven't changed any of the view distance settings in BethINI yet.

Share this post


Link to post
Share on other sites

Try changing DynDOLODGrassMode to 0 in NGIO and see if there is a difference. 

Share this post


Link to post
Share on other sites
Posted (edited)

From my original post:

Quote

Changing the mode in NGIO to zero works (sort of), the bare areas fill in with appropriate grasses but that takes DynDOLOD out of the picture and completely tanks performance.

FPS drops to the twenties everywhere.

Edited by Mephitic
Fix typo

Share this post


Link to post
Share on other sites

If that is the case, your NGIO config cannot be the values recommended above. Type in the console the following to see what they are being set to:

getini "fGrassStartFadeDistance:Grass" 
getini "fGrassMinStartFadeDistance:Grass" 
getini "fGrassFadeRange:Grass" 
getini "iGrassCellRadius:Grass" 
getini "bEnableGrassFade:Grass" 

Also attach your NGIO config. You might have it set wrong somehow. 

Share this post


Link to post
Share on other sites

When you generated DynDOLOD, did you set Mode to 1 or 2? You have it set to 2 in NGIO, so if you didn't use mode 2 in DynDOLOD, set it to 1.

When you generated grass cache, did you use SuperDenseGrass of 8?

The console indicates that the grass fade distances are not set high enough in the INI files. Please set fGrassStartFadeDistance to 6144 in SkyrimPrefs.ini and fGrassFadeRange to 14128 in Skyrim.ini. 

Share this post


Link to post
Share on other sites
24 minutes ago, DoubleYou said:

When you generated DynDOLOD, did you set Mode to 1 or 2? You have it set to 2 in NGIO, so if you didn't use mode 2 in DynDOLOD, set it to 1.

When you generated grass cache, did you use SuperDenseGrass of 8?

The console indicates that the grass fade distances are not set high enough in the INI files. Please set fGrassStartFadeDistance to 6144 in SkyrimPrefs.ini and fGrassFadeRange to 14128 in Skyrim.ini. 

I had the mode set to 1 when I generated DynDOLOD. Setting it to 1 or 2 in NGIO makes only a marginal difference.

I will, however, set it to 2 in DynDOLOD and re-generate, per your suggestion.

I have the SuperDenseGrass toggle set to False in NGIO. I will set it to True and allow the SuperDenseMode of 8 to take effect.

I have set the SkyrimnPrefs fGrassStartFadeDistance and fGrassFadeRange in Skyrim.ini to the suggested values.

Thank you for your suggestions, and I'll report back after re-running all of the tools.

Share this post


Link to post
Share on other sites
On 3/24/2022 at 10:13 AM, Mephitic said:

I guess the only question remaining is draw distance - I haven't changed any of the view distance settings in BethINI yet.

BethINI will set your [terrainmanager] LOD distance settings as they should be if you followed that piece of the guide. You can also check these settings in DynDOLOD MCM config to see if they match expected values, which should be as follows for 'Ultra' BethINI and slightly lower (but proportionately similar) for 'High':

[TerrainManager]
fBlockLevel0Distance=57344
fBlockLevel1Distance=147456
fBlockMaximumDistance=327680
fSplitDistanceMult=1.0000

You should NOT need to run Mode 2 to get this working. Something is off in your setup if that's the case.

Share this post


Link to post
Share on other sites

Well, thank you all for your help and advice but I'm throwing in the towel on this one. I'll live with scorched earth, it is better than the 15 fps alternative.

I have heeded and implemented all of your suggestions and re-tun the tools and this is the latest result.

The pic on the left is with NGIO DynDOLODGrassMode set to 0. The pic is what I would expect if DynDOLOD were in the driver's seat but of course it is not and the FPS hovers at less than 20.

The pic in the center is with DynDOLODGrassMode set to 1, and the one on the right is when it is set to 2. There is very little difference between them and FPS is acceptable.

There is, as you say, something wrong in my setup but given the time and effort required to run the processes and probably do the divide-and-conquer thing on my load order, I'm all out of motivation to try to fix it.

I do want to thank you again for your help and advice, you folks are the best.

489830_20220325085912_1.thumb.png.f00ae67f62fdb350953103f6de7426da.png489830_20220325090453_1.thumb.png.0908ad64e544ad34a7fd2af13c9f083d.png489830_20220325090227_1.thumb.png.9f32763d2f0cb7e4771ca99fc5a0a259.png

Share this post


Link to post
Share on other sites
2 hours ago, Mephitic said:

Well, thank you all for your help and advice but I'm throwing in the towel on this one. I'll live with scorched earth, it is better than the 15 fps alternative.

I have heeded and implemented all of your suggestions and re-tun the tools and this is the latest result.

The pic on the left is with NGIO DynDOLODGrassMode set to 0. The pic is what I would expect if DynDOLOD were in the driver's seat but of course it is not and the FPS hovers at less than 20.

The pic in the center is with DynDOLODGrassMode set to 1, and the one on the right is when it is set to 2. There is very little difference between them and FPS is acceptable.

There is, as you say, something wrong in my setup but given the time and effort required to run the processes and probably do the divide-and-conquer thing on my load order, I'm all out of motivation to try to fix it.

I do want to thank you again for your help and advice, you folks are the best.

489830_20220325085912_1.thumb.png.f00ae67f62fdb350953103f6de7426da.png489830_20220325090453_1.thumb.png.0908ad64e544ad34a7fd2af13c9f083d.png489830_20220325090227_1.thumb.png.9f32763d2f0cb7e4771ca99fc5a0a259.png

Always remember that the NGIO grass mode and DynDOLOD grass mode travel together as described in the doc. You should be setting DynDOLODGrassMode=1 in NGIO and using the terrainmanager settings and grass settings I posted previously. You must run TexGen 3 with grass ticked followed by DynDOLOD 3 using Mode 1 and selecting 'High' preset. You have grass LOD, so that's not the issue.

The only other potential issue is that you have NGIO config settings overriding game INI settings. With the terrainmanager settings I provided, be certain that you have the following either commented out or enabled with these values. This could fix your entire issue without regenerating cache or DynDOLOD:

OverwriteGrassDistance = 6144
OverwriteGrassFadeRange = 14128

If you care to try again at some point in the future, this will work ;)

Otherwise, post on the DynDOLOD topic with your DynDOLOD logs, and sheson will help you find the issue. It will take some doing that route.

I also just updated our Grass LOD guide so that it is now correct for your situation.

Share this post


Link to post
Share on other sites

Those two Overwrite settings have been at those values in my GrassControl.config.txt since before my first post and haven't changed.

The corresponding values in Skyrim.ini and SkyrimPrefs.ini also match those values and also haven't changed.

I'll bring the issue up with Sheson et. al. at some future point.

Again, thank you for all of your advice and help.

  • Like 1

Share this post


Link to post
Share on other sites
On 3/24/2022 at 3:12 PM, Mephitic said:

I had the mode set to 1 when I generated DynDOLOD. Setting it to 1 or 2 in NGIO makes only a marginal difference.

I will, however, set it to 2 in DynDOLOD and re-generate, per your suggestion.

I have the SuperDenseGrass toggle set to False in NGIO. I will set it to True and allow the SuperDenseMode of 8 to take effect.

I have set the SkyrimnPrefs fGrassStartFadeDistance and fGrassFadeRange in Skyrim.ini to the suggested values.

Thank you for your suggestions, and I'll report back after re-running all of the tools.

You have completely misunderstood me :confused:

Do NOT use mode 2 at all. Set NGIO to mode 1. Set DynDOLOD to mode 1. Don't use mode 2. I was asking which mode you had used when generating DynDOLOD, not asking you to switch everything to mode 2.

Do NOT use SuperDenseGrass if you want good performance.

The console screenshot you linked proves that the game is reading the fGrassStartFadeDistance and fGrassFadeRange as 7000 and 1000 respectively. This is likely what is causing the gap in grass draw distance. Since your NGIO config appears to be correct, this doesn't make sense to me as it should be overwriting these values, and may be that there is something conflicting with NGIO causing it not to set these values correctly. At any rate, those settings seem to indicate that you may not be modifying the correct INI files, or perhaps the correct NGIO config file. If you are using Mod Organizer, it uses a separate set of INI files separate from the default in Documents\My Games\Skyrim Special Edition.

23 hours ago, z929669 said:

BethINI will set your [terrainmanager] LOD distance settings as they should be if you followed that piece of the guide. You can also check these settings in DynDOLOD MCM config to see if they match expected values, which should be as follows for 'Ultra' BethINI and slightly lower (but proportionately similar) for 'High':


[TerrainManager]
fBlockLevel0Distance=57344
fBlockLevel1Distance=147456
fBlockMaximumDistance=327680
fSplitDistanceMult=1.0000

You should NOT need to run Mode 2 to get this working. Something is off in your setup if that's the case.

These settings do not affect this. At any rate, these values probably should be removed from the guide, as I have better settings in current BethINI presets.

EDIT (z929669): Corrected terrainmanager values for posterity.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Halde
      Hey all!
      Did my complete STEP installment. I have two issues. The first is that there is a shadow following my character, at least at evening hours, around 6:30 pm ingame as can be seen on the screenshot. The sun is over the Falkreath hold, when I walk close, the edge of the shadow follows at the same distance it is in the screenshot. Meaning I can only see the sun, I can't be in the sun. This seems to be specific to the area surounding Falkreath however. The issue seems to be tied to something that generates or renders at approximately the distance of the shadow seen in the screenshot, because a similar, but much less visible effect appears when walking around other places such as around Riverwood or the plains of Whiterun. 
      The other is no dual sheathe. 
      I don't know what could've caused this, did the STEP setup by the letter, including Nemesis, so I'm thinking it might be one of the few mods I installed outside of STEP.
      These mods are
      Civil War Overhaul
      Expanded Towns and Cities
      Vigilant and the accompanied hi-res textures for the areas made for that
      Apocalypse + Vokrii compatibility
      Cloaks of Skyrim + CCOR compatibility patch
      While my knowledge is quite limited on the subject, the only thing I'm thinking that perhaps Cloaks of Skyrim could mess with the dual sheath. I haven't troubleshooted yet by trying to turn them off, I will do so tomorrow - merely wanted to put this out there, in case someone had experienced this themselves and immediately know the issue.
      Hoping for help!
      ~Sincerely
      Halde

    • By GraczNet
      Hello,
      I would like to remove WACCF from conflict resolution patch, but I'm new to xEdit. Is it enough that I uncheck it in CR patch installer? STEP guide says that "a minor subset of this mod's changes are forced by the Step patches". Could anyone point me at which records to remove? Thanks in advance
    • By Halde
      Title says it all, couldn't find a thread on it, and it's not mentioned in the guide. I'm leaning towards renaming it?
      ~Sincerely
      Halde
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.