Jump to content
  • 0
ValkyrieXRAY

SKSE for SSE will not launch through MO2

Question

I recently reinstalled Skyrim Special Edition on my PC and decided to use MO2 after failing to use Vortex. Fell in love with how simple and easy it is, and I regret that I didn't use MO years ago or MO2 whenever it was released. I launched the game out of the SKSE 64 executable and realized that none of my plugins were loaded in so I did a quick google search and realized that I needed to launch SKSE out of MO2. When I tried, the game had a black screen for a second like it does right before it loads the intro screen, and then it just crashes. Back to MO2. I have tried tons of solutions online, but so far nothing has worked. I would really be thankful if someone could help me get this sorted out. Thanks.

Edited by ValkyrieXRAY

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

There are a number of pitfalls that can prevent SKSE and the game from working correctly so I suggest using a vanilla profile with no mods installed to work through these:

 

Do not install Skyrim or Mod Organizer into C:\Program Files, C:\Program Files (x86) or any other UAC protected folder. Note that Windows 10 adds extra layers of protection on these folders that may prevent Mod Organizer's virtual file system from working.

 

Do not install Mod Organizer into the Steam or Skyrim folder because the virtual file system will not work correctly.

 

Using File Explorer, right click on ModOrganizer.exe and click Properties. If you see an Unblock button or checkbox, you need to click Unblock and click OK. If you are on Windows 10, you may need to repeat this for every DLL in the Mod Organizer folder and its subfolders. The recommended solution is to download Mod Organizer from Nexus, immediately unblock the file you downloaded, and then install or extract the files to the appropriate folder.

 

Run SkyrimSE.exe from Mod Organizer to verify you can run the base game without any issues.

 

Ensure you are using SKSE 2.0.16 and Skyrim SE 1.5.80. You can find the version number by right clicking SkyrimSE.exe, go to the details tab, and look at Product Version. If this is not 1.5.80, you'll need to run Steam and let it update Skyrim SE to the latest version.

 

In your vanilla profile (without any other mods installed and with a clean Data folder), install the SKSE scripts and try to run skse_loader.exe from Mod Organizer. You can do this my clicking install mod and select SKSE in the folder you downloaded it to. If you see a red "No game data", right click on the Data folder and click Set data folder.

 

 

When you install SKSE, you should copy only skse64_1_5_80.dll, skse64_loader.exe and skse64_steam_loader.dll to the Skyrim Special Edition folder (the folder containing SkyrimSE.exe). All of the scripts should be installed as a mod in Mod Organizer using the steps above.

Share this post


Link to post
Share on other sites
  • 0

Thanks Greg. After disabling all my mods and installing the SKSE scripts through MO, SKSE will now run out of MO. Now I just got to fix my load order

Share this post


Link to post
Share on other sites
  • 0

Thanks Greg. After disabling all my mods and installing the SKSE scripts through MO, SKSE will now run out of MO. Now I just got to fix my load order

Also something to keep an eye out for are mods that aren't updated to the latest SKSE version. These mods can cause the game to not launch, so if you're having an issue with the game not launching with mods active this is one thing to check. Most authors are pretty good about updating their mods for new SKSE releases, though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By sheson
      DynDOLOD DLL beta for Skyrim, Skyrim Special Edition and Skyrim VR
      So far all versions of DynDOLOD use the SKSE plugin PapyrusUtil for the optional dynamic LOD in the game. Starting with version 2.45 there is now the alternative DynDOLOD DLL available.
      The current DLL version is 2.45. It works with dynamic LOD generated by DynDOLOD Standalone 2.45 and newer.
      Read the ..DynDOLOD\Docs\DynDOLOD_DLL.html included in DynDOLOD Standalone for an explanation about DynDOLOD DLL, installation instructions (overwrite papyrus scripts of DynDOLOD Resources) and how it works.
      If there are problems with it, check DynDOLOD_DLL.html and the DynDOLOD FAQ first before posting.
      If a DynDOLOD.DLL version is required for a game version that is not listed below, request it in this thread. First, search this thread if it has been requested already, though. The future will tell how long it takes to release updates.
      Typically a new DynDOLOD.DLL is required for each new game version, but not each new SKSE version. For example a DynDOLOD.DLL compiled with SKSE64 2.0.9 also works with SKSE64 2.0.10 for the same game version.
      Nexus Downloads for DynDOLOD 2.45 and higher
      DynDOLOD DLL for Skyrim
      DynDOLOD DLL SE for Skyrim Special Edition
      DynDOLOD DLL VR for Skyrim VR
      Mega Mirrors:
      DynDOLOD.DLL + Scripts for Skyrim 1.9.32 (overwrite the papyrus scripts included in DynDOLOD Resources)
      DynDOLOD Scripts for Skyrim Special Edition and Skyrim VR (overwrite the papyrus scripts included in DynDOLOD Resources SE)
      DynDOLOD.DLL for Skyrim Special Edition 1.5.39
      DynDOLOD.DLL for Skyrim Special Edition 1.5.50
      DynDOLOD.DLL for Skyrim Special Edition 1.5.53
      DynDOLOD.DLL for Skyrim Special Edition 1.5.62
      DynDOLOD.DLL for Skyrim Special Edition 1.5.73
      DynDOLOD.DLL for Skyrim Special Edition 1.5.80
      DynDOLOD.DLL for Skyrim Special Edition 1.5.97
      DynDOLOD.DLL for Skyrim VR 1.4.15
    • By qwrtui1245
      Hi, 
      I'm modding SkyrimSE with MO2 by following this version of the step guide: https://stepmodifications.org/wiki/SkyrimSE:1.0.0#04-Foundation. I've followed everything until now but experience problems with the first mod I need to install without using Nexus. It's Skyrim SE particle patch for ENB and I downloaded 'SPECIAL EDITION > ALL-IN-ONE INSTALLATION > LATEST VERSION (GOOGLE DRIVE)'. It's installation went fine (Situation A) but when I have to enable the optional ESP 'Particle Patch for ENB SSE.esp' I get the message 'Plugin not found: Particle Patch for ENB SSE.esp' in my log (Situation B). 
      I've tried: reinstalling the mod, refreshing, enabling and disabling the mod, restarting MO2, re-downloading the file. It doesn't fix my problem. I've added the pictures of situation A and B. I hope there are people who can help me here. Thanks so much in advance!
      Situation A

      Situation B

       
    • By Newtant
      Hello!

      I've stumbled upon a weird issue that I haven't encountered or read about before. I'm running Windows 8.1 and a fresh install of Fallout New Vegas with no mods so far. I'm trying to get Mod Organizer and the 4GB exe to work together, but despite following all of the advice, tips and workarounds it's still not happening. Right now I can launch the 4GB exe through Mod Organizer. The game starts, I can load a save and 'play'. The problem is that all of the text has disappeared or is invisible. I can only navigate the main menu by memory, the ingame popups regarding the DLC is missing the text as well.

      This issue does not happen if I start the game on its own with the normal exe.
      This issue does not happen if I start the 4GB exe on its own.

      It only happens if I start the either the normal or the 4GB exe through Mod Organizer.

      NVSE is being loaded, it doesn't matter if I'm using NVSE stable or beta.
      I'm using NVAC, without it the game crashes before arriving at the main menu. NVAC seems to be working, the log is showing several handled errors. (Pastebin)
      Yes, I've added '-laaexe .\FalloutMO.exe' to the launch arguments, that helped me get around the access is denied error but produced this text error.
      I did try compatability modes, I've tried starting MO, the 4GB or both as administrator. No dice.

      I've arrived at a point where I really don't know what it could be or what I could try next. One thing I do know, however, is that I can't go back to the pre-MO modding, so I'm turning to you helpful people and hope that someone here has an idea.

      Thanks in advance!
       
      Pictures:
      New Vegas installation folder
      Mod Organizer executable settings
      Disappeared text main menu #1
      Disappeared text main menu #2
      Disappeared text ingame
       
      Edit:
       
      I deleted all of the fallout .inis as well in case some of my text/font settings were messed up, but that didn't work either.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.