Jump to content
  • 0

.NET Timeout while running external installer


Haifisch7734
 Share

Question

Hello

 

when I try to install mods like SkyUI or Quality World Map, which need to run external installer, I get stuck at "running external installer" window for about 15-20 minutes, then I get errorcode 5 with this message:

 

TaBqLUr.png

 

which means:

 

The property 'InstallationPaths' could not be created from it's default value. Error message: Timed out waiting for a program to execute. The command being executed was "C:\Windows\Microsoft.NET\Framework\v2.0.50727\csc.exe" /noconfig /fullpaths @"C:\Users\Wojciech\AppData\Local\Temp\ehbjyame.cmdline".

 

I found no solution for this in this forum and in the internet.

 

I have Windows 10 and newest version of Mod Organizer.

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Yes, I upgraded my Windows 8.1. I have installed few versions of .NET, including v3.5 and v4.0

 

L7Hgyss.png

 

I've tried changing .NET versions in NexusClientCLI.exe.config, but it didn't really help. When I changed supportedRuntime to "v3.5", installator told to install .NET v3.5, which is already installed (I tried to install it manually, but its installer doesn't even start). When I changed supported to "v4.0" or "v4.0.30319", I got error CS1703:

 

U17GBYr.png

 

"An assembly with the same identity 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' has already been imported. Try removing one of the duplicate references."

 

And I couldn't find solution for this problem.

Link to comment
Share on other sites

  • 0

Open the Control Panel, Programs, Turn Windows Features On or Off, check the .NET Framework 3.5 in the list, and click OK. This should hopefully fix the issue.

It's already checked.

 

Error Code 5 is typically a permissions issue. Try and see if running as admin fixes the issue. My guess is a temporary directory does not have the correct permissions.

I changed my TEMP and TMP variables from "C:\Windows\Temp" to "AppData\Local\Temp", I have Skyrim and MO installed on E: drive, I tried running as admin, still nothing.

Link to comment
Share on other sites

  • 0

I'm also having the same exact problem installing SkyUI
I've upgraded from win7 to Windows 10 and was trying to update my mods when this stopped me.

I confirmed I have both the latest 4.6 .NET and version 3.5 active.

I guess I'll follow suit as if I know what I'm doing. This is my mo_interface.log and if you need a modorganizer.log I can get some but they won't fit in pastebin's character limitations.
Let me know if you need any other feedback to assist in finding the cause. I, myself, am not sure where to go from here.

Link to comment
Share on other sites

  • 0

I've recently built a new Windows 10 system and only today have I gotten around to installing MO and Skyrim.

There is no issue with my computer with regard to .NET errors. Steam correctly installs .NET 3.5 when you choose to run Skyrim for the first time and MO calls the external installer when SkyUI is installed.

 

There has to be some deeper issues with your OS that you will need to investigate in order to solve this error.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.