Jump to content
  • 0
Sign in to follow this  
aaltair

Anisotropic Filtering On/Off?

Question

Hi,

 

I was recently told by someone knowledgeable that it looks like my anisotropic filtering is off. It's enabled in my ENB so I was confused by this. It was suggested I turn it off in the ENB and on in my drivers. I did this, no change. I enabled it a variety of different ways and any way I do it I see no change, including turning it off everywhere. 

 

Here is a picture of the tundra with AF enabled in my ENB but off everywhere else, as instructed by the ENB author:

 

MVd835rl.png

 

https://imgur.com/MVd835r

 

And here is a picture with AF disabled everywhere- drivers, skyrim launcher, enb, all off:

 

7ADe0Zjl.png

 

https://imgur.com/7ADe0Zj

 

 

I should also say it was this picture which prompted the observation that AF was off. I don't know what else to take a picture of for an example. 

 

So... I don't know what to make of this and really, I don't even know what it's -supposed- to look like with AF off, so I can't even say what's wrong with the picture other than clearly it's not working if I can turn it off everywhere and get the same result. Does the image look wrong to you guys? What is it supposed to look like with AF and why would my AF not be working? 

 

Here's a picture of the relevant parts of the Inspector pane, I don't know what most of it does, I just followed STEP and the ENB author's recommendations:

 

oQfkgWem.png

 

https://imgur.com/oQfkgWe

 

Any help with this puzzling situation would be wonderful.

 

*Edit: I just realized my thumbnails were not going full size when clicked for some reason, so I added direct links below the images.

Edited by aaltair

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

If you have it on in ENB you use that type of AF. If you have the driver version on you use that. Not much more to it then that. 

 

The driver version would always overwrite the ENB version if it is on and set to override. 

 

I am going to guess that the author thinks about the LODbias feature in your enblocal.ini. It is an expanded way of sorta doing what AF does.. but where you can scale how much it does it. If the value of that aint the same as on the authors computer, then it will look very different very quickly. 

 

Also it really depends on which textures are used. Higher detail textures tend to have more "blacks" in them, which the LODbias will emphasize more just like all sharpen techniques does. 

Share this post


Link to post
Share on other sites
  • 0

But if I turn AF to Off in both the drivers and the ENB, shouldn't I see some sort of difference, or is it that subtle?

 

In my enblocal the lod bias is:

 

ForceLodBias=false
LodBias=0.0
 
I've not seen anything saying I should change that.

Share this post


Link to post
Share on other sites
  • 0

The effect is rather subtle if you do not know what to look for. In general it is texture sharpness. So it is mostly only relevant when you got something sorta up close. The reason you can also sometimes notice it in the distance is because of grass textures... when your grass density is sufficient the change it makes to the texture will make the effect noticeable. 

 

You can go to the wikipedia entry for the effect and see the comparison image there... it is rather subtle on most textures. 

Share this post


Link to post
Share on other sites
  • 0

It becomes very obvious if you look at textures at a very small angle, like around the corner of a building.

Share this post


Link to post
Share on other sites
  • 0

Well, I tried looking at roads with it completely disabled, then with it enabled in ENB only, then with it disabled in ENB and enabled in drivers, and I see no difference between the three. This leads me to believe that something, somewhere, somehow, is forcing it off no matter what, or on no matter what, or I'm really just that blind and can't tell the difference.

 

It's bugging me either way.

 

If you guys wouldn't mind terribly, could you just look at these three pics and tell me if there is any difference between them to you? If there isn't any difference between the three I really want to try and figure out why, and whether it's being forced on or forced off by something, maybe something I missed or something weird with my computer or skyrim install.

 

AF is off in ENB, Drivers and Skyrim Launcher

 

AF is On in the enblocal only

 

driver-controlled AF

 

Same road, same time of day, same weather.

 

With the wiki picture of AF on/off I could see a very noticeable difference, but with these three pictures I can't, and judging from the blurriness of the road a short distance away I am inclined to think AF is off in all three scenarios.

 

Edit: I did as Spock suggested and checked out a building corner. Here's the result:

 

AF Off

 

ENB AF On

Edited by aaltair

Share this post


Link to post
Share on other sites
  • 0

It is, it's just the same result no matter what I set it to, whether enabled in the ENB or drivers or both or neither. That's what has me puzzled.

Share this post


Link to post
Share on other sites
  • 0

When doing compare shots... make sure you do it in the exact same spot all the time. Since the effect is so rather subtle, and you have other post processing effects overlaying as well it will be really difficult to notice the difference. 

Share this post


Link to post
Share on other sites
  • 0

Turn it off in your SkyrimPrefs.ini for your current profile in MO (make sure all AA is off as well in that INI). Then turn it on in ENBlocal.ini.

Share this post


Link to post
Share on other sites
  • 0

You will get better compares if you have your shot, then turn off your mouse, save the game and then take the comparison shots (without moving the mouse). Try to make the angle even smaller around the corner, you will definitely see the difference in AF.

Here is a rather extreme example of what AF does (this is probably an older game with less post processing effects so it is more visible):

https://www.tweakguides.com/images/GGDSG_22.jpg

Share this post


Link to post
Share on other sites
  • 0

hishutup: my graphics card is an nvidia 760

 

I will take a couple more compares with it on/off and at a smaller angle as Spock suggested, tomorrow. Although, if the in-game effect really is so subtle that you can only notice it if you stand at just the right angle, maybe I shouldn't be worrying about it so much, lol.

Share this post


Link to post
Share on other sites
  • 0

AF can be kind of subtle depending on the scene. Stuff like normal mapping, parallax and post processing can mask the effect a little. This really depends on the scene. I suggested an even smaller angle simply because you can immediately tell then if AF is on or off. If it is off, the wall will become so blurred that you can immediately tell.

Those corner shots look like AF is enabled in both of them though.

 

As a general guideline, I would always keep AF at 16x, it is very cheap but usually has a great effect on quality, even if you cannot always pinpoint it.

 

I just noticed my direct image link from my previous post doesn't work. It's the example from this article (scroll down to the AF section):

https://www.tweakguides.com/Graphics_11.html

Edited by Spock

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By zsark
      What the title says, pic pretty much shows it all. Using Silent Horizons ENB.

      plugins.txt Load Order.txt
    • By zsark
      So I'm having this issue where ENB seams to break the "seamless" horizon provided by cathedral weathers. Doesn't seem to matter what ENB I use, no conflicts in Xedit however I have read on a few forums (STEP) that this issue seems to be present no matter what and the more detailed rendering offered by ENB can make this issue more noticeable. Also this definitely seems more prominent during dawn/dusk nor really visible during other times. I'm not sure if it's really a mod issue, or if it's just another one of those fugly bethesda seams that we all inevitably see. ENB doesn't seem to matter I always notice this on clear dawn/dusks. Any input or advice would be appreciated. (Issue is easier to see in game than in screenshots) Here's  a link to a post I made on LL with screenshots. https://www.loverslab.com/topic/182711-skyrim-se-enbs-and-sky-mesh-issue/#comment-3631259
       
      Load Order.txt plugins.txt
      Edited to remove formatting
    • By EssArrBee
      Discussion Topic:
      ENBoost by Boris Vorontsov
      Wiki Link

      STEP does not recommend downloading the Skyrim Nexus version of ENBoost due to incorrect settings for STEP.
      Grab the latest binary from ENB Dev: https://enbdev.com/download_mod_tesskyrim.html
       
      Boris's VRAMSizeTest Tool for ENBoost: https://enbdev.com/download_vramsizetest.html
      For Skyrim run the DX9 version. For Windows 7, subtract 170 from the value the tool gives. For Windows 8/10, subtract 305 from the value the tool gives. Set VideoMemorySizeMb in the "Enblocal.ini" file to the resulting value.
      CTD and Performance patch ENBoost by Boris Vorontsov

      Looks like Boris has pretty much figured out his memory fix and released it on the nexus. I believe you still need ENB and then the file on the nexus is an extra INI that is dependent on your videocard.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.