Jump to content

Recommended Posts

I updated DynDOLOD DLL NG to the latest version (alpha 28 for 1.5.x) from nexus, but now Skyrim says "dyndolod.dll and papyrus script versions do not match"

Link to comment
Share on other sites

3 hours ago, tabaras said:

I updated DynDOLOD DLL NG to the latest version (alpha 28 for 1.5.x) from nexus, but now Skyrim says "dyndolod.dll and papyrus script versions do not match"

Use DynDOLOD DLL NG and Scripts Alpha 27 in the meantime. https://dyndolod.info/Help/Large-Reference-Bugs-Workarounds#Requirements

Reuploaded Alpha 28, hopefully now with correct runtime version.

  • Like 1
Link to comment
Share on other sites

I'm having and issue with my new output not initializing in game, I'm running 1.6.640 and my dyndolod version expired. That's no problem I was actually excited, so i updated dyndolod and the resources/dll ran it successfully switched to it with a clean save and nothing. If I go back to my old output and dll v24 it works, so i finally realized i needed to update my papyrusutils. Okay no problem... so here's where I'm wondering if I'm missing something. Dyndo dll 28.1 requires paputil 4.6 which requires skse 2.2.6 so even if you get an output it can't function on 1.6.640 anymore because it can only go up to skse 2.2.3 and paputil 4.4?

Link to comment
Share on other sites

6 hours ago, UnqualifiedKoala said:

I'm having and issue with my new output not initializing in game, I'm running 1.6.640 and my dyndolod version expired. That's no problem I was actually excited, so i updated dyndolod and the resources/dll ran it successfully switched to it with a clean save and nothing. If I go back to my old output and dll v24 it works, so i finally realized i needed to update my papyrusutils. Okay no problem... so here's where I'm wondering if I'm missing something. Dyndo dll 28.1 requires paputil 4.6 which requires skse 2.2.6 so even if you get an output it can't function on 1.6.640 anymore because it can only go up to skse 2.2.3 and paputil 4.4?

Read https://dyndolod.info/Official-DynDOLOD-Support-Forum#Post-Logs which DynDOLOD log and debug log to upload when making posts.
Also upload the papyrus logs as exaplained.
Also upload the c:\Users\[USERNAME]\Documents\My Games\Skyrim Special Edition\SKSE\DynDOLOD.log as explained in https://dyndolod.info/Help/DynDOLOD-DLL#Troubleshooting

DynDOLOD DLL SE does not require PapyrusUtil. The DynDOLOD DLL SE together with the DynDOLOD DLL SE Scripts is a drop-in replacement that can be used instead of PapyrusUtil. The current version of the DynDOLOD DLL SE Scripts is 2.82.9.

PapyrusUtil 4.6 is for runtime 1.6.1170. If you are using 1.6.640, then you obvious need to use Version 4.4 for SKSE 2.2.2+, Skyrim 1.6.640, & Address Library

Link to comment
Share on other sites

  • 1 month later...
58 minutes ago, stjameshawke said:

I switched from the normal Dyndolod DLL to the NG version (Alpha 29) for my latest game, and it makes my terrain looks worse than vanilla. Reverted. 

Read https://dyndolod.info/Official-DynDOLOD-Support-Forum#Post-Logs which logs and debug logs to post when making posts.

Read https://dyndolod.info/Official-DynDOLOD-Support-Forum#In-Game-Screenshots how to make useful screenshots.

https://dyndolod.info/Official-DynDOLOD-Support-Forum
Report the actual problem or error message without making assumptions or asking leading questions. Read the explanations and tips below, especially about what information and logs to provide and how. Also see Don't ask to ask, just ask and How do I ask a good question? Try not to make posts that only promise more information, logs etc. in the future. If it takes time to first gather information, logs etc. it is fine to just take it and then post when ready.
Disabling something is typically a troubleshooting step and not a fix, especially when trying to circumvent errors or problems. Research the issue and report problems to the official DynDOLOD support forum, so they can be properly troubleshooted and fixed, whatever their reasons are.

DynDOLOD and consequently DynDOLOD DLL NG or its former alternatives do not directly affect full terrain or terrain LOD meshes or textures. See https://dyndolod.info/Help/DynDOLOD-DLL:
The DynDOLOD DLL NG and Scripts for Skyrim SE, Skyrim AE, Enderal SE, Skyrim VR and Enderal VR controls dynamic LOD via native code instead of papyrus scripts and also fixes several LOD related bugs, like object LOD not unloading after fast travel, tree LOD missing after fast travel and large reference bugs.

DynDOLOD is a tool to generate a tree and object LOD patch based on the the current load order and the user choices. If the terrain in the active cells or the terrain LOD in the distance looks worse than vanilla, then it most likely has nothing to do with using DynDOLOD DLL NG, DynDOLOD DLL SE or PapyrusUtil.

Link to comment
Share on other sites

I am trying to generate LODs for modded Enderal SE from GOG. This is the standalone version of the game, based on older versions of Skyrim SE and SKSE. I installed the latest versions of DynDOLOD 3.0, DynDOLOD Resources SE 3 and DynDOLOD DLL NG for 1.5.x/1.6.x using MO2. When trying to launch DynDOLODx64 the tool fails to start with the following error. 

Error: DynDOLOD.DLL from DynDOLOD.DLL and Scripts not found! Dynamic LOD can not be generated. Verify correct installation of the DynDOLOD.DLL from DynDOLOD.DLL and Scripts.

Here is the full log: https://pastebin.com/TTPNfERC

Some other notes:

  • I tried running the older PapyrusUtil + DynDOLOD DLL SE version and that works fine. The issue only happens with DynDOLOD DLL NG.
  • DynDOLOD DLL NG works fine with the game itself (SKSE loads it correctly), only the LOD generation tool says it can't find the files.
  • xLODGen and TexGen have no issues with the same setup and the same launch arguments in MO2.
Link to comment
Share on other sites

7 hours ago, Sack said:

I am trying to generate LODs for modded Enderal SE from GOG. This is the standalone version of the game, based on older versions of Skyrim SE and SKSE. I installed the latest versions of DynDOLOD 3.0, DynDOLOD Resources SE 3 and DynDOLOD DLL NG for 1.5.x/1.6.x using MO2. When trying to launch DynDOLODx64 the tool fails to start with the following error. 

Error: DynDOLOD.DLL from DynDOLOD.DLL and Scripts not found! Dynamic LOD can not be generated. Verify correct installation of the DynDOLOD.DLL from DynDOLOD.DLL and Scripts.

Here is the full log: https://pastebin.com/TTPNfERC

Some other notes:

  • I tried running the older PapyrusUtil + DynDOLOD DLL SE version and that works fine. The issue only happens with DynDOLOD DLL NG.
  • DynDOLOD DLL NG works fine with the game itself (SKSE loads it correctly), only the LOD generation tool says it can't find the files.
  • xLODGen and TexGen have no issues with the same setup and the same launch arguments in MO2.

Moved to the DynDOLOD DLL thread.

See https://dyndolod.info/Official-DynDOLOD-Support-Forum#Post-Logs which DynDOLOD log to also upload in addition to the debug log. Also upload the papyrus log.
Also upload the DynDOLOD.log as explained in https://dyndolod.info/Help/DynDOLOD-DLL#Troubleshooting

The message means, that the papyrus scripts included in DynDOLOD DLL NG are being overwritten by the papyrus scripts from 1 - DynDOLOD DLL SE - Scripts  from DynDOLOD DLL SE.

If the intention is to use use DynDOLOD DLL NG, remove the 1 - DynDOLOD DLL SE - Scripts and make sure that nothing overwrites anything from DynDOLOD DLL NG.

Link to comment
Share on other sites

4 hours ago, sheson said:

Moved to the DynDOLOD DLL thread.

See https://dyndolod.info/Official-DynDOLOD-Support-Forum#Post-Logs which DynDOLOD log to also upload in addition to the debug log. Also upload the papyrus log.
Also upload the DynDOLOD.log as explained in https://dyndolod.info/Help/DynDOLOD-DLL#Troubleshooting

The message means, that the papyrus scripts included in DynDOLOD DLL NG are being overwritten by the papyrus scripts from 1 - DynDOLOD DLL SE - Scripts  from DynDOLOD DLL SE.

If the intention is to use use DynDOLOD DLL NG, remove the 1 - DynDOLOD DLL SE - Scripts and make sure that nothing overwrites anything from DynDOLOD DLL NG.

Apologies for posting in the wrong section.

DynDOLOD DLL SE is not installed when this error happens. Nothing is overwriting DynDOLOD DLL NG according to MO2. To make sure, I just tried again on a clean MO2 profile with nothing installed other than DynDOLOD, and the result is still the same. You can see what that looks like here.

Here are all the logs for this new, clean, install showing the same error:

DynDOLOD_ENderalSE_log.txt https://pastebin.com/1BQ5wHnB

DynDOLOD_EnderalSE_Debug_log.txt https://pastebin.com/cBf6v0ED

Papyrus.0.log: https://pastebin.com/r30dkJcR

Edited by Sack
fixed link
Link to comment
Share on other sites

What can cause the distance settings to suddenly change to zero during play? After playing a while the distant terrain stops loading; when I check the Settings section of the MCM, fBlockLevel0Distance, fBlockLevel1Distance, fBlockMaximumDistance, and fTreeLoadDistance are all zero. SkyrimPrefs.ini still has the old settings (including after exiting the game). I can manually set the sliders to something more "normal" and everything immediately starts rendering again. I suspected ShadowBoost was responsible but this happens on a new game without it also. I've carefully picked through my modlist for anything that might change settings like this (such as SSE FPS Stabilizer, which I don't have installed) but am pretty sure there isn't anything.

Running Resources Alpha-50 and DLL NG Alpha-29. Rebuilt LOD with the latest version when this started happening but no change.

Hoping this is a known issue that I've just missed somewhere.

Link to comment
Share on other sites

Was just curious about your thoughts on this discussion.

https://github.com/SaneEngineer/No-Grass-In-Objects-NG/issues/20

It talks about frequent crashing during the grass cache process if either True Hud or Dyndolod DLL NG is enabled.  I don't recall experiencing this with 1.5.97, but seems to be something a lot are experiencing in 1.6.1130+

 

Link to comment
Share on other sites

5 hours ago, Sack said:

Apologies for posting in the wrong section.

DynDOLOD DLL SE is not installed when this error happens. Nothing is overwriting DynDOLOD DLL NG according to MO2. To make sure, I just tried again on a clean MO2 profile with nothing installed other than DynDOLOD, and the result is still the same. You can see what that looks like here.

Here are all the logs for this new, clean, install showing the same error:

DynDOLOD_ENderalSE_log.txt https://pastebin.com/1BQ5wHnB

DynDOLOD_EnderalSE_Debug_log.txt https://pastebin.com/cBf6v0ED

Papyrus.0.log: https://pastebin.com/r30dkJcR

Also upload the DynDOLOD.log as explained in https://dyndolod.info/Help/DynDOLOD-DLL#Troubleshooting

Doublecheck the game data path C:\Games\Enderal Special Edition GOG\Data\ used by DynDOLOD is the same one that is also used by MO2.

In MO2, right Window Data tab, enter "DynDOLOD" without the double quotes into bottom Filer field. Unfold the [+] Scripts Folder. Make sure to enable the Name, Mod, Type, Size and Data columns.

There should be 10 SHESON_DynDOLOD_*.pex scripts. Three from DynDOLOD Resources SE and seven from DynDOLOD DLL NG.
Upload a screenshot of that.

Link to comment
Share on other sites

1 hour ago, Vraylle said:

What can cause the distance settings to suddenly change to zero during play? After playing a while the distant terrain stops loading; when I check the Settings section of the MCM, fBlockLevel0Distance, fBlockLevel1Distance, fBlockMaximumDistance, and fTreeLoadDistance are all zero. SkyrimPrefs.ini still has the old settings (including after exiting the game). I can manually set the sliders to something more "normal" and everything immediately starts rendering again. I suspected ShadowBoost was responsible but this happens on a new game without it also. I've carefully picked through my modlist for anything that might change settings like this (such as SSE FPS Stabilizer, which I don't have installed) but am pretty sure there isn't anything.

Running Resources Alpha-50 and DLL NG Alpha-29. Rebuilt LOD with the latest version when this started happening but no change.

Hoping this is a known issue that I've just missed somewhere.

Read https://dyndolod.info/Official-DynDOLOD-Support-Forum#Post-Logs which DynDOLOD log and debug log to upload when making posts.

As explained at https://dyndolod.info/Help/DynDOLOD-DLL#Troubleshooting, also upload the DynDOLOD.log from the Documents ... SKSE folder.

It might be possible this happens because of something modifying how fast travel, loading worldspaces or events work in the engine. If you know how to replicate it, edit DynDOLOD output ..\skse\plugins\DynDOLOD_Data\DynDOLOD_NG_Worlds.txt with notepad and change debug=true and add a new line debuglevel=5 underneath it. Then start the game and do whatever is required for settings to be zero. Then upload DynDOLOD.log from the Documents ... SKSE folder.

Link to comment
Share on other sites

18 minutes ago, Soulmancer said:

Was just curious about your thoughts on this discussion.

https://github.com/SaneEngineer/No-Grass-In-Objects-NG/issues/20

It talks about frequent crashing during the grass cache process if either True Hud or Dyndolod DLL NG is enabled.  I don't recall experiencing this with 1.5.97, but seems to be something a lot are experiencing in 1.6.1130+

https://github.com/SaneEngineer/No-Grass-In-Objects-NG/issues/20#issuecomment-2078555904
DynDOLOD DLL NG Alpha-23 was just released today, and I tried that with NGIO-NG-1.0.12-1.6.640 and it ran normal

https://dyndolod.info/Official-DynDOLOD-Support-Forum
Report the actual problem or error message without making assumptions or asking leading questions. 

https://dyndolod.info/Official-DynDOLOD-Support-Forum#Rudimentary-Troubleshooting

https://dyndolod.info/Official-DynDOLOD-Support-Forum#Post-Logs
In case of CTD in the game, upload the crash log from .NET Script Framework or Crash Logger.

 

Link to comment
Share on other sites

2 hours ago, sheson said:

Also upload the DynDOLOD.log as explained in https://dyndolod.info/Help/DynDOLOD-DLL#Troubleshooting

Doublecheck the game data path C:\Games\Enderal Special Edition GOG\Data\ used by DynDOLOD is the same one that is also used by MO2.

In MO2, right Window Data tab, enter "DynDOLOD" without the double quotes into bottom Filer field. Unfold the [+] Scripts Folder. Make sure to enable the Name, Mod, Type, Size and Data columns.

There should be 10 SHESON_DynDOLOD_*.pex scripts. Three from DynDOLOD Resources SE and seven from DynDOLOD DLL NG.
Upload a screenshot of that.

Sorry, here is the right log file, DynDOLOD.log: https://pastebin.com/19PsUGFx

Here is a screenshot of the MO2 folder structure as you requested. Everything seems to match what you're describing.

As far as I can tell, all the folders are configured correctly. As mentioned earlier, using DynDOLOD DLL SE with the exact same setup works fine, as you can see here. The only difference between these two attempts is I swapped DynDOLOD DLL NG with DynDOLOD DLL SE, everything else is using the same settings across all applications.

Thank you for your patience.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.