Jump to content
  • 0

TES5Edit Errors Sorting Masters on WryeBash Orange File



Amazingly, I finished the S.T.E.P. through Section 2.   The game starts, the main screen comes up, gives me a red warning about ENBoost, and then just sits there.  I've checked enblocal.ini, skse.ini, skyrim.ini and skyrimprefs.ini, and they appear correct to me.  But, since I'm a noob at ini edits and MO, WryeBase and TES5Edit, I have no certainty that they are accurate.  I read on this WryeBash form of another who, when trying to rerun WryeBash, generated red or orange mods.  I had two of them.  I followed the instructions (run TES5Edit, Select None, Select one of the red or orange files, then let TES5Edit do its thing.  After it completes, right-click on the problem mod and Sort Masters, wait a minute, then close).  That worked for STEP Compilation Patch, but it does NOT work for hearthfiresextended.esp.  When I run TES5Edit on hearthfiresextended.esp, I get this "assertion failure" error:


date/time         : 2016-01-20, 12:47:01, 11ms
computer name     : ALIENS
user name         : owner <admin>
registered owner  : owner
operating system  : Windows 7 x64 Service Pack 1 build 7601
system language   : English
system up time    : 2 days 2 hours
program up time   : 1 minute
processors        : 4x AMD Phenom II X4 955 Processor
physical memory   : 3457/8191 MB (free/total)
free disk space   : (C:) 92.51 GB (D:) 88.67 GB
display mode      : 2560x1440, 32 bit
process id        : $2044
allocated memory  : 765.19 MB
command line      : "D:\Steam\steamapps\common\Skyrim\TES5Edit.exe" -o:"C:\TESLODGenOutput"
executable        : TES5Edit.exe
exec. date/time   : 2015-11-08 23:07
version           :
compiled with     : Delphi XE
madExcept version : 4.0.5
callstack crc     : $911c6a74, $62d3a2bb, $e1de316a
exception number  : 1
exception class   : EAssertionFailed
exception message : Assertion failure (D:\Projects\TES5Edit\wbDefinitionsTES5.pas, line 2207).

main thread ($27cc):
008fde2b +1e3 TES5Edit.exe wbDefinitionsTES5  2208 +32 wbNVNMParentDecider
007494e7 +013 TES5Edit.exe wbInterface       12589  +1 TwbUnionDef.Decide
0074992c +03c TES5Edit.exe wbInterface       12687  +5 TwbUnionDef.GetSize
007bb1db +02f TES5Edit.exe wbImplementation  15345  +2 TwbValueBase.InitDataPtr
007b96be +072 TES5Edit.exe wbImplementation  14716  +7 TwbDataContainer.Create
007ba6e0 +048 TES5Edit.exe wbImplementation  15129  +5 TwbValueBase.Create
007b62b6 +27a TES5Edit.exe wbImplementation  13840 +30 StructDoInit
007a5945 +105 TES5Edit.exe wbImplementation   9398 +21 TwbSubRecord.Init
0078e4ff +08b TES5Edit.exe wbImplementation   3877 +12 TwbContainer.DoInit
007a56f0 +008 TES5Edit.exe wbImplementation   9334  +1 TwbSubRecord.DoInit
007a6c8a +03e TES5Edit.exe wbImplementation   9803  +6 TwbSubRecord.MasterIndicesUpdated
0078fd73 +083 TES5Edit.exe wbImplementation   4415  +6 TwbContainer.MasterIndicesUpdated
0079d246 +132 TES5Edit.exe wbImplementation   7562 +33 TwbMainRecord.MasterIndicesUpdated
0078fd73 +083 TES5Edit.exe wbImplementation   4415  +6 TwbContainer.MasterIndicesUpdated
007ad713 +013 TES5Edit.exe wbImplementation  10958  +1 TwbGroupRecord.MasterIndicesUpdated
0078fd73 +083 TES5Edit.exe wbImplementation   4415  +6 TwbContainer.MasterIndicesUpdated
0078ccb0 +3b8 TES5Edit.exe wbImplementation   3361 +38 TwbFile.SortMasters
00a69063 +093 TES5Edit.exe frmViewMain        8841  +8 TfrmMain.mniNavSortMastersClick
00525e97 +0a7 TES5Edit.exe Menus                       TMenuItem.Click
00527393 +013 TES5Edit.exe Menus                       TMenu.DispatchCommand
00528572 +082 TES5Edit.exe Menus                       TPopupList.WndProc
005284c1 +01d TES5Edit.exe Menus                       TPopupList.MainWndProc
004c4e8c +014 TES5Edit.exe Classes                     StdWndProc
76bb7885 +00a USER32.dll                               DispatchMessageW
005b2133 +0f3 TES5Edit.exe Forms                       TApplication.ProcessMessage
005b2176 +00a TES5Edit.exe Forms                       TApplication.HandleMessage
005b24a1 +0c9 TES5Edit.exe Forms                       TApplication.Run
00a91faf +05f TES5Edit.exe TES5Edit             77  +7 initialization
75333378 +010 kernel32.dll                             BaseThreadInitThunk

thread $1c5c:
75333378 +10 kernel32.dll  BaseThreadInitThunk

thread $be4 (TWorkerThread):
7754f90a +0e ntdll.dll                           NtWaitForSingleObject
76ce14a5 +92 KERNELBASE.dll                      WaitForSingleObjectEx
7533118f +3e kernel32.dll                        WaitForSingleObjectEx
75331143 +0d kernel32.dll                        WaitForSingleObject
005d21e9 +19 TES5Edit.exe   VirtualTrees 6308 +3 TWorkerThread.Execute
00472cf7 +2b TES5Edit.exe   madExcept            HookedTThreadExecute
004c21c6 +42 TES5Edit.exe   Classes              ThreadProc
00407588 +28 TES5Edit.exe   System        148 +0 ThreadWrapper
00472bd9 +0d TES5Edit.exe   madExcept            CallThreadProcSafe
00472c43 +37 TES5Edit.exe   madExcept            ThreadExceptFrame
75333378 +10 kernel32.dll                        BaseThreadInitThunk
>> created by main thread ($27cc) at:
005d20d1 +19 TES5Edit.exe   VirtualTrees 6251 +1 TWorkerThread.Create

thread $3f8:
77551f7f +0b ntdll.dll     NtWaitForWorkViaWorkerFactory
75333378 +10 kernel32.dll  BaseThreadInitThunk

thread $2284:
77550196 +0e ntdll.dll     NtWaitForMultipleObjects
75333378 +10 kernel32.dll  BaseThreadInitThunk

thread $27fc:
77551f7f +0b ntdll.dll     NtWaitForWorkViaWorkerFactory
75333378 +10 kernel32.dll  BaseThreadInitThunk

thread $2340:
77551f7f +0b ntdll.dll     NtWaitForWorkViaWorkerFactory
75333378 +10 kernel32.dll  BaseThreadInitThunk

thread $16f8:
77551f7f +0b ntdll.dll     NtWaitForWorkViaWorkerFactory
75333378 +10 kernel32.dll  BaseThreadInitThunk

I STILL think there's something wrong with one or more of my ini files, but I need to fix this WryeBash red or orange problem, as well.


Help, please?

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Firstly I think the error message is due to an out-of-date script: wbDefinitionsTES5.pas, used by xEdit and thus failing to find the function, but more importantly I think you might find the last comment in this topic enlightening.


With regards xEdit and any tool that leverages it such as Mator's tools or DynDoLOD, be sure to use the latest scripts, usually found in the archive of those tools or on the xEdit GitHub repo.

Link to comment
Share on other sites

  • 0

Thank you, I must have searched incorrectly, or misspelled a word or something to have not seen that thread.  Basically, the advise is to ignore it.  As for my add-ons being up-to-date(?).  Ya got me, I just installed them all within the last 10 days for the first time on my machine, having never used them before.  Maybe something got added to TES5Edit since then?  I'll double-check the versions on all of 'em again.  Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.