Jump to content
  • 0

Skyrim doesn't register custom input when launched with MO


2567
 Share

Question

Hey. I've recently bought DualShock4, and I tried to get it working with skyrim. On the first try, everything worked fine, except my touchpad didn't work, and I couldn't bind any hotkeys. That's when I downloaded DS4Windows and edited control map (nexus link), which worked perfectly. Well, at least until I tried playing through MO.

 

I'll put it the simplest way possible:

                           Key bound in DS4Windows -     M
                            Button it was bound to - Swipe down
                                    Expected input -     M
                          SKSE launched from steam -     M
         SKSE/Skyrim launched with modpack profile -    %na%  (no input)
SKSE/Skyrim launched with completely clean profile -    %na%  (no input)

//These were tested by:
//  1. Loading old saves, and testing if map opened up
//  2. Creating new game, and trying writing in console using the button (touchpad in this case)
//  3. Trying writing in console in menu using the button (touchpad in this case)
//  4. Trying typing in console using the button (touchpad in this case)

// Always the same result as the one above.

Any ideas? Should I report it as a bug?

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Welcome to STEP @2567

 

I would imagine the problem here is because this mod is modifiying a file in the game's Data folder, if installed according to the mod's instructions:

*********Installation*********
1. Go to \"Skyrim > Data > Interface > Controls > PC\"
2. Rename \"controlmap.txt\" to \"controlmap(backup).txt\"
2. Extract the file from the download and copy \"controlmap.txt\" to 
\"Skyrim > Data > Interface > Controls > PC\"

Whereas MO is probably not passing that file onto the mod if started via MO.

 

Does this behaviour exist when that mod is loaded as a mod via MO? Install it with MO and inside the "Install Mods" dialogue right-click on <data> and Create directory... and name it Interface. Do the same on this newly created folder and create one called Controls then drag the file: controlmap.txt to this folder. The dialogue's message at the bottom should change to Looks good and you can press Install.

Activate the new mod and this file will now be active in the VFS, which you can check by examining the Data tab of MO to see this mod's file listed.

I can't test this as I don't have a XBOX controller.

Link to comment
Share on other sites

  • 0

I'm sorry, I forgot to mention that I've tried that (It was my first guess too). Still the same. I know the mod is working, because I can use the keyboard while the controller is connected (plus I can see it in the Data tab). Still no input from bound buttons on the gamepad though.

 

I'm pretty sure it's not my computer, because I've just tried it on my laptop too, and it's the same.

I've also tried launching through Script Extender mode (just to try everything), but nothing.

 

Specs are:

PC:
 - Win10 64-bit - Pro
 - i5-3550K
 - GTX970
 - 8GB RAM (one kingston hyperx blu)
 - Skyrim on SSD, MO on SSD, MO's mods saved on HDD
Laptop:
 - Win10 64-bit - Home
 - i7-4710HQ
 - GTX860m
 - 16GB RAM (some notebook ram)
 - Skyrim and whole MO on HDD

(Sorry for the late update, I've posted right before going to sleep yesterday)

Edited by 2567
Link to comment
Share on other sites

  • 0

Ok, there might be a misunderstanding. I'm not using XBOX controller, but PS4 controller, DualShock4. DS4 has no official drivers for Windows, so when you just plug it in, it will behave like generic gamepad. However, there is unofficial driver called DS4Windows, which tricks Windows into thinking that the DS4 is XBOX controller. That assures bigger compatibility, as many games on PC had controller support made with the XBOX controller in mind. 

So, the controller doesn't, by itself, need any software, but it needs software if I want to use the hotkeys. I'll try to launch DS4Windows through MO, and let you know what it did.

 

I've made a few pictures to show you how DS4Windows looks.

Edited by 2567
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.