Jump to content
  • 0

Persistent ENB Transparency Bug


Ekko
 Share

Question

Yes, I know, another person with this problem. I promise you I've read all the relevant posts on these and other forums before creating this thread.

 

I am using:

 

New Vegas with EssArrBee's F&LNV mod build

NVidia GTX 760

ENB 0.278

Mod Organizer 1.3.8

 

 

The problem:

 

In some locations (but not all), textures will turn transparent or disappear entirely when viewed from certain angles. This applies to characters as well as geography.

 

 

Things I have tried before posting:

 

>Disabled antialiasing, anisotropic filtering, and water from the game launcher, clicked HDR

>Opened NVidia control panel, manually disabled antialiasing, anisotropic, etc. despite each being on application-controlled already

>Disabled Steam Overlay

>Checked the fallout ini and falloutprefs ini (through the mod organizer tool) to make certain I had copied the F&L settings precisely

>Turned off antialiasing, shadows, and pretty much every other effect in turn in the ENB effect menu in game

>Installed the NV ENB patch .203 and overwrote .278, then reverted back to .278 when that didnt work

>Uninstalled the wrapper version of ENB entirely and installed/ran the injector version (with the ENB Injector application thingy)

?Moved the d3d9.dll to the execs folder, then into the game folder, then into both places, then back just into execs (as the guide instructs)

>Installed the transparency fix mod from Nexus, in conjunction with each of the above in series

>System restart

 

These forums have helped me fix a dozen problems over the last 3 days, but not this one. I've exhausted the steam forums, then enbdev forums, youtube, and google to no avail.

 

Please, help...

Edited by Ekko
Link to comment
Share on other sites

Recommended Posts

  • 0

Open enblocal.ini and make sure FixTransparencyBugs is set to false.

from enblocal.ini:

 

[FIX]
FixGameBugs=false
FixTransparencyBugs=false
IgnoreGECK=true
 
I do notice that there is a force AA setting in the enblocal ini, though...would setting that to false change anything for the better?
Edited by Ekko
Link to comment
Share on other sites

  • 0

Well, you might turn off all the ENB effects in the enbseries.ini and see if it persists. That way you can see if it's from ENB effects being turned on or not. Then start turning them on one by one until it happens again.

 

ALL of the settings...

 

Well ok, this might take a bit.

 

Do you means under [Effects] or...ALL OF THEM?

Edited by Ekko
Link to comment
Share on other sites

  • 0

I think you can turn the [Global] UseEffect off and that will turn off everything. Then see if works for the transparency. 

Turning UseEffect off does, in fact, fix the transparency. Should I go through activating everything one at a time?

Link to comment
Share on other sites

  • 0

Update: As far as I'm aware, I've gone through every true/false setting in the enbseries ini and flipped it to false, then run the game and still had the transparency problem. Disabling everything in global still fixes it, but at the cost of...you know, all the effects.

 

Should I go through each section and not only switch true/false to false, but also X.XX number settings to 0?

 

EDIT: To be clear, I went through and toggled about 5 true/false settings that were set to "true" to "false" at a time, then loaded the game. If it didn't work, I flipped them back on and tried 5 more true/false settings. I've now gone through them all to no avail.

 

Here are the ones I toggled false:

 

[PROXY]
EnableProxyLibrary=true
InitProxyFunctions=true
 
 
[FIX]
FixGameBugs=true
FixTransparencyBugs=true
 
[GAME]
SpeedHack=true
 
[ENGINE]
ForceAnisotropicFiltering=true
 
[EFFECT]
EnableBloom=true
EnableAdaptation=true
EnableAmbientOcclusion=true
EnableDepthOfField=true
EnableSunRays=true
EnableDetailedShadow=true
EnableLens=true
EnableSunGlare=true
 
[sSAO_SSIL]
UseIndirectLighting=true
 
EnableSupersampling=true
 
EnableDenoiser=true
 
[NIGHTDAY]
DetectorDefaultDay=false
 
[ADAPTATION]
ForceMinMaxValues=true
 
[sKY]
Enable=true
 
[colorCORRECTION]
UsePaletteTexture=true
 
[ANTIALIASING]
EnableEdgeAA=true
 
 
UPDATE:
I have now tried setting every numerical effect in enbseries ini to 0.0, five at a time, and the transparency persisted. I don't understand how this could be possible...why would turning it off globally fix it, but turning every single setting off not?
 
Edited by Ekko
Link to comment
Share on other sites

  • 0

That is already set to false by default for me.

 

I can, in game, disable useeffect under global in the ENB interface and make the transparency go away along with every other ENB effect. When I untick them manually, though, the problem does not go away even when I untick literally every setting. I have even tried turning each numerical setting to 0 one at a time and it has not made this transparency go away.

Edited by Ekko
Link to comment
Share on other sites

  • 0

No, since this one (ENB of the Apocalypse) is very highly rated, looks nice, and seems to work for nearly everyone. I suppose I could try a different one, but that still doesn't explain why THIS one never seems to work. I'll try RUST ENB and see what happens.

 

UPDATE:

 

I have tried uninstalling ENB of the Apoc and replacing it with RUST, COBALT, and RUDY ENB. Every single one has the same problem, every single one continues to have that problem with all features manually disabled, and every single one stops being a problem when globally turned off.

 

UPDATE II:

 

I discovered that I had accidentally duplicated the d3d9.dll into both the game directory and the execs folder, countering F&LNV's instructions (guide says just have it in the execs). I deleted the redundant one in the game directory and left the one in the execs folder and ran the game. I now get an "ENB BOOST MODE ON" message in red text in the upper left corner of the screen when launching the game, whereas before I got the ENB white text messaging. Once in game, there is no ENB whatsoever, though, and no menu to turn it on with (Shift+Enter doesn't work). I don't know if this has anything to do with my current transparency problem, but thought I'd mention it in case it did. As of now, I have reverted to putting d3d9.dll in both places so that there is an ENB active.

Edited by Ekko
Link to comment
Share on other sites

  • 0

I've kept this page open in my browser for a week now hoping for an answer, but I guess if there was one to be had it would have been shared by now. I'll consider this thread dead if there is no response by tomorrow evening.

Edited by Ekko
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.