Jump to content
ilct

Can't find source of missing dependencies in CR patch

Recommended Posts

I'm trying to install the Step modlist for the second time (after TexGen wouldn't work, I deleted the instance and started with a clean install). This time I'm having a problem I didn't have last time: LOOT is telling me I'm missing required .es* files for (Step Patch - CR - TCIY.esp), (TCIY_CRF_Patch.esp), (Step Patch - CR - CCOR.esp), (Step Patch - CR - CACO.esp), and (Step Patch - Conflict Resolution.esp). I checked my modlist against the Step guide, and I'm not missing any mods as far as I can tell. Here are the relevant screenshots. What am I missing here?

Spoiler

Bch47Od.pngyxwyMf8.pngbhnJgPE.png

 

Share this post


Link to post
Share on other sites

You don't have the CC content in your game. The AE guide requires the AE Update with all CC content. Not just the four freebees.

Share this post


Link to post
Share on other sites
Posted (edited)
29 minutes ago, z929669 said:

You don't have the CC content in your game. The AE guide requires the AE Update with all CC content. Not just the four freebees.

I'm following the 1.5.97 guide. Maybe I have the wrong Step patch, but the only "Main" file on the Nexus page is v 2.0.0, and the archives only list the old patches, they're not available for download.

FYI, I used the downgrade patch "best of both worlds" version to set up Skyrim. As I understand it, it's supposed to patch the .exe back to 1.5.97 but leave in the CC content from 1.6.x. Is something in the Step patching process reading this as a 1.6 exe or something?

Edited by ilct

Share this post


Link to post
Share on other sites
1 hour ago, ilct said:

I'm following the 1.5.97 guide. Maybe I have the wrong Step patch, but the only "Main" file on the Nexus page is v 2.0.0, and the archives only list the old patches, they're not available for download.

FYI, I used the downgrade patch "best of both worlds" version to set up Skyrim. As I understand it, it's supposed to patch the .exe back to 1.5.97 but leave in the CC content from 1.6.x. Is something in the Step patching process reading this as a 1.6 exe or something?

The 2.0.0 guide doesn't support 1.5.xx game. You will need to tweak the patches yourself to remove the CC dependencies. The Step patches rely on the CC content, which in turn likely rely on records in the 1.6.xxx game plugin masters, IDK for sure.

Share this post


Link to post
Share on other sites
23 minutes ago, z929669 said:

The 2.0.0 guide doesn't support 1.5.xx game. You will need to tweak the patches yourself to remove the CC dependencies. The Step patches rely on the CC content, which in turn likely rely on records in the 1.6.xxx game plugin masters, IDK for sure.

What I mean is, I'm following the 1.5.97 guide here on the site. When it links me to the Step Patch CR page on Nexus, the only patch available to download, as far as I can tell,  is 2.0.0. If this is a patch that only works with AE, is the last available 1.5.97-compatible patch available for download somewhere? If not, is the 1.5.97 Step guide simply unusable anymore?

Share this post


Link to post
Share on other sites

 

27 minutes ago, ilct said:

What I mean is, I'm following the 1.5.97 guide here on the site.

You're misunderstanding. The STEP 2.0.0 guide requires Skyrim 1.6.x with the AE content. This. That's 70 additional Creation Club modules. You only have the base Skyrim SE content (4 free Creation Club modules).

There is no '1.5.97' guide here on the site. If you know of one, please provide the link.

You can use Skyrim.exe 1.5.97 with the STEP 2.0.0 guide if you want, but it's not supported, meaning you need to pick the correct mod versions yourself and you're on your own if you run into issues. And you still need the AE content no matter what version of Skyrim you use.

Share this post


Link to post
Share on other sites
55 minutes ago, ilct said:

What I mean is, I'm following the 1.5.97 guide here on the site. When it links me to the Step Patch CR page on Nexus, the only patch available to download, as far as I can tell,  is 2.0.0. If this is a patch that only works with AE, is the last available 1.5.97-compatible patch available for download somewhere? If not, is the 1.5.97 Step guide simply unusable anymore?

Yes, look in the file archive and get the highest 1.0.x patches. You will want to follow Step 1.0.0 guide though. This will be challenging, since most of those mods have updated to AE. It may be simpler to do as Mousetick mentioned and plod your way through our AE guide. Either way, we don't support it for these reasons.

Share this post


Link to post
Share on other sites
50 minutes ago, Mousetick said:

 

You're misunderstanding. The STEP 2.0.0 guide requires Skyrim 1.6.x with the AE content. This. That's 70 additional Creation Club modules. You only have the base Skyrim SE content (4 free Creation Club modules).

There is no '1.5.97' guide here on the site. If you know of one, please provide the link.

You can use Skyrim.exe 1.5.97 with the STEP 2.0.0 guide if you want, but it's not supported, meaning you need to pick the correct mod versions yourself and you're on your own if you run into issues. And you still need the AE content no matter what version of Skyrim you use.

https://stepmodifications.org/wiki/SkyrimSE:1.0.0

"WARNING: This guide is NOT compatible with SkyrimSE 1.6.x (Anniversary Edition compatibility update). To use this guide, you MUST have a copy of SkyrimSE 1.5.97 prior to the Steam update."

Share this post


Link to post
Share on other sites
Posted (edited)
46 minutes ago, z929669 said:

Yes, look in the file archive and get the highest 1.0.x patches. You will want to follow Step 1.0.0 guide though. This will be challenging, since most of those mods have updated to AE. It may be simpler to do as Mousetick mentioned and plod your way through our AE guide. Either way, we don't support it for these reasons.

The Step patch and Oakwood are the only ones I have, AFAIK, that aren't compatible with pre-AE. If this is the file archive you're talking about, I don't see a way to download any of the previous file versions. The section header says, "The files in this section are for reference only and are no longer supported by the mod author. Please ensure you are using the latest version before asking for support with this mod." If I try to expand the 1.x.x patches, it looks like it only gives a changelog entry.

https://www.nexusmods.com/skyrimspecialedition/mods/31054/?tab=files&category=archived

 

EDIT: I'm also wondering how I didn't have this problem in my first attempt installing Step last week, unless I just installed/configured the Step CR patch incorrectly in the first place.

Edited by ilct

Share this post


Link to post
Share on other sites

You're trying to fit a square peg in a round hole.

By using the Downgrade Patcher with "Best of Both Worlds" you ended up with the Skyrim.exe 1.5.97 game executable along with the Skyrim 1.6.x content. And now you're attempting to use a mod guide designed for Skyrim.exe 1.5.97 with Skyrim 1.5.97 content.

  • Either completely downgrade your Skyrim installation to 1.5.97, both executable, content and all, and keep following the STEP 1.0.0 guide.
  • Or completely update it Skyrim 1.6.x, both executable, content and all, upgrading it to add the AE content as well, and follow the STEP 2.0.0 guide.

If you can't download the archived Step patches, I have an old CR patch v1.0.6 lying around but I don't know if I'm allowed to share it with you. I don't have a copy of the old L&W patch.

Share this post


Link to post
Share on other sites
Posted (edited)
23 minutes ago, Mousetick said:

You're trying to fit a square peg in a round hole.

By using the Downgrade Patcher with "Best of Both Worlds" you ended up with the Skyrim.exe 1.5.97 game executable along with the Skyrim 1.6.x content. And now you're attempting to use a mod guide designed for Skyrim.exe 1.5.97 with Skyrim 1.5.97 content.

  • Either completely downgrade your Skyrim installation to 1.5.97, both executable, content and all, and keep following the STEP 1.0.0 guide.
  • Or completely update it Skyrim 1.6.x, both executable, content and all, upgrading it to add the AE content as well, and follow the STEP 2.0.0 guide.

If you can't download the archived Step patches, I have an old CR patch v1.0.6 lying around but I don't know if I'm allowed to share it with you. I don't have a copy of the old L&W patch.

I'm fine with doing a full downgrade to 1.5.97 with no 1.6 content. Is it possible to run the downgrade patcher again, if Skyrim is already installed and downgraded? And will changing the Skyrim exe require a full reinstall of everything set up in MO2, or is it enough for everything to point to Skyrim.exe as long as it exists in the proper directory?

Edited by ilct

Share this post


Link to post
Share on other sites
20 minutes ago, ilct said:

Is it possible to run the downgrade patcher again, if Skyrim is already installed and downgraded?

I don't know. I'd say probably not. Best to reset everything to latest using Steam's "verify integrity of game files" or Steam's uninstall followed by install, then run the Downgrade Patcher again.

Share this post


Link to post
Share on other sites
1 hour ago, ilct said:

And will changing the Skyrim exe require a full reinstall of everything set up in MO2, or is it enough for everything to point to Skyrim.exe as long as it exists in the proper directory?

You can keep everything as is in MO2 and just continue from where you left off, as long as you installed the tools and the mods in folders completely separate from the Skyrim game installation folder as instructed by the guide, and everything points to the correct folder containing SkyrimSE.exe.

The only thing you'll need to watch out for are the .exe and .dll files (off the top of my head: those from SKSE64 and SSE Engine Fixes) copied directly within Skyrim's game installation folder. Those may have been removed by your reset to 1.5.97, in which case you'll need to copy them again.

Share this post


Link to post
Share on other sites
8 hours ago, Mousetick said:

If you can't download the archived Step patches, I have an old CR patch v1.0.6 lying around but I don't know if I'm allowed to share it with you. I don't have a copy of the old L&W patch.

there are no restrictions on sharing our files. Feel free to do so.

I'd rather follow our latest guide under 1.5.97 than try to follow our previous guide with said patch. Either way, lots of manual patching and caveats involved. I'd rather have a current mod list too.

Share this post


Link to post
Share on other sites
42 minutes ago, z929669 said:

I'd rather follow our latest guide under 1.5.97 than try to follow our previous guide with said patch. Either way, lots of manual patching and caveats involved. I'd rather have a current mod list too.

You're right, latest guide under 1.5.97 would work - as long as the OP fulfilled the AE content requirements. Looks like I've led the OP down the wrong path then. Oops :(

Anyway, here is the old CR patch for the 1.0.0 guide, attached.

 

Step Patch - Conflict Resolution-31054-1-0-6-1639089888.7z

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Halde
      Hey all!
      Did my complete STEP installment. I have two issues. The first is that there is a shadow following my character, at least at evening hours, around 6:30 pm ingame as can be seen on the screenshot. The sun is over the Falkreath hold, when I walk close, the edge of the shadow follows at the same distance it is in the screenshot. Meaning I can only see the sun, I can't be in the sun. This seems to be specific to the area surounding Falkreath however. The issue seems to be tied to something that generates or renders at approximately the distance of the shadow seen in the screenshot, because a similar, but much less visible effect appears when walking around other places such as around Riverwood or the plains of Whiterun. 
      The other is no dual sheathe. 
      I don't know what could've caused this, did the STEP setup by the letter, including Nemesis, so I'm thinking it might be one of the few mods I installed outside of STEP.
      These mods are
      Civil War Overhaul
      Expanded Towns and Cities
      Vigilant and the accompanied hi-res textures for the areas made for that
      Apocalypse + Vokrii compatibility
      Cloaks of Skyrim + CCOR compatibility patch
      While my knowledge is quite limited on the subject, the only thing I'm thinking that perhaps Cloaks of Skyrim could mess with the dual sheath. I haven't troubleshooted yet by trying to turn them off, I will do so tomorrow - merely wanted to put this out there, in case someone had experienced this themselves and immediately know the issue.
      Hoping for help!
      ~Sincerely
      Halde

    • By GraczNet
      Hello,
      I would like to remove WACCF from conflict resolution patch, but I'm new to xEdit. Is it enough that I uncheck it in CR patch installer? STEP guide says that "a minor subset of this mod's changes are forced by the Step patches". Could anyone point me at which records to remove? Thanks in advance
    • By Halde
      Title says it all, couldn't find a thread on it, and it's not mentioned in the guide. I'm leaning towards renaming it?
      ~Sincerely
      Halde
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.