Jump to content
lupus_hegemonia

I'm facing a very annoying shadows' glitch.

Recommended Posts

Okay...
...I'm really pissed with this "glitch". It starts when I'm install few mods; not a lot, few! (When the game is totally vanilla I'm not facing this "glitch").
Currently, I have installed VERY FEW mods, following CFS111's Guide here (and I'm on Step6):

https://steamcommunity.com/sharedfiles/filedetails/?id=929828423

Well... what's the "glitch":

When I'm walking/running/moving OUTDOOR (not while I am interior), the shadows from the ENTIRE world (not just near me), are totally gone - dissapeared! When I'm stopping, all shadows appearing as normal! I thought it was my (quite much tweaked) ini files. So, I deleted them (made backup first) and I created brand new (via Launcher running). No tweaks, just the default ini files that always been created when you running for first time the Launcher...
...but the "glitch" is there, haven't gone!

It's driving me crazy! I can't understand why's this happening... I also update the GPU (nVidia GTX 1070) drivers, nothing changed. I made a new profile in MO2 (without mods, totally vanilla game) and... the "glitch" gone! There isn't any shadows "dissapearing-reappearing". So...? What? I can't installing mods anymore? Because when I'm start installing mods, the "glitch" is coming back...

Here are what I have in nVidia Inspector (perhaps here is the problem?):

https://prnt.sc/26rjt51

Please, can anybody help me to solve this?
It's super annoying, I can't play the damn game like that...

Share this post


Link to post
Share on other sites
14 minutes ago, lupus_hegemonia said:

Okay...
...I'm really pissed with this "glitch". It starts when I'm install few mods; not a lot, few! (When the game is totally vanilla I'm not facing this "glitch").
Currently, I have installed VERY FEW mods, following CFS111's Guide here (and I'm on Step6):

https://steamcommunity.com/sharedfiles/filedetails/?id=929828423

Well... what's the "glitch":

When I'm walking/running/moving OUTDOOR (not while I am interior), the shadows from the ENTIRE world (not just near me), are totally gone - dissapeared! When I'm stopping, all shadows appearing as normal! I thought it was my (quite much tweaked) ini files. So, I deleted them (made backup first) and I created brand new (via Launcher running). No tweaks, just the default ini files that always been created when you running for first time the Launcher...
...but the "glitch" is there, haven't gone!

It's driving me crazy! I can't understand why's this happening... I also update the GPU (nVidia GTX 1070) drivers, nothing changed. I made a new profile in MO2 (without mods, totally vanilla game) and... the "glitch" gone! There isn't any shadows "dissapearing-reappearing". So...? What? I can't installing mods anymore? Because when I'm start installing mods, the "glitch" is coming back...

Here are what I have in nVidia Inspector (perhaps here is the problem?):

https://prnt.sc/26rjt51

Please, can anybody help me to solve this?
It's super annoying, I can't play the damn game like that...

It's most likely an INI setting for shadows and provided by a mod (if this only happens with a mod installed). Look at each mod and see if one of them has an INI override.

Aside from that, you can use BethINI to configure your game INIs and avoid issues caused by improper INI settings.

Mod INIs load with their plugins when named accordingly. If you use MO, then I think the INIs will load with the mod regardless, but @DoubleYou will know for sure.

Share this post


Link to post
Share on other sites

You seem to have customized the Nvidia inspector profile to use ambient occlusion? I don't think that works. You should use mostly default settings for Skyrim Special Edition. Not all nVidia settings work for every game. 

Also, please upload your ini files, tell us about your mod manager, etc. Need more hard details. 

Share this post


Link to post
Share on other sites
50 minutes ago, z929669 said:

It's most likely an INI setting for shadows and provided by a mod (if this only happens with a mod installed). Look at each mod and see if one of them has an INI override.

Aside from that, you can use BethINI to configure your game INIs and avoid issues caused by improper INI settings.

Mod INIs load with their plugins when named accordingly. If you use MO, then I think the INIs will load with the mod regardless, but @DoubleYou will know for sure.

Currently, since I'm following Charlies' Guide, I haven't installed anything consurning shadows/lights etc.
If you check his mod, I'm in his Step 6 - and there isn't any mod altering shadows, lights, etc. And for first time (after many years) I'm using again the MO2.

Also, I used... my tweaked ini files... brand new (from Launcher) created... and BethINI tweaks! Nothing changed, the "glitch" still remains.

45 minutes ago, DoubleYou said:

You seem to have customized the Nvidia inspector profile to use ambient occlusion? I don't think that works. You should use mostly default settings for Skyrim Special Edition. Not all nVidia settings work for every game. 

Also, please upload your ini files, tell us about your mod manager, etc. Need more hard details. 

Okay... So, I should disable that in Inspector?
Can you provide me, please, the usual/default settings for Skyrim SE - for the Inspector?

Here are my own (quite tweaked) ini files:

Skyrim.ini SkyrimPrefs.ini

Share this post


Link to post
Share on other sites

Only those, they have .ini files:
image.thumb.png.43b5ca775fddbdacda016afcc3f44ad9.png
 

I checked in the MO2's "Mods" directory and there are just these with .ini files.

I checked in the MO2's "Mods" directory and there are just these with .ini files.

These are my installed mods so far:
image.thumb.png.f0f88a1e20580569f4fbdd44148b6f45.png

image.thumb.png.c582820ae3fa01192e76404eff84a75b.png

Share this post


Link to post
Share on other sites

These "SVOTP" files, are all game's textures edited or replaced by me, all packed into BSA with "dummy" plugins (via CAO).

 

 

Edited by lupus_hegemonia

Share this post


Link to post
Share on other sites
2 hours ago, lupus_hegemonia said:

Only those, they have .ini files:
image.thumb.png.43b5ca775fddbdacda016afcc3f44ad9.png
 

I checked in the MO2's "Mods" directory and there are just these with .ini files.

I checked in the MO2's "Mods" directory and there are just these with .ini files.

These are my installed mods so far:
image.thumb.png.f0f88a1e20580569f4fbdd44148b6f45.png

image.thumb.png.c582820ae3fa01192e76404eff84a75b.png

Only INI files for enabled mods can override the game INI settings. You should set up your game INIs using BethINI as described here. Once those are saved, test to see if you issue persists. If it does, you must go to your BethINI-edited INI files in the MO profile you are using and cross reference both of them against all of the mod INI files to see if any of those mod INI settings are overriding your shadows settings in the saved game INIs. You will not want to change all settings provided by mods. Just those that may be causing the shadows issue. See the INI reference doc for all relevant settings definitions.

Your driver settings (e.g., ambient occlusion) should have no impact on whether or not shadows show up in game, but you may still want to take DY's advice on those as well. I use AMD, and ambient occlusion via my drivers does impact my display in game for the better, but it's redundant with INI and ENB settings .... and none of them toggle shadows for me.

Share this post


Link to post
Share on other sites

 

48 minutes ago, z929669 said:

Only INI files for enabled mods can override the game INI settings. You should set up your game INIs using BethINI as described here. Once those are saved, test to see if you issue persists. If it does, you must go to your BethINI-edited INI files in the MO profile you are using and cross reference both of them against all of the mod INI files to see if any of those mod INI settings are overriding your shadows settings in the saved game INIs. You will not want to change all settings provided by mods. Just those that may be causing the shadows issue. See the INI reference doc for all relevant settings definitions.

Your driver settings (e.g., ambient occlusion) should have no impact on whether or not shadows show up in game, but you may still want to take DY's advice on those as well. I use AMD, and ambient occlusion via my drivers does impact my display in game for the better, but it's redundant with INI and ENB settings .... and none of them toggle shadows for me.

I wrote it already this... 
I tried the BethINI from the very first moment I faced this "glitch"; didn't help.
 

Quote

you must go to your BethINI-edited INI files in the MO profile you are using and cross reference both of them against all of the mod INI files to see if any of those mod INI settings are overriding your shadows settings in the saved game INIs.

And how am I doing this?

Quote

See the INI reference doc for all relevant settings definitions.

I already have done all of these.
I didn't "tweaked myself" my ini files, I checked guides like STEP's.

Share this post


Link to post
Share on other sites

You open the mod INI files and look for any settings that also exist in skyrim.ini and skyrimprefs.ini. If there are settings affecting shadows, disable those in the mod INI.

It's probably fastest to disable all mods that have INIs to see if that resolves. Then you will know one of them is causing this. Then enable them one by one until the issue comes back. then you have your INI to fix.

We don't support the guide you are following, and we have limited information, so you will need to troubleshoot like this.

Share this post


Link to post
Share on other sites

But, I already wrote you - and show you.
I have only 4 mods with ini files... and none of these have shadows' settings. They are irrelevant mods (consurning shadows).

Share this post


Link to post
Share on other sites
1 hour ago, lupus_hegemonia said:

But, I already wrote you - and show you.
I have only 4 mods with ini files... and none of these have shadows' settings. They are irrelevant mods (consurning shadows).

Then disable half of your mods. See if the issue persists. If not, re-enable those and disable the other half. Check again. Continue this way until the issue is resolved and you find the mod causing it.

Share this post


Link to post
Share on other sites

So...
I removed all the mods, I turned back to vanilla... and the "glitch" is gone.
Now, I'll installing ONE-BY-ONE each mod and I'll checking the ingame, to see WHEN this "glitch" will appear.

Do we have a link about the default/recommended nVidia hardware settings for SSE?

Share this post


Link to post
Share on other sites

I believe that changing the following in Skyrim.ini will fix your problem:

[Display]
bDisableShadowJumps=1

The bug only occurs in specific cases, and may be fixed entirely in the SSE Engine Fixes updated version for AE edition, but I haven't tested. The problem is intermittent, meaning that one moment everything is fine, and the next minute it's a big issue.

Share this post


Link to post
Share on other sites
31 minutes ago, lupus_hegemonia said:

I'm not using the AE. Will this run in 1.5.97 of mine?

You're question is unclear. I am saying that setting bDisableShadowJumps=0 as you have it is known to cause the shadow issue as shown in the video. That setting is irrelevant to the game version you are using.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Baboo77
      ENB makes my character's skin look really really pale and kind of makes the entire game look cold.  Which settings would I be looking at to make the colors a little warmer?
    • By MisterMorden
      I see in the guide it says to install LW dawnbreaker with dwarven/dwemer sheath but for the enb light installation instructions is says to choose default dawnbraker sheath and not alt sheath...I was just wondering why that may be. 
    • By DoubleYou
      Discussion topic:
      Cathedral - 3D Tundra Cotton by Dr Jacopo
      Wiki Link
      The vanilla cotton plant is modeled somewhat after a flowering commercial cotton plant: Google Images of cotton plants
      Herbalist's Guide to Skyrim depicts it after the tundra cotton plant, which is more like a grass. Google Images of tundra cotton
      This mod blends the two, giving it the leaves of a commercial cotton plant and the flower of a tundra cotton plant.
      I consider this a significant deviation from vanilla, so I would not recommend for Step, but it looks fantastic.
      Compares:
      Vanilla --> Cathedral Plants --> Hybrid's HD Plants --> Cathedral - 3D Tundra Cotton

       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.