Jump to content
  • 0
Sign in to follow this  
Wolfgrim

DynDOLOD, Oldrim, LOD Objects vanish, distant waterfalls not animated

Question

Hello,

I installed DynDOLOD (via MO2) multiple times, followed the tutorial videos, tried with and without the .dll etc. and encounter two issues.

1. Certain LOD Objects - large structures like the College of Winterhold and Bleak Falls Barrow vanish when looking at them from certain positions in the worldspace

Everything fine: 

rVFrBkb.jpg

 

Vanished (one step backwards; a few meters away from tower stone - same happens close to the Dark Brotherhood sanctuary near dawnstar with the college LOD): 

NbMIzQd.jpg

2. Distant Waterfalls are static - no matter if I have Skyfalls and Skymills installed or not or if it is the vanilla version or the SDO version (I used SDO up until now)

I've been trying to get this to work for days and could not find a solution online.
Please help. I really want to use DynDOLOD.

Here is my DynDOLOD_TES5_log: https://drive.google.com/open?id=1_-eWlrsmq5MU1Qyo3SxjIFG_eIFvmhxa

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

1. Vanishing LOD is caused by the game broken pre-computed occlusion as a simple test in the vanilla game verifies.

 

FAQ: Game: Rectangular holes in LOD

 
A: Caused by vanilla pre-computed occlusion. Has nothing to do with the LOD data itself. Either use xLODGen or DynDOLOD to update the data. See the 'TVDT - Occlusion Data' section in ..DynDOLOD\Docs\DynDOLOD_Manual.html and https://forum.step-project.com/topic/14250-skyrim-tvdt-occlusion-data/
 
 
2. As explained in the manual, disable SkyFalls+Mills for best results. Install DynDOLOD Resources.
 
Simply generate LOD by clicking Low, Medium, High when using the Wizard option or make sure to load Low, Medium or High rules and to check  "Generate DynDOLOD"  on the advanced options before clicking the OK button to start LOD generation.
 
Install the generated output as a mod making sure nothing it is not overwritten. Enable the plugin. Once in the game make sure it says "DynDOLOD successfully initialized", check its SkyUI MCM that it is active.
 
Large animated waterfalls are then automatically added for the next 11 "cells" before turning static at higher LOD levels/map.
 
 
Check if other dynamic LOD shows, like windmill fans, waterwheels, Gildergreen in Whiterun.
 
 
Read and follow the install instructions:
 
From the DynDOLOD Standalone archive copy the content of the 'DynDOLOD' folder, which contains the files DynDOLOD.exe, TexGen.exe, DynDOLOD_QuickStart.html and the sub folders 'Docs' and 'Edit Scripts' with all their content into a new 'DynDOLOD' folder outside of special OS folders like 'Programs Files' or 'Program Files (x86)', the SteamApps or game folders and Mod Organizers virtual file structure. Do not mix with old versions or xEdit/xLODGen installation.
 
 
 
Do not install the game to special Windows folders like Programs Files x86. Follow any basic modding guide.
Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

Thank you.

 

 

1. Vanishing LOD is caused by the game broken pre-computed occlusion as a simple test in the vanilla game verifies.

 

FAQ: Game: Rectangular holes in LOD

 
A: Caused by vanilla pre-computed occlusion. Has nothing to do with the LOD data itself. Either use xLODGen or DynDOLOD to update the data. See the 'TVDT - Occlusion Data' section in ..DynDOLOD\Docs\DynDOLOD_Manual.html and https://forum.step-project.com/topic/14250-skyrim-tvdt-occlusion-data/
 

I created DynDOLOD and now will use xlodgen beta for Occlusion. Which Mode should I use? "+TVDT -Flat +Border"?

 

 

 

Check if other dynamic LOD shows, like windmill fans, waterwheels, Gildergreen in Whiterun.
 

 

 

Windmill fans worked fine. The Gildergreen only is visible after I visited Whiterun childworld - before doing so the plaza shows no tree when looked at from Tamriel worldspace.

Edited by Wolfgrim

Share this post


Link to post
Share on other sites
  • 0

For occlusion generation read https://forum.step-project.com/topic/14250-skyrim-tvdt-occlusion-culling-data/.

 

Read the included documentation Skyrim-Occlusion-Readme.txt in the xLODGen archive and the TVDT - Occlusion Data section in Docs/DynDOLOD_Manual.html to learn about TVDT data, how to generate it and the settings.

 

For Tamriel typically use -Flat +Border

 

Make sure to test with a new game, coc whiterun from the main menu console for example.

 

If waterfalls still don't have animated LOD then, enable papyrus logging and check if there are related error messages.

 

If there are no related error message, check if plugins modify the waterfalls.

 

If no plugins modify the waterfalls upload/pastebin

DynDOLOD\Edit Scripts\Export\LODGen_TES5_Tamriel.txt

DynDOLOD\Edit Scripts\DynDOLOD\cache\DynDOLOD_TES5_dyndolodfiles.txt

DynDOLOD\Edit Scripts\DynDOLOD\cache\DynDOLOD_TES5_dyndolod.txt

DynDOLOD\Edit Scripts\DynDOLOD\cache\DynDOLOD_TES5_rules.txt

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

It seems to work now. At least I haven't noticed any of the issues I had before so far.

Thank you so much for your help!  ::D:  :clap: 

 

Share this post


Link to post
Share on other sites
  • 0

Well. Except one of my player homes. Greyhill Keep. (Uses only vanilla assets.) It looks like this in LOD. xD 

zcvKwDH.jpg
Closeup:
OgMAqcb.jpg

Edited by Wolfgrim

Share this post


Link to post
Share on other sites
  • 0

Works fine in a new game here.

 

59721-1580425119-983606738.jpeg

 

Those main buildings parts seem to be dynamic LOD as well (because they use an EnableParent), so the same troubleshooting steps still apply.

 

See if disabling the bashed patch changes anything. If so, create it anew without the ImportCells.

But check for errors in the papyrus log first.

Edited by sheson

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By sheson
      DynDOLOD DLL for Skyrim, Skyrim Special Edition, Skyrim Anniversary Edition and Skyrim VR
      So far all versions of DynDOLOD use the SKSE plugin PapyrusUtil for the optional dynamic LOD in the game. Starting with version 2.45 there is now the alternative DynDOLOD DLL available.
      The current DLL version is 2.45. It works with dynamic LOD generated by DynDOLOD Standalone 2.45 and newer.
      Read the ..DynDOLOD\Docs\DynDOLOD_DLL.html included in DynDOLOD Standalone for an explanation about DynDOLOD DLL, installation instructions (overwrite papyrus scripts of DynDOLOD Resources) and how it works.
      If there are problems with it, check DynDOLOD_DLL.html and the DynDOLOD FAQ first before posting.
      If a DynDOLOD.DLL version is required for a game version that is not listed below, request it in this thread. First, search this thread if it has been requested already, though. The future will tell how long it takes to release updates.
      Typically a new DynDOLOD.DLL is required for each new game version, but not each new SKSE version. For example a DynDOLOD.DLL compiled with SKSE64 2.0.9 also works with SKSE64 2.0.10 for the same game version.
      Nexus Downloads for DynDOLOD 2.45 and higher
      DynDOLOD DLL for Skyrim
      DynDOLOD DLL SE for Skyrim Special Edition
      DynDOLOD DLL VR for Skyrim VR
      Mega Mirrors:
      DynDOLOD.DLL + Scripts for Skyrim 1.9.32 (overwrite the papyrus scripts included in DynDOLOD Resources)
      DynDOLOD Scripts for Skyrim Special Edition and Skyrim VR (overwrite the papyrus scripts included in DynDOLOD Resources SE)
      DynDOLOD.DLL for Skyrim Special Edition 1.5.39
      DynDOLOD.DLL for Skyrim Special Edition 1.5.50
      DynDOLOD.DLL for Skyrim Special Edition 1.5.53
      DynDOLOD.DLL for Skyrim Special Edition 1.5.62
      DynDOLOD.DLL for Skyrim Special Edition 1.5.73
      DynDOLOD.DLL for Skyrim Special Edition 1.5.80
      DynDOLOD.DLL for Skyrim Special Edition 1.5.97
      DynDOLOD.DLL for Skyrim Special Edition 1.6.318
      DynDOLOD.DLL for Skyrim Special Edition 1.6.323
      DynDOLOD.DLL for Skyrim Special Edition 1.6.342
      DynDOLOD.DLL for Skyrim Special Edition 1.6.353
      DynDOLOD.DLL for Skyrim Special Edition 1.6.629
      DynDOLOD.DLL for Skyrim Special Edition 1.6.640
      DynDOLOD.DLL for Skyrim Special Edition GOG 1.6.659 (untested)
      DynDOLOD.DLL for Skyrim VR 1.4.15
    • By Ease
      I have a problem with two excessively glowing window textures that I've been troubleshooting for several hours now and I cannot seem to figure it out. The problem is only resolved if I disable DynDOLOD and I had to go through my entire load order to figure that out. The almighty Google hasn't found me a whole lot of information on it either. I've read through the Glow LOD section of the dyndolod.info webpage and have messed around with just about every setting I can, but still, I cannot solve this problem. I'm completely open to the idea that it's one of my mods conflicting with DynDOLOD, but I cannot for the life of me figure out what. It may be right under my nose too. I wouldn't be surprised.
      The two windows in question seem to be (according to more informative console) WRTempleOfK01 and WRHouseWind02. 
      Things I have tried:
      Making a fresh save file Disabling any texture mods I am using that change any architecture in Whiterun Disabling my lighting mods Generating LODs without any form of FX, candles, windows glow or any form of LOD glow available Rebuilding ENB shader cache Tweaking window lighting in my ENB settings I've included my mod list as well in case anyone here has a bigger brain than me and can spot the problem just by looking at what I have.
      In the screenshot attached you can see the problem I'm having. Any help on this would be greatly appreciated because I'm not the best at this stuff. Thanks!

      EDIT: Well, after several hours of trying to figure it out, I finally isolated the problem minutes after making this thread. I thought about deleting the thread but instead maybe this might help out someone else in the future. The file causing the issue specifically was in TexGen_Output under textures/architecture/whiterun/wrwindows01_g.dds. I hid the file and now my windows are glowing properly, ending my hours of suffering over a minute detail. 
      Below is a screenshot of the corrected glow on the windows. 

      modlist.txt
    • By 1990srider
      So currently I'm trying to get the stockade mesh in the mesh/clutter/stockade/.nif to show up as full mesh in my lod generations. Because I'm creating new full models using Dyndolod. I've gotten everything else and every other type of model to do what I need it to. Ive tried .....esp/esm;formid I've tried the file path shortened and full all the way to be of the nif file being included. 
       
      4 is full 8 is full 16 is full. I've had this issue also with highherothgar floor models not showing ether... I spelled that wrong in here but yeah. I've tried looking for another rule or mesh mask the could be interfering and I can't find anything. Anyone have any idea what could be wrong?? I'm not trying to generate a lower poly lod I'm using this for other purposes.
       
       
       
       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.