Jump to content
  • 0
AnalogProphet

Wrye Bash unable to install mods due to extraction failure

Question

The basic issue is that I've been unable to install the UOP via Wrye Bash because when I click Install on the Wrye Bash context menu I get the following error: Extraction failed: 7z.exe return value: 7.  Details follow:

 

 

 

I've recently completed a clean installation of Oblivion: GOTY Steam Edition.  After installing the game via the Steam installer I also installed OBMM, OBSE, Wrye Bash and BOSS.  I've launched Oblivion and made a savegame file, and the game appears to be working and stable so far.  

 

My next step would be to install the Unofficial Oblivion Patch using Wrye Bash, and this is where I'm running into problems.

This is my first attempt at doing a BAIN installation - up to now I've always used OBMM or manual installation for mods.  I'm using an Acer laptop that's running Windows 10.  All files are installed on the C: drive and not in the Program Files directory.  Here are the steps I'm taking:

 

1. Download the UOP (version 3.5.6) to a desktop folder named Oblivion Mods
2. Open Wrye Bash
3. Click on the Wrye Bash Installer tab
4. Drag the UOP archive from my Oblivion Mods folder to the Wrye Bash Installer tab
5. A pop up asks if I want to Move or Copy the file and I select Copy
6. Click on the UOP archive in the Wrye Bash Installer tab so it's highlighted
7. Uncheck the UOP Vampire Aging & Face Fix .esp in the esp/m filter section of Wrye Bash (bottom right corner)
8. Right click on the UOP archive in the Wrye Bash Installer tab and select Install from the context menu
9. Then I receive the following error: Extraction failed: 7z.exe return value: 7
 
Here is my load order, in case it helps:
 
00  DLCShiveringIsles.esp
01  DLCHorseArmor.esp
02  DLCOrrery.esp
03  DLCVileLair.esp
04  DLCMehrunesRazor.esp
05  DLCSpellTomes.esp
06  DLCThievesDen.esp
07  DLCBattlehornCastle.esp
08  DLCFrostcrag.esp
09  Knights.esp
 
I have downloaded versions 3.5.6 and 3.5.5 of the UOP from the Nexus site multiple times to eliminate 'corrupted download' as a cause of the issue.  I've also downloaded 7zip, WinZip and WinRar multiple times from different sites and set them systematically as default programs for opening .zip files.  I've uninstalled, re-downloaded, and reinstalled Wrye Bash from different sites.  I've also tried copying the UOP archive to the /Bash Installers folder directly instead of trying to Move or Copy it directly to the Wrye Bash Intallers tab.  I'm at a loss, and any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

7zip changed their compression format recently and the archive extractor that ships with WB doesn't recognise it. I'm not sure there is an official update yet try one of the unofficial builds on discord or AFKmods I'm using Sharlikan's fork with basic FOMOD support.

Share this post


Link to post
Share on other sites
  • 0

7zip changed their compression format recently and the archive extractor that ships with WB doesn't recognise it. I'm not sure there is an official update yet try one of the unofficial builds on discord or AFKmods I'm using Sharlikan's fork with basic FOMOD support.

Thanks for letting me know about 7zip's change in format - this should explain why it's not working for me (but not why I can't seem to find any other posts about this issue...).  I don't understand the second half of your response - by 'unofficial build' do you mean the Unofficial Oblivion Patch?  By FOMOD support do you mean .omod format?

Share this post


Link to post
Share on other sites
  • 0

7zip changed their compression format recently and the archive extractor that ships with WB doesn't recognise it. I'm not sure there is an official update yet try one of the unofficial builds on discord or AFKmods I'm using Sharlikan's fork with basic FOMOD support.

Also - if the compression format change is what's causing me problems, couldn't I just download and use an older version of 7zip that does work with Wrye Bash?  Or does 7zip auto-update?  You wouldn't happen to know which version/s do work would you?

Share this post


Link to post
Share on other sites
  • 0

7zip changed their compression format recently and the archive extractor that ships with WB doesn't recognise it. I'm not sure there is an official update yet try one of the unofficial builds on discord or AFKmods I'm using Sharlikan's fork with basic FOMOD support.

I went all the way back to 7zip version 9.20, which was released in 2010, and I'm still getting the same error - so I believe the problem isn't caused by 7zip.  I've also tried WinZip and WinRAR and I get the same error.  I'm pretty sure I've ruled out the zip archive software, Wrye Bash, the Unofficial Oblivion Patch itself and malware as culprits, so I don't know where else to look.  I work in tech support and it seems like there's something I'm missing here - some problem with the steps I'm taking that I can't see.  The fact that this is my first time trying to use a BAIN installer seems too big a clue, and I wish I had done it a few times before now so I could rule out my process.

Edited by AnalogProphet

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.