Jump to content
SuspectDevice

Hello, new here, go easy on me - STEP:Extended Adding Mods through MO

Recommended Posts

Hi,

So first off, I just have to say that the work the STEP team has done is truly exemplary. I actually can't fully express my gratitude and appreciation for the quality of the guides and information provided. I do subscribe as a premium member to Nexus so hopefully some of that flows to the guys that de-mystify Skyrim modding. 

 

I spent a long time modding Skyrim with NMM and had been running different setups since 2012. Last year I moved from NMM to MO. Never looked back. 

 

I had looked at the STEP work over time. I was intrigued but thought I was doing OK without taking on such an apparently prescribed approach. I weakened in my resolve of late and spent hours adhering to the STEP:Extended install in its entirety. I left nothing out. And it kills it, entirely. It is like a brand new game. It is what Batshita should be doing for actual game releases. Such a foundation would make everything so much more interesting as the genius modders on Nexus and STEP could focus on enhancing a base level game that rocks.

 

All that said, I have a little problem. I am adding additional mods such as Immortal Lydia, One Tweak, Alternate Start and a number of others.  The issue is that the Mods appear in MO left and right panel but do not appear to activate in MCM or in the game. I am guessing this is something stupid by me, hence, the brown nosing above so that you guys might go easy on an old gamer who is trying to have a modicum of modernity. 

 

 I have looked through all of the STEP guides and have failed to see the steps I need to take. I just added the Mods as I would any mod to an MO profile. 

 

Am I the biggest dope here?

 

Cheers,

 

Heno

Share this post


Link to post
Share on other sites

Most mods don't have MCM menus; they need to include some SkyUI interfaces to support this. Do you have mods that should have SkyUI menus and mention this on their Nexus page but don't seem to have SkyUI menus?

Share this post


Link to post
Share on other sites

Yeah those mods do not have MCM's.  

 

from the One Tweak page;

Configuration file is [game install directory]/Data/SKSE/Plugins/OneTweak.ini, it will be created after first run.
NOTE: MO users require to edit OneTweak.ini trough MO.
 
If alternate start is not activating in game it is likely because the plugin is not activated in MO's left pane, or possibly the archive is not activated in the 'Archives' tab in MO's left pane.  Though if that were the case I'd imagine you'd just be seeing a lot of missing textures / meshes (purple stuff, exclamation marks), or maybe CTD.

Share this post


Link to post
Share on other sites

Most mods don't have MCM menus; they need to include some SkyUI interfaces to support this. Do you have mods that should have SkyUI menus and mention this on their Nexus page but don't seem to have SkyUI menus?

 

One Tweak and Alternate Start had MCM menus in a prior installation. Within MO, they are checked active. Plus they are checked active in the Archive tab. It is like they are just being ignored even though they are in the load order. Would you know where can check that MO is point to the right place. I have a couple of STEP guide profiles including a vanilla one and one with higher texture sizes, alongside the one I am running that follows STEP:Extended to the letter. Maybe, I've managed to confuse things.........

 

Yeah those mods do not have MCM's.  

 

from the One Tweak page;

Configuration file is [game install directory]/Data/SKSE/Plugins/OneTweak.ini, it will be created after first run.
NOTE: MO users require to edit OneTweak.ini trough MO.
 
If alternate start is not activating in game it is likely because the plugin is not activated in MO's left pane, or possibly the archive is not activated in the 'Archives' tab in MO's left pane.  Though if that were the case I'd imagine you'd just be seeing a lot of missing textures / meshes (purple stuff, exclamation marks), or maybe CTD.

 

The profile is running as perfectly as I am sure you guys at STEP would wish for. It is perfect, no problems, no missing textures, no stuttering, no CTDs. I'll look at the OneTweak.ini and report back. 

 

Note: the mods I have been trying to add are all based on changing fundamental character or gameplay settings. Whilst tyring to figure the problem out, I have also being playing a pure STEP:Extended profile. I even died three times in Swindlers Den. And the game is starting to suck me in like I happened when I played Skyrim first, or Oblivion, or even Morrowind. I do want to solve this problem but it has caused me to fall in love withj Tamriel all over again. Thank you so much. 

Share this post


Link to post
Share on other sites

There is no trick whatsoever to the installation of Alternate Start. If the other esp's in that profile are activated and working, there is no reason I can think of that it should not work as well, provided its .esp and .bsa are activated in the profile you are using.

 

As far as I'm aware, Alt Start has never had an MCM. Not sure where you're getting that from. Perhaps you're thinking of Disparity.

You say 'within MO, they are checked active'... I apologize but must re-iterate; is the plugin (.esp) activated in the 'Plugins' tab of MO's left pane?

The only other thing I can think of is; are you certain you have done the necessary .ini tweaks for the .ini's that correspond with the profile in question? MO houses seperate .ini's for each profile, it's necessary to point BethINI to each specific profile.

Edited by baronaatista

Share this post


Link to post
Share on other sites

As far as I'm aware, Alt Start has never had an MCM. Not sure where you're getting that from. Perhaps you're thinking of Disparity.

Or perhaps Skyrim Unbound, which is another alternate start mod that includes an MCM.

Share this post


Link to post
Share on other sites

thanks for the responses

 

So yes, it was Skyrim Unbound with the MCM menu. So all good there.

 

I tried looking through everything that everyone suggested and found that the installation was as correct as I could perceive it to be. I decided to go to 2N Patches in STEP guide. I went through the steps as if it was a new installation. As far as i can tell, everything is running as expected including the new mod that I added. So I think I am good. I'll just thrash it for a few days and see how things go.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.