Jump to content
  • 0
Mattchion

Mod Organizer fails load the right crafting menu

Question

I hate the smithing menu for skyui 5.1, so I downloaded SkyUI-Away, installed in MO, and used the filetree view to hide all menus besides craftingmenu.swf. MO claims it sees the conflict with SkyUI's menu of the same name, and that SkyUI-Away wins the conflict. I've heard from others that they managed this same procedure with no issue. Yet for me, the game always has SkyUI's smithing menu when I run it. I always start skyrim via SKSE in Mod Organizer. My mod set is virtually all step and step extended mods with slightly higher resolution settings. On top of that is only a few additional weapon, armor, and clothing mods, most of which are ones that run through Complete Crafting Overhaul. I've asked on the SkyUI page and it's been asserted that SkyUI cannot refuse to use the original crafting menu since it's a mod, so the issue is probably with Mod Organizer. How is it possible for Mod Organizer to pick a winner for a conflict correctly and then not apply it's decision at runtime?

 

Edit: i understand now that it was probably silly of me to think Skyui might be at fault when all it does is replace menus and add mcm, but at the time (6 am after 3 hours of fighting to make this crap stop) I was focused on the one mod and menu that was seriously hindering my experience with the game. The amount of armor and weapons in that menu when you have everything unlocked is absurdly tedious to browse through with the tabs they chose, and it lacks the gold and diamond necklace for some reason.

Edited by Mattchion

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Check in the archives tab if you have MO managing archives.

 

If not, turn it on.

 

I noticed that when archive management is off, MO didn't show some conflicts.

 

Shot in the dark, but it might do the trick. Dunno.

 

Edit: More info.

 

Edit 2: Nevermind, if you're hiding files then it's not a BSA. Not sure on this, hopefully someone with more knowledge than I will pop by.

 

Only other thing I can think is have you tried to not hide any of the SkyUI-Away files? I.E. use the whole mod? Does that work at all?

Share this post


Link to post
Share on other sites
  • 0

I have MO managing the archives. In the data tab, interfaces folder, it clearly shows that it's pulling the craftingmenu.swf from SkyUI-Away, and the rest of the menus from skyui's bsa. You don't need the whole mod enabled if only one menu really needs replacing, which is what I assert with the crafting menu for smithing. Lots of people do this.

Share this post


Link to post
Share on other sites
  • 0

I checked the SkyUI-Away page, and apparently it is compatible with SkyUI 5.1. And Mattchion is right on the mark when he mentions that you can only disable a specific menu if you want by hiding the other files...it says so right on the Nexus page.

 

So yeah, I have no idea why it is not working for you. I've never used SkyUI-Away, so I'm not really familiar with it.

 

Maybe Grant or Greg or someone else smarter than I might have a clue.

Share this post


Link to post
Share on other sites
  • 0

Hopefully. I tried redownloading and installing both SkyUI and SkyUI-Away and no dice again. I can't revert to SkyUI 4.something because it's possible the other mods are expecting 5.1, but this smithing menu is so bad I'd revert if I could. According to other users I shouldn't have to though. All SkyUI-Away does is add the vanilla menus back by inserting them in the data\interfaces folder as loose files, thereby overwriting the skyui.bsa by default when a conflict arises. As one last shot in the dark, I will extract the interfaces.bsa from vanilla skyrim myself and slip the craftingmenu.swf from that in. If it fails, then I dunno what to do. This may be more of a problem with the game itself somehow, or maybe the bashed patch I made as STEP directed but before adding this mod. I doubt it on that last part, but I don't know enough to be sure.

Share this post


Link to post
Share on other sites
  • 0

Maybe try this first:

 

Download SkyUI-Away 5.0 manually.

Exact the files somewhere.

Delete everything except the Interface/craftingmenu.swf file you want

Re-archive it

Install through MO

Share this post


Link to post
Share on other sites
  • 0

I was following your topic in the Nexus forum and was frankly bemused that you could have an error like that. I am glad that you decided to ask here as it is much easier to get information diagnosed by all of us when it's in the same place.

So, you are going to have to provide the contents of your profile folder, preferably zipped, or by posting it to a site like PasteBin or if you wish post each *.txt here in spoiler tags. (See the citizenship guidelines below on how.)

 

To establish a baseline, I have installed the complete STEP 2.9.2 guide and then I have SkyUI-Away loading after everything else and ALL the original menus are now used along with SkyUI errors in game to remind me that I'm using the wrong *.swf files. This is the way it should happen for you, if SkyUI is not telling you there are different *.swf files loading then the game is not running the profile you imagine it is.

Share this post


Link to post
Share on other sites
  • 0

Will do, Grant. When I'm not at a Toledo Mudhens game. XD And I am doing it similarly. Except I'm only trying to use the craftingmenu from SkyUI-Away. No warnings come up, so either the menu is a copy of skyui's by some impossible feat or the game isn't accepting the right menu...somehow; I'd guess, anyways.

Share this post


Link to post
Share on other sites
  • 0

To just use the crafting menu the way I set it up was to hide all the *.swf files in MO except the craftingmenu.swf. The game shows all the SkyUI menus for bartering, spells, inventory, map etc. except it uses the original for the crafting.

 

I'm really interested to see what is going on with your game because there aren't that many mods that touch these files so the chances of conflict a very small.

Share this post


Link to post
Share on other sites
  • 0

Attached is the entire folder for the profile I'm currently using. If you need something more, just let me know. Thank you for being willing to look at this, because I'm still new to building mod sets and troubleshooting mod sets, heh. STEP was a lot of help and taught me quite a lot, but I know there's plenty I don't know.skyrim rajirr mod set.zip

Share this post


Link to post
Share on other sites
  • 0

Hmm... can you create a copy of this profile using MO's Profile manager and then disable everything except SkyUI and SkyUI-Away? I can't see any obvious issues with any mods you have installed.

If the problem persists with a minimal setup then the culprit will lie elsewhere, perhaps there is a rogue *.swf installed in the Data directory.

 

Are you completely satisfied with the ordering of the installed mods? A large portion of the modlist appears to be in alphabetical order, which isn't necessarily a problem, just curious.

Share this post


Link to post
Share on other sites
  • 0

I'll try, but Mod Organizer isn't detecting any mods messing with the craftingmenu.swf besides SkyUI and SkyUI-Away. And the alphabetical order is kind of accidental. I have another profile that's pure Step: Extended and I tried to enable the mods in order as I needed, installing variants as I preferred as well, but Mod Organizer kept them more or less ordered just like that. MO glitched and disabled almost all plugins on my profile the first time I installed SkyUI-Away or some time shortly before that when i was opening and closing MO on occassion without making changes or anything for a month or so, so I rushed down the plugins list in frustration, re-enabling all the mods in whatever order they were in. Plugins sort according to LOOT anyways though.

Edited by Mattchion

Share this post


Link to post
Share on other sites
  • 0

Okay, this is weird. I ran it with the cleaned vanilla plugins, USKP, Papyrus, skyui, and skyui-away. And it says in the data tab of MO that the craftingmenu.swf is from skyui-away as usual, but yet again when i booted a save that starts just inside helgen keep where I spawned an anvil for testing purposes the other night (to see if maybe i just needed to take my modset and start a new game to get it to work right), it chose skyui's menu. I feel like that menu is mocking me at this point.

Edited by Mattchion

Share this post


Link to post
Share on other sites
  • 0

If you're running LAL start a new game and choose the option that places you in Riverwood Inn and from there head over to the blacksmith. Let's assume that somehow the craftingmenu is being 'baked into' the prior save.

Share this post


Link to post
Share on other sites
  • 0

I need to sleep now. I'll try installing lal tomorrow if I have time and do a fresh save. A menu being baked into a save seems unlikely, I'd hope, but with mod set building I should use lal anyways so I can test mod sets fully a lot faster and avoid more instances of crazy flying prisoner carts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.