Jump to content
  • 0
Sign in to follow this  
disi

MO Limits for files?

Question

I think Mod Organizer hits a limit in how many files or mods it can handle or Skyrim has a limit.

 

How can I make Skyrim start and load a game in 20min and how do I return to 2min?

Either activate Molag Bals Inferno AND DynDoLOD OR Helveton The Fate of the Mountain AND DynDoLOD OR Molag Bals Inferno AND Helveton The Fate of the Mountain. Running only one of these is fine and I can start Skyrim rather quickly.

 

If I have this slow loading:

Once I am ingame, it behaves normal and I can enter/leave buildings or fast travel normally in maybe 5-30sec (depends if the textures are cached and the place obviously).

Dying means I have to stop TESV.exe and restart the game because it cannot load the last auto- or quicksave in ~20-30min I once waited.

 

Monitoring: My VRAM is shown through MSI Afterburner on the screen and for the TESV.exe memory check, I run the Task Manager on the second screen (CPU is max at ~40% during the whole process of loading Skyrim).

 

If I start Skyrim, then TESV.exe is at

~300MB when it shows the loading screen

~700MB when it shows the menu

 

Then I load the savegame (not played much 18-19mb):

Only one of those mods + my current load order:

It takes ~1-2min for TESV.exe to go to ~800MB memory and then loads the textures in ~20-30sec, finally brings up the screen in the game at ~900MB.

Two or more of those mods + my current load order:

It can take ~10-20min or more for TESV.exe to crawl to ~900MB memory and then loads the textures in ~20-30sec, finally brings up the screen in the game at ~1000MB.

 

This is ~100MB more to load, but it takes ten times as long to do so.

 

I noticed no difference in using BSA or extract them during installation (except for the official ones, that I didn't touch and are preloaded anyway).

As for DynDoLOD, it comes with lots of scripts and tiny files, there is no difference in loading times if I use Low, Medium or High (seems to be the same amount of scripts).

 

I even removed something as big as Falskaar from the load order, but the problem remains with Molag Bals Inferno and Helveton [and|or] DynDoLOD.

 

Question: are there limits on how many files MO can handle and is there a way to tune this somehow?

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Adding "Safety Load" back to my load order and it loads every single savegame (with Molag Bals Inferno, Helveton The Fate of the Mountain and DynDoLOD enabled) in under 2min (I removed it on rumours the memory patch would make it obsolete).

https://www.nexusmods.com/skyrim/mods/46465/?

Edited by disi

Share this post


Link to post
Share on other sites
  • 0

This situation you are trying to explain sounds very... odd to me. Maybe try re-explaining?

Share this post


Link to post
Share on other sites
  • 0

I think you either installed the Memory Patch wrong, or need to increase the values in order for it to work correctly. Safety Load is a band-aid.

Share this post


Link to post
Share on other sites
  • 0

This situation you are trying to explain sounds very... odd to me. Maybe try re-explaining?

 

I think you either installed the Memory Patch wrong, or need to increase the values in order for it to work correctly. Safety Load is a band-aid.

Fact is: Without the Safety Load, I cannot load a save game in a reasonable time (under 4-5min) with a lot of mods, worlds and dynamic distance LOD.

 

How do you install the memory patch wrong? It is just two lines in the skse.ini (currently):

[Memory]
DefaultHeapInitialAllocMB=1024
ScrapHeapSizeMB=256

From my observations with Memory Blocks Log, if it goes all the way up to 768MB, the game crashes/freezes instead of creating a new block.

 

It got me thinking if VFS drasticly slows down at a certain point or something else hits a limit...

 

p.s. Since yesterday I recreated the whole mod-list, threw everything in that I would be remotely insterested in while staying below 255 plugins, regenerated new LOD for all worlds, created a complete fresh save game (17MB at start), waited for Eternal Darkness to finish its script (hung out for ~1h realtime in a cave).

Loading it with safety load: 5:30min

Loading without safety load: 5:45min

 

Someone fry me a stork, I cannot reproduce it now with the new save. Still takes very long to load...

loadorder.txt

Edited by disi

Share this post


Link to post
Share on other sites
  • 0

Ah! That's because setting DefaultHeapInitialAllocMB to 1024 makes the 768 the crash/freeze limit, which is exactly what I thought was happening. Increase it to a higher value. It will always be 256 less than DefaultHeapInitialAllocMB.

Share this post


Link to post
Share on other sites
  • 0

I am sorry to blame MO (real fan of it).

 

A complete remove of DynDoLOD fixes the issue with any other mod constellations. It just has too many scripts to load and the more worlds you build them for the more will run. There were somewhat 200+ active scripts at a time, which all needed to be reinitialized from a serialized state, plus all the variables etc. I guess this just kills the Skyrim engine.

Share this post


Link to post
Share on other sites
  • 0

Did you read DoubleYou's last post or just ignore it?

I did read and test it, made no real difference. Hitting the 768MB limit was rare and usually never during loading a game.

 

My game was too big and I had to get rid of some heavier mods.

 

Removing Hearthfire helped a lot with the loading times of save games (at least 2min down). For some reason Helveton The Fate of the Mountain is a Hearthfire mod and had to go in the process (so did Immersive Castle Volkihar and Book Covers of Skyrim :( )

Oh wonder, I can now instant enter houses (0.5-1sec loading times) and no crashes whatsoever around Falkreath Hold ^^

 

With mostly the same mods, minus DynDoLOD, Hearthfire, Immersive Castle Volkihar, Book Covers of Skyrim and Helveton The Fate of the Mountain.

 

p.s. the initial size of a save game went also down to 12mb.

 

pps. I am thinking of putting DynDoLOD back in now... as this is a really amazing tool. The trick here is to find a balance and not hit the roof.

Edited by disi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Sayoregg
      I am using MO2. I installed DynDOLOD in a separate directory than my game and not in program files or anything. In MO2 I added -sse to the arguments for both programs (I'm using the x64 versions of them if that's relevant). Without the arguments the programs give a totally different error so I'm guessing that it isn't the issue. When I do try to run the programs (Both DynDOLOD and texgen), I'm getting this error log. Gonna use TexGen's as an example.
                     [00:00:00.063]    TexGen based on xEdit x64 (DAB7081D) starting session 2021-04-15 10:01:59
                     [00:00:00.073]    Game Mode: SSE
                     [00:00:00.078]    Game Name: Skyrim Special Edition
                     [00:00:00.084]    Using Skyrim Special Edition Data Path: C:\Program Files(x86)\Steam\steamapps\common\Skyrim Special Edition\Data\
                     [00:00:00.089]    Using Backup Path: C:\Program Files(x86)\Steam\steamapps\common\Skyrim Special Edition\Data\SSEEdit Backups\
                     [00:00:00.095]    Using Scripts Path: D:\Programs (D)\DyndoLOD\Edit Scripts\
                     [00:00:00.101]    Using Cache Path: D:\Programs (D)\DyndoLOD\Edit Scripts\DynDOLOD\cache\
                     [00:00:00.107]    Using Temp Path: C:\Users\Sayor\AppData\Local\Temp\SSEEdit\
                     [00:00:00.114]    Using ini: C:\Users\Sayor\Documents\My Games\Skyrim Special Edition\Skyrim.ini
                     [00:00:00.124]    Using save path: C:\Users\Sayor\Documents\My Games\Skyrim Special Edition\Saves\
                     [00:00:00.132]    Using plugin list: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\Plugins.txt
                     [00:00:00.140]    Using settings file: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\DynDOLOD_settings.ini
                     [00:00:00.157]    Using language: English
                     [00:00:00.167]    Using general string encoding: 1252  (ANSI - Latin I)
                     [00:00:00.176]    Using translatable string encoding: 1252  (ANSI - Latin I)
                     [00:00:00.192]    Using VMAD string encoding: 65001 (UTF-8)
                     [00:00:00.202]    Loading active plugin list: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\Plugins.txt
                     [00:00:00.218]    Fatal: Error loading plugin list: <EDirectoryNotFoundException: The specified path was not found>
      I have checked the path it is trying to load "Plugins.txt" from and there wasn't any file called like that there, only a "DynDOLOD_settings.ini". I asked one guy in a discord server for help because I knew he used DynDOLOD. His Plugins.txt file is completely empty, and DynDOLOD worked for him, so I created an empty Plugins.txt file there, yet the programs still give the same error.
    • By Dragoonman
      Firstly, I'll go ahead and explain that I have just over 200 mods in my Skyrim build. I use mod organizer and have followed S.T.E.P as well as several online videos from the likes of Gopher explaining how to install some of the more difficult mods such as perkus maximus. I know how to create merge patches, bash patches, and have cleaned all of my mods (with the exception of Hunterborn and Guard Dialogue Overhaul as their mod pages said not to) with TES5edit.

      However, though my build is stable when exploring interior spaces in Skyrim, I have crashes randomly when exploring the outdoors.

      Sometimes Skyrim will CTD open entering combat while outside. Other times it will CTD when just walking or running around. And sometimes I will talk to an NPC outside and Skyrim will CTD. The only thing I know that the CTDs have in common is that I'm outside when they happen.

      I've run Skyrim Performance Monitor and stay under the 3.1 gb crash limit, so I'm thinking it had to be some sort of script error or perhaps conflicting mods.

      Here is my mod load order.
       
      Here are my PC specs.
       
      I've already edited my SKSE.ini to look like this:
       
       
      I have speedhack enabled on my ENB.
      If someone could take a look at it and tell me if they see some conflicting mods or perhaps a faulty load order, that would be incredible.
       
      My modlist is for me to enjoy a difficult and yet rewarding skyrim which hopefully can look beautiful at the same time. I've seen a few people show off their mod builds which contain even more mods than my own, so hopefully I'm not simply overlooking something silly like a limit.

      I figure it would either be a mod dealing with spawning or combat outdoors, but I haven't really been able to find evidence to back my theory up. Perhaps I installed the patches for my mods in an incorrect order?
       
      The way I have my mods organized is the order in which I install them, so the patches for things like Perkus Maximus, EBD, ASIS, and Dual Sheath Redux are installed in the order that you see them.
       
      I've been trying to make this build stable for over a month now and have done everything short of going through the mods one at a time and disabling them which would take an eternity based on the fact that I would have to repatch everything everytime I disabled a mod. The game is perfectly stable without any of the patches installed and the mods requiring them disabled so far as I could tell, but after the patches are installed things seem to go downhill.
      Any of you experienced modders out there have any ideas? I would prefer to keep all of the mods I currently have, but if I have to chunk some of them in favor of actually being able to play I'll do it, though Perkus Maximus and ASIS are must haves for me.
       
      Thank you in advance! I hope I can get this working before Fallout 4 absorbs all of my interests and consumes me. Please let me know if I need to include any further information.
       
    • By LiquidAurum
      Hi,
      Below is my modlist. I crash to desktop everytime I load a saved game. However, there is one save that loads for a while, but after a while that crashes to desktop as well. Now I assumed at first it's because that was interior, but that doesn't seem to be the case either, as the interior's do load successfully but CTD after a while. I ran loot and did find some conflicting .esp's. and were disabled (ClimatesOfTamriel-Dungeons Hazardous/Hardcore and COT-Interiors-Cold/Warm). Now even after those are unchecked it still CTD. Could htis be a lack of VRAM issue? I don't see how it could be as I've ran this exact ENB befofre (granted almost a year ago). If you guys need the order of my plugins/mods please let me know. 
      Thank you all in advance. 
       
       
      https://drive.google.com/file/d/0B401Ci0KQvVrX29XeU9RdWVZY28/view
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.