Jump to content
  • 0
Cameron9428

Can't get SMAA to work with ENB

Question

For some reason that I can't ascertain I can't get SMAA to function at all with ENB. I've followed the step guide. Here's my ini files:

 

enbseries.ini:

[PROXY]
EnableProxyLibrary=true
InitProxyFunctions=true
ProxyLibrary=d3d9_smaa.dll

 

enblocal.ini:

[PROXY]
EnableProxyLibrary=true
InitProxyFunctions=true
ProxyLibrary=d3d9_smaa.dll

 

^I really don't know which one I'm supposed to write this in, so I put it in both. According to STEP enbseries.ini doesn't even have a [proxy] section, but lots of people say to put it in enbseries anyway, Not sure it's redundant or not.

 

I have skyrim's aa turned off as well of course. SMAA injector, SMAA.fx, SMAA.h and d3d9_smaa.dll are all in the skyrim root folder. Pressing pausebreak yeields no difference in quality. Anyone have an idea what I could be doing wrong? Thanks xD

Edited by Cameron9428

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

The PROXY section goes in enblocal.ini (do not include it in enbseries.ini). You can read the instructions in Guide:ENB, but it looks as if you have it about right. Note that other overlays (like MSI Afterburner) may prevent SMAA from being injected.

Share this post


Link to post
Share on other sites
  • 0

It goes in enblocal and only in that file. You also need the injector.ini file from SMAA in your skyrim directory.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Mebantiza
      Just a quick question, is there any difference at all between SMAA screenshot quality, and 'standard' enb screenshots? I fairly sure there is not, the file sizes are all the same 9.2mb per@1920x1200. 
       
      thanks.
    • By DoubleYou
      In testing and taking screenshots, I think it would be worthwhile to recommend all users abandon iMultiSample altogether. It is intensively performance costly, and the built-in FXAA appears to even be better. See the compares below.
       

       
      iMultiSample=0 and bFXAAEnabled=0
      iMultiSample=2 and bFXAAEnabled=0
      iMultiSample=4 and bFXAAEnabled=0
      iMultiSample=8 and bFXAAEnabled=0
      iMultiSample=0 and bFXAAEnabled=1
       
      If you think that these compares progress from worst to best, then you agree.
    • By Adonis_VII
      Does the SMAA injector linked on the ENB wiki work with the Fallout versions of ENB?  I set it up as per the instructions, but I don't notice any improvement over vanilla ENB when using ULTRA.  The shimmer is everywhere and it's horrible.  For reference, I normally just run ENBoost with 8xQ [8x Multisampling], Transparency Multisampling Enabled, and Transparency Supersampling at 4x Sparse Grid Supersampling.  When testing with full ENB, I have everything set at default values for the driver, and turn off AA and AF in fallout ini.  This issue occurs when launching with MO, 4GB directly, NVSE directly, or the actual FalloutNV.exe so I'm not sure it is any of those in particular.  Single card or SLI (GTX980) doesn't change anything.  My install is done following F&L.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.