Jump to content
  • 0
Sign in to follow this  
GrantSP

Mod Organizer and software that interferes with it

Question

Many, many reports are made about various issues with the functionality of MO that can be attributed to an overly zealous AV package, or some other software that operates on a file without your consent.

 

  • Whenever you see errors about missing files, or support functions not working, or "failed to spawn '[program name]': failed to start process (Access is denied. [5])" check to see that your AV package hasn't been messing with those before you ask here.
  • Functions that seem to stall or hang entirely are usually because your AV package is stopping the system from operating on those files/folders by either interrupting the copy process or removing the copied file afterward.
  • The running of tools used inside MO, or called from it (e.g. FNIS), have been hindered by these AV packages. Even seemingly unrelated errors about files that contain no executable code can be traced to AV behaviour.
  • For anyone using Windows 10 (or any successive iteration after this post) you will need to go to your settings and follow these steps:
    • Open Settings, and click/tap on the Gaming icon.
    • Click/tap on Game bar on the left side, and turn on (default) or off Record game clips, screenshots and broadcast using Game DVR.
    • Unselect Show Game Bar when I play full screen games that Microsoft has verified

As a matter of course, one of the first things to check when you experience problems is your AV package.

That is not to say these tools are broken or useless, though many are in fact next to useless, but rather the algorithms they use to determine "malicious" behaviour isn't clever enough to distinguish between what is and isn't "bad".

 

Most AV packages have the ability to set aside certain programmes or folders from the process so that they can operate unhindered, whichever package you use it is strongly urged that you examine how to do so with MO.

 

Another type of software that routinely causes havoc for MO is "in game overlay" software, from whichever company that provides: AMD, nVidia, Steam, etc. Adding another layer of code into the hooking process is playing with fire as MO will lose control of the process at some point in the execution and your game will likely crash, not load or otherwise fail to function properly.

 

File backup software is also known to make file access errors with MO as the files that are being accessed, or tried to, are being actively checked by that sort of software. This will interfere with the 'hooking' code of MO.

 

All the code used by MO is freely available on the GitHub so there is no chance of malicious code being introduced into it. You are of course encouraged to check for yourself if you so desire. 

 

 

Not specifically MO related but I have also made a brief guide for removing the more annoying software in Windows 10 that often gets in the way of MO. (Though most of it can be left if you desire.)

Edited by GrantSP
Updated to help with Windows 10 Creator update.

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Similar Content

    • By Fargh
      Hello,
       
      I just finished getting a STEP extended installation setup. My machine generally seems happy about it. Mind you, I found the process a little confusing, so I may have done something wrong during setup. I did not use all of the patches for this reason, though I did use the extended patch and at least one more.
       
      My existing character used mods that I removed, so I get a warning when I load it. Assuming that is not the problem, let me describe what is happening:
       
      I load into the save file just fine. I can move around with no problems. The last time I ran it, I fast traveled to Whiterun and my 'home' there, no problem. Then I fast traveled to some other town (if this is important I can look it up)...and I went into a building that had crashed every previous time I tried to go (been trying to solve my own problem, which is how my character is no longer stuck in a croutch). This time it let me in before crashing. The floor was black, like a texture didn't load. A man was in the hallway in what appeared to be a glowing purple rubber smock (something was not right there). He also had a unibrow that was remarkably similar to that found on Burt from Sesame Street. At this point, it crashed again.
       
      Anyone have a guess as to what mod(s) is/are causing the problem? I have a new gaming laptop, so my assumption is that it isn't the hardware. No FPS drop at all.
       
      I use Nexus  Mod Manager and MO. I used LOOT, not BOSS. I have no idea how to export my load order.
       
      Thank you
       
       
    • By harley5656
      I really could use some help with this problem and cant seem to find the awnswer.  If this is located else where, I'm sorry I just could not find it.
       
      I am using Mod Organizer v 1.1.1 and everything was working quite well with a bunch of mods, but now I'm having problems.
       
      I  unselected all Mods but Skyrim.esm, Update.esm, Hearthfires.esm and Dragonborn.esm.  I go to run FNIS like before, however I am not getting the "GenerateFNISforUsers.exe failed to Run"  after running FNIS v 4.1.1
      The strange part is its happening 95% of the time, but in my testing sometimes it seems to work.  However, when I reproduce the same steps the error occurs again.
      I've tried everything to fix it but have no clue.  If any of you can provide some insight I would appricate it greatly!
    • By Tykune
      I was going through LOOT and doing some cleaning, and I came across a peculiar message involving 'FacegenForKids.esp', which is part of the Simple Children mod. I have an image below of this odd warning and wanted to ask if this is something I should go through editing in USSEP or is this something to just ignore?
       

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.