Jump to content

v2.3.0 - Feedback & Bug Reports


Recommended Posts

16 hours ago, AcesofDeath7 said:

The main file for Better Base Sites no longer has the LUA file

 

Thanks, I've corrected this. For the longest time the LUA in the files was more updated than the one on the page. Looks they the author has changed gears a bit and finally took it out of the PAK.

Link to comment
Share on other sites

  • 1 month later...

Since Skyrim mods are being updated, I decided to play NMS again for the time being. Thanks so much for making a comprehensive Guide for it! Especially about AMUMSS, since I could never figure out how to get it to work before.

However, I did run into some things that were different from the AMUMSS descriptions/ workflow while following the guide:

I am guessing AMUMSS had an update since you last updated the guide (13 days ago according to GitHub). The thing that threw me most about the updated version, is that it now asks if you want to run Buildmod.bat in Full/ Dev or Lean mode. Since I had no idea, I have been running it into (F)ull mode. I hope that is ok?

Also, during the final STEP patch creation, the only question/ option I got was "??? Would you like or [N]ot to COPY Some or [A]ll Created Mod PAKs to your game folder and DELETE [DISABLEMODS.TXT]". After selecting N as instructed, it started building the patch without any of the other options. The end result had the 6 conflicts as mentioned and no other errors. I haven't tested in game yet, because I didn't want to forget where I noticed the "deviations" and the associated text, but I am assuming the output/ patch is fine. If not, I will let you know.

Another thing I noticed, which is probably just me though, is that PSArcTool from Nexus didn't want to run at all on my PC. I scanned for virusses/ other icky stuff (found none), then made an exception for my AntiVirus, but no dice. I downloaded the version from GitHub (as linked in the forum post) and that did work fine for me. So no idea what caused that. Just thought I would mention it if anyone else has that issue.

Apart from those things, everything went smoothly.

Edited by ButchDiavolo
Link to comment
Share on other sites

52 minutes ago, ButchDiavolo said:

Since Skyrim mods are being updated, I decided to play NMS again for the time being. Thanks so much for making a comprehensive Guide for it! Especially about AMUMSS, since I could never figure out how to get it to work before.

However, I did run into some things that were different from the AMUMSS descriptions/ workflow while following the guide:

I am guessing AMUMSS had an update since you last updated the guide (13 days ago according to GitHub). The thing that threw me most about the updated version, is that it now asks if you want to run Buildmod.bat in Full/ Dev or Lean mode. Since I had no idea, I have been running it into (F)ull mode. I hope that is ok?

Also, during the final STEP patch creation, the only question/ option I got was "??? Would you like or [N]ot to COPY Some or [A]ll Created Mod PAKs to your game folder and DELETE [DISABLEMODS.TXT]". After selecting N as instructed, it started building the patch without any of the other options. The end result had the 6 conflicts as mentioned and no other errors. I haven't tested in game yet, because I didn't want to forget where I noticed the "deviations" and the associated text, but I am assuming the output/ patch is fine. If not, I will let you know.

Another thing I noticed, which is probably just me though, is that PSArcTool from Nexus didn't want to run at all on my PC. I scanned for virusses/ other icky stuff (found none), then made an exception for my AntiVirus, but no dice. I downloaded the version from GitHub (as linked in the forum post) and that did work fine for me. So no idea what caused that. Just thought I would mention it if anyone else has that issue.

Apart from those things, everything went smoothly.

Thanks. Yeah, I need to updated those few things. Sounds like you did it right, though.

Link to comment
Share on other sites

6 hours ago, TechAngel85 said:

Thanks. Yeah, I need to updated those few things. Sounds like you did it right, though.

It looks like it, since I haven't had any problems or weird things happening. *dives back into the Multiverse*

Link to comment
Share on other sites

So... No Man's Sky just got a big update (4.0 Waypoint). Since it has been years since I last played No Man's Sky, I can't remember what happens with mods when NMS updates. Can I assume this will cause mods to not work/ cause CTDs?

*mutters about the irony of replaying NMS during the latest SkyrimSE/AE mod upset*

Link to comment
Share on other sites

21 minutes ago, ButchDiavolo said:

So... No Man's Sky just got a big update (4.0 Waypoint). Since it has been years since I last played No Man's Sky, I can't remember what happens with mods when NMS updates. Can I assume this will cause mods to not work/ cause CTDs?

*mutters about the irony of replaying NMS during the latest SkyrimSE/AE mod upset*

Yep. A lot of mods will need to update. Luckily the main tool is already updated to support it. The Step Guide is broken until I can verify all the changes and the mods within it are all updated. Many are already being updated, but we all know that Hello Games will often fire off small bugfixes at a rate of one or two a week after major version updates. They already have a new experimental branch and log in the pipeline. 

The Guide will be updated as I am able to get the work done. Personally, I'm limited to a few free hours here and there until my free days (Wed & Thur). You can still play the game, but just unmodded or with limiting to the mods that have updated. Keep in mind they restore the "DISABLEMODS.txt" file every update so it'll need to be removed again if you want to play with limited mods in the meantime.

Link to comment
Share on other sites

Hi Tech, more questions from me. Is it true that the mods that use AMUMSS and the lua files just need to be be re-run to get them to work, regardless of updates? Meaning, the lua's/ AMUMSS combination make them version independent? Or am I misreading the comments at some mods?

Link to comment
Share on other sites

2 hours ago, ButchDiavolo said:

Hi Tech, more questions from me. Is it true that the mods that use AMUMSS and the lua files just need to be be re-run to get them to work, regardless of updates? Meaning, the lua's/ AMUMSS combination make them version independent? Or am I misreading the comments at some mods?

Yes. They has to rebuild the files using the newest game files, but the big advantage of LUA files is they mostly work across updates unless settings have been removed by Hello Games that the LUAs are trying to find. Even then it'll likely just toss a warning and continue on, skipping what it can't find. So yes, LUA need to be rebuild each update but they often last through the chaotic update schedule that Hello Games has without the author needing to do anything.

Link to comment
Share on other sites

44 minutes ago, TechAngel85 said:

Yes. They has to rebuild the files using the newest game files, but the big advantage of LUA files is they mostly work across updates unless settings have been removed by Hello Games that the LUAs are trying to find. Even then it'll likely just toss a warning and continue on, skipping what it can't find. So yes, LUA need to be rebuild each update but they often last through the chaotic update schedule that Hello Games has without the author needing to do anything.

Awesome, thanks! In that case I guess that all the "normal" MO2 install mods have already been updated. So I would only need to rerun the AMUMSS ones to get NMS to work again? Except I guess the STEP Patch. *Silly me, the Step Patch are lua's as well.

Edited by ButchDiavolo
Link to comment
Share on other sites

8 hours ago, ButchDiavolo said:

Awesome, thanks! In that case I guess that all the "normal" MO2 install mods have already been updated. So I would only need to rerun the AMUMSS ones to get NMS to work again? Except I guess the STEP Patch. *Silly me, the Step Patch are lua's as well.

Well, the entire Foundation section is broken right now due to Better Planet Generation, so you can skip it. You can also skip Windrex as it's been reported as broken. We'll see what happens with these mods over the next week or so. The remainder of the Guide is fine. I am updating the Resource Files as there have been some settings removed that need to be removed from the LUAs. AMUMSS will toss either an error or a warning for those, but it may still run. I haven't tried running them, myself, since I'm still updating them; so I can't say for sure what will happen.

Link to comment
Share on other sites

7 hours ago, TechAngel85 said:

Well, the entire Foundation section is broken right now due to Better Planet Generation, so you can skip it. You can also skip Windrex as it's been reported as broken. We'll see what happens with these mods over the next week or so. The remainder of the Guide is fine. I am updating the Resource Files as there have been some settings removed that need to be removed from the LUAs. AMUMSS will toss either an error or a warning for those, but it may still run. I haven't tried running them, myself, since I'm still updating them; so I can't say for sure what will happen.

I redid the whole guide and regenerated everything that needs to be generated with AMUMSS, including Better Planet, Windrex and the Step Patch. I didn't see any warnings or errors in AMUMSS. The end result of it all was the same 6 conflicts. The game started just fine. I started a new game and, while the new game setup threw me off a bit, the game loaded fine as well. So far so good.

I didn't play very long, just went to the ship. This is the only thing I noticed that didn't really work: the mod that puts the ship closer to the rezzing site. Other than that, it seemed to work just fine, but I am about to play a bit longer to see if I can find any other things. So far it seems playable.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.