Jump to content
  • 0
planetmorgoth

Generate a custom .lod for custom worldspace

Question

Hi I was wondering how I would go about generating a custom lodsettings .lod file for my custom worldspace. Currently I'm just using the Tamrield.lod but renamed to my mods name. But I believe that is causing the problem of the worldmap inheriting some of the properties of the main worldmap (See img attached, Mountain clouds where there shouldn't be.)

 

Any help appreciated.

MountainThatShouldNotBeThere#Wack.PNG

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 1

Use LodFileGenerator to generate a proper .lod file. Additional information on generating custom LOD for your worldspace may be found here: https://dyndolod.info/Mod-Authors

Also of interest you may find this guide by Jonx0r (author of Wyrmstooth) which has much information that is mostly correct for a lot of things. Some things could be done more simply, especially relating to LODs, but it is very high quality nonetheless and on point.

Especially of interest is his guide to changing the clouds for the world map. I recommend a simpler approach, however, and just remove them altogether by pointing them to a blank Cloud Model. You may be able to reuse the model from Solstheim however (DLC02\Sky\DLC2WorldMapCloudBank_Low.nif), as it is a smaller worldspace.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
On 3/23/2022 at 6:32 PM, DoubleYou said:

Use LodFileGenerator to generate a proper .lod file. Additional information on generating custom LOD for your worldspace may be found here: https://dyndolod.info/Mod-Authors

Also of interest you may find this guide by Jonx0r (author of Wyrmstooth) which has much information that is mostly correct for a lot of things. Some things could be done more simply, especially relating to LODs, but it is very high quality nonetheless and on point.

Especially of interest is his guide to changing the clouds for the world map. I recommend a simpler approach, however, and just remove them altogether by pointing them to a blank Cloud Model. You may be able to reuse the model from Solstheim however (DLC02\Sky\DLC2WorldMapCloudBank_Low.nif), as it is a smaller worldspace.

Wow thanks so much for that Wrymstooth tutorial that is so much useful information!

Edit: Although I did come across one problem that I have always been having, I can't seem to add my files to Create Archive window. I drag them over and nothing happens, they are in the Data folder, and I'm selecting the files not the folders containing them so I'm not sure what I'm doing wrong. If you know a possible solution that would help, but thanks for the help given already! (Pg 1163 of New Lands Mod Mega Tutorial PDF)

Edited by planetmorgoth

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By planetmorgoth
      Hi I'm trying to make a mod that adds a new land, and I have the LOD generated on my main PC using xLodGen and it works great. But I can't figure out how to get the LOD working on another PC after installing the .zip with MO2. The LOD generation output gets put in the overwrite folder on my main PC and I was wondering how to get that put into a .zip so MO2 can install it all at once.
       
      Thanks for any help, and sorry if this has been asked before but I can't find anything.
    • By Jordo24
      I'd like to know how to use xedit or the creation kit to make files a .esl, I followed this guide
      https://www.afkmods.com/index.php?/topic/5079-plugin-files-and-you-esmeslesp/
      and I cant really understand it, if anyone has step by step instructions please let me know!
    • By Bluegunk
      I've happily been using Creation Kit through MO2 the last few days with no issues. This afternoon it refuses to load in MO2 - crashes with the dreaded "Creation Kit has stopped working".
       
      However, it works outside MO2.
       
      I'm running Win 10, everything on an SSD away from Program Files.
      I tried reinstalling Creation Kit, reinstalling MO2, running a file verification on the system, checking Registry with CCLeaner, usual restarts etc.  No luck.
       
      The Windows Error Log gives me this:
       
      Faulting application name: CreationKit.exe, version: 1.3.9.0, time stamp: 0x58486f09
      Faulting module name: ucrtbase.dll, version: 10.0.14393.0, time stamp: 0x578997b5
      Exception code: 0xc0000409
      Fault offset: 0x000000000006d5b8
      Faulting process ID: 0x2f60
      Faulting application start time: 0x01d26f5bb7cb358e
      Faulting application path: G:\GAMES\Steam\steamapps\common\Skyrim Special Edition\CreationKit.exe
      Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
      Report ID: d6761478-a6c5-4e10-9da8-db660f12aaf0
      Faulting package full name:
      Faulting package-relative application ID:
       
      Any help much appreciated! Thank you!
       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.