Jump to content
  • 0
Liraeli

MO2 not launching SKSE w/ mods enabled

Question

I've deleted all my MO2 logs, booted MO2 and copied them, but I'm not familiar with MO2, so I don't know what the issue could be. My issue sounds very similar this issue posted to the forum;

 

Hi, I haven't been able to get MO2 to load Skyrim SE using the SKSE loader. Both Skyrim and the loader work fine when used outside MO2 but when I try to open them inside the program it seems to think about it but doesn't start running them. There doesn't seem to be any error messages that I can see.

 

Any ideas about what could be causing this or what I could do to fix it?

 

https://forum.step-project.com/topic/14001-mo2-wont-load-skse/

 

Hopefully the issue isn't huge. Here's my usvfs file from the MO2 logs if that helps;

 

https://pastebin.com/ejz40W65

 

Thanks anyway :)

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

You'd think, with mods being a very possible cause for the issue, that I would have remembered to post them 

 

[spoiler=My Modlist] 0 0 Skyrim.esm
1 1 Update.esm
2 2 Dawnguard.esm
3 3 HearthFires.esm
4 4 Dragonborn.esm
5 5 Unofficial Skyrim Special Edition Patch.esp
254 FE 0 Landscape and Water Fixes.esp
6 6 Skyrim Project Optimization - Full Version.esm
254 FE 1 AHZmoreHUDInventory.esl
7 7 LegacyoftheDragonborn.esm
8 8 MajesticMountains_Landscape.esm
9 9 BSAssets.esm
254 FE 2 RealisticWaterTwo - Resources.esm
10 a BSHeartland.esm
11 b BS_DLC_patch.esp
12 c SkyUI_SE.esp
13 d Enhanced Vanilla Trees SSE.esp
14 e Landscape Fixes For Grass Mods.esp
254 FE 3 MajesticMountains.esp
15 f Cathedral Landscapes.esp
16 10 dD - Enhanced Blood Main LITE.esp
17 11 UnlimitedBookshelves.esp
18 12 SMIM-SE-Merged-All.esp
19 13 Audio Overhaul Skyrim.esp
20 14 Gildergreen Regrown.esp
254 FE 4 SunDaytimeNorth_MM_default.esp
21 15 DeadlySpellImpacts.esp
254 FE 5 Frost Meshes Patch.esp
22 16 DustEffectsSSE.esp
254 FE 6 SkygazerMoonsSize.esp
23 17 ORM-Arvak.esp
24 18 Cathedral Weathers.esp
254 FE 7 AOS_Cathedral Weathers Patch.esp
25 19 VWA_VanillaWarpaintsAbsolution.esp
26 1a NB-Scars.esp
27 1b Beards.esp
28 1c Brows.esp
29 1d CrittersAintSnitches.esp
30 1e Dragon Stalking Fix.esp
31 1f ReasonableMovementSpeed.esp
254 FE 8 Landscape and Water Fixes - Patch - Relighting Skyrim.esp
32 20 Waterbreathing Breathless Emerge SSE.esp
33 21 SmoothShores.esp
34 22 Cutting Room Floor.esp
35 23 AI Overhaul.esp
36 24 Realistic Boat Bobbing.esp
37 25 Thunderchild - Epic Shout Package.esp
38 26 DragonShoutVoice.esp
39 27 Better Stealth AI for Followers.esp
40 28 Realistic AI Detection 2 SE Lite.esp
254 FE 9 TavernAIFix.esp
41 29 Disease Descriptions.esp
42 2a Guard Dialogue Overhaul.esp
43 2b Weapons Armor Clothing & Clutter Fixes.esp
254 FE a Hearthfires Houses Building Fix.esp
44 2c Improved Traps.esp
45 2d Oakwood.esp
46 2e Run For Your Lives.esp
47 2f Oblivion Gates Remade.esp
48 30 Helarchen Creek.esp
254 FE b DBM_CRF_Patch.esp
254 FE c RBB - Oakwood Patch.esp
254 FE d RBB - USSEP Patch.esp
49 31 BetterContainerControls.esp
50 32 iHUD.esp
51 33 Chesko_LoreBasedLoadingScreens.esp
52 34 AHZmoreHUD.esp
53 35 RaceMenu.esp
54 36 RaceMenuPlugin.esp
55 37 SMIM-Bruma-Patch.esp
254 FE e CathedralWeatherMCM.esp
56 38 StormLightning.esp
57 39 WondersofWeather.esp
254 FE f DBM_WACCF_Patch.esp
58 3a imp_helm_legend.esp
254 FE 10 DBM_UnlimitedBookshelves_Patch.esp
254 FE 11 DBM_AOS_Patch.esp
254 FE 12 DBM_RuinsClutterImproved_Patch.esp
254 FE 13 DBM_SMIM_Patch.esp
254 FE 14 ImprovedClosefacedHelmets_WACCF.esp
254 FE 15 Audio Overhaul Skyrim - WACCF and LotD Patch.esp
254 FE 16 WACCF - CRF Consistency Patch.esp
254 FE 17 WACCF - USSEP Arch-Mage Consistency Patch.esp
254 FE 18 Beyond Bruma - Trade and Barter Patch.esp
254 FE 19 AOS - Catherdral Weathers Patch.esp
59 3b Apocalypse - Magic of Skyrim.esp
60 3c 20 More Perk Points.esp
61 3d Trade & Barter.esp
254 FE 1a DBM_TradeBarter_Patch.esp
62 3e Ordinator - Perks of Skyrim.esp
254 FE 1b Ordinator - Beyond Skyrim Bruma Patch.esp
254 FE 1c Ordinator_WACCF_Patch.esp
63 3f Apocalypse - Ordinator Compatibility Patch.esp
64 40 Alternate Start - Live Another Life.esp
65 41 Relationship Dialogue Overhaul.esp
66 42 RDO - CRF + USSEP Patch.esp
67 43 Luminosity Lighting Overhaul.esp
68 44 RealisticWaterTwo.esp
254 FE 1d RealisticWaterTwo - Beyond Skyrim Bruma.esp
254 FE 1e Realistic Water Two - Landscape For Grass Mods Patch.esp
254 FE 1f Oakwood - Realistic Water Two 2.0.0 Patch.esp
254 FE 20 RealisticWaterTwo - Cutting Room Floor Patch.esp
69 45 RealisticWaterTwo - Luminosity Patch.esp
70 46 WACCF_BashedPatchLvlListFix.esp

 

 

I should also clarify, i'm running the most recent version of MO2, 2.3. Again, thanks

Share this post


Link to post
Share on other sites
  • 0

You need to run the SKSE loader to launch Skyrim or at least check that. See the instructions at the bottom of the page (also, review the whole page just to be sure).

 

It could also be that you have not followed/read the System Setup Guide completely/correctly. I personally install Steam in its default location and MO2 according to the STEP Guide; however, I have taken ownership of all files on all drives and given myself "full control", which would be frowned upon by the more paranoid security gurus. Installing Steam and all mod-related tools/mods to a custom path and taking ownership + revising security to those paths is the more secure way of doing things ... all addressed in the guide linked.

 

Also, follow STEP 1 of the STEP Guide and probably also STEP 2 & STEP 5.

Share this post


Link to post
Share on other sites
  • 0

I have been following the STEP guidelines, but I just checked over the SKSE page to make sure I didn't miss any steps, and I think I didn't. I have been launching Skyrim through MO2, through SKSE, but alas, doesn't boot.

 

I've also reviewed the System Setup Guide, again to make sure it isn't user error at that level, but I've followed the modding folder guide, Steam is installed on my HDD with a game library on the SSD, which is where SSE is located, was a new installation of course. I haven't backed my game up (Stupid, ik, but shouldn't be an issue), I've configured my display driver, calibrated my display and disabled all overlays, so I'm sure the issue isn't here.

 

And after a quick review of Step 1 and 2, I can be certain I've followed instructions as written, I haven't touched Step 5 just yet, as I had just finished my modlist, and was booting the game to make sure it ran, as the guide advises. Thanks for the quick reply!

Edited by Liraeli

Share this post


Link to post
Share on other sites
  • 0

What is returned if you open the console and type in:

GetSKSEVersion

Share this post


Link to post
Share on other sites
  • 0

can I see a screen shot of the SKSE mod installed in MO. Expand all folders.

Share this post


Link to post
Share on other sites
  • 0

It looks correct ... but there are also three files that should be in the actual Skyrim Special Edition game folder adjacent to the REAL /Data dir.

 

Also, to partially rule out SKSE, try launching the game via MO using the Skyrim launcher. If it loads, you should see an SKSE not running message, but it *should* still load even if there is an issue is with SKSE config.

 

BUT, before you do that: did you configure LOOT in MO2 per the STEP guide instructions? Did you run LOOT? Apply load order changes? Read LOOT warnings/errors and correct them? Do these things first. Then ...

 

... since you are running a custom mod list, next step would be to disable all mods but for the cleaned SSE masters and SKSE64. Then try launching with the SKSE launcher in MO2. If it works, you likely have a mod compatibility issue. In that case, enable mods in small batches down the list, run LOOT, sort/apply, launch game until it crashes to find the culprit(s).

Share this post


Link to post
Share on other sites
  • 0

Which 3 are those files? Hopefully i've just somehow copied instead of cutting somewhere, regardless, thanks.

 

I wasn't sure whether it had loaded through SSE before, but upon a check, it does the same booting from Skyrim Special Edition in MO2, as well as from the Skyrim Special Edition Launcher in MO2 :/ 

Share this post


Link to post
Share on other sites
  • 0

That was good enough, I just wanted to see is the scripts folder was at the right place.

 

According to the log you are launching the proper executable. C:\Games\SteamLibrarySSD\steamapps\common\Skyrim Special Edition\skse64_loader.exe

 

MO is installed in its own folder, C:\Modding\Tools\Mod Organizer, which is good.

 

The game is not installed in the Programs Files folder, C:\Games\SteamLibrarySSD\steamapps\common\Skyrim Special Edition\, which is good.

 

The return of the GetSKSEVersion shows that SKSE is running. If it were not running SkyUI SE would inform you that is wasn’t loaded.

 

All that looks good. Can you post your skse64.log? It will be in My Games\Skyrim Special Edition\SKSE folder. I just want to compare it to mine.

 

Also, I would like to know if you have run the games default launcher recently? That needs to be done anytime there is a change to the game like “verify integrity of game files†has been run. MO will still run the game when you do this and not complain, but you may get random problems.

 

As for Mo, did you have a previous version installed and then upgraded to 2.3.0? If you did how did you update to MO 2, download from Nexus executable or use the button on the top right of the app?

 

I have not used the Step Project in a while so I do not know what mods that require SKSE, so can you be more specific as to what is not working?

Share this post


Link to post
Share on other sites
  • 0

Okay, I found the correct SKSE folder, here is the skse64 folder contained within (There was a skee64 log also, not sure what that is, but confused me for a bit when I didn't see the difference) https://pastebin.com/G34cAY3R

 

I did run the game's default launcher, like I said in the first post, the launchers did run fine outside of MO2, and since then I haven't made any changes to the game. 

 

As for MO2, I had 2.2-something, i had downloaded it literally the night before 2.3 became available, and I downloaded the update through the button at the top right of the screen, when the alert popped up it was available the next morning.

 

I'm sorry, but I'm not sure what exactly you mean,

1. So you'd like a list of which mods I have require SKSE?

2. You may have to be more specific as to what you'd like to know, I don't think I know what isn't working, but I can try to answer any questions you have. 

Share this post


Link to post
Share on other sites
  • 0

I have not been modding or playing Skyrim for a while, my time is spent in Fallout 4, so I am not familiar with the mods in the STEP guide and what they do.

 

The title says “MO2 not launching SKSE w/ mods enabled†and you then say, “I haven't been able to get MO2 to load Skyrim SE using the SKSE loaderâ€. Going on that information I had to look to see if SKSK is loading, which it looks like it is. Now I think we must look at MO2 “not launching Skyrimâ€. So, when you run the SKSE launcher through MO how far along do you get? Do you see a brief window, the SKSE loader, before the game? Are we crashing? Does the game start all?  that sort of stuff.

 

You say you have updated MO via the update button. I would ask that you go to the MO2 download page and download the “Mod Organizer 2 (Archive)â€, which is the first one. Once downloaded, click on the archive, select properties, general tab and check the box next to unblock then select OK to close before you extract it. Doing this will not

 

You then want to open the MO install folder and open the downloaded archive, make sure MO is not running. Select all the files in the archive and extract them into the MO folder, overwriting all files when asked. Do not run MO just yet. The reason I want you to do this is I had a bad install when I updated by using the update button that would crash an executable when run and overwriting the files fixed it.

 

The way MO works, hooking executables, many anti-virus programs will flag this as a threat and isolate some files MO needs to work. Before you run MO open whatever anti-virus you use and open the settings and look for where you can white list the MO install folder. Once you do this you can run MO.

Share this post


Link to post
Share on other sites
  • 0

Okay, so when I try to run SSE from MO2, first a load box shows up that says

"Preparing vfs"

Promptly followed by

"Mod Organiser is locked while the application is running.

SkyrimSE.exe"

That stays up for no more than 10 seconds before it all disappears, and MO2 reverts to before I clicked "run". Nothing appears in the log box at the bottom of the screen, the screen doesn't flash black when it fails, and Task Manager never shows Skyrim, so I don't believe it booted and crashed.

 

When booting SKSE it's slightly different, everything in MO2 looks the same, but Task Manager shows that

"a component of the Skyrim SE ..."

Runs, followed by Skyrim itself, but again, after less than 10 seconds, it disappears and MO2 reverts to normal, as if I hadn't tried to run anything. Nothing in the logs.

 

This doesnt occur when I select my vanilla Skyrim profile, which has no mods enabled, nor does it occur on my Oldrim game instance, which has 5 mods enabled. 

 

I've just seen the new 2.31 update file for MO2, so i'll update to it using the method you suggested

 

I'm fairly certain my antivirus isn't to blame, as I disabled it while I attempted to boot the game, and the same issues occurred. I have MO2 as whitelisted as I know how to do, my antivirus is unfamiliar to me, so there may be a way to do more than I have, but considering the results of my test, I don't believe it to be the issue, yet

 

 

EDIT: Updated from 2.3 to 2.3.1 using the method you suggested, went smoothly, however didn't change the results of booting SSE or SKSE, unfortunately

Edited by Liraeli

Share this post


Link to post
Share on other sites
  • 0

Lets try to eliminate bad game ini files.

 

Try making a new profile (Configure profiles/ Create) with "Default game INI settings" checked. Then switch to it. Don't worry the new profile will have all the mods, but they will be unchecked and alphabetical order. Try running the game without anything checked and using the regular game launcher to see if the game will start and maybe play for a couple of minutes. If it starts then enable SKSE data mod and launch the game from the SKSE launcher. Report back when you can.

Share this post


Link to post
Share on other sites
  • 0

Okay, so yesterday I played around 5 hours on the Default INI file, no crashes, but as i'm getting ready to make lunch, the game blackscreens and crashes. I saved my game, fast traveled, did all the normal things, but honestly I think this was just my computer.

 

For some unknown reason, my computer blackscreen's occasionally, not sure what causes it, but it causes most games with decent graphics to crash when I get sound+video back in a couple seconds. My drivers are up to date and i'm running two screens, VGA and HDMI, and they crash at the same time, so I don't think it's a faulty cable. I've even had to rebuild my PC into a new case for unrelated reasons, and the problem persisted through it. If anyone has any ideas about that, lmk...

 

Regardless, I'll play for a few hours with SKSE, see what results I get. Thanks again for the help, I appreciate it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By qwrtui1245
      Hi, 
      I'm modding SkyrimSE with MO2 by following this version of the step guide: https://stepmodifications.org/wiki/SkyrimSE:1.0.0#04-Foundation. I've followed everything until now but experience problems with the first mod I need to install without using Nexus. It's Skyrim SE particle patch for ENB and I downloaded 'SPECIAL EDITION > ALL-IN-ONE INSTALLATION > LATEST VERSION (GOOGLE DRIVE)'. It's installation went fine (Situation A) but when I have to enable the optional ESP 'Particle Patch for ENB SSE.esp' I get the message 'Plugin not found: Particle Patch for ENB SSE.esp' in my log (Situation B). 
      I've tried: reinstalling the mod, refreshing, enabling and disabling the mod, restarting MO2, re-downloading the file. It doesn't fix my problem. I've added the pictures of situation A and B. I hope there are people who can help me here. Thanks so much in advance!
      Situation A

      Situation B

       
    • By Newtant
      Hello!

      I've stumbled upon a weird issue that I haven't encountered or read about before. I'm running Windows 8.1 and a fresh install of Fallout New Vegas with no mods so far. I'm trying to get Mod Organizer and the 4GB exe to work together, but despite following all of the advice, tips and workarounds it's still not happening. Right now I can launch the 4GB exe through Mod Organizer. The game starts, I can load a save and 'play'. The problem is that all of the text has disappeared or is invisible. I can only navigate the main menu by memory, the ingame popups regarding the DLC is missing the text as well.

      This issue does not happen if I start the game on its own with the normal exe.
      This issue does not happen if I start the 4GB exe on its own.

      It only happens if I start the either the normal or the 4GB exe through Mod Organizer.

      NVSE is being loaded, it doesn't matter if I'm using NVSE stable or beta.
      I'm using NVAC, without it the game crashes before arriving at the main menu. NVAC seems to be working, the log is showing several handled errors. (Pastebin)
      Yes, I've added '-laaexe .\FalloutMO.exe' to the launch arguments, that helped me get around the access is denied error but produced this text error.
      I did try compatability modes, I've tried starting MO, the 4GB or both as administrator. No dice.

      I've arrived at a point where I really don't know what it could be or what I could try next. One thing I do know, however, is that I can't go back to the pre-MO modding, so I'm turning to you helpful people and hope that someone here has an idea.

      Thanks in advance!
       
      Pictures:
      New Vegas installation folder
      Mod Organizer executable settings
      Disappeared text main menu #1
      Disappeared text main menu #2
      Disappeared text ingame
       
      Edit:
       
      I deleted all of the fallout .inis as well in case some of my text/font settings were messed up, but that didn't work either.
    • By Dennai
      Is there a way to make GaryBash work with MO in Fallout 3? I tried to use it as executable, but MO wouldn't recognized the Wrye launcher as such. It surprised me, because MO had no problem recognizing the Wrye Bash launcher for Oblivion, but I don't have the same luck with Wrye Flash. When I browse the Moppy folder to try to find the Binary, Wrye Bash Debug is the only application the MO can see.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.