Jump to content
  • 0
Sign in to follow this  
XxLeafeater27xX

DynDOLOD no longer detecting my Farm Mod after rerunning it.

Question

So quick and easy, 

 

When I originally ran DynDOLOD, my farm mod "White River Farm" was detected and therefor it rendered the LOD for it. 

 

However, I have since reran DynDOLOD and now my mod has no longer been recognized as a master, and therefor the LOD has not been generated. 

 

I made sure to check that DynDOLOD saw my mod in the loader and indeed it did. I've reinstalled my farm from nexus, reran DynDOLOD, and checked again and it no longer generates my mod's LOD, nor does it see it as a master. I am a bit confused hence why I am here. Is this something on my end that I need to do with my Mod or is this something I am doing wrong? I have ran DynDOLOD the same way before and now within the last day it just will not generate for the farm. Looking for some insight here. 

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Assuming you are using the same version of DynDOLOD and settings, then either the plugin changed or required LOD resources went missing from the load order.

 

The message log lists each loaded plugin. Make sure it is enabled and listed in plugins.txt and shows up in the log.

 

LOD models are assigned via full model filename matching as explained in DynDOLOD_Mod_Authors.html.

 

If no LOD models exists a mesh rule should be added to use the full model for static object and/or dynamic LOD.

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

My mod uses vanilla assets for everything besides the scripts to build it. I've checked the plugins.txt and it shows up. It was working before and I made sure that the DynDOLOD option was selected when generating. Made sure I was an interior cell and stopped DynDOLOD before creating a clean save and then regenerating. The LOD model for the farm is the same as the Drunken Huntsman and all other parts of the farm are architecture from the vanilla game, all with vanilla LODs. It was previously working on an Old generation then I reran it and now it fails to generate for it. I'm Using MO2 as well, which I know has been having issues with DynDOLOD and other programs. Think that might have something to do with it? The LOD was generated for everything else in my LO.

Share this post


Link to post
Share on other sites
  • 0

Did the DynDOLOD version change?

 

Did the DynDOLOD Resources change?

 

What changed between the two generations?

 

Does the log show that the plugin is loaded?

 

Did you test with a new game?

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

Nothing changed in any way. even reinstalled the resources. 

 

The difference between generations was the installment of the White River Farm. Nothing else was changed.

 

Log shows plugin listed

 

Tested on 2 different brand new saves, each different generations with DynDOLOD option clicked. SKSE folder generated, meshes generated, textures, scripts etc. No errors in the generation process. TexGen also has no errors. 

Share this post


Link to post
Share on other sites
  • 0

So what changed with the mod between generation?

 

Load DynDOLOD.esp in xEdit. Unfold Worldspace, Tamriel, Persistent Worldspace Cell D74, Persistent. Sort by EditorID column.

There should be references with EditorID starting with WhiteRiverFarmesp_*

 

For example, for the initial destroyed shack there should be a WhiteRiverFarmesp_0A2268_DynDOLOD_LOD

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

Found the issue.

 

I deleted my old DynDOLOD generation from the left hand pane in MO2. However, the program then put the old DynDOLOD.esp and .esm hidden in the file of the new generation. Which of course overwrote it each time, therefor the .esp never was actually updated even though I deleted the old version. It seems MO2 wasn't functioning normally and I finally was able to delete the old .esp and .esm from the MO2. Seems MO2 was struggling to actually delete the folder and what it contained. Thanks Sheson

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By sheson
      DynDOLOD DLL for Skyrim, Skyrim Special Edition, Skyrim Anniversary Edition and Skyrim VR
      So far all versions of DynDOLOD use the SKSE plugin PapyrusUtil for the optional dynamic LOD in the game. Starting with version 2.45 there is now the alternative DynDOLOD DLL available.
      The current DLL version is 2.45. It works with dynamic LOD generated by DynDOLOD Standalone 2.45 and newer.
      Read the ..DynDOLOD\Docs\DynDOLOD_DLL.html included in DynDOLOD Standalone for an explanation about DynDOLOD DLL, installation instructions (overwrite papyrus scripts of DynDOLOD Resources) and how it works.
      If there are problems with it, check DynDOLOD_DLL.html and the DynDOLOD FAQ first before posting.
      If a DynDOLOD.DLL version is required for a game version that is not listed below, request it in this thread. First, search this thread if it has been requested already, though. The future will tell how long it takes to release updates.
      Typically a new DynDOLOD.DLL is required for each new game version, but not each new SKSE version. For example a DynDOLOD.DLL compiled with SKSE64 2.0.9 also works with SKSE64 2.0.10 for the same game version.
      Nexus Downloads for DynDOLOD 2.45 and higher
      DynDOLOD DLL for Skyrim
      DynDOLOD DLL SE for Skyrim Special Edition
      DynDOLOD DLL VR for Skyrim VR
      Mega Mirrors:
      DynDOLOD.DLL + Scripts for Skyrim 1.9.32 (overwrite the papyrus scripts included in DynDOLOD Resources)
      DynDOLOD Scripts for Skyrim Special Edition and Skyrim VR (overwrite the papyrus scripts included in DynDOLOD Resources SE)
      DynDOLOD.DLL for Skyrim Special Edition 1.5.39
      DynDOLOD.DLL for Skyrim Special Edition 1.5.50
      DynDOLOD.DLL for Skyrim Special Edition 1.5.53
      DynDOLOD.DLL for Skyrim Special Edition 1.5.62
      DynDOLOD.DLL for Skyrim Special Edition 1.5.73
      DynDOLOD.DLL for Skyrim Special Edition 1.5.80
      DynDOLOD.DLL for Skyrim Special Edition 1.5.97
      DynDOLOD.DLL for Skyrim Special Edition 1.6.318
      DynDOLOD.DLL for Skyrim Special Edition 1.6.323
      DynDOLOD.DLL for Skyrim Special Edition 1.6.342
      DynDOLOD.DLL for Skyrim Special Edition 1.6.353
      DynDOLOD.DLL for Skyrim Special Edition 1.6.629
      DynDOLOD.DLL for Skyrim Special Edition 1.6.640
      DynDOLOD.DLL for Skyrim Special Edition GOG 1.6.659 (untested)
      DynDOLOD.DLL for Skyrim VR 1.4.15
    • By Ease
      I have a problem with two excessively glowing window textures that I've been troubleshooting for several hours now and I cannot seem to figure it out. The problem is only resolved if I disable DynDOLOD and I had to go through my entire load order to figure that out. The almighty Google hasn't found me a whole lot of information on it either. I've read through the Glow LOD section of the dyndolod.info webpage and have messed around with just about every setting I can, but still, I cannot solve this problem. I'm completely open to the idea that it's one of my mods conflicting with DynDOLOD, but I cannot for the life of me figure out what. It may be right under my nose too. I wouldn't be surprised.
      The two windows in question seem to be (according to more informative console) WRTempleOfK01 and WRHouseWind02. 
      Things I have tried:
      Making a fresh save file Disabling any texture mods I am using that change any architecture in Whiterun Disabling my lighting mods Generating LODs without any form of FX, candles, windows glow or any form of LOD glow available Rebuilding ENB shader cache Tweaking window lighting in my ENB settings I've included my mod list as well in case anyone here has a bigger brain than me and can spot the problem just by looking at what I have.
      In the screenshot attached you can see the problem I'm having. Any help on this would be greatly appreciated because I'm not the best at this stuff. Thanks!

      EDIT: Well, after several hours of trying to figure it out, I finally isolated the problem minutes after making this thread. I thought about deleting the thread but instead maybe this might help out someone else in the future. The file causing the issue specifically was in TexGen_Output under textures/architecture/whiterun/wrwindows01_g.dds. I hid the file and now my windows are glowing properly, ending my hours of suffering over a minute detail. 
      Below is a screenshot of the corrected glow on the windows. 

      modlist.txt
    • By 1990srider
      So currently I'm trying to get the stockade mesh in the mesh/clutter/stockade/.nif to show up as full mesh in my lod generations. Because I'm creating new full models using Dyndolod. I've gotten everything else and every other type of model to do what I need it to. Ive tried .....esp/esm;formid I've tried the file path shortened and full all the way to be of the nif file being included. 
       
      4 is full 8 is full 16 is full. I've had this issue also with highherothgar floor models not showing ether... I spelled that wrong in here but yeah. I've tried looking for another rule or mesh mask the could be interfering and I can't find anything. Anyone have any idea what could be wrong?? I'm not trying to generate a lower poly lod I'm using this for other purposes.
       
       
       
       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.