Jump to content
  • 0
jwingrider

MO2 Crashes when trying to do anything other than install a mod

Question

I have been struggling with this for the past 2 days and about at my wits end... I switched all my mods from NMM to MO2 because I loved the original MO and believe it is such a better utility! (So thank you for continuing to develop it!) I am using it for Skyrim SE. I was able to get everything I wanted installed and it will run the game, which is great but I am experiencing the following problems.

 

1. MO2 will crash every time I try to install from an archive file

2. MO2 crashes when I try to run LOOT

3. MO2 will crash every time I try to create a new executable (such as FNIS or Wrye Bash). This isn't even tryng to run them. Every time I click the ... box to create a path, MO2 crashes with a "Woops" message and I can't even create the path. This is the biggest problem for me. I feel confident in my load order and found a way around loading from archive files, but I need to make a bashed leveled list and I can't make it work. I am not the most knowledgeable when it comes to programs but I was able to make executables work fine in the original MO so I don't THINK it's something I messed up (but it could be!) I would appreciate any help/workarounds anyone can provide on this matter!!

 

A few more points, MO2 is installed in C:\Steam\steamapps\common\Skyrim Special Edition\Mod Organizer 2 and I think I made sure it has full permissions... I am running Windows 10. 

 

Thanks to anyone who may offer insight! I'm pulling my hair out here!

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

A few more points, MO2 is installed in C:\Steam\steamapps\common\Skyrim Special Edition\Mod Organizer 2 and I think I made sure it has full permissions... I am running Windows 10.

What version of MO2 are you using? 2.0.8.3 is known to have issues with long paths, so assuming your expanded mods are in "C:\Steam\steamapps\common\Skyrim Special Edition\Mod Organizer 2\Skyrim Special Edition\mods\..." that's some pretty long paths already, not even considering how the paths will be further increased by long mod names and mods with lots of deeply nested loose files.

 

See https://github.com/LePresidente/modorganizer/issues/82 and https://github.com/LePresidente/modorganizer/issues/85

 

I personally have MO2 itself (the executable) install in its default install path, but have its "downloads", "mods", "cache", etc. directories on another drive, as X:\MO\FO4\{mods,downloads,cache,...} (I'm playing Fallout 4, you would probably want "SSE") and I haven't encountered the bug reported in the mentioned issues.

Share this post


Link to post
Share on other sites
  • 0

I really appreciate the response. I tried to move MO to a shorter file path and it does the same thing. Crashes every time I try to do anything other than install a mod. It's so frustrating... Any other thoughts for me to try before I give up and go back to NMM? :/

Share this post


Link to post
Share on other sites
  • 0

Check the link in my signature about tricky software and take special note of the instructions about the game bar in Win 10.

Let us know if this is the issue in your case, there have been a few reports about the Creator update of Win 10 breaking MO's functionality but since I don't have that update, and I have otherwise fixed MS from spying on me, I can't test this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.