Jump to content
  • 0
Sign in to follow this  
darkside

Should MO 2 development focus only on 64-bit games (FO4 and Skyrim SE), not older games?

Question

Should MO 2 development focus only on 64-bit games (FO4 and Skyrim SE), not older games?

 

MO version 1.3.11 works perfectly fine with older games (FO3, FNV, Skyrim). Why reinventing the wheel?

 

Developer has limited time.

 

Just my opinion. Thanks for picking up the torch from Tannin.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Depends. Does the 64-bit framework natively support 32-bit applications (aka older games)? If so, the focus could be to get the 64-bit side working soundly for both FO4 and SSE, then toss in the required tweaks it takes to support another game. If the code and framework supports 32-bit by default, then I see no reason not to include it eventually. I'm no programmer, though, so I could be way off track here. :^_^:

Share this post


Link to post
Share on other sites
  • 0

I agree. MO2 should focus only on 64 bit games. The 32 bit ones are already well covered by mo1/others managers.

 

Better focus on 64 bit and give a full stable experience than focus on both and give less updates/finished work.

 

Sent from my SM-G925F using Tapatalk

Share this post


Link to post
Share on other sites
  • 0

Actually I'm of a different opinion. I think you need to focus on both ... The issues the current release version of MO has with the updated Wrye bash (307 official release is any day) is the same for both versions and drastically affects creating a valid bash patch. It also affects which patches can be merged.

 

Any valid release of MO2 will absolutely need to clean up LOOT 10.2 and Wrye bash integration. If you fix it for 64 bit, you've already drastically improved 32 bit as well. Though 64bit IS more important moving forward.

 

Might I recommend opening a dialog with the Wrye bash team at

 

Wrye Bash - Thread #112 - Page 7 - Oblivion Mods - Bethesda Softworks Forums

 

Wrinklyninja is already there along with Arthmoor. I'm just helping to test a little.

 

BTW ... Thanks for picking this up. I've been using WB since the SSE release and I really do miss my virtual data folder :) It would be really cool if there was some way to merge in the advanced error checking/reporting functions of WB into the new MO-SE. and I'd love to see you add the capability of ENB handling (swapping presets just like profiles) it's just basic file keeping one stinking folder higher LOL.

 

We've got a few people getting ready to beta for you over at my help thread on the SSE forums. Please drop by and say hello. We'll start gathering data for you. Ilja, CFS111, and I already have bug tracking EXP.

 

https://steamcommunity.com/app/489830/discussions/0/154643795211522292/

 

Thanks again

 

 

Share this post


Link to post
Share on other sites
  • 0

I'd actually prefer it supported both. There are plenty of utlities updated for 64 bit that are ether intended for for older games and have compatibility, or are 64bit only now, such as 3DS max, which works for ALL games

Edited by CyborgArmGUn

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.