Jump to content
  • 0

ENB Stutter (About to give up)


Tandem
 Share

Question

THANK YOU to everyone who helped out here!  Still not 100% sure what's happening on a technical level (I imagine my symptoms will show up again if I put the textures under heavier stress) but solved the symptoms at least.

 

Nvidia must have reset my settings when I reinstalled Skyrim and it changed Anistropic Filtering to 16x instead of being Application Controlled.  Switching to Application Controlled fixed 95% of the issues.

 

I used an ini posted by a user lower in the section and the stuttering returned even with the AF setting corrected... so there's more going on here than I can see.  Memory Hacks and Reduce System settings as below once again alleviated the stutter.

 

It would probably be helpful to find more of the root cause here, but this is at least a start!

 

 

ORIGINAL POST

---------------------

 

 

 

First off, thanks for putting together such a comprehensive set of mods.. I felt it was too nit picky but playing them all together really has an additive impact!

 

TLDR:  ENB is causing macro stutter on a near game breaking level.  Ini tweaks have had no impact.  Uninstalling ENB entirely and running the same Skyrim STEP setup is flawlessly smooth with no stutter.  (1) will playing STEP Enhanced without ENB cause issues down the line?  (2) Is there something I'm totally missing with ENB to fix the stutter?

 

SYSTEM

AMD FX 8350 4.00 GHZ 8 Core

12 GB RAM

Windows 8.1 64 Bit

Nvidia GTX 980

Solid State Drive

 

INSTALL:
STEP 2.2.9.2, including bashing and DynDOLODing

 

Spent the weekend installing STEP and running into serious stutter then reinstalling STEP from scratch to make sure I didn't make any mistakes, which I am now completely sure I've done every single instruction precisely.

 

Basically, when entering a save there is a gigantic stutter (macro stutter) that will freeze anywhere from 300ms to 5 seconds followed by a dozen more stutters as I spin my character around loading elements around me.  Opening a menu or book will cause a similar hitch.

 

Over time walking around as game items load into my RAM or VRAM the game smooths out, but maddeningly opening the map completely resets the behavior or going to an interior cell then exterior again.  I also notice the effect is degenerative and after 30 minutes or so I need to restart Skyrim.

 

I've tweaked every .ini field you have in your guides with no noticable change.  Especially the [MEMORY] section of ENB trying out each setting and increment.  Fullscreen borderless had no impact.

 

Skyrim is playable but not enjoyable.  Combat will stutter in particular as new spells or decals are used.

 

I used ENB FXAA SweetFX Manager v4.1 to remove ENB entirely (to be sure I didn't miss a file) and launched the same setup and it is completely flawlessly silky smooth.

 

Does anyone have a suggestion to get ENB up and running correctly?  Would playing STEP without ENB cause issues down the road?

 

Thanks!

[PROXY]
EnableProxyLibrary=false
InitProxyFunctions=true
ProxyLibrary=other_d3d9.dll

[GLOBAL]
UsePatchSpeedhackWithoutGraphics=true
UseDefferedRendering=false
IgnoreCreationKit=true

[PERFORMANCE]
SpeedHack=true
EnableOcclusionCulling=true

[MULTIHEAD]
ForceVideoAdapterIndex=false
VideoAdapterIndex=0

[MEMORY]
ExpandSystemMemoryX64=false
ReduceSystemMemoryUsage=true
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=512
VideoMemorySizeMb=3714
EnableCompression=false
AutodetectVideoMemorySize=false

[WINDOW]
ForceBorderless=true
ForceBorderlessFullscreen=true

[ENGINE]
ForceAnisotropicFiltering=true
MaxAnisotropy=8
ForceLodBias=false
LodBias=0.0
AddDisplaySuperSamplingResolutions=false
EnableVSync=true
VSyncSkipNumFrames=0

[LIMITER]
WaitBusyRenderer=false
EnableFPSLimit=false
FPSLimit=10.0

[INPUT]
//shift
KeyCombination=16
//f12
KeyUseEffect=123
//home
KeyFPSLimit=36
//num /       106
KeyShowFPS=106
//print screen
KeyScreenshot=44
//enter
KeyEditor=13
//f4
KeyFreeVRAM=115
//B
KeyBruteForce=66

[ADAPTIVEQUALITY]
Enable=false
Quality=1
DesiredFPS=20.0

[ANTIALIASING]
EnableEdgeAA=false
EnableTemporalAA=false
EnableSubPixelAA=false

[FIX]
FixGameBugs=true
FixParallaxBugs=true
FixParallaxTerrain=false
FixAliasedTextures=true
IgnoreInventory=true
FixTintGamma=true
RemoveBlur=false
FixSubSurfaceScattering=true
FixSkyReflection=true
FixCursorVisibility=true
FixLag=false

[LONGEXPOSURE]
EnableLongExposureMode=false
Time=1.0
BlendMax=0.0

Edited by Tandem
Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0

That is strange indeed. Sure there is nothing running in the background? Any kind of tuner? My next guess would be ENB version or graphics driver.

 

Did you disable AA and AF in the drivers?

 

https://enbdev.com/download_mod_tesskyrim.html

 

Please try 0.303 and 0.292. You just need the d3d9.dll and ENBHost.exe from the wrapper version and your enblocal.ini. Nothing else.

 

You can also try this ini:

 

 

 

[PROXY]
EnableProxyLibrary=false
InitProxyFunctions=true
ProxyLibrary=other_d3d9.dll

[GLOBAL]
UsePatchSpeedhackWithoutGraphics=true
UseDefferedRendering=true
IgnoreCreationKit=true

[PERFORMANCE]
SpeedHack=true
EnableOcclusionCulling=false
EnableZPrepass=false

[MULTIHEAD]
ForceVideoAdapterIndex=false
VideoAdapterIndex=0

[MEMORY]
ExpandSystemMemoryX64=true
ReduceSystemMemoryUsage=true
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=256
VideoMemorySizeMb=4000
EnableCompression=false
AutodetectVideoMemorySize=false

[WINDOW]
ForceBorderless=false
ForceBorderlessFullscreen=false

[ENGINE]
ForceAnisotropicFiltering=false
MaxAnisotropy=0
ForceLodBias=false
LodBias=-0.35
EnableVSync=false
VSyncSkipNumFrames=0
AddDisplaySuperSamplingResolutions=false

[LIMITER]
WaitBusyRenderer=false
EnableFPSLimit=false
FPSLimit=40.0

[iNPUT]
//back
KeyReadConfig=8
//shift
KeyCombination=16
//f12
KeyUseEffect=123
//home
KeyFPSLimit=36
//num /       106
KeyShowFPS=106
//insert
KeyScreenshot=45
//enter
KeyEditor=13
//
KeyFreeVRAM=35
KeyBruteForce=66

[ADAPTIVEQUALITY]
Enable=false
Quality=1
DesiredFPS=20.0

[ANTIALIASING]
EnableEdgeAA=false
EnableTemporalAA=false
EnableSubPixelAA=false
EnableTransparencyAA=false

[FIX]
FixGameBugs=true
FixParallaxBugs=true
FixAliasedTextures=false
IgnoreInventory=true
FixTintGamma=false
RemoveBlur=false
FixSubSurfaceScattering=true
FixSkyReflection=true
FixCursorVisibility=true
FixParallaxTerrain=false
FixLag=false
[LONGEXPOSURE]
EnableLongExposureMode=false
Time=1.0
BlendMax=0.0

 

 

 

Edited by Spock
Link to comment
Share on other sites

  • 0

Those settings seem fine at first glance.

Off the top of my head there are a myriad of different things you could try. But it would probably take several hours. I would highly recommend ENBoost because you might hit the 4 gb limit and cause crashes.

 

Did you test Skyrim without ENB? Just deleting the dll will do the trick.

If that fixes the problem, I would try a preset ENB (with an example enb local file) and see if that works.

 

Do you use anti virus or any other "optimization" software?

Edited by Spock
Link to comment
Share on other sites

  • 0

First, some users (like myself) who have the VRAM available can play without ENBoost, but we don't recommended it. I have 4GB VRAM.

 

Second, remove the ENB manager from the equation. These have caused issues in the past and manually managing ENB files is not hard once you learn what the files are.

 

Third, cut your "ReservedMemorySizeMb" in half to 256 to see if that helps; set "InitProxyFunctions=true" to "false".

 

Also, make sure you're not hitting "Shift+B" which enables Brute Force and will bring your system to its knees.

Link to comment
Share on other sites

  • 0

The Brute Forve mode only applies to SSAO and SSIL, without either of those active BruteForce won't impact performance, at least shouldn't and personally haven't noticed any decrease in performance when SSAO was off and BruteForce was on.

Link to comment
Share on other sites

  • 0

 

 

Did you test Skyrim without ENB? Just deleting the dll will do the trick.

If that fixes the problem, I would try a preset ENB (with an example enb local file) and see if that works.

 

Do you use anti virus or any other "optimization" software?

Yes, without ENB it is running flawlessly over the short term.  Will test longer to see if I hit a crash.

 

No optimization software.  Had Avast up but I've disabled it to simplify modding issues.

 

 

Second, remove the ENB manager from the equation. These have caused issues in the past and manually managing ENB files is not hard once you learn what the files are.

 

Third, cut your "ReservedMemorySizeMb" in half to 256 to see if that helps; set "InitProxyFunctions=true" to "false".

 

Also, make sure you're not hitting "Shift+B" which enables Brute Force and will bring your system to its knees.

Okay on ENB Manager!  Just used it to remove ENB cleanly as I didn't want to miss a file.  Removed!

 

I've tried Reserved Memory Size MB in every increment of 128 from the minimum to the maximum with no luck.  Trying initProxy now

 

Sure that Shift-B isn't the cause, but thanks on the heads up!

 

 

 

 

 

 

 

Thanks everyone!

Link to comment
Share on other sites

  • 0

Just noticed load time is 3x with ENB enabled... also sound has a delay in the main menu whereas with ENB off it does not.  Not sure if that helps.

 

Tried

InitProxyFunctions=true

no impact

 

Performance Monitor on ENB Enabled

yJWtZk4.png

 

 

Performance monitor ENB disabled.. same mods same save same run path and map usage

Y2C4fBT.png

Edited by Tandem
Link to comment
Share on other sites

  • 0

AFAIK, the reason you should use ENBoost it isn't necessarily the amount of VRAM you have, apart from apparently improving overall performance it's mainly to avoid hitting the 3.1GB (?) memory limit and crashing because of it. I'm under the impression ReduceSystemMemoryUsage=true enables the memory handling part to avoid hitting this limit. Using this feature seems to induce stuttering. If you don't crash with it set to false and you don't use the graphics of ENB, you can try using no ENB at all. Or, if you feel lucky, you can try setting ReduceSystemMemoryUsage to false and EnableUnsafeMemoryHacks to True. It makes the gameplay very smooth for me, but it eventually always crashes. I'm using a way heavier setup than STEP though, so that might be the reason. You only seem to hit 2GB VRAM max judging from that image.

A quote from Boris about EnableUnsafeMemoryHacks:

 

 

I can't say something specific. Setting depends from the texture mods installed, greater texture resolution means higher memory usage. Closer you come to the limit where vram is full, greater chance to have stuttering if setting are not correct. For no stuttering with lot of vram and not too much texture mods i prefer unsafe memory hacks, because testing the game with running very fast and at such conditions streamed textures by the ENBoost produce noticable delays. If amount of texture mods with crazy resolutions (like 4k) is the killer, unsafe memory hack just gives performance until you find the place where camera viewport look at textures summary about the same size as you vram size, in such scenario unsafe memory hack will have very low performance and autodetect vram size rules (and reserved about 64-256 mb). Negative side of disabling unsafe memory hacks is that game have multithreading bugs and if texture loading/creating takes too long time, ctd may occur. This "too long" is not actually long and depends from random factor when threads fighting with each other, so the bigger texture size and higher bits per pixel of it's format - the longer loading time is and greater chance to crash the game.

I'm not sure I understand everything that he says here, but it won't hurt to try.

 

I see you are forcing borderless fullscreen, from the original (possibly outdated) ENBoost Nexus page:

 

 

2) Lower performance when borderless window mode turned on together with vsync,
to fix disable any of them.

 

So maybe try using normal fullscreen by setting ForceBorderless & ForceBorderlessFullscreen to false.

 

 

Finally, apart from ENB(oost) settings DynDOLOD can be a real performance killer. I'd recommend not using the High DynDOLOD profile and to try setting your Terrain Manager settings in Skyrimprefs.ini to their High values instead of Ultra or, alternatively, play around with them in the DynDOLOD MCM and see if that makes any difference.

 

Also, the GPU dropping to zero are probably the moments it hangs (perhaps VRAM is 'refreshed'?) and I'd say they are the effects rather than the cause of his problem, because he said his game runs smoothly without ENB.

Edited by Pretendeavor
Link to comment
Share on other sites

  • 0

AF in the driver solved this issues nearly entirely... 95% improvement.  I still feel stutter on the initial load and opening the map but incredible improvement.

Will test other solutions just to be thorough to help anyone in the future with my issues.

That is strange indeed. Sure there is nothing running in the background? Any kind of tuner? My next guess would be ENB version or graphics driver.

 

Did you disable AA and AF in the drivers?

 

https://enbdev.com/download_mod_tesskyrim.html

 

Please try 0.303 and 0.292. You just need the d3d9.dll and ENBHost.exe from the wrapper version and your enblocal.ini. Nothing else.

 

No Tuners running I keep my OS limited to the basics.

AF was set to 16 surprisingly in the Gforce driver as I thought it had been modified... tested application controlled and off and both had same result (see top of this post)

 

Ran your custom INI and *WITH* AF fixed as above I once again had stutter but about 50% as bad as it was before.  

Setting fullscreen borderless=true had no impact

upping ReservedMemorySizeMb=1024 had a slight improvement

ExpandSystemMemoryX64=false no impact

 

Not sure what else to play with in your ini to once again remove stutter... my ini is stutter free now though with AF application controlled in drivers.

 

Can anyone hypothesize what's going on here?  Is a conflicting AF setting causing the stutters or is it merely putting more stress on and thus exposing the core problem?

 

I'm under the impression ReduceSystemMemoryUsage=true enables the memory handling part to avoid hitting this limit. Using this feature seems to induce stuttering. If you don't crash with it set to false and you don't use the graphics of ENB, you can try using no ENB at all. Or, if you feel lucky, you can try setting ReduceSystemMemoryUsage to false and EnableUnsafeMemoryHacks to True. It makes the gameplay very smooth for me, but it eventually always crashes. I'm using a way heavier setup than STEP though, so that might be the reason. You only seem to hit 2GB VRAM max judging from that image.

 

 

 

Also, the GPU dropping to zero are probably the moments it hangs (perhaps VRAM is 'refreshed'?) and I'd say they are the effects rather than the cause of his problem, because he said his game runs smoothly without ENB.

WITH AF fixed as above, and WITH the ini supplied by Spock... ReduceSystemMemoryUsage=false was a 95% improvement!

EnableUnsafeMemoryHacks=true on top of that appeared to improve further slightly, but may be placebo.

 

Agree with you assessment of GPU dropping to zero... there are zero frames running during a stutter so GPU has nothing to do... effect rather than cause

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.