Jump to content
  • 0
Sign in to follow this  
navuhodonosor

New STEP with some Immersion-survival mods works like charm!.

Question

Installed step core and added few mods for my liking:

Immersive Horses, Climates of tamriel, Cloaks of Skyrim, Winter is coming, Campfire, Frostfall, Hunterborn ( with campfire patch), INeed and Immersive patrols.

Working really great with no problems at all.

Thank you guys, I am still coming back to this game because of your hard work!

  • Upvote 1

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

It would be awesome if you could add the load order settings and the patches you've used. CoT, for example, needs to be patched into Audio Overhaul for Skyrim 2 and ELE.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Mr_Moal
      Pack now formally under update.  Post 5 (https://forum.step-project.com/topic/10307-everything-the-kitchen-sink/?p=162236) holds the old information. 
       
       
      Link: https://wiki.step-project.com/Pack:Everything_%2B_The_Kitchen_Sink
       
       
       
      (2017 07 20) Since these STEP Packs will be formally discontinued come STEP 3.0, I will be moving this pack to "Mod Picker", and continuing work on it there.  
    • By SerArthurDayne
      My MCM menu for SIC is gone or not loading, I followed exact STEP SRLE procedures from start to finish but it won't load. 

      I also don't see it writing or being overwritten by any other mod in MO. I even cleaned my save as well as did a new restart but no luck

      I'm totally perplexed as this works fine with STEP Core and STEP Extended + 100 other extra mods I have running on another setup with no issues.
       
      Any help would be appreciated, thanks.
    • By Zerotix
      My STEP Core is working so I have that profile done within MO. Decided to copy/paste the profile and add the mods I wanted, so I checked the Packs page and found the MIME guide. I thought to myself "well.... that sucks, I wish I just followed this guide instead." However, there are only a select few mods I want to work with my game. So far the mods work, but when I try to add Moonpath to Elswyr, Immersive Armors, or Interesting NPCs, my game takes over 10 minutes to start a new game, then crashes. Then, for some reason, when I untick those mods, rebuild the bashed patch, and load up the game, the same thing happens until I untick Immersive Orc Strongholds and load up the game.
       
      I tried installing them one by one. I tried looking for conflicting mods, such as Weapons and Armor Fixes Remade, or the aMiridian mods, but I don't know exactly what to look for, and I've been at this for days now lol.
       
      At this point, I just want to start playing the game. I really want these few mods to work, so I'm willing to go back and try again from the STEP Core Skyrim :)
       

      enblocal.ini
      Skyrim.ini
      SkyrimPrefs.ini
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.