Jump to content
Sign in to follow this  
T0rvadaL

Can my computer handle SR:LE?

Recommended Posts

Hi, i want to download Skyrim Revisited Legendary Edition, but i don't know if my computer can handle it. I would like to know if it can. If not, are there any mod that i can skip to make the game playable. I'm aiming for at least 40fps. 50 fps would be faboulous.

 

 

SPECS:

 

16gb Ram

Intel Core i7-4770K CPU @ 3.50 GHz (8 CPUs)

NVIDIA GeForce GTX 760   3gb

 

 

Share this post


Link to post
Share on other sites

I have round about the same specs (a bit worse) and I get around 35 GPS outside and 30-27 in citys

Share this post


Link to post
Share on other sites

You'll be able to run it probably around 30-40 FPS outdoors if you tweak your ini settings properly. I'd recommend following the recommendations in this guide just don't add the REGS mods if you don't have a REGS install.

https://wiki.step-project.com/Pack:Guide_to_Run_SRLE_with_REGS_on_Medium_Systems

 

 

I have round about the same specs (a bit worse) and I get around 35 GPS outside and 30-27 in citys

I forgot about this post and haven't seen your replies until now. Sorry for that. Thank you both, and i'm using that "Medium Systems" guide and i'm trying to download as many 1024 textures as possible. Hopefully it will run fine. :)

Share this post


Link to post
Share on other sites

I have a GTX 760 2GB and SR:LE runs fine. I went with some performance options relative to the guide.. mostly clutter, bottles, food etc. I used the 1k-2k performance option of Vivid Landscapes. But you have more VRAM than me so I doubt you need to worry too much about reducing your textures.

 

Not tested my new setup much yet but with NLA ENB I'm generally staying well over 30 fps outdoors. Vividian was a little less demanding IIRC.

Edited by Pegasus33

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By samuelr29
      I tried creating a shortcut with MO to launch BodySlide but when I launch it, a process appears, but no window.  I can manually launch it, but if I do that, none of the CBBE assets are detected, naturally.  It would need to be executed with VFS to have access to those, I assume.  When I went to test this in the data tab, it will open when I right click and select "execute" but if I select "execute with VFS" I get only a process and no window.  I've tried re-installing it multiple times, but I still don't know if I missed a crucial step.  I've already installed Nemesis and LOOT and both of those work just fine, it's only BodySlide that is giving me trrouble. Apart from what I have already gleaned, I have no idea what to do next, so suggestions would be appreciated.
    • By TechAngel85
      Discussion topic:
      Skyrim Project Optimization SE by rgabriel15/Pritster5
      Mod Picker Link

    • By DankTemplar
      Hey! I've been having this issue for well over a year; I follow the instructions for Dyndolod+Open Cities in the manual/from the GamerPoets web page, generate my LOD and get double LODs created for these cities and I could really use the help getting this nightmare fixed.
      To clarify; the tutorial told me to;
      Disable Open Cities+patches Run Dyndolod+select appropriate setting (high+custom tree and water LOD rules for getting rid of water LOD seams+generating 3D tree LODs which worked fantastically! Basically all I did was make use of the full models for water and used the appropriate static models for trees) Disable generate Dyndolod, enable the other options (except trees for me as generating 3D tree LODs means generate tree LOD is greyed out, per the manual instructions) Start+exit (not save+exit when complete) Comment out Open Cities from Dynodlolod_SSE.ini under the heading warnmodfilename+save document Re-enable Open Cities+patches in your load order Run Dyndolod+select identical setting which you selected in .2 Enable generate Dyndolod, disable generate *insert option here* Start+save and exit when complete. Install via your method of choice. I've also minded my load order since Dyndolod copies records from the last overriding file (this fixed my Solitude Open Cities LOD issue) but this hasn't fixed my Whiterun Open Cities LOD issue (and I've no city overhaul mods installed specifically for Whiterun so conflicting records in theory shouldn't be an issue here).
      So....ummm...please help? lol
      Attached is my load order in it's full glory!
       
       
      LoadOrder_SkyrimSE_2021-04-16T14-39-55.txt
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.