Jump to content
  • 0

Can't get TES4LODGen to work in Mod Organizer.



I have gotten everything set up in MO, I've used it for a long time in Skyrim.


Now in oblivion I have all my mods set up, everything is working terrificly. 


However I'm at my last hurdle and I can't seem to jump over it.  I've used MO to install tes4lodgen.exe, but when I run it, it detects all my installed mods in MO but then comes up with the error message "An error occured while loading modules. Editing is disabled. Check the message log and correct the error."


The last line of the log reads: "[00:00] Background Loader: Fatal: <EStreamError: Cannot open D:\SteamLibrary\steamapps\common\Oblivion\Data\Oblivion - Meshes.bsa.The system cannot find the file specified>"


This is impossible, as I have checked, double-checked and triple-checked that the file is there.  I've even deleted it and re-installed it with Steam's file validation, I've changed the date with timestamp editors, I've even added new registry entries with regedit.


The only way tes4lodgen.exe will detect this file is if I run it from the vanilla /data folder...  but then, of course, it won't detect any of the mods I installed using MO...


I run the .exe from mod organizer's executables list in the same way I've run other programs, but I just don't understand why it isn't working.


Thanks in advance for any advice.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

1 - Where would I find such a log?


2 - Yes


3 - Yes, and no.


I've solved the problem temporarily by simply copy/pasting all active .esps which add structures to Tamriel into the vanilla /data directory, and also copy/pasting all meshes and textures from AEVWD and tes4ll's file structures into oblivion\data.


I then made a new .rar archive with the distantLOD folder that tes4lodgen.exe created in oblivion\data (when I ran it from that location with the added files) and installed the new archive as though it were a mod via MO.  Now everything appears in game as it should.


I'm posting this clunky solution in case someone else out there has this problem and needs a workaround.  It's sloppy and time-consuming, but it works.

Link to comment
Share on other sites

  • 0

The logs are found in the folder under the MO root folder called: 'logs'


Also I wouldn't call this a solution in the same way I wouldn't call removing your leg 'solves' your aching feet.


As much as I would like to offer further help, you haven't actually provided anything in the way of diagnostic information. If you wish to provide the information I asked for, feel free to do so. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.