Jump to content
  • 0
zhokar

Adding Perkus Maximus to STEP Core install, Patcher won't work

Question

Hey guys. Not sure whether to post this into the mod thread or here.

 

I've gotten my STEP Core installation running smoothly and added Perkus Maximus, Immersive Weapons & Armor, Frostfall, JaySus Swords - patch version and some other mods on top. The other mods not mentioned to not include items or lists relevant to the issue.

 

Before creating my bashed patch, and after installing and ordering everything else, I ran the Perkus Maximus patcher and got the dreaded null error. The patcher runs fine naked so it's not an issue with java or the patcher.

 

I'm not sure how to get it working. I've tried disabling all other mods and only enabling mods with relevant items and lists one after the other but I still get the error. At this point I'm not even sure disabling the mods in Mod Organizer really makes the patcher ignore them. Where does the patcher get its mod info?

 

Has anyone gotten Perkus Maximus working as intended for a STEP install and or knows how I can get the patcher to run?

EDIT: I've read that I should patch AFTER bash. Did that, still getting the error.
Also, would it help just adding ANY mod that doesn't have items or where the item category and stats don't matter to the blocklist? Or would unpatched leveled lists from those mods still result in a borked PerMa?

 

Last lines of the patcher log:

 

 

[707][ARMO-DEBUG-EB:]  key: EnchWeaponFear06 | values: [sCC_Weapon_Ill_Ench_PhantomStrike06, SCC_Weapon_Des_Ench_Breach06, SCC_Weapon_Alt_Ench_Throw06, SCC_Weapon_Des_Ench_Fratricide06]

[708][EXCEPTION]  java.lang.NullPointerException
at skyproc.Mod.addRecord(Mod.java:356)
at patcher.BookPatcher.runChanges(BookPatcher.java:151)
at patcher.Runner.patch(Runner.java:51)
at skyprocstarter.SkyProcStarter.runChangesToPatch(SkyProcStarter.java:206)
at skyproc.gui.SUMGUI$ProcessingThread.run(SUMGUI.java:952)
at java.lang.Thread.run(Unknown Source)
Edited by zhokar

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Yeah, I would run the patcher last after everything - you want to include the bashed patch in it.  Other than that, I don't know... I'm considering using PerMa also, but haven't actually tried to run it yet.

 

EDIT: I'm tired of doing TES5Edits... even though I could probably get it working right in less than a day I'm just tired of reconfiguring mods and plugin edits and then testing things in-game.  And there are a number of patches needed (and available).  It's easy to do it for things that affect the beginning game, but hard to do for things that affect higher-level play.  Even though this mod looks great and the patcher, for me at least, "seems" to do a great done of taking what's already installed and modifying it for PerMa (as I have noticed by using TES5Edit to review the changes), I'm just not totally sure that everything (all the other mods) installed and integrated is actually going to work as intended within the game, or be horribly unbalanced and some things broken even if they don't cause CTDs.  I'm just not knowledgeable enough to know exactly everything going on.  Maybe I'll come back to this after a few months.

Edited by oqhansoloqo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Fargh
      Hello,
       
      I just finished getting a STEP extended installation setup. My machine generally seems happy about it. Mind you, I found the process a little confusing, so I may have done something wrong during setup. I did not use all of the patches for this reason, though I did use the extended patch and at least one more.
       
      My existing character used mods that I removed, so I get a warning when I load it. Assuming that is not the problem, let me describe what is happening:
       
      I load into the save file just fine. I can move around with no problems. The last time I ran it, I fast traveled to Whiterun and my 'home' there, no problem. Then I fast traveled to some other town (if this is important I can look it up)...and I went into a building that had crashed every previous time I tried to go (been trying to solve my own problem, which is how my character is no longer stuck in a croutch). This time it let me in before crashing. The floor was black, like a texture didn't load. A man was in the hallway in what appeared to be a glowing purple rubber smock (something was not right there). He also had a unibrow that was remarkably similar to that found on Burt from Sesame Street. At this point, it crashed again.
       
      Anyone have a guess as to what mod(s) is/are causing the problem? I have a new gaming laptop, so my assumption is that it isn't the hardware. No FPS drop at all.
       
      I use Nexus  Mod Manager and MO. I used LOOT, not BOSS. I have no idea how to export my load order.
       
      Thank you
       
       
    • By harley5656
      I really could use some help with this problem and cant seem to find the awnswer.  If this is located else where, I'm sorry I just could not find it.
       
      I am using Mod Organizer v 1.1.1 and everything was working quite well with a bunch of mods, but now I'm having problems.
       
      I  unselected all Mods but Skyrim.esm, Update.esm, Hearthfires.esm and Dragonborn.esm.  I go to run FNIS like before, however I am not getting the "GenerateFNISforUsers.exe failed to Run"  after running FNIS v 4.1.1
      The strange part is its happening 95% of the time, but in my testing sometimes it seems to work.  However, when I reproduce the same steps the error occurs again.
      I've tried everything to fix it but have no clue.  If any of you can provide some insight I would appricate it greatly!
    • By AyleidRuin
      Hello STEP!  I have a problem with New Vegas/Fear n Loathing with a 360 Controller.
      At first I was unable to switch from 1st to 3rd person camera views.  Now the "wait" menu won't come up and I am unable to wait.
       
      Both Problems are not solved yet.  I have gone threw many threads and found some solutions that don't work for me.  But I believe the Mods in the Fear and Loathing are interfering somehow.
       
      I am NOW downloading a Pinnacle Profile for Project Nevada.  Testing that now.
       
      Thank You for your Time 😄
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.