Jump to content
  • 0
Sign in to follow this  
Gorillaford

Mod Organizer Error: Executable "javaw.exe" not found when trying to launch Skyrim

Question

I am having a problem that I have never encountered before, nor have I ever read of anything like this hapening to anyone else. First of all, I updated my Java (but I didn't remove old files, they're still there) while trying to make Patchus Mauximus work for me. Eventually I ran it through SUM along with my Dual sheath Redux mod and it worked fine. I went into my game and noticed that Dual Sheath Redux wasn't working, swords were still at characters sides rather than on thier backs. So I exited the game and opened Mod Organizer. I went to launch Dual Sheath Redux patcher through MO's executables and nothing happened. Nothing. So after trying a few things, I opened the task manager to see what was happening, if anything was happening, and I tried launching DSR again. When I did, javaw.exe would appear in the list of open programs for about a second then disappear again.

 

So I decided I would just play until I got this figured out. I went to launch SKSE through the executables list and that's whe I get the error:

 

MO Error: Executable "javaw.exe" not found

 

So now, not only do my patchers no longer work, but Skyrim itself won't even launch.

 

I've tried updaing java, removing and reinstalling java, installed developer kit, I tried manually pointing to javaw.exe, but all to no avail. It simply won't recgnize it. Is there anyone out there who has ever had this problem or might know a little more about it than I do? Thank you for taking the time to read my post.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

You say you updated your Java installation. This may mean you will have to update the executables path in your MO exe links.

 

Before updating Java it may have had a path like:

"C:\Program Files (x86)\Java\jre7\bin\javaw.exe"

After updating Java the path may now be:

"C:\Program Files (x86)\Java\jre8\bin\javaw.exe"

Note the change in the folder name that points to the version 8 file.

 

You shouldn't have to make those changes. I have a couple of different versions of Java on my system and the paths don't usually change but it might be something worth checking.

 

Of course this is all assuming the versions of Java you are updating are NOT 64bit. You are only using 32bit Java?

 

Also, in the Nexus post (I'm assuming that was you) you stated you tried to run the game with the SKSE option and were presented with a message about a missing java executable. Did you modify those 'Executable' parameters when trying to add the 'Patchus Maximus' exe by mistake?

I ask this because of a peculiarity in MO were after modifying or adding a new executable, the drop-down list reverts to the top option and not the one you just edited. Did you perhaps make changes to the SKSE option as well?

Edited by GrantSP

Share this post


Link to post
Share on other sites
  • 0

@GrantSP

Thank you so much!!! You fixed my game ;)

Last Update has been too long...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By DogWada
      I'm using MO2 for Skyrim LE. When i first installed MO2 i selected "Create a portable instance" when i was prompted, so i don't have a global instance, i'm not sure if that's ok? I used Vortex before this and had no issues with FNIS so i do know how to use it.

      At this point i've watched multiple MO setup and installation guides and read a bunch of forum posts but i can't get GenerateFNISforUsers.exe to work when it's run through MO Executables. When i run it, it says:
      Generator: C:\Games\MO2\mods\2 FNIS Behavior 7_6\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      ">>Warning: Bad installation. Generator not run from <Skyrim_Data>\Tools\GenerateFNIS_for_Users. If you use a mod manager, run FNIS from its list of supported tools.<<
      Skyrim 32bit: ??.??.?? - C:\Games\Steam\steamapps\common\Skyrim\ (Steam)
      >>Warning: Expected generator path: C:\Games\Steam\steamapps\common\Skyrim\data\tools\GenerateFNIS_for_Users not found<<"
      But when i run "Explore Virtual Folder" and open GenerateFNISforUsers.exe there it loads all my mods fine. I could just activate it this way or go to the data tab in the right MO pane and right-click GenerateFNISforUsers.exe and select "Execute with VFS" each time but i'm concerned something won't work if im doing it this way, and it's less convenient to activate it like this every time.
      I did what this guide said: https://youtu.be/53472H4lAuA?t=597(timestamped) but this didn't work for me either. For him when he runs the GenerateFNISforUsers.exe through MO tools it says "MO is locked while the executionable is running", for me i get this message: and FNIS doesn't show on my screen so i can't see if it's loading my mods correctly or anything. If i click "Unlock" it says: and i think crashes FNIS. If i don't press unlock and just wait a few seconds the message will go away and my overwrite folder will have contents.
      After all of that if i set the Executables to the same directory i used for this process it still just gives me the same 2 warnings like i said at the start of the post.
      So what am i doing wrong here? What should i do?
       
    • By ApparatusHappy
      Ive been modding for a few years now, and its gone without a hitch. I dont use vortex since its over complicated, and use a community driven NMM (Nexus Mod Manager.) Ive tried installing skse64 to play my new mod profile, but i cant seem to load it on skse. It somewhat loads on vanilla, but very buggy and a ton of mods wont work. Ive uninstalled, reinstalled, disabled and re enabled, and ive even run on administrator, and reinstalled SKSE itself. Nothing seems to be working. i can give screenshots if needed
    • By frihyland
      Discussion thread:
      Mod Organizer Guide by DoubleYou & Step Modifications
      Wiki Link --> DOCUMENTATION UPDATE TOPIC
       

      This thread is for discussion and improvement of the Mod Organizer Guide on the wiki.
       
       
       
      This thread is for discussion of the Mod Organizer Guide, and should NOT be used for support/troubleshooting. Please use the Official Support Forum for support/troubleshooting.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.