Jump to content

Step 5 and Arachnophobia Mod


Youmuu
 Share

Recommended Posts

I got to step 5 in the STEP guide for Skyrim AE and I wanted to add the Arachnophobia mod to replace spiders in the game, but running TexGen and DynDOLOD gives me an error due to a record override from the Arachnophobia mod. I've tried to unwisely ignore the error and proceed anyways but when I launch a new game, it gives the "DynDOLOD.dll papyrus scripts are the wrong version" message. Is there anything I can do about this or is Arachnophobia (or the Insect be gone mod) simply incompatible with the STEP guide?

Link to comment
Share on other sites

Are you sure this is caused by Arachnophobia? First verify in 04-Foundation you have DynDOLOD Resources SE 3.0.0 and right below this you have DynDOLOD DLL NG and Scripts 3.00. The order is important here because the scripts and assets in DynDOLOD DLL should override the scripts and assets in DynDOLOD Resources.

If you install Arachnophobia, you should ensure it's in the proper order in the right pane and you'll need to use xEdit to resolve some conflicts.

Link to comment
Share on other sites

As instructed by DynDOLOD DLL install instructions and mentioned a few times around here, the install priority in the MO left pane is (irrespective of the versions of each being used):

  1. Papyrus
  2. DynDOLOD Resources
  3. DynDOLOD DLL

The plugin priority in MO right pane should be determined by LOOT. If mods in left pane or plugins in right pane change in either composition or priority, TexGen and DynDOLOD should be run again.

If a savegame exists based on the previous mod composition/priority and associated DynDOLOD output, it's best to establish a clean save when swapping out DynDOLOD outputs and plugins. This procedure is described in the main area of the DynDOLOD MCM and in the DynDOLOD documentation. We also have a more rigorous clean save procedure linked at beginning of the 2.2.0 guide changelog.

Link to comment
Share on other sites

Ok I managed to fix it, but it does turn out that Arachnophobia isn't done right as after cleaning with xEdit, it still gives the record override errors. I swapped to the Insects Begone mod and after converting a couple plugins to SSE, it works fine as a substitute.

It mostly turns out I didn't have the latest Papyrus tweaks which were only updated 3 days ago (I don't remember if I just downloaded the wrong version or I just missed the updated version) and after reinstalling papyrus and dyndolod, and regenerating the LODs, it seems to work fine now. Oops :embarassed:

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.