Jump to content
  • 0
bchick1

Skyrim SE CTD before main menu when DynDOLOD enabled

Question

I have installed the following via instructional video by GamerPoets video (

) ...

I am using MO2 v2.2.2

DynDOLOD v2.76 package

DynDOLOD v2.75 Resources package

 

I ran LOOT and established load order then tested the entire mod load by playing the game prior to beginning the DynDOLOD install.

 

I installed the 'Resources package' into MO2 and enabled

I ran TexGen from MO2 excutable and zipped the output file and created a mod in MO2 and enabled

I ran DynDOLOD from MO2 executable and zipped all resultant files and created a mod in MO2 and enabled

 

At the bottom of my load order:

 

DynDOLOD Resources SE v2.75

TexGen Out

DynDoLod Out

____________________

 

When starting up the game, the very initial 'Bethesda gear' screen will display then it goes dark and CTD to desktop. The intro does not reach the main menu screen.  Removing all elements of the DynDOLOD install the game starts normally.

 

Not sure where to look for a definitive answer for this.

 

 

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Explain what you mean by "Removing all elements of the DynDOLOD install".

 

This sounds like an issue with an outdated SKSE64 plugin, for example PapyrusUtil. 

 

Check the c:\Users\[username]\Documents\My Games\[skyrim|Skyrim Special Edition|Skyrim VR]\SKSE\[skse|skse64].log for errors

 

DynDOLOD Resources SE does not cause crashes.

TexGen Output does not cause crashes.

DynDOLOD Output can cause crashes if there were bad assets in the load order that are used by it for LOD. They can typically only cause crashes while/once a worldspace is loaded.

 

As mentioned on several occasions, read the included manual and FAQ in case of problems:

 

FAQ: Game: ILS or CTD
 
A: More LOD uses more memory and this can cause infinite loading screen (ILS) or crash to desktop (CTD) if the game is not setup correctly. This should generally not be a problem with Skyrim Special Edition or Skyrim VR, but for Skyrim double check heap memory usage (block 1) with Memory Blocks Log from https://www.nexusmods.com/skyrim/mods/50471/ and adjust SKSE or SSME memory settings. Or use the alternative OSAllocator from crash fixes with pre-loader. Remove satefy-load if it is used. Setup ENBoost correctly. Set ExpandSystemMemoryX64=false in enblocal.ini. 
 
A: Do not use the experimental TreeFullFallBack setting without understanding what it does and what it is for. 
 
A: If heap memory is not the cause of CTD see ..DynDOLOD\Docs\DynDOLOD-README.txt for checking if a missing or invalid nif model used for dynamic LOD is the cause. 
 
A: Large load orders with many plugins might surpass the reference handle cap. SSE Engine fixes prints a warning. See https://www.reddit.com/r/skyrimmods/comments/ag4wm7/psa_the_reference_handle_cap_or_diagnosing_one_of/ Setting Temporary=1 in ..DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_[GameMode].ini may help in these situations, however converting large new land plugins to ESM is the preferred solution. 
 
A: If there are problems saving in Skyrim Special Edition, install SSE Engine Fixes 4.8 or newer and set SaveGameMaxSize = true in the EngineFixes.ini. Alternatively add/set [saveGame] uiCompression=1 in Skyrim.INI to change from the default 2 for LZ4 to 1 for zlib compression. 0 means no compression like games are saved in Skyrim.
Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

Thank you very much for your response!  I will review your response and reply with info. THanks!

Share this post


Link to post
Share on other sites
  • 0

Explain what you mean by "Removing all elements of the DynDOLOD install".

________ I meant that I 'disabled' the three elements of the DynDOLOD install in MO2: DynDOLOD Resources; TexGen Output; and DynDOLOD ouput (DynDOLOD.esp and .esm)

This sounds like an issue with an outdated SKSE64 plugin, for example PapyrusUtil.

A: _________Papyrus SE  v 3.8  (version 3.8 for SKSE64 2.0.17 & SSE 1.5.97)


Check the c:\Users\[username]\Documents\My Games\[skyrim|Skyrim Special Edition|Skyrim VR]\SKSE\[skse|skse64].log for errors
A:___________There were no errors shown. however unlike a normal SKSE log which ends with 'Init complete' the pertinent log abruptly stops in processing without generating any messages.
 

DynDOLOD Resources SE does not cause crashes.
TexGen Output does not cause crashes.
DynDOLOD Output can cause crashes if there were bad assets in the load order that are used by it for LOD. They can typically only cause crashes while/once a worldspace is loaded.
Game does not get into any worldspace. Typically CTD when the 'Dragon' Icon first appears just prior to main menu.
 

As mentioned on several occasions, read the included manual and FAQ in case of problems:

 
FAQ: Game: ILS or CTD
 
A: More LOD uses more memory and this can cause infinite loading screen (ILS) or crash to desktop (CTD) if the game is not setup correctly. This should generally not be a problem with Skyrim Special Edition or Skyrim VR, but for Skyrim double check heap memory usage (block 1) with Memory Blocks Log from https://www.nexusmod...rim/mods/50471/ and adjust SKSE or SSME memory settings. Or use the alternative OSAllocator from crash fixes with pre-loader. Remove satefy-load if it is used. Setup ENBoost correctly. Set ExpandSystemMemoryX64=false in enblocal.ini.
 
A: Do not use the experimental TreeFullFallBack setting without understanding what it does and what it is for.
 
A: If heap memory is not the cause of CTD see ..DynDOLOD\Docs\DynDOLOD-README.txt for checking if a missing or invalid nif model used for dynamic LOD is the cause.
 
A: Large load orders with many plugins might surpass the reference handle cap. SSE Engine fixes prints a warning. See https://www.reddit.c...gnosing_one_of/ Setting Temporary=1 in ..DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_[GameMode].ini may help in these situations, however converting large new land plugins to ESM is the preferred solution.

ESM= 28
ESP=219
ESL= 36 Active
 
A: If there are problems saving in Skyrim Special Edition, install SSE Engine Fixes 4.8 or newer and set SaveGameMaxSize = true in the EngineFixes.ini. Alternatively add/set [saveGame] uiCompression=1 in Skyrim.INI to change from the default 2 for LZ4 to 1 for zlib compression. 0 means no compression like games are saved in Skyrim.

Edited by sheson, Today, 10:03 PM.

    + 0

Upload or paste entire log to a file service or pastebin when making an error report.

Share this post


Link to post
Share on other sites
  • 0

SSE engine fixes are and have been in place. checked for current version and modified engine.ini as suggested

 

I have compressed notepad file of current load order but I am not sure how to send it in this forum

Edited by bchick1

Share this post


Link to post
Share on other sites
  • 0

Upload files to a file service or paste log file to pastebin.com

 

Especially post the SKSE64.log that stop abruptly. Maybe clean out the entire SKSE log folder, start the game and then check all logfiles created for issues.

 

Narrow down what part might be causing the issue. Report findings as soon as issue stops.

 

With everything enabled start by hiding only the meshes folder from DynDOLOD output.

If it still has issue, hide DynDOLOD.esp

If it still has issue, hide DynDOLOD.esm

If it still has issue, hide TexGen Output

If it still has issue, hide DynDOLOD Resources SE. If that is the cause, try redownloading and reinstall.

Share this post


Link to post
Share on other sites
  • 0

Upload files to a file service or paste log file to pastebin.com

 https://1drv.ms/u/s!Aos6lGcTaGEJq1W4HXjMm_BPXL-C?e=DCh09w

NOTES:  
(a) 'Bash' Patch was built WITHOUT inclusion of DynDOLOD components. All DynDOLOD components are
therefore loaded OUTSIDE of 'BASH' patch

(b) 'occlusion.esp' was built with 'XLODGen64' (Xedit v 4.1.3.1 ) using 'occlusion' option ONLY.
In troubleshooting this issue, 'occlusion.esp' was disabled without significant results.
 
©  Just as a matter of FYI and my own curiosity, the game runs fine with 'XLODGen64' loaded and configured with ALL OPTIONS checked.
While I understand that XLODGen is to be run for 'Terrain' only (I installed using Shesons video) and is a different 'animal' than DynDOLOD, I was experimenting.
XLODGen is, of course, disabled in MO2 when testing DynDOLOD.


Especially post the SKSE64.log that stop abruptly.
Maybe clean out the entire SKSE log folder,
start the game and then check all logfiles created for issues.

 DONE

Narrow down what part might be causing the issue. Report findings as soon as issue stops.
IN PROGRESS

Share this post


Link to post
Share on other sites
  • 0

Skyrim SE starts ok with 'DynDOLOD.esp' ONLY removed and all other plugins active.

Edited by bchick1

Share this post


Link to post
Share on other sites
  • 0

Created a 'Test Profile' in MO2 with only vanilla game. Ran TexGen and DynDOLOD installs.

Game starts and runs fine. (of course!)

However, unsure how to effectively/efficiently test against all other mods in load order. <!>

Share this post


Link to post
Share on other sites
  • 0

Is Interface\Translations\TimingIsEverything_ENGLISH.txt the last english txt file in the folder?

 

The game is installed to Program Files x86. Consider moving it outside of that special windows folders as explained by any modding guide.

 

So if you leave everything else from DynDOLOD output active and only disable the DynDOLOD.esp the game doesn't start to its menu.

Test if it makes any difference if you hide the scripts folder from DynDOLOD Recourse SE. It most likely won't.

 

Test if it loads without the Bashed Patch being active.

Do the Bashed Patch before DynDOLOD and leave it active. Use latest version from https://github.com/Wrye-Code-Collection/wrye-bash/releases/ or do not check Import cells with earlier versions.

 

If issue still happens then, and only disabling the DynDOLOD.esp allows the game to start, upload the DynDOLOD.esm, DynDOLOD.esp and DynDOLOD\Logs\DynDOLOD_SSE_log.txt to a file service / paste bin. Truncate the log to the last generation for the esp.

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

  RE: 'Timing is Everything" is mod 248 out of 285.  I did try disabling the mod to see if the SKSE log would progress, but no it didn't. I also disabled mods 249 onward with no good result.

 

As to 'profilesx86', that is the Steam folder (complete path ... "E:\Program Files (x86)\Steam\steamapps\common\Skyrim Special Edition". I reserve the C: drive for the O/S only

 

I have always tested with the Wrye Bash file deactivated, considering it basically irrelevant to this issue. However I have been careful to exclude DynDoLod plugins from the generation of the bash file.

 

UPloaded all requested files to    https://1drv.ms/u/s!...BPXL-C?e=DCh09w

 

Also uploaded complete SKSE files with more info since game started (without DynDOLOD.esp)

Share this post


Link to post
Share on other sites
  • 0

While most likely unrelated to the problem starting the game, pay attention to the install instructions to avoid unnecessary trouble:

 

From the DynDOLOD Standalone archive copy the content of the 'DynDOLOD' folder, which contains the files DynDOLOD.exe, TexGen.exe, DynDOLOD_QuickStart.html and the sub folders 'Docs' and 'Edit Scripts' with all their content into a new 'DynDOLOD' folder outside of special OS folders like 'Programs Files' or 'Program Files (x86)', the SteamApps or game folders and Mod Organizers virtual file structure. Do not mix with old versions or xEdit/xLODGen installation.

 

I downloaded the files, but won't have time to start looking at them until some time tomorrow. If you continue to test with more and more plugins enabled, post the results please.

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

Thanks!  If I can think of anything further, I will communicate. Time is not important here.

The game actually looks really good with the XLODgen running!

Share this post


Link to post
Share on other sites
  • 0

ok ... thank you for communicating. If I can help further in testing or otherwise, just let me know.

I am  retired from IT where I spent many years in software and hardware integration in the healthcare industry. I did a lot of testing of dev's beta releases.

My point is that i know how this goes!

Edited by bchick1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By CultureBomb
      I'm following the STEP 2.0.0 guide and I just finished setting up ENB. The game worked perfectly prior to installing ENB but now the game crashes when ENB tries to compile shaders when running for the first time. I'm yet to run DynDOLOD and TexGen. Installing the ENB Light 0.98 Alpha 2 update file produced an error stating that the vanilla torch file was missing from the FOMOD installer stating that the mod might not work properly. Attached are my crash logs.
      System Specs:
      CPU: Ryzen 5 5600X
      GPU: RTX 3070
      RAM: 16GB
      crash-2022-09-01-00-18-58.log crash-2022-09-01-00-19-33.log crash-2022-09-01-00-33-34.log crash-2022-09-01-00-47-08.log crash-2022-09-01-00-51-22.log crash-2022-09-01-01-32-53.log
    • By beeleth
      Hello, I need some help with an issue in my game. The game kept crashing whenever I entered High Hrothgar. This is from the crash log:
      It mentions ENB there so I tried changing ENB to no avail. Google search also doesn't really get me anywhere since the people that got this issue had offending mods that I don't have. I use VERVE ENB with the recommended enbhost (v292), following this guide https://www.sinitargaming.com/skyrim_graphics.html#google_vignette.
      Everything was fine with a few occasional CTD but nothing too concerning. Only now I got a constant CTD. If anybody knows how to read crash logs, please help me. If I need to post my load order too, do tell. I don't have time to post it now but will do if requested later.
    • By Arcfell
      I've modded Skyrim following the STEP guide back in March. I've played multiple characters/saved games since.
      I currently have a Character with 4 saves that for the most part crash to desktop(log attached) on loading the save:
      One is a quick save This is in Bleak Falls Sanctum I've managed to load the quick save once which promptly CTD when I tried to save again (still in Bleak Falls Sanctum) This only happened once and I cannot replicate this. The other three are auto saves One in Bleak Falls Sanctum The other 2 in Bleak Falls Barrow
        I have some very early (level 1) saves on the above character that still work, however I'd prefer if the above could be recovered. This crash is isolated to these saves, as all other Characters/Saves still work. No new mod installs or updates have occurred since the first STEP installation in March I've ran LOOT and tried sorting plugins Any help recovering these saves would be appreciated.
      crash-2022-05-18-12-23-25.log
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.