Jump to content
  • 0

Skyrim won't recognize my NVIDIA card



I tried to run SKSE through MO today to play Skyrim, and it crashed. I knew this wasn't due to any of my mods missing masters, so I decided to run Skyrim Launcher through MO to see what happens. It said it would detect my hardware and adjust my settings, like it does on first launch or if your .ini files are missing. it shortly stopped responding and i had to close it. When I ran the launcher through MO again, it did not try to detect my hardware settings, so I selected Options and saw that it was trying to use my integrated Intel graphics card. It would not detect my NVIDIA card.


I looked at the skyrim.ini file located within the MO profile directory and saw that it only had two items in it: language=english, and sd3ddevice="Intel® HD Graphics 4600".


I opened the Skyrim.ini located in my Skyrim documents directory and copied everything into the skyrim.ini in my MO profile, and I manually set sd3ddevice to"NVIDIA GeForce GTX 765m" . I tried to run SKSE thru MO, and crash.


Next I looked at Skyrimprefs.ini within my MO profile and found that it also had a sd3ddevice setting, which was set to "Intel® HD Graphics 4600". I changed this also to my NVIDIA card and tried to run SKSE, and it crashed again.


Any time I change sd3ddevice to my NVIDIA card in Skyrimprefs.ini and then run the launcher, the launcher tries to detect my hardware and then stops responding. Opening Skyrimprefs.ini shows that it changed sd3ddevice back to my Intel card. It does not, however, change the same setting in my skyrim.ini, which I have manually set to my NVIDIA card.


It is very interesting to note that if I delete both Skyrim.ini and Skyrimprefs.ini from within my MO profile and then run the launcher, which subsequently crashes after trying to detect my hardware settings, within the newly created Skyrim.ini I will find only sd3ddevice, which is set to my Intel card. What's interesting is that, in the .ini files in my normal Skyrim documents directory, the setting sd3dd3vice only exists in Skyrimprefs.ini and NOT within Skyrim.ini.


I have already checked the NVIDIA Control Panel settings for tesv.exe and changed it to use my NVIDIA card, and also set modorganizer.exe to use my NVIDIA card as well (even though I don't think that does anything).


Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

sd3ddevice= is not a setting, it is only reported/written the first time you run Skyrim and is never used by the game again. You need to force your laptop to use your nVidia GPU before you set up or run Skyrim.

Ah, ok. So how do I force my laptop to use my nVidia card, then? As I said, I have already checked (and double-checked) in nVidia Control Panel that tesv.exe is using my nVidia card. Is there something else I need to do?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.