Jump to content
  • 0
Sign in to follow this  
elwaps

[STEP + REGS + Requiem + CWO + More] Help with Bugfixing, increasing Performance and Merging

Question

Hi everyone. I hope this part of the forum is appropriate for my thread, looking at the sections I haven't found something more fitting for a general mod build thread than the General one. If threads like this aren't allowed or desirable in the STEP forums please tell me (and don't just delete it - that way I got the chance to copy the content and post it elsewhere).

 

If you're not interested in investing some time going through stuff please leave this thread now. On the other hand, as I'm trying to improve my modding in general, you could also learn something (more likely from others potentially helping me than from me myself).

 

 

Goals:

1 Immersion (first person mods, no fast travel except for carts,...)

2 Lore Compatibility (no LotR stuff, no weird monsters,...)

3 Visuals (maxed out as long as the game is just playable)

4 Realism (no overpowered stuff/homes, deleveled world, SexLab,...)

5 Performance (aiming for stable 30fps with my card as 60 turned out to be unrealistic)

in this order.

 

 

 

Specs:

i7 3930K @ Stock

GTX 680 4GB OC @ StockOC

8GB DDR3 1333MHz

Windows 10 x64

Windows & Skyrim installed on SSD

 

 

 

My current setup [v4]:

View on modwat.ch (including Modlist, Plugin List, Skyrim.ini. Skyrimprefs.ini)

Modlist Tags

[sC] = STEP Core

[sE] = STEP Extended

[sX] = STEP Replacement (XP32 Extended)

[PRG] = PACK REGS

[PRQ] = PACK Requiem

[PWE] = PACK War Ensemble

[MISC] = Other mods

[sXLB] = SexLab

[FILES] = Patch Output

[PATCH] = Patches

 

 

Recent Changes [v3 - v4]:

 

- reinstalled non-Requiem version of "[sC] Soul Gems Differ", see below

- deactivated "[PRQ] Requiem - The Roleplaying Overhaul" as I suspect it to cause the freezes or CTDs

- deactivated "[PRQ] Requiem 1.9 Patch Central" and "[FILES] Requiem", see above

- deactivated all Requiem Patches (EBQO, ETaC, BOYD, AOS2 and MAS), see above

- deactivated "[PWE] Immersive Patrols" and see if it fixes the naked intro bug, freezes or CTDs

- deactivated "[sC] Birds and Flocks" accidentially after creating DynDOLOD Worlds the last time ^^

- removed "[MISC] UNP Clothing Merchants" and "UCM HDT Patch" as it doesn't fit lore

- removed "GQJ_DG_vampireamuletfix.esp" and "Traps Make Noise.esp" as they were merged into the Bashed Patch

 

 

Older Changes [v2 - v3]:

 

- reinstalled "Viewable Faction Ranks" to hopefully eliminate the double MCM menu

- reinstalled "Fair Skin Complexion" to make it ready for ENB

- added "Morning Fogs at Skyrim"

- added "UNP Clothing Merchants" and "UCM HDT Patch" for proper clothing

- added "HDT HighHeel System" for some shoes from the above patch

- deactivated "Civil War Overhaul" to reduce script load as script overload was probably the reason for freezes

- removed "Dragons Shout with Voice" as I don't like the sounds

- removed "Immersive First Person View" as "Skyrim Enhanced Camera" is the better alternative

- renamed and manually resorted the entire list

 

 

 

 

Changes compared to STEP and PACKS:

 

STEP Extended

- Replaced "Even Better Quest Objectives" 1.5.6 with 1.5.5 as the new version requires "Unofficial Skyrim Legendary Edition Patch"

- Replaced "XP32 Maximum Skeleton" with "XP32 Maximum Skeleton Extended" to make "UNP HDT-PE BBP TBBP" and "SexLab Framework" compatible

- Skipped "Dragons Shout with Voices" as I didn't like the sounds

- Added "Realistic Water Two" ENB Textures for ENB compatibility

 

REGS

- Skipped the Gameplay altering, unrealistic section at the end

 

REQUIEM

- Skipped the patches from the old Patch Central and instead used the new one as the guide is about 1.7 and not 1.9

- Didn't delete the allegedly included STEP mods as I didn't know if they were also in 1.9

 

WAR ENSEMBLE

- Skipped "Civil War Repairs" as it was reported buggy and would probably have conflicted with ETaC and similar mods

 

 

Changes to Load Order:

 

Mod List

- ignored instruction to move [sC] Skyrim Flora Overhaul after [MISC] Skyrim Bigger Trees as I couldn't find visible conflicts the other way around

- moved [MISC] Skyrim Bigger Trees before [PRG] Helgen Reborn according to SBT's readme

- moved [PRG] Expanded Towns and Cities after [MISC] Skyrim Bigger Trees according to SBT's readme

- moved [sE] Bring Out Your Dead" after "[MISC] Skyrim Bigger Trees according to SBT's readme

- ignored instruction to move [sE] Lanterns of Skyrim after [MISC] Skyrim Better Trees as it probably only means the Roads option I have deactivated

- moved [MISC] HDT Physics Extensions before [MISC] DIMONIZED UNP according to HDT's readme

- moved [sC] Ultimate HD Fire Effects" after [MISC] Skyrim Particle Patch for ENB according to Particle Patch's readme

- moved [PRG] Expanded Towns and Cities after [PRG] Helgen Reborn according to ETaC's readme

- moved [MISC] Skyrim Immersive Creatures before [PRG] Expanded Towns and Cities according to ETaC's readme

- moved [MISC] Legacy of the Dragonborn before [PRG] Expanded Towns and Cities according to ETaC's readme

- moved [sC] Realistic Water Two after [PRG] Realistic Boat Bobbing according to RBB's readme

 

Plugins

- STEP rules applied

- REGS rules applied

- All REGS mods manually checked for load order instructions, applied if present

- Applied all rules from Mod List to Plugins

- Loading Inhabitants of Skyrim after Perfect Legionnaire and Immersive Patrols to hopefully fix the naked intro bug

- Rest is managed by LOOT

- DynDOLOD is manually moved to the bottom before creating LODs

 

 

 

 

MCM Settings [v4]:

 

Auto Unequip Ammo: Activate Follower Addon

Autosave Manager: Incremental 10min, Hotkey, Save with Weapon Drawn

Better Fast Travel: Disable Fast Travel, Enable Helgen as Location and Destination

Convenient Horses: Activate Following Horses, Activate Follower Addon

Dual Wield Parrying: Hotkey

Immersive Creatures: Purist Preset, Additional Spawns Off, Random Spawns Off

Immersive HUD: Force Hide Crosshair, Fast Fade, Transparency for Everything 50%

Lanterns of Skyrim: Check every 25 Seconds, Disable Laterns at Roads

Lock Overhaul: Activate, Activate Smash Locks for One and Two Handed Weapons, Activate Magic

Minty's Lightning: Activate Hostile Lightning

Sleep Tight: Set both to Random

 

 

 

 

Performance [v3]:

10-20 fps: Around Falkreath

15-20 fps: Riverwood, Lush woods

15-25 fps: Outside Riften, Whiterun, Solitude Docks

20-30 fps: Outside areas without fog

25-30 fps: Outside areas with fog

25-35 fps: First minute of intro, Dayspring Pass

 

 

 

Wishlist:

- New armors and weapons

- Free up esps by merging

- HiRes horse textures

 

 

 

Patching the Game

 

1 Delete the content of DynDOLOD TexGen and Worlds

2 Replace DynDOLOD with the original mod, else its esp would stop DSR and Requiem patches from working due to missing masters

3 Run LOOT and apply the suggested load order

4 Run WyreBash, move Requiem for the Indifferent.esp below the Bashed Patch, click rebuild and let it deactivate the mods it wants, Merge Patches, Tweak Settings and Leveled-Lists (the latter is why Requiem has to load afterwards)

5 Put the stuff from Overwrite into my Bashed Patch folder in the load order and reactivate the mods WyreBash has deactivated

6 Dummy-run the Requiem patch, else the Dual Sheath Redux one would complain about missing masters in Requiem and put the results into the Requiem Patch folder

7 Run the DSR Patch and put the results into the DSR Patch folder

8 Run FNIS and put the results into the FNIS Patch folder

9 Run the Requiem Patch again and put the results into the Requiem Patch folder

10 Put DynDOLOD.esp at the very end of the plugin order and run DynDOLOD TexGen through TES5Edit, go to the output folder, zip the textures and install them into my DynDOLOD TexGen Patch

11 Deactivate BirdsAndFlocksHF and run DynDOLOD Worlds through TES5Edit, go to the output folder, zip the folders and install them into my DynDOLOD Worlds Patch, afterwards reactivate BirdsAndFlocksHF and put it back to its original plugin load order place

12 Run the game

 

 

 

 

Gamebreaking bugs:

 

5) [v0] Game freezes

Game froze once after about two hours of testing, presumably because of heavy script load, investigating, already removed SkyTEST as it is said to be a beast when it comes to scriptheavy mods. Could also be due to Bigger Trees as it happened during riding a horse near Falkreath, but for a performance related thing I would expect a CTD instead of a freeze. Sound was still playing. 

[v1] had another freeze after about one hour of testing, therefore SkyTEST, uGridsToLoad, the ini settings for trees aswell as replacing Skyrim Bigger Trees with the Lite version didn't help.

[v2] another freeze after about one hour of testing. As the ENB drastically reduced fps while the disabling of SexLab should have reduced scriptload by alot, the freezes don't seem to be related to either frames per second or SexLab, instead they seem to be time related which is really weird. Will try to disable more scriptheavy mods for v3

[v2] had another freeze, this time after about 40 minutes. This time I had Papyrus Logging running and this is the last "VM is frozen" message:

"[11/15/2015 - 11:18:28PM] Suspended stack count is over our warning threshold, dumping stacks:

[11/15/2015 - 11:18:28PM] VM is freezing...
[11/15/2015 - 11:18:28PM] VM is frozen"
There's 12 "VM is frozen" messages in the entire document, mostly while saving with Autosave Manager which makes sense as the game horribly lags every time a new save is made:
"[11/15/2015 - 10:57:17PM] VM is freezing...
[11/15/2015 - 10:57:17PM] VM is frozen
[11/15/2015 - 10:57:18PM] Saving game...
[11/15/2015 - 10:57:19PM] VM is thawing..."
The upper one however is the one that matches the time when my game totally gave up and froze to death. The document is about 10 MB in size, when I tried to paste it to pastebin (or this thread as spoiler) Chrome would kill itself because of the over 3000 pages. What should I do?
[v3] two more freezes, both near Riften in the woods at 20fps respectively 11fps. Both occured after about 30-60 minutes. These lines are from the logs of the second one
"[11/16/2015 - 03:54:29PM] VM is freezing...
[11/16/2015 - 03:54:29PM] VM is frozen
[11/16/2015 - 03:54:30PM] Saving game...
[11/16/2015 - 03:54:31PM] VM is thawing...
[11/16/2015 - 03:54:33PM] Warning: Property"
The respective lines before each freeze seem to be random and are different each time.

 

10) [v0] Crash to Desktop

Had a CTD after running a while near Markarth. I was hit by a Forsworn arrow before but the crash happened at least a minute after that. Other than a random cave there was absolutely nothing which I would connect to a CTD. Framerate was at 40-50.

[v2] Did the exact same "Markarth Run" again, this time without crashing. Seems to be not location related.

[v2] Had another CTD after creating a new character and starting the vanilla intro. Game CTD'd after loading screen, cart was shown for a second. Papyrus Log pointed out several errors connected to "REQ_ConditionalSubEffect.psc" which is a part of Requiem. Still, the last entry before the "freeze" message was "CWIMCMenuQuest" which should be Immersive College of Winterhold.

[v2] Loaded the exact same character again, shortly before talking to the statue in Alternate Start and choosing the Vanilla start. This time everything worked fine.

[v3] The beginning of the intro once CTD'd but when trying another few times it seemed to work, however, the game once CTD'd without log after the female officer from the intro said "Archers!"

 

24) [v2] Savegames cannot be loaded

Obviously due to already present script overload in savegame files, savegames with a playtime of more than 20 minutes lead to a CTD. Needs to be confirmed. Should be gone/better with CWO deactivated in v3.

 

25) [v3] Player stuck in Helgen Keep

The player character gets stuck (can't move, once running while not moving) after entering Helgen Keep after the vanilla intro. Only typing "epc" into the console resolves the problem


 

Really annoying bugs:

 

26) [v3] Staff fragment imitating movements

Screenshot While using a staff, after a while a fragment of that staff gets displayed top left of the screen, imitating the movements of the actual staff. No idea what this could be related to but its annoying as hell.

 

 

Mild bugs:

 

2) [v0, v1, v2, v3] Red Screen Flashing near Solitude

When walking up to Solitude, coming from the crossing leading to the docks, I experience two red screen flashes where the entire screen turns (translucently) red for a moment. Happens the first time when I'm still near the crossing and a second time shortly before I reach the door. The only red screen problems Google would find were about a red Skyrim logo or red loading screens. The bug isn't game breaking but it would be nice to get rid of it. Someone told me this would be fixed with the Unofficial Legendary patch, in that case I'll have to wait for STEP 2.3.0

 

17) [v2, v3] Ultra bright ETaC Object

Screenshot Screenshot2 Strange bright object with ID 00079a00. Can be seen from far distance, is unbelievably bright and produces ten times more lensflare than the actual sun. TES5Edit says that it is placed by ETaC - Complete.esp and that it would be "CraftingSmelterMarker1". Anyone?

[v3] Rearranging load orders didn't solve the problem

 

20) [v2, v3] Naked NPCs during Intro

Screenshot Screenshot2 During the intro sequence, Ralof and one Imperial officer is missing clothes. Probably connected to Helgen Reborn (improbable as already present in v0), Civil War Overhaul (improbable as already present in v0), Immersive Patrols (probable) or Perfect Legionnaire. Also, fighting occurs near the carts which is probably due to Immersive Patrols but doesn't really destroy the intro. Also, the back shield of the carriage rider clips through the carriage, which must be due to Perfect Legionnaire. I will ignore this as Perfect Legionnaire looks awesome.

As I later noticed the Imperial doing the list was looking differently before. He was defined by "Inhabitants of Skyrim - NPC Overhaul" before which now got overwritten by either CWO, Perfect Legionnaire or Immersive Patrols. Will test this with v3.

[v3] Rearranging load orders and deactivating CWO didn't resolve the problem

 

21) [v2] Floating Wall near Whiterun

Screenshot Screenshot2 A piece of stonewall with the ID 7502b500 is floating near Whiterun, you can see it when you turn left and look into the Sky after entering the first gate. TES5Edit says it belongs to the questmod "The Shadow of Meresis". There seems to be no fix. Any idea if/how I could hide/remove this piece of stone?

 

23) [v0, v1, v2, v3] Intro Priest keeps talking

Female priest is supposed to be interrupted while praying by "For the love of Talos - shut up!" but she's continuing in the background for at least another 2 seconds

[v3] Problem still present, seems to be vanilla

 

 

Solved Bugs:

 

1) [v0] Raven Rock Intro bugged

 When going to Raven Rock by boat, if you move the mouse left/right in the ship-entering-docks-scene the entire boat gets boosted into the respective opposite direction. As soon as the scripted scene is over, the problem is gone.

[v2] From the Alternate Start readme: "If you pick the ship arrival start for Raven Rock, the mouse is not being locked down for some reason when the function is called to run the animated ship ride. No know solution for this exists as of yet. Avoid moving the mouse. It will disrupt the scene, even though the boat will arrive properly. It just looks goofy as hell."

 

3) [v0] Conflicts between "JK's Skyrim" and "ETaC"

Screenshot Clipping in Riverwood and at the Dawnstar docks and probably some other places - resolved, I've mistakenly installed JK's Skyrim (instead of Major Cities) together with ETaC. Dumb me. To identify clipping or misplaced items just open the console and click the items from there. It will show you which mod they belong to.

 

4) [v0] Gameplay feels stuttery

Although especially in the wilds the framerate is always above 30 (mostly 40-60) the game feels a bit stuttery, probably due to changes in framerate caused by grass/tree mods, currently trying to resolve this by increasing uGridsToLoad and replacing Skyrim Bigger Trees with the Lite version, other than that limiting the fps to 30 would provide a stable framerate and therefore probably help too

[v1] feels better now that I have replaced Bigger Trees with the Lite version, still not resolved completely

[v2] stuttery feeling is almost completely gone, only in cities (with really low fps) it seems like the game has to load stuff and stutters because of that. Other than that, even tho the fps is REALLY low, the ENB seems to have fixed the stuttering!

 

6) [v0] Tree and LOD popping

 Screenshot Trees (esp. near Riften) coming "to life" from plane LOD pictures VERY near to the player (which looks odd and ugly), currently trying to fix this by using higher LODs for Skyrim Bigger Trees Light (if they get used at all due to DynDOLOD) and by extending the tree render number & distance in the inis. 

[v2] Problem resolved thanks to following the STEP Tree Settings Guide, tree popping (and LOD popping with it) was completely eliminated
 

7) [v0, v1] First Person bugged

Immersive First Person View theoretically works flawless - as long as you never leave first person view. As soon as you go to 3rd person ONCE and then go back to 1st person, it is broken forever. Instead of being perfectly aligned to my body like after starting the game I can now look at my hollow insides when looking down and when running and stopping my chest "overtakes" me and its insides are visible for a moment even when not looking down. This can't be fixed by saving and loading but only by loading an earlier safegame where I wasn't in 3rd person yet or by starting a new game. Could be due to using IFPV and Skyrim Enhanced Camera at the same time, will test disabling one of them soon.

[v2] Problem resolved, it was actually an incompatibility between IFPV and SEC. By only using SEC I can switch between 1st and 3rd person without any problems. Will test SEC with SexLab in the next version to determine if its usable

 

8) [v0] "Better Fast Travel" Dialogue reappears

This is somehow connected to Better Fast Travel but I've used this mod already in the past and didn't have this problem. Every time when I get unto the cart and the screen goes black, the dialogue comes up again (on the blackscreen, before the loading screen) and the guy starts talking again until he gets silenced by the loading screen.

[v1] problem disappeared without any apparent reason

[v2] problem is back, this time without sound but with dialogue on blackscreen. Seems to be random. Couldn't find anything about it on Google.

[v2] problem disappeared again, again without any apparent reason

 

9) [v0, v1, v2] Double "Viewable Factions"

"Factions" is showing up twice in the MCM menu. Couldn't find anything about it on Google.

[v3] The problem disappeared after reinstalling the mod

 

11) [v0, v1] Abrupt Animations

The animations when switching from going straight to strafing seem to be missing, there is simply no transition. Could be connected with IFPV/SEC. Strangely sometimes the transitions are smooth, couldn't find a trigger yet. Could this be to FNIS set to Gender Animations in addition to Skeleton Fix? Always set this just to be sure to have SexLab animations running correctly OR because of using XP32 Extended instead of XP32?

[v2] Problem was fixed, probably by deactivating Immersive First Person View

 

13) [v1] Character Shadow Striping

Screenshot Almost classic bug where an actor plus overwhelmed physics led to someone weirdly spinning and twitching after death. This was the first time I've ever seen this happening in Skyrim, else I wouldn't have mentioned it at all. I guess there's no solution within the game engine. Could be a hint towards script overload?!

[v3] As the problem occurred only once during many hours of testing three different versions I'm gonna count it as vanilla bug and put it to solved.

 

12) [v1] Actor Spinning

Screenshot Also pretty classic to Skyrim is the shadow clipping/striping on characters (see screenshot upper back). Before weirdly fiddling with the ini files I will try fixing this by using an ENB as ENBs also tend to fix "normal" shadow striping.

[v2] Shadow striping, especially on characters, was completely eliminated by using ENB

 

14) [v1] Horizon blurs out too low/high

 Screenshot The horizon seems to end too low respectively the sky seems to start too high and there seems to be a blurred out area between both, had that problem in the past and found a way to fix it back then, I think it had to do with the load order

[v2] Screenshot seems to be either fixed by ENB or weather (fog) related. Couldn't see it this time.

 

15) [v1] "RaceMenu" Zoom Bug

When starting a new game using Alternate Start and being in the RaceMenu, the default view is zoomed out. When I press Alt to zoom in, the first time it will bug into zoomed view and immediately zoom out. After that, everything works fine.

[v2] The problem seems to have fixed itself

[v3] Problem came back but I can't remember using RaceMenu without it so I think it is a feature

 

16) [v1] "Better Fast Travel" Dialogue missing

At least before CWO starts respectively I've found the dragon's victim in Helgen (Alternate Start) the cart driver from Better Fast Travel doesn't offer the dialogue option "I'd like to hire your carriage". Couldn't find anything about it on Google.

[v2] Going to him after starting vanilla, this time the cart driver showed the dialogue. Perhaps this had something to do with the added dialogue option by SexLab, which is now deactivated?

 

18) [v2] Mountain Clouds clipping during Fog

Screenshot Distant mountain clouds are clipping through and flickering at foggy weather

[v3] Rearranging the Superior and ENB fog mods seems to have resolved this problem

 

19) [v2] Intro sequence bugged

Intro sequence, that was still working in v0 (didn't test in v1) is now bugged. The Helgen door doesn't open anymore for the cars and after waiting in front of the door while continuing to ride mine gets stuck at one of the walls. Probably connected to Helgen Reborn, Civil War Overhaul, Immersive Patrols or Perfect Legionnaire.

[v2] Tried it again (see 10, second edit) and this time the doors opened when they should. To be sure I've played the entire intro sequence and it worked just fine. Will have an eye on this.

[v3] The Helgen door now opens every time

 

22) [v2] Intro Captain twitching

Female captain is slightly twitching between reading the list and going to the block. Don't know if this was already in with vanilla.

[v3] The problem was solved in this version, probably changing the load order or doing another FNIS helped

 

 

 

 

To do list for [v4]:

- Check if changing the load order eliminated the floating wall in front of Whiterun

- Keep eyes open for morning fogs

- Play 2 hours and check for freezes and CTDs

- Try to load savegames after 20, 40 and 60 minutes

- Use a staff and check for fragment bug

- Check the intro for naked soldiers

 

 

 

Current Look of the Game [v2]:

2015-11-15_000399zj7c.jpg2015-11-15_00043sxk2s.jpg2015-11-15_00064orkno.jpg2015-11-15_00067ztjfg.jpg

2015-11-15_00070r8jcz.jpg2015-11-15_00078urk1z.jpg2015-11-15_00081vrkfs.jpg2015-11-15_000851tjiy.jpg

2015-11-15_00092bekkt.jpg2015-11-15_00098sqj0n.jpg2015-11-15_00106evj3r.jpg2015-11-15_0010977je2.jpg

2015-11-15_00110ydjxv.jpg2015-11-15_00065npj7c.jpg

Edited by elwaps

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

With regards to  [v2, v3] Naked NPCs during Intro   this was due to Immersive Armors.  The newest 8.0 version resolves the naked NPC's during the Intro.                                                 

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.