Jump to content
  • 0
minusESP

M.O. won't download with manager

Question

Trying to make Firefox aware of nxm I read this in the S.T.E.P. guide under trouble shooting:

If you are using Firefox, open Firefox, and inside Options, go to the Applications tab. Search for nxm and point it toward the nxmhandler application located inside the Mod Organizer directory if the option exists.

This tip seems to be missing some detail: What content type? I assumed it should be compressed files and set action to nxmhandler.exe.for content compressed (zipped) folder. This dosen't help me; I still receive an error message from Firefox when I click the download with manager button for any file on Nexus.

 

"The address wasn't understood
Firefox doesn't know how to open this address, because one of the following protocols (nxm) isn't associated with any program or is not allowed in this context.
You might need to install other software to open this address".

I have also clicked the associate with Download with manager links button in the M.O.Nexus tab. Can someone please elaborate on how to make Firefox aware of nxm?

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

The "Content type" is the 'nxm' file protocol. If you have tried to download a file with Firefox you will have an entry for that.

In the next column, "Action", choose the 'nxmhandler.exe'.

 

As a Chrome user I had to install Firefox just now to verify these instructions and it works exactly as described in the wiki.

If you are seeing anything different you will need to provide screenshots of the "Option -- Application" tab to show us what is available for you.

Share this post


Link to post
Share on other sites
  • 0

The "Content type" is the 'nxm' file protocol. If you have tried to download a file with Firefox you will have an entry for that.

In the next column, "Action", choose the 'nxmhandler.exe'.

 

As a Chrome user I had to install Firefox just now to verify these instructions and it works exactly as described in the wiki.

If you are seeing anything different you will need to provide screenshots of the "Option -- Application" tab to show us what is available for you.

I guess that's my problem then, nxm doesn't show up in the table at all. would you happen to know how to add it?

Share this post


Link to post
Share on other sites
  • 0

Set the dialog in firefox to always ask. The next time you download with manager you should get a window asking how to handle the download. One item should be nxm and the other should be browse to file. If nxm is not in the list use the browse button to navigate to the nxmhandler.exe in modorganizer install that you are using.

Share this post


Link to post
Share on other sites
  • 0

Set the dialog in firefox to always ask. The next time you download with manager you should get a window asking how to handle the download. One item should be nxm and the other should be browse to file. If nxm is not in the list use the browse button to navigate to the nxmhandler.exe in modorganizer install that you are using.

Thank you for your response GSDFan

 

By "set the dialog box" I take it to mean to set the downloads (where to save downloads) setting on the Firefox Options, General settings page to "always ask me where to save files. " On the Firefox application page nxm never appears as a choice in the table under content and there is no option to browse to nxmhandler.exe under content type, nxm is not listed under content type. The only option available is to browse to

nxmhandler.exe under Action. Setting "always ask me" on the Options, Applications page makes no sense to me since nxm never appears in the "content type" column of the table. It seems to me this is the problem that needs to be solved; How to add nxm to the content column. Btw download with manager never has poped up a window asking how to handle the download.

It just pops up a window from firefox:

 

"The address wasn't understood

Firefox doesn't know how to open this address, because one of the following protocols (nxm) isn't associated with any program or is not allowed in this context.

You might need to install other software to open this address". As I said the download with manager option has never worked from day one since I installed M.O.

 

So this seems to be the question: How to make the association. Is there a file in M.O. that has settings for browser being used (that can be edited.)

Share this post


Link to post
Share on other sites
  • 0

This may sound like an obvious question but have you actually browsed to Nexus and tried to download a mod using the 'Download with Manager' button?

 

It sounds like you haven't!

 

None of the steps being described here are specific to Mod Organizer.

The 'nxm' file protocol is something the Nexus sites have developed and the way Firefox, or any browser handles them, is specific to each browser.

The only connection to MO is that when your browser handles these 'nxm' files correctly, MO is called to do the download, not your browser.

Share this post


Link to post
Share on other sites
  • 0

In Firefox applications, NXM set it to always ask.

 

post-1366-0-33654000-1444703869_thumb.png

 

When download with manager is pressed you should see the Launch Application dialog.

 

post-1366-0-80413200-1444703831_thumb.png

 

If NXM is not available then browse to the handler in the MO directory.

Share this post


Link to post
Share on other sites
  • 0

In Firefox applications, NXM set it to always ask.

 

 

When download with manager is pressed you should see the Launch Application dialog.

 

attachicon.gifScreenshot - 10_11_2015 , 2_55_48 AM.png

 

If NXM is not available then browse to the handler in the MO directory.

I am not familliar with whatever browser you made those snips from, Firefox looks a bit different, the first snip is the error message FF gives when I attempt to download with manager. The next one is Options-Applications, as you see nxm does not appear under content and from what I just read on the mozilla support site (and from my own experience) content can not be added or removed from here; you can only set the way it is handeled.                                                                               post-8116-0-28564800-1444709858_thumb.png

post-8116-0-83227100-1444709912_thumb.png                         post-8116-0-10313600-1444709942_thumb.png

Edited by minusESP

Share this post


Link to post
Share on other sites
  • 0

Somehow you have changed the default action Firefox takes when it encounters new filetypes.

 

Try this method to remove ALL current associated filetypes you have set with Firefox and see whether you are presented with the 'Launch Application' dialogue shown above.

 

Find the file "mimetypes.rdf" which should be in this folder:

"C:\Users\{username}\AppData\Roaming\Mozilla\Firefox\Profiles\13jzgkpd.default\mimeTypes.rdf"

 

The characters in Yellow may be different on your system.

 

Delete it and re-start Firefox.

Share this post


Link to post
Share on other sites
  • 0

Okay, deleted mimeTypes.rdf as you suggested, restarted FF; results remain the same when attempting to download with manager.

post-8116-0-13585500-1444762647_thumb.png

Share this post


Link to post
Share on other sites
  • 0

Use Windows Explorer to browse to your Mod Organizer folder and double click (run) nxmhandler.exe. This opens the NXM Handler application. Select the appropriate games/binary from the list (in case you have more than one) and click Register active. This registers the NXM handler in the Windows registry so Firefox can find it.

 

Now run Firefox and try to download a mod using the Download with manager button. This time you should be prompted to select Mod Organizer.

 

Unfortunately, this step is very easy to overlook because you only do it once and forget it.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Use Windows Explorer to browse to your Mod Organizer folder and double click (run) nxmhandler.exe. This opens the NXM Handler application. Select the appropriate games/binary from the list (in case you have more than one) and click Register active. This registers the NXM handler in the Windows registry so Firefox can find it.

 

Now run Firefox and try to download a mod using the Download with manager button. This time you should be prompted to select Mod Organizer.

 

Unfortunately, this step is very easy to overlook because you only do it once and forget it.

YES! -> post-8116-0-47258600-1444799358_thumb.png                      :thumbsup: 

Thank You Greg, and thanks to everyone else that helped and replied to my post(s) about this nasty little problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.