Jump to content
  • 0

Announcement: Mod Organizer 1.3b (the b is for beta) and the future of MO - UPDATED 1.3.5 is out to the public





New beta version 1.3.1 available on Sourceforge.

This should fix all reported problems. The only thing I couldn't make any sense of is the report of load order being reverted, could someone please work out reliable steps to reproduce it?



I just uploaded a beta of MO Version 1.3 to sourceforge: https://sourceforge.net/projects/modorganizer/files/?


Before I go into the changes, let me first advice against using this version as your primary installation. While it seems to be relatively stable and I've been using it on my own system for a few weeks now I will refuse to even feel bad if this ruins your setup.

Still, I would appreciate any feedback.


Right, features.

  • Integration of loot 0.7 beta
  • the integrated loot can now be updated without a new release of MO. (1)
  • the mod list now has a new column that displays icons based on the content of the mod so you can quickly see if a mod contains, say, esps or textures or skse plugins or ...
  • the mod list can be filtered by their content
  • When you click a mod that has conflicts, the conflicting mods now get a colored highlight in the list.

Apart from this there have been a couple of changes under the hood:

  • MO is now based on the current version of Qt (5.4 instead of 4.8). Unfortunately this also leads to a 4MB bigger archive.
  • Windows XP is no longer supported.
  • more game-specific functionality has been factored out into plugins. While this won't suffice to support non-gamebryo games right now it may be possible for someone (not me) to write a Morrowind plugin.


(1) To update loot, get the "loot api" download from the loot github page at https://github.com/loot/loot/releases/ and copy the loot32.dll contained within to the loot directory of MO.



Since I already have your attention I'd like to also announce that this is probably going to be the last feature-release of MO, at lease for a while.

This is not saying that I'll stop working on MO but the project has become too large for a single person to work on effectively in their very limit spare time and since it doesn't look like an active development community is forming around MO I decided to focus my time on very specific topics.

This will allow me to work on those things more effectively while allowing me to keep a shred of sanity.


So what I'll continue to do is:

  • Fix bugs in the core application
  • Fix severe bugs in the virtualisation library and plugins
  • Add plugin interfaces on demand
  • Work on a new virtualisation library that is more flexible and supports 64 bit
  • Anything that I deem enjoyable. ;)

What I will no longer do is:

  • Add any features (unless I deem the implementation fun)
  • Answer any requests for help (be it PM, mail or on the forums) unless it's "I want to help out with MO but I need advice" or something like that
  • Do the german translation
  • Fix "minor" problems or "medium" problems in the vfs system and plugins
  • Maintain "lists" like the categories mappings, configurator settings file,...
  • Work on the tutorials in any way


The reason I will only fix severe bugs in the vfs library is that this lib will hopefully be replaced anyway when the new one is working.

The reason I will only fix severe bugs in the plugins is that I believe those plugins are sufficiently simple that others could easily work on those.


If you don't know, the features implemented in plugins is: all the installers, the tools below the "tools" menu, the diagnostic messages (exclamation mark) and now parts of the functionality specific to gamebryo games.



Known issues with MO 1.3 beta:

  • right now filtering by the mod list by "checked, unchecked, update, ..." doesn't work.
  • +1 3
Link to comment
Share on other sites

Recommended Posts

  • 0

This sounds great! ::): A couple of questions.


If we were to report potential problems, were would you prefer them to be reported? On your normal bugtracker over at The Bug Genie or concentrated/only in this thread?


Just to be sure, so am I correct, that the current LOOT API that you incorporated into this first MO 1.3 Beta is "LOOT.API.v0.7.0-beta.4-0-g5aca14b.7z"? I just ask because I always test the newest LOOT snapshot builds for wrinklyninja and thus my <normal> LOOT verison is currently 0.7.0 Beta 4-26 (the absolute newest available). And if I were to test the new MO version I of course would like both the normal LOOT as well as your via API inbuild LOOT versions to be in sync.

Edited by pStyl3
Link to comment
Share on other sites

  • 0

For this beta either post to the issue tracker as usual or post in this thread, both is fine. Just don't send issue reports by PM or create a new thread for a single issue, those might get overlooked.


Regarding loot: yes, the dll included in MO is 0.7.0 beta 4

  • +1 1
Link to comment
Share on other sites

  • 0

Thank you for the clarification.


I already have one thing to report. I am currently trying to pinpoint the exact reproduction steps, but currently it looks like that MO 1.3b crashes sometimes upon removing files from the left pane.


Crash #1

What I did was:

- Install and activate SKSE 1.7.2 Scripts

- Install and activate SKSE.ini

- Deactivate SKSE.ini

- Rightclick on SKSE.ini, select "Remove"

--> Crash


Crash #2

Dump file for this one will be send via email.

- Here I just installed both, and then tried to delete the Scripts mod


Error message

I got this one right after starting MO, both mods were not activated, just like it is shown in the image. When I tried to remove that .ini mod, that error message pop'ed up.



Here's also the content of mo_interface.log, IIRC it was from the first crash:


17:22:39 [D] Working directory: C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest
17:22:39 [D] MO at: C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest
17:22:39 [D] looking for plugins in C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\plugins
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/bsaExtractor.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/checkFNIS.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/diagnoseBasic.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/gameFallout3.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/gameFalloutNV.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/gameOblivion.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/gameSkyrim.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/iniEditor.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/installerBAIN.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/installerBundle.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/installerFomod.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/installerManual.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/installerNCC.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/installerQuick.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/NMMImport.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/previewBase.dll"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/pyCfg.py"
17:22:39 [D] loaded plugin "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/plugins/proxyPython.dll"
17:22:39 [D] game path: C:\Spiele\Steam\steamapps\common\Skyrim
17:22:39 [D] managing game at C:\Spiele\Steam\steamapps\common\Skyrim
17:22:39 [D] setting up configured executables
17:22:39 [D] configured profile: Default
17:22:39 [D] initializing tutorials
17:22:39 [D] localization file qt_de-DE not found
17:22:39 [D] localization file organizer_de-DE not found
17:22:39 [D] loaded language de-DE
17:22:39 [D] interface LAN-Verbindung seems to be up (address: fe80::7444:5503:7d89:9c5f%10)
17:22:39 [D] localization file bsaExtractor_de-DE not found
17:22:39 [D] localization file checkFNIS_de-DE not found
17:22:39 [D] localization file diagnoseBasic_de-DE not found
17:22:39 [D] localization file gameFallout3_de-DE not found
17:22:39 [D] localization file gameFalloutNV_de-DE not found
17:22:39 [D] localization file gameOblivion_de-DE not found
17:22:39 [D] localization file gameSkyrim_de-DE not found
17:22:39 [D] localization file iniEditor_de-DE not found
17:22:39 [D] localization file installerBAIN_de-DE not found
17:22:39 [D] localization file installerBundle_de-DE not found
17:22:39 [D] localization file installerFomod_de-DE not found
17:22:39 [D] localization file installerManual_de-DE not found
17:22:39 [D] localization file installerNCC_de-DE not found
17:22:39 [D] localization file installerQuick_de-DE not found
17:22:39 [D] localization file NMMImport_de-DE not found
17:22:39 [D] localization file previewBase_de-DE not found
17:22:39 [D] localization file proxyPython_de-DE not found
17:22:39 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\modlist.txt saved
17:22:39 [D] displaying main window
17:22:40 [D] this version is newer than the current version on nexus ( vs
17:22:41 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\modlist.txt saved
17:22:50 [D] simple expression matched, using name only
17:22:50 [D] passed mod id: 0, guessed id: -1
17:22:50 [D] using mod name "SKSE ini" (id 0) -> C:/Spiele/Modding/Skyrim/Mods/SKSE_ini.rar
17:22:50 [D] SKSE on the top level
17:22:50 [D] SKSE on the top level
17:22:53 [D] offering installation dialog
17:22:54 [D] installing to "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/mods\SKSE ini"
17:22:54 [D] Installation successful
17:22:54 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\modlist.txt saved
17:22:57 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\plugins.txt saved
17:22:57 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\loadorder.txt saved
17:22:57 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\lockedorder.txt saved
17:22:57 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\archives.txt saved
17:22:59 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\modlist.txt saved
17:23:02 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\lockedorder.txt saved
17:23:04 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\modlist.txt saved
17:23:11 [D] mod "SKSE ini" (profile "C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/profiles/Default") not found
17:23:13 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\modlist.txt saved
17:23:15 [D] interface LAN-Verbindung seems to be up (address: fe80::7444:5503:7d89:9c5f%10)
17:23:15 [D] save C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/webcache/cookies.dat
17:23:15 [W] External WM_DESTROY received for  QWidgetWindow(0xeda0a20, name = "QProgressDialogClassWindow") , parent:  QObject(0x0)  , transient parent:  QObject(0x0)
17:23:15 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\initweaks.ini saved
17:23:15 [D] C:\Spiele\Modding\0_Programme\MO_1_3_BetaTest\profiles\Default\lockedorder.txt saved
17:23:15 [D] save C:/Spiele/Modding/0_Programme/MO_1_3_BetaTest/webcache/nexus_cookies.dat


Edited by pStyl3
Link to comment
Share on other sites

  • 0

BSA loading of the greyed out BSAs worked for me. I tried loading about 5 extra BSAs that I couldn't load with previous versions. I'll add my observation to the tracker.


For FNV, I could not get the 4GB Loader to work at all. Tried with and without the -laaexe .\FalloutMO.exe argument. I could get the NVSe loader to start just fine, but with my heavily modded profile it crashes when loading a save due to running out of memory, so I'll need to have that part figured out to really test out stuff for FNV.


Forgot to mention the 4GB Loader error: Application load error 3:0000065432


Maybe even add a BSA icon to the content column. That is pretty sweet by the way. Also, the highlighted red and green rows is going to be such a godsend for mods that have lots of conflicts like large texture packs. Even if no one else used that feature, it was worth implementing just for the amount I'll make use of it. 


One bug I noticed was the hovertext for plugins being transparent.



I'll do some Skryim testing too as time permits.

Link to comment
Share on other sites

  • 0

Downloaded and installed a couple of mods using version 1.3b now: MO Setup


Overall my first impressions are that, aside from the crash issue upon deleting files, it is a pretty stable build. I had no further major problems, downloading mods was working as intended (btw, was the "green download progression bar has holes" issue fixed by 1.3b?), LOOT (inbuild + external) as well as Wrye Bash 305 and xEdit 3.0.33 svn1898 are working fine so far if run through MO.


A few minor quirks cropped up on the way. First, take a look at this screenshot. The vertical scroll bar of the left pane has a bunch of areas where the new conflict color is displayed ontop of it.


Also .. it appears, that sometimes the mod with the lowest priority number (0, so the highest one in the left pane) will sort of get automatically "focused" (as if I would leftclick on it). For example I think that happens when I have MO run in the background and do stuff in FireFox and then return to MO. That wasn't an "issue" in MO 1.2.18, but with 1.3b it can be a bit irritating. In my case, I have the Unofficial Skyrim Patch at the top of my left pane .. when now the top mod get's focused (for whatever reason) without me doing that intentionally, and optop that happens quite regularly, that is a bit perplexing and irritating as the red conflict color will showup "suddenly".


Then please take a look at this screenshot. First, "interface" should probably be written "Interface". Second, could there be added a little bit of space between the image and the textstrings?


One icon

More than one icon

--> In the first case, maybe prevent the tooltip from linebreaking (seeing as it doesn't linebreak when more than one icon per mod are displayed)?


Last but not least, would it be possible to increase the quality(/resolution) of the new content icons? When hoovering over them they will be displayed a bit bigger, and then some of them look a bit to pixilated I would say.



That's all I have for now.

Edited by pStyl3
Link to comment
Share on other sites

  • 0

Testing with TTW - FNV engine


1.  I also crash if I attempt to delete files.

2.  I can not seem to reorder my mod order in the right pane like I used to.  I have to use Wrye Flash to do that.  Confirmed problem by using 1.2.18, and I was able to change the load order in the right plane.

3.  Panzer is now recognized as an ESM and not an ESP.  Can not test further until the problem with 4GB loader is fixed.

4.  I also receive the Application Error 3:0000065432 when I tried to use FNV4 GB loader.  Confirmed problem by using 1.2.18, and the game loaded without error.

Edited by KeltecRFB
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.