Jump to content
  • 0
Sign in to follow this  
Danik882010

Help Papyrus Compiler Fix For 64-bit Systems

Question

Hello everyone I am new to modding so please be patient with my noob questions. Also forgive me if this question has been answered before, I was not able to find an answer in the forums. I am following the Skyrim Revisited: Legendary Edition guide by Neovalen and I'm stuck in the "Papyrus Compiler Fix For 64-bit Systems" section. 

 

-So far I have installed .NET Framework Software Development Kit (Windows SDK) into C:/Program Files. It expands to C:/Program Files/Microsoft SDKs/Windows/v7.1/Bin/Net 4.0 Tools to get to the corflags

 

-My Skyrim install directory is in C:/Games/Steam/SteamApps/Common/Skyrim. 

 

-According to my understanding of the guide I am supposed to type in "C:/Program Files/Microsoft SDKs/Windows/v7.1/Bin/Net 4.0 Tools" in to the command prompt followed by "corflags /32bit+ C:/Games/Steam/SteamApps/Common/Skyrim/Papyrus Compiler/PapyrusCompiler.exe" in the command prompt. 

 

- I have practically no knowledge of how to use the command prompt and copy paste inst working. I've tried to learn more about how to use command prompt but it gets more confusing the more I read about it.

 

- When I open my command prompt it always starts off with C:\user\(my user name)\

 

QUESTION 1) 

What do I put into my command prompt in order to force PapyrusCompiler.exe to run in 32 bit mode?

 

QUESTION 2)

I am following the "Skyrim Revisited: Legendary Edition" guide but I've also come across just the regular "Skyrim Revisited" guide. Is there a difference? I have all the dlc and hi res dlc installed via steam and both of the Skyrim Revisited guides list the same prerequisites. Does the Skyrim Revisited: Legendary Edition guide require the Skyrim Legendary Edition game to work properly?

 

Thanks all for the help in advance.

 

https://wiki.step-project.com/User:Danik882010/SystemSpecs

Edited by Danik882010

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

First time I hear about this 64 bits fix.

I also had trouble launching papyrus compiler on my Windows 7 x64t, so just created a pair of config files to force it to use older .NET version, works fine for me now.

Try to unpack those files into "Skyrim\Papyrus Compiler " folder.

Papyrus Compiler.zip

Share this post


Link to post
Share on other sites
  • 0

Hi

I have issues with this on win 7. I have tried to understand this for two hour now and installed and uninstalled Microsoft Windows SDK for Windows 7 and .NET Framework 4 several times with no luck so far.

 

Im running win 7 64bit and here is what I have done so far:

1. Uninstalled Microsoft Visual C++ 2010 Redistributable

2. Downloaded and installed Microsoft Windows SDK for Windows 7 and .NET Framework 4

3. But when I try to run the commanded: corflags /32bit+ F:/Steam2/SteamApps/common/Skyrim/Papyrus Compiler/PapyrusCompiler.exe

 

this happen:

'corflags' is not recognized as an internal or external command, operable program or batch file.

 

And when I check folder "C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\bin\NETFX 4.0 Tools" the only files is:

sn.exe

sn.exe.config

 

Is this right?

 

Anyway, I see that zilav posted a zip files with config files. This seem to good to be true, but can I just skip the whole corflag command and just unzip this files?

 

Thanks for any help.

Share this post


Link to post
Share on other sites
  • 0

No that doesn't look right. There should be the 'corflags.exe' in that folder. Also ensure that ALL paths in that command line that contain spaces are inclosed in double quotes.

 

"F:/Steam2/SteamApps/common/Skyrim/Papyrus Compiler/PapyrusCompiler.exe"

 

not

F:/Steam2/SteamApps/common/Skyrim/Papyrus Compiler/PapyrusCompiler.exe

Share this post


Link to post
Share on other sites
  • 0

Thanks for your reply GrantSP

 

I tried with quotes and without quotes and tried different spaces between but I was not sure so thanks.

 

Anyway, since corflags.exe is not there nothing work atm.

 

Can I use the zip file from zilav and skip the whole process?

 

And why is there no corflags.exe? I also tried installing all the tools in the "SDK for windows" but still not there.

Edited by xxx78

Share this post


Link to post
Share on other sites
  • 0

This download dont seem to have corflags.exe Microsoft Windows SDK for Windows 7 and .NET Framework 4 , at least I can't find it anywhere.

 

But this have corflag: .NET Framework 2.0 Software Development Kit (SDK) (x64)

 

But it install corflag.exe in this location: C:\Program Files\Microsoft.NET\SDK\v2.0 64bit\Bin

 

This also have corflag: Windows Software Development Kit (SDK) for Windows 8.1

 

Here corflag.exe is installed in: C:\Program Files (x86)\Microsoft SDKs\Windows\v8.1A\bin\NETFX 4.5.1 Tools

 

hehe, Im sorry for being such a noob but this make no sense to me ans I have no idea if I can run the "Papyrus Compiler Fix For 64-bit Systems" using corflag from any of this locations?

 

PS: I'm running win 7.

Edited by xxx78

Share this post


Link to post
Share on other sites
  • 0

Well, since you have Win7 64bit you can safely use the installed 'corflags.exe' in your 'C:\Program Files\Microsoft.NET\SDK\v2.0 64bit\Bin' location.

 

You should remove the Win8.1 install as that should contain files that are compatible for Win8.1, not what you are running.

 

So the entire line you will need to input should be:

"C:\Program Files\Microsoft.NET\SDK\v2.0 64bit\Bin\corflags.exe" /32bit+ "F:/Steam2/SteamApps/common/Skyrim/Papyrus Compiler/PapyrusCompiler.exe"

All this command is saying is:

  1. Call the 'corflags.exe' program found at this location (path to file in the first set of double quotes)
  2. Run it with the 32bit enabler switch (/32bit+)
  3. Apply that fix to the program defined by the second path (the path in the second set of double quotes)

This is of course based on the assumption the paths you have supplied in this thread are actually the correct paths. If you have installed either the 'corflags.exe' or the 'papyruscompiler.exe' into another location(s), simply change the command to point to that new location(s).

Share this post


Link to post
Share on other sites
  • 0

Thanks a lot for clarifying this issue GrantSP

Thanks also for explaining what the command actually do

 

I have no idea if this worked but this was what happened when I executed the command. I did it in two different ways just to be sure ;)

 

2015_05_08_1313.png

Edited by xxx78

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Bothello
      Need help with fixing CTD problems.
      i've been modding my game for a year now with none of these issues and as of late been having crashes with "BSTextureDB" and "BSLightingShaderProperty". I already wanted to change my mods so i thought heck it i'll start from scratch. Done that but half way trough i still have the same problems. Almost every report names a deferent mod... SMIM, High Poly Project, my grass mod, Majestic Mountains, NPC Overhauls, ect... these mostly  occurs at cities like Whiterun, Windhelm and Solitude, but isn't limited to it.
      The crash reports of the last 3 days are in the attachment area. Hope anyone could help me 
      Crash_2021_9_18_12-16-3.txt Crash_2021_9_18_13-4-29.txt Crash_2021_9_18_14-49-5.txt Crash_2021_9_19_11-57-27.txt Crash_2021_9_19_12-4-6.txt Crash_2021_9_19_12-8-35.txt Crash_2021_9_17_11-3-8.txt Crash_2021_9_17_11-52-23.txt Crash_2021_9_17_13-10-20.txt Crash_2021_9_17_13-13-49.txt Crash_2021_9_17_13-58-12.txt Crash_2021_9_17_15-15-30.txt
    • By samuelr29
      I tried creating a shortcut with MO to launch BodySlide but when I launch it, a process appears, but no window.  I can manually launch it, but if I do that, none of the CBBE assets are detected, naturally.  It would need to be executed with VFS to have access to those, I assume.  When I went to test this in the data tab, it will open when I right click and select "execute" but if I select "execute with VFS" I get only a process and no window.  I've tried re-installing it multiple times, but I still don't know if I missed a crucial step.  I've already installed Nemesis and LOOT and both of those work just fine, it's only BodySlide that is giving me trrouble. Apart from what I have already gleaned, I have no idea what to do next, so suggestions would be appreciated.
    • By DankTemplar
      Hey! I've been having this issue for well over a year; I follow the instructions for Dyndolod+Open Cities in the manual/from the GamerPoets web page, generate my LOD and get double LODs created for these cities and I could really use the help getting this nightmare fixed.
      To clarify; the tutorial told me to;
      Disable Open Cities+patches Run Dyndolod+select appropriate setting (high+custom tree and water LOD rules for getting rid of water LOD seams+generating 3D tree LODs which worked fantastically! Basically all I did was make use of the full models for water and used the appropriate static models for trees) Disable generate Dyndolod, enable the other options (except trees for me as generating 3D tree LODs means generate tree LOD is greyed out, per the manual instructions) Start+exit (not save+exit when complete) Comment out Open Cities from Dynodlolod_SSE.ini under the heading warnmodfilename+save document Re-enable Open Cities+patches in your load order Run Dyndolod+select identical setting which you selected in .2 Enable generate Dyndolod, disable generate *insert option here* Start+save and exit when complete. Install via your method of choice. I've also minded my load order since Dyndolod copies records from the last overriding file (this fixed my Solitude Open Cities LOD issue) but this hasn't fixed my Whiterun Open Cities LOD issue (and I've no city overhaul mods installed specifically for Whiterun so conflicting records in theory shouldn't be an issue here).
      So....ummm...please help? lol
      Attached is my load order in it's full glory!
       
       
      LoadOrder_SkyrimSE_2021-04-16T14-39-55.txt
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.