Jump to content
tregolani

Vanilla Chaos Damage Enchant Broken?

Recommended Posts

Hey all!
 
After doing some delving, I believe I have stumbled upon a bit of a bug in the vanilla "Dragonborn" code, and would like a bit of advice as to how to fix it.
 
Essentially, the Chaos damage enchant is broken when being applied to a new weapon via the enchanting table.  For some reason, only one of the damage sources can be modified via the slider in the enchanting UI, and thus only one of the damage sources (Shock damage in the vanilla enchant) is being scaled, whereas the rest are staying at the default value.  However, for weapons found in the world, it isn't a problem, since they have a set enchantment.  
 
I made a quick mod in the CK that modified the magic effect description for the fire/frost components of the enchant, and took a few screenshots to show the issue more clearly.  
 
 
Has this been noted before?  Does anyone know how to fix this?  It seems that in-game, the enchanting slider will modify whichever magic effect has the highest "Base Cost" value, and in the case of the Chaos Damage enchant, the base cost for each of the components is as follows:
 
Fire = 6.5
Frost = 6.0
Shock = 7.0
 
The shock component is the one with the default description of "50% chance for each fire, frost, and shock to deal <mag> points of damage", and due to its "base cost", it is the one that gets modified via the slider in game, making the tooltip look correct.  However, my last two screenshots show that only 1 component is being modified in-game, and therefore shows that the vanilla Chaos enchant seems to be broken.
 
Experienced modders - is there a way to fix this? 
Edited by tregolani

Share this post


Link to post
Share on other sites

At very least you should enter this as a bug on the Unofficial Skyrim Patch bugfix website so they can try to fix it, in addition to looking for a nearterm fix.

Share this post


Link to post
Share on other sites

At very least you should enter this as a bug on the Unofficial Skyrim Patch bugfix website so they can try to fix it, in addition to looking for a nearterm fix.

Sounds good.  I'll post it to the buglist over at AFK mods (if the site ever lets me validate my email in order to be allowed to post...) 

 

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By samuelr29
      I tried creating a shortcut with MO to launch BodySlide but when I launch it, a process appears, but no window.  I can manually launch it, but if I do that, none of the CBBE assets are detected, naturally.  It would need to be executed with VFS to have access to those, I assume.  When I went to test this in the data tab, it will open when I right click and select "execute" but if I select "execute with VFS" I get only a process and no window.  I've tried re-installing it multiple times, but I still don't know if I missed a crucial step.  I've already installed Nemesis and LOOT and both of those work just fine, it's only BodySlide that is giving me trrouble. Apart from what I have already gleaned, I have no idea what to do next, so suggestions would be appreciated.
    • By DankTemplar
      Hey! I've been having this issue for well over a year; I follow the instructions for Dyndolod+Open Cities in the manual/from the GamerPoets web page, generate my LOD and get double LODs created for these cities and I could really use the help getting this nightmare fixed.
      To clarify; the tutorial told me to;
      Disable Open Cities+patches Run Dyndolod+select appropriate setting (high+custom tree and water LOD rules for getting rid of water LOD seams+generating 3D tree LODs which worked fantastically! Basically all I did was make use of the full models for water and used the appropriate static models for trees) Disable generate Dyndolod, enable the other options (except trees for me as generating 3D tree LODs means generate tree LOD is greyed out, per the manual instructions) Start+exit (not save+exit when complete) Comment out Open Cities from Dynodlolod_SSE.ini under the heading warnmodfilename+save document Re-enable Open Cities+patches in your load order Run Dyndolod+select identical setting which you selected in .2 Enable generate Dyndolod, disable generate *insert option here* Start+save and exit when complete. Install via your method of choice. I've also minded my load order since Dyndolod copies records from the last overriding file (this fixed my Solitude Open Cities LOD issue) but this hasn't fixed my Whiterun Open Cities LOD issue (and I've no city overhaul mods installed specifically for Whiterun so conflicting records in theory shouldn't be an issue here).
      So....ummm...please help? lol
      Attached is my load order in it's full glory!
       
       
      LoadOrder_SkyrimSE_2021-04-16T14-39-55.txt
    • By Mare
      Every second or so in game I get a strange stutter/hitching that only seems to happen when im moving or looking around, I can hold 60fps solidly and my computer isn't under pressure from the game and everything runs perfectly besides this stutter.
      Very light modlist right now with only dyndolod, obsidian weathers + enb, aswell as cbbe and the usual smim and unofficial patch.
      Running on a rtx2070.
      If anyone knows a solution for this you would be a lifesaver.
      Video example:
       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.