Jump to content

New WYSIWYG Editor


Recommended Posts

Several weeks in the making, we now have a new WYSIWYG editor.


The inital load time as javascript is downloaded to your computer will be a few seconds, but response times will increase afterword. So if you don't see the editor right away, just give it a few seconds.


I made as much of an effort as I could to ensure cross browser compatibility, but there are a few minor quirks related specifically to IE. Some can't be worked around, others I just haven't found a way to yet. But none of the minor issues should affect functionality.


A few noteable features:

  • Autogrow - The editor will automatically grow as you type up to a maximum of 500px.
  • Maximize - The maximimize button is located just to the right of the Source button which expands the editing area to fill the browser viewport.
  • Full WYSIWYG support for code and php blocks.
  • Image insertion will be limited initially to 200px in width to help keep the post manageable for large images. After submitting, they will still be picked up by the gallery.
  • Inserting a video will add a small fake object with an icon representing the type of video you have inserted.
  • Double clicking on a link, image, or video object will open the appropriate dialog window allowing you to change values as needed.
  • Smilies do not appear on the left hand side while the editor is activated. All smilies configured within the system are available via the smiley button in the toolbar.
  • Clicking the save button in the toolbar is the same as clicking the Post Thread button.
If you come across any bugs or problems while using the editor, please reply to this thread and provide as much detail as you can so I can more reliably track down the culprit.


Thanks, and enjoy a hopefully more pleasant posting experience. :dance:

Link to comment
Share on other sites

  • Replies 37
  • Created
  • Last Reply

Not sure if bug or I can't use text editors:


If I go to quote someone who quoted someone else, I can't figure out how to remove my "quotie's" quote without manually doing it through the source editor. I hope this makes sense, but basically: hitting backspace over a quote inside a quote just pushes it to the top and I can't figure out how to remove it inside the WYSIWYG mode.

Link to comment
Share on other sites

This is a little more tricky compared to most other formatting due to the fact that quote html structure with author information are maintained and thus more complex (in the editors eyes).


The easiest way to remove a quote from inside another quote is to select the quote contents you want to remove (do not select the Wrote line). Then hit delete which will remove the text and leave you with an empty quote from the author. Then either hitting Backspace or Delete from inside the quote will finally remove the block.

Link to comment
Share on other sites

A few fixes were applied for the editor.


Among them is Quick Reply support. It is disabled for all users by default, but if you want to enable the editor for Quick Reply, select USER PROFILE from your user menu on the top bar.


Then on the left hand side under the Your Profile group, select Edit Options. When the page updates, look under the Thread View Options group to the right, and there is a new checkbox titled "Enable WYSIWYG editor for quick reply?". Check the checkbox, then click the Update Options button.

Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.