Jump to content

NET Script Framework - (ArgumentException)


Jarda
 Share

Recommended Posts

I've stumbled upon this error while I was following the SkyrimSE S.T.E.P. guide:

CE3ycxD.png

Using SSE Engine Fixes skse64 Preloader as the guide says, but I also tried DLL Plugin Loader and had the same issue.

Here is the Net Script Framework log:

Spoiler

[31 Jul 2021 12:08:20.565] Initializing framework version 10.
[31 Jul 2021 12:08:20.565] Loaded configuration file.
[31 Jul 2021 12:08:20.565] Preparing .NET code hooking.
[31 Jul 2021 12:08:20.581] Loading game library.
[31 Jul 2021 12:08:21.643] Loaded game library for `The Elder Scrolls V: Skyrim Special Edition` (14).
[31 Jul 2021 12:08:21.643] Running game version is 1.5.97.0
[31 Jul 2021 12:08:24.284] (ArgumentException): "Trying to install hook at 0x7FF7F9845C80, but the expected byte pattern of "48 89 5C 24 08" does not match!" at
[31 Jul 2021 12:08:24.284] --------------------------------------------------------------------------------------------------------------------------------------------
[31 Jul 2021 12:08:24.284]    em NetScriptFramework.Memory.AddHookIfNoOverlap(HookInfo self, IntPtr begin, Int32 size, String pattern) na C:\Games\SkyrimMods\NetScriptFramework\NetScriptFramework\Framework\Memory.cs:linha 2709
[31 Jul 2021 12:08:24.284]    em NetScriptFramework.Memory.WriteHook(HookParameters parameters) na C:\Games\SkyrimMods\NetScriptFramework\NetScriptFramework\Framework\Memory.cs:linha 2494
[31 Jul 2021 12:08:24.284]    em NetScriptFramework.EventHook`1..ctor(EventHookFlags flags, String key, EventHookParameters`1[] args) na C:\Games\SkyrimMods\NetScriptFramework\NetScriptFramework\Framework\Event.cs:linha 515
[31 Jul 2021 12:08:24.284]    em NetScriptFramework.SkyrimSE.Events.InitializeEvents() na c:\games\skyrimmods\netscriptframework\netscriptframework.skyrimse\events.h:linha 1448
[31 Jul 2021 12:08:24.284]    em NetScriptFramework.SkyrimSE.SkyrimSEGame.Initialize() na c:\games\skyrimmods\netscriptframework\netscriptframework.skyrimse\game.cpp:linha 499
[31 Jul 2021 12:08:24.284]    em NetScriptFramework.Game._initialize() na C:\Games\SkyrimMods\NetScriptFramework\NetScriptFramework\Framework\Game.cs:linha 198
[31 Jul 2021 12:08:24.284]    em NetScriptFramework.Main.LoadGameInfo() na C:\Games\SkyrimMods\NetScriptFramework\NetScriptFramework\Main.cs:linha 805
[31 Jul 2021 12:08:24.284]    em NetScriptFramework.Main._Initialize_Actual(FrameworkInitializationParameters p) na C:\Games\SkyrimMods\NetScriptFramework\NetScriptFramework\Main.cs:linha 366
[31 Jul 2021 12:08:24.284]    em NetScriptFramework.Main.Initialize(FrameworkInitializationParameters p) na C:\Games\SkyrimMods\NetScriptFramework\NetScriptFramework\Main.cs:linha 308
[31 Jul 2021 12:08:24.284] --------------------------------------------------------------------------------------------------------------------------------------------
[31 Jul 2021 12:09:25.527] Shutting down framework.
[31 Jul 2021 12:09:25.527] Shutting down plugins.
[31 Jul 2021 12:09:25.527] Shutdown complete.

 

I've just started following the guide instructions and honestly I have no idea about what could be wrong.

EDIT: Both SSE and MO2 are not installed in any UAC-controlled folders and none of the mod's dlls has an Unblock button or checkbox on it's properties.

EDIT for solved: I think the issue was the game executable which I've removed SteamStub from in order to play without Steam client/service. Sometimes I do this when I want the game to have access to as many hardware resources as possible.

Starting the game with the unmodified executable and with Steam running solved the issue for good.

Edited by Jarda
Solved
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.